Fix name problems with man page and logrotate. Also rc?d/* is causing failure.
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.4 2002/03/24 13:32:42 swa Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # PRIVOXY team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define oldname junkbuster
31 %define privoxyconf %{_sysconfdir}/%{oldname}
32
33 Summary: Privoxy - privacy enhancing proxy
34 Vendor: http://ijbswa.sourceforge.net
35 Name: privoxy
36 Version: 2.9.13
37 Release: 1
38 Source0: http://www.waldherr.org/%{name}/privoxy-%{version}.tar.gz
39 License: GPL
40 BuildRoot: %{_tmppath}/%{name}-%{version}-root
41 Group: Networking/Utilities
42 URL: http://ijbswa.sourceforge.net/
43 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
44 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
45 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
46 BuildRequires: perl gzip sed docbook-utils libtool
47 Conflicts: junkbuster-raw junkbuster-blank junkbuster
48
49 %description 
50 Privoxy is a web proxy with advanced filtering capabilities for
51 protecting privacy, filtering web page content, managing cookies,
52 controlling access, and removing ads, banners, pop-ups and other
53 obnoxious Internet junk. Privoxy has a very flexible configuration and
54 can be customized to suit individual needs and tastes. Internet
55 Privoxy has application for both stand-alone systems and multi-user
56 networks.
57
58 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
59 was originally written by JunkBusters Corporation, and was released as
60 free open-source software under the GNU GPL. Stefan Waldherr made many
61 improvements, and started the SourceForge project to continue
62 development. Several other developers are now contributing.
63
64 %prep
65 %setup -q -c
66
67 %build
68 autoconf
69 %configure
70 make 
71 make redhat-dok
72
73 ## Explicitily stripping is not recomended.
74 ## This is handled altomaticaly by RPM, and can couse troubles if
75 ## anyone wants to build an unstriped version - morcego
76 #strip %{name}
77
78 %install
79 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
80 mkdir -p %{buildroot}%{_sbindir} \
81          %{buildroot}%{_mandir}/man1 \
82          %{buildroot}%{_localstatedir}/log/%{name} \
83          %{buildroot}%{privoxyconf}/templates \
84          %{buildroot}%{_sysconfdir}/logrotate.d \
85          %{buildroot}%{_sysconfdir}/rc.d/init.d 
86
87 ## Manual gziping of manpages should not be done, once it can
88 ## break the building on some distributions. Anyway, rpm does it
89 ## automagicaly these days
90 ## Gziping the documentation files is not recomended - morcego
91 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
92
93 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
94
95 ## We need to change the man section internaly on the manpage
96 ## -- morcego (sugestion by Hal Burgiss)
97 #cp -f %{name}.1 %{buildroot}%{_mandir}/man8/%{name}.8
98
99 # do we need this???
100 #sed -e 's@^.TH JUNKBUSTER 1@.TH JUNKBUSTER 8@g' %{oldname}.1 > %{buildroot}%{_mandir}/man8/%{oldname}.8
101 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
102 cp -f *.action %{buildroot}%{privoxyconf}/
103 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
104 cp -f trust %{buildroot}%{privoxyconf}/trust
105 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
106 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
107 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
108 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
109
110 # verify all file locations, etc. in the config file
111 # don't start with ^ or commented lines are not replaced
112 ## Changing the sed paramter delimiter to @, so we don't have to
113 ## escape the slashes
114 cat config | \
115     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
116 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
117 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
118 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
119 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
120 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
121 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
122     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
123     %{buildroot}%{privoxyconf}/config
124 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
125     %{buildroot}%{privoxyconf}/default.action
126
127 ## Macros are expanded even on commentaries. So, we have to use %%
128 ## -- morcego
129 #%%makeinstall
130
131 %pre
132 # We check to see if the user privoxy exists.
133 # If it does, we do nothing
134 # If we don't, we check to see if the user junkbust exist and, in case it
135 # does, we change it do junkbuster. If it also does not exist, we create the
136 # privoxy user -- morcego
137 id privoxy > /dev/null 2>&1 
138 if [ $? -eq 1 ]; then
139         id privoxy > /dev/null 2>&1 
140         if [ $? -eq 0 ]; then
141                 /usr/sbin/usermod -l privoxy -d %{_sysconfdir}/%{name} -s "" privoxy  > /dev/null 2>&1
142         else
143                 /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" privoxy > /dev/null 2>&1 
144         fi
145 fi
146
147 %post
148 # for upgrade from 2.0.x
149 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
150  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
151 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
152  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
153 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
154 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
155 if [ "$1" = "1" ]; then
156 #     /sbin/chkconfig --add %{name}
157         /sbin/service %{name} condrestart > /dev/null 2>&1
158 fi
159 # 01/09/02 HB, getting rid of any user=junkbust
160 # Changed by morcego to use the id command.
161 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
162
163 %preun
164 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
165 /sbin/chkconfig --del %{oldname} ||;
166
167 if [ "$1" = "0" ]; then
168         /sbin/service %{name} stop > /dev/null 2>&1 ||:
169 fi
170
171 %postun
172 #if [ "$1" -ge "1" ]; then
173 #       /sbin/service %{name} condrestart > /dev/null 2>&1
174 #fi
175 # dont forget to remove user and group privoxy
176 id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
177
178 %clean
179 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
180
181 %files
182 %defattr(0644,root,root,0755)
183 %doc README AUTHORS ChangeLog
184 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
185 %doc doc/webserver/developer-manual
186 %doc doc/webserver/user-manual
187 %doc doc/webserver/ijb_docs.css
188 #%doc %{name}.weekly %{name}.monthly AUTHORS
189
190 %dir %{privoxyconf}
191 %dir %{privoxyconf}/templates
192 %attr(0744,privoxy,privoxy) %dir %{_localstatedir}/log/%{name}
193
194 %attr(0744,privoxy,privoxy)%{_sbindir}/%{name}
195
196 # We should not use wildchars here. This could mask missing files problems
197 # -- morcego
198 %config %{privoxyconf}/config
199 %config %{privoxyconf}/advanced.action
200 %config %{privoxyconf}/basic.action
201 %config %{privoxyconf}/intermediate.action
202 %config %{privoxyconf}/default.action
203 %config %{privoxyconf}/default.filter
204 %config %{privoxyconf}/trust
205
206 %config %{privoxyconf}/templates/blocked
207 %config %{privoxyconf}/templates/blocked-compact
208 %config %{privoxyconf}/templates/cgi-error-404
209 %config %{privoxyconf}/templates/cgi-error-bad-param
210 %config %{privoxyconf}/templates/cgi-error-disabled
211 %config %{privoxyconf}/templates/cgi-error-file
212 %config %{privoxyconf}/templates/cgi-error-modified
213 %config %{privoxyconf}/templates/cgi-error-parse
214 %config %{privoxyconf}/templates/connect-failed
215 %config %{privoxyconf}/templates/default
216 %config %{privoxyconf}/templates/edit-actions-add-url-form
217 %config %{privoxyconf}/templates/edit-actions-for-url
218 %config %{privoxyconf}/templates/edit-actions-list
219 %config %{privoxyconf}/templates/edit-actions-list-section
220 %config %{privoxyconf}/templates/edit-actions-list-url
221 %config %{privoxyconf}/templates/edit-actions-remove-url-form
222 %config %{privoxyconf}/templates/edit-actions-url-form
223 %config %{privoxyconf}/templates/no-such-domain
224 %config %{privoxyconf}/templates/show-request
225 %config %{privoxyconf}/templates/show-status
226 %config %{privoxyconf}/templates/show-status-file
227 %config %{privoxyconf}/templates/show-url-info
228 %config %{privoxyconf}/templates/show-version
229 %config %{privoxyconf}/templates/toggle
230 %config %{privoxyconf}/templates/toggle-mini
231 %config %{privoxyconf}/templates/untrusted
232
233 %config %{_sysconfdir}/logrotate.d/%{name}
234 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
235 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
236 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
237 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
238 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
239 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/S84%{name}
240 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
241 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/S84%{name}
242
243 %{_mandir}/man1/%{name}.*
244
245 %changelog
246 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
247 + junkbusterng-2.9.13-1
248 - Fixed build problems re: name conflicts with man page and logrotate.
249 - Commented out rc?d/* configs for time being, which are causing a build 
250 - failure.
251
252 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
253 + junkbusterng-2.9.13-1
254 - References to the expression ijb where changed where possible
255 - New package name: junkbusterng (all in lower case, acording to
256   the LSB recomendation)
257 - Version changed to: 2.9.13
258 - Release: 1
259 - Added: junkbuster to obsoletes and conflicts (Not sure this is
260   right. If it obsoletes, why conflict ? Have to check it later)
261 - Summary changed: Stefan, please check and aprove it
262 - Changes description to use the new name
263 - Sed string was NOT changed. Have to wait to the manpage to
264   change first
265 - Keeping the user junkbuster for now. It will require some aditional
266   changes on the script (scheduled for the next specfile release)
267 - Added post entry to move the old logfile to the new log directory
268 - Removing "chkconfig --add" entry (not good to have it automaticaly
269   added to the startup list).
270 - Added preun section to stop the service with the old name, as well
271   as remove it from the startup list
272 - Removed the chkconfig --del entry from the conditional block on
273   the preun scriptlet (now handled on the %files section)
274
275 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
276 - added ijb_docs.css to docs.
277
278 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
279 + junkbuster-2.9.11-8 
280 - Take out --enable-no-gifs, breaks some browsers.
281
282 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
283 + junkbuster-2.9.11-8 
284 - Add --enable-no-gifs to configure.
285
286 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
287 + junkbuster-2.9.11-7
288 - Added BuildRequires to libtool.
289
290 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
291 + junkbuster-2.9.11-6
292 - Changed the routined that handle the junkbust and junkbuster users on
293   %%pre and %%post to work in a smoother manner
294 - %%files now uses hardcoded usernames, to avoid problems with package
295   name changes in the future
296
297 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
298 + junkbuster-2.9.11-5
299 - Added "make redhat-dok" to the build process
300 - Added docbook-utils to BuildRequires
301
302 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
303 + junkbuster-2.9.11-4
304 - Changing man section in the manpage from 1 to 8
305 - We now require packages, not files, to avoid issues with apt
306
307 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
308 + junkbuster-2.9.11-3
309 - Fixing permissions of the init script
310
311 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
312 + junkbuster-2.9.11-2
313 - General specfile fixup, using the best recomended practices, including:
314         - Adding -q to %%setup
315         - Using macros whereever possible
316         - Not using wildchars on %%files section
317         - Doubling the percentage char on changelog and comments, to
318           avoid rpm expanding them
319
320 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
321 - /bin/false for shell causes init script to fail. Reverting.
322
323 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
324 - Removed UID 73. Included user-manual and developer-manual in docs.
325   Include other actions files. Default shell is now /bin/false.
326   Userdel user=junkbust. ChangeLog was not zipped. Removed 
327   RPM_OPT_FLAGS kludge.
328
329 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
330 - add paranoia check for 'rm -rf %%{buildroot}'
331 - add gzip to 'BuildRequires'
332
333 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
334 - actionsfile is now ijb.action.
335
336 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
337 - Compress manpage
338 - Add more documents for installation
339 - Add version string to name and source
340
341 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
342 - Back to user 'junkbuster' and fix configure macro.
343
344 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
345 - More changes for user 'junkbust'. Init script had 'junkbuster'.
346
347 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
348 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
349 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
350
351 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
352 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
353 - made sure no default shell exists for user junkbust.
354
355 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
356 - rework of RPM
357
358 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
359 - CLF Logging patch by davep@cyw.uklinux.net
360 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
361
362 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
363 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
364 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
365   numerous fixes and enhancements for Steve's patch.
366 - adamlock@netscape.com (Adam Lock) in the windows version:
367   - Taskbar activity spinner always spins even when logging is
368   turned off (which is the default) - people who don't
369   like the spinner can turn it off from a menu option.
370   - Taskbar popup menu has a options submenu - people can now
371   open the settings files for cookies, blockers etc.
372   without opening the JB window.
373   - Logging functionality works again
374   - Buffer overflow is fixed - new code uses a bigger buffer
375   and snprintf so it shouldn't overflow anymore.
376 - Fixed userid swa, group learning problem while installing.
377   root must build RPM.
378 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
379   core dump when there is no log file.
380 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
381 - Fixed man page to include imagefile and popupfile.
382 - Sanity check for the statistics function added.
383 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
384  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
385  With IIS/5, it appears to omit the trailing \r\n from http header
386  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
387  responds with a HTTP 302 redirect header.  However, this header
388  message is missing the trailing \r\n.  IIS/5 then closes the
389  connection.  Junkbuster, unfortunately, discards the header becomes
390  it thinks it is incomplete - and it is.  MS have transmitted an
391  incomplete header!
392 - Added bug reports and patch submission forms in the docs.
393
394 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
395        Andrew <anw@tirana.freewire.co.uk> extended the JB:
396        Display of statistics of the total number of requests and the number
397        of requests filtered by junkbuster, also the percentage of requests
398        filtered. Suppression of the listing of files on the proxy-args page.
399        All stuff optional and configurable.
400
401 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
402        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
403        code which prevented the JB from handling URLs of the form
404        user:password@www.foo.com. Fixed.
405
406 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
407         Blank images are no longer cached, thanks to a hint from Markus 
408         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
409         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
410         on the correct browser version nowadays. Incorporated many 
411         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
412         spec file. Fixed logging problem and since runlevel 2 does not 
413         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
414         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
415         <walker@netgate.net>. You should now be able to build this RPM as 
416         a non-root user (mathias@weidner.sem.lipsia.de).
417
418 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
419         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
420         to allow more sophisticated matching of blocked images. Logrotate
421         logfile. Added files for auto-updating the blocklist et al.
422
423 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
424         Configure blank version via config file. No separate blank
425         version anymore. Added Roland's <roland@spinnaker.rhein.de>
426         patch to show a logo instead of a blank area. Added a suggestion
427         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
428         More regexps in the blocklist. Prepared the forwardfile for
429         squid. Extended image regexp with help from gabriel 
430         <somlo@CS.ColoState.EDU>.
431
432 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
433         All RPMs now identify themselves in the show-proxy-args page.
434         Released Windoze version. Run junkbuster as nobody instead of
435         root. 
436
437 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
438         Newest version. First release (hence the little version number
439         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
440         security over 2.0.1; some multi-user sites will need to change 
441         the listen-address in the configuration file. The blank version of
442         the Internet Junkbuster has a more sophisticated way of replacing
443         images. All RPMs identify themselves in the show-proxy-args page.
444
445 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
446         Modified the blocking feature, so that only GIFs and JPEGs are
447         blocked and replaced but not HTML pages. Thanks to 
448         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
449         idea. Added numerous stuff to the blocklist. Keep patches in
450         seperate files and no longer in diffs (easier to maintain).
451
452 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
453         Moved config files to /etc/junkbuster directory, moved man page,
454         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
455         Made new version junkbuster-raw (which is only a stripped version of 
456         the junkuster rpm, i.e. without my blocklist, etc.)
457
458 * Tue Jun 16 1998 (2.0-1)
459         Uhm, not that much. Just a new junkbuster version that
460         fixes a couple of bugs ... and of course a bigger 
461         blocklist with the unique Now-less-ads-than-ever(SM)
462         feature.
463         Oh, one thing: I changed the default user agent to Linux -- no 
464         need anymore to support Apple.
465
466 * Tue Jun 16 1998 (2.0-0)
467         Now-less-ads-than-ever (SM)
468         compiled with gcc instead of cc
469         compiled with -O3, thus it should be a little faster
470         show-proxy-args now works
471         /etc/junkbuster.init wasn't necessary
472
473 * Tue Jun 16 1998 (1.4)
474         some more config files were put into /etc
475         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
476         displayed by Netscape instead of the blocked image.
477         Read http://www.waldherr.org/junkbuster/ for
478         further info.
479
480 * Tue Jun 16 1998 (1.3)
481         The program has been moved to /usr/sbin (from /usr/local/bin)
482         Init- and stopscripts (/etc/rc.d/rc*) have been added so
483         that the junkbuster starts automatically during bootup.
484         The /etc/blocklist file is much more sophisticated. Theoretically
485         one should e.g. browse all major US and German newspapers without
486         seeing one annoying ad.
487         junkbuster.init was modified. It now starts junkbuster with an
488         additional "-r @" flag.
489
490 # $Log: privoxy-rh.spec,v $
491 # Revision 1.4  2002/03/24 13:32:42  swa
492 # name change related issues
493 #
494 # Revision 1.3  2002/03/24 12:56:21  swa
495 # name change related issues.
496 #
497 # Revision 1.2  2002/03/24 11:40:14  swa
498 # name change
499 #
500 # Revision 1.1  2002/03/24 11:23:44  swa
501 # name change
502 #
503 # Revision 1.1  2002/03/22 20:53:03  morcego
504 # - Ongoing process to change name to JunkbusterNG
505 # - configure/configure.in: no change needed
506 # - GNUmakefile.in:
507 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
508 #         - PROGRAM    = jbng@EXEEXT@
509 #         - rh-spec now references as junkbusterng-rh.spec
510 #         - redhat-upload: references changed to junkbusterng-* (package names)
511 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
512 #         - tarball-src: now JunkbusterNG-*
513 #         - install: initscript now junkbusterng.init and junkbusterng (when
514 #                    installed)
515 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
516 # - junkbusterng.spec:
517 #         - References to the expression ijb where changed where possible
518 #         - New package name: junkbusterng (all in lower case, acording to
519 #           the LSB recomendation)
520 #         - Version changed to: 2.9.13
521 #         - Release: 1
522 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
523 #           right. If it obsoletes, why conflict ? Have to check it later)
524 #         - Summary changed: Stefan, please check and aprove it
525 #         - Changes description to use the new name
526 #         - Sed string was NOT changed. Have to wait to the manpage to
527 #           change first
528 #         - Keeping the user junkbuster for now. It will require some aditional
529 #           changes on the script (scheduled for the next specfile release)
530 #         - Added post entry to move the old logfile to the new log directory
531 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
532 #           added to the startup list).
533 #         - Added preun section to stop the service with the old name, as well
534 #           as remove it from the startup list
535 #         - Removed the chkconfig --del entry from the conditional block on
536 #           the preun scriptlet (now handled on the %files section)
537 # - junkbuster.init: renamed to junkbusterng.init
538 # - junkbusterng.init:
539 #         - Changed JB_BIN to jbng
540 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
541 #           be used where necessary (config dir)
542 #
543 # Aditional notes:
544 # - The config directory is /etc/junkbuster yet. Have to change it on the
545 # specfile, after it is changes on the code
546 # - The only files that got renamed on the cvs tree were the rh specfile and
547 # the init file. Some file references got changes on the makefile and on the
548 # rh-spec (as listed above)
549 #
550 # Revision 1.43  2002/03/21 16:04:10  hal9
551 # added ijb_docs.css to %doc
552 #
553 # Revision 1.42  2002/03/12 13:41:18  sarantis
554 # remove hard-coded "ijbswa" string in build phase
555 #
556 # Revision 1.41  2002/03/11 22:58:32  hal9
557 # Remove --enable-no-gifs
558 #
559 # Revision 1.39  2002/03/08 18:57:29  swa
560 # remove user junkbuster after de-installation.
561 #
562 # Revision 1.38  2002/03/08 13:45:27  morcego
563 # Adding libtool to Buildrequires
564 #
565 # Revision 1.37  2002/03/07 19:23:49  swa
566 # i hate to scroll. suse: wrong configdir.
567 #
568 # Revision 1.36  2002/03/07 05:06:54  morcego
569 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
570 #
571 # Revision 1.34  2002/03/07 00:11:57  morcego
572 # Few changes on the %pre and %post sections of the rh specfile to handle
573 # usernames more cleanly
574 #
575 # Revision 1.33  2002/03/05 13:13:57  morcego
576 # - Added "make redhat-dok" to the build phase
577 # - Added docbook-utils to BuildRequires
578 #
579 # Revision 1.32  2002/03/05 12:34:24  morcego
580 # - Changing section internaly on the manpage from 1 to 8
581 # - We now require packages, not files, to avoid issues with apt
582 #
583 # Revision 1.31  2002/03/04 18:06:09  morcego
584 # SPECFILE: fixing permissing of the init script (broken by the last change)
585 #
586 # Revision 1.30  2002/03/04 16:18:03  morcego
587 # General cleanup of the rh specfile.
588 #
589 # %changelog
590 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
591 # + junkbuster-2.9.11-2
592 # - General specfile fixup, using the best recomended practices, including:
593 #         - Adding -q to %%setup
594 #         - Using macros whereever possible
595 #         - Not using wildchars on %%files section
596 #         - Doubling the percentage char on changelog and comments, to
597 #           avoid rpm expanding them
598 #
599 # Revision 1.29  2002/03/03 19:21:22  hal9
600 # Init script fails if shell is /bin/false.
601 #
602 # Revision 1.28  2002/01/09 18:34:03  hal9
603 # nit.
604 #
605 # Revision 1.27  2002/01/09 18:32:02  hal9
606 # Removed RPM_OPT_FLAGS kludge.
607 #
608 # Revision 1.26  2002/01/09 18:21:10  hal9
609 # A few minor updates.
610 #
611 # Revision 1.25  2001/12/28 01:45:36  steudten
612 # Add paranoia check and BuildReq: gzip
613 #
614 # Revision 1.24  2001/12/01 21:43:14  hal9
615 # Allowed for new ijb.action file.
616 #
617 # Revision 1.23  2001/11/06 12:09:03  steudten
618 # Compress doc files. Install README and AUTHORS at last as document.
619 #
620 # Revision 1.22  2001/11/05 21:37:34  steudten
621 # Fix to include the actual version for name.
622 # Let the 'real' packager be included - sorry stefan.
623 #
624 # Revision 1.21  2001/10/31 19:27:27  swa
625 # consistent description. new name for suse since
626 # we had troubles with rpms of identical names
627 # on the webserver.
628 #
629 # Revision 1.20  2001/10/24 15:45:49  hal9
630 # To keep Thomas happy (aka correcting my  mistakes)
631 #
632 # Revision 1.19  2001/10/15 03:23:59  hal9
633 # Nits.
634 #
635 # Revision 1.17  2001/10/10 18:59:28  hal9
636 # Minor change for init script.
637 #
638 # Revision 1.16  2001/09/24 20:56:23  hal9
639 # Minor changes.
640 #
641 # Revision 1.13  2001/09/10 17:44:43  swa
642 # integrate three pieces of documentation. needs work.
643 # will not build cleanly under redhat.
644 #
645 # Revision 1.12  2001/09/10 16:25:04  swa
646 # copy all templates. version updated.
647 #
648 # Revision 1.11  2001/07/03 11:00:25  sarantis
649 # replaced permissionsfile with actionsfile
650 #
651 # Revision 1.10  2001/07/03 09:34:44  sarantis
652 # bumped up version number.
653 #
654 # Revision 1.9  2001/06/12 18:15:29  swa
655 # the %% in front of configure (see tag below) confused
656 # the rpm build process on 7.1.
657 #
658 # Revision 1.8  2001/06/12 17:15:56  swa
659 # fixes, because a clean build on rh6.1 was impossible.
660 # GZIP confuses make, %% configure confuses rpm, etc.
661 #
662 # Revision 1.7  2001/06/11 12:17:26  sarantis
663 # fix typo in %%post
664 #
665 # Revision 1.6  2001/06/11 11:28:25  sarantis
666 # Further optimizations and adaptations in the spec file.
667 #
668 # Revision 1.5  2001/06/09 09:14:11  swa
669 # shamelessly adapted RPM stuff from the newest rpm that
670 # RedHat provided for the JB.
671 #
672 # Revision 1.4  2001/06/08 20:54:18  swa
673 # type with status file. remove forward et. al from file list.
674 #
675 # Revision 1.3  2001/06/07 17:28:10  swa
676 # cosmetics
677 #
678 # Revision 1.2  2001/06/04 18:31:58  swa
679 # files are now prefixed with either `confdir' or `logdir'.
680 # `make redhat-dist' replaces both entries confdir and logdir
681 # with redhat values
682 #
683 # Revision 1.1  2001/06/04 10:44:57  swa
684 # `make redhatr-dist' now works. Except for the paths
685 # in the config file.
686 #
687 #
688 #