Add autoheader, etc.
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.6 2002/03/24 19:56:40 hal9 Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # PRIVOXY team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define oldname junkbuster
31 %define privoxyconf %{_sysconfdir}/%{name}
32
33 Summary: Privoxy - privacy enhancing proxy
34 Vendor: http://ijbswa.sourceforge.net
35 Name: privoxy
36 Version: 2.9.13
37 Release: 1
38 Source0: http://www.waldherr.org/%{name}/privoxy-%{version}.tar.gz
39 License: GPL
40 BuildRoot: %{_tmppath}/%{name}-%{version}-root
41 Group: Networking/Utilities
42 URL: http://ijbswa.sourceforge.net/
43 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
44 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
45 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
46 BuildRequires: perl gzip sed docbook-utils libtool autoconf
47 Conflicts: junkbuster-raw junkbuster-blank junkbuster
48
49 %description 
50 Privoxy is a web proxy with advanced filtering capabilities for
51 protecting privacy, filtering web page content, managing cookies,
52 controlling access, and removing ads, banners, pop-ups and other
53 obnoxious Internet junk. Privoxy has a very flexible configuration and
54 can be customized to suit individual needs and tastes. Internet
55 Privoxy has application for both stand-alone systems and multi-user
56 networks.
57
58 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
59 was originally written by JunkBusters Corporation, and was released as
60 free open-source software under the GNU GPL. Stefan Waldherr made many
61 improvements, and started the SourceForge project to continue
62 development. Several other developers are now contributing.
63
64 %prep
65 %setup -q -c
66
67 %build
68 autoheader
69 autoconf
70 %configure
71 make 
72 make redhat-dok
73
74 ## Explicitily stripping is not recomended.
75 ## This is handled altomaticaly by RPM, and can couse troubles if
76 ## anyone wants to build an unstriped version - morcego
77 #strip %{name}
78
79 %install
80 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
81 mkdir -p %{buildroot}%{_sbindir} \
82          %{buildroot}%{_mandir}/man1 \
83          %{buildroot}%{_localstatedir}/log/%{name} \
84          %{buildroot}%{privoxyconf}/templates \
85          %{buildroot}%{_sysconfdir}/logrotate.d \
86          %{buildroot}%{_sysconfdir}/rc.d/init.d 
87
88 ## Manual gziping of manpages should not be done, once it can
89 ## break the building on some distributions. Anyway, rpm does it
90 ## automagicaly these days
91 ## Gziping the documentation files is not recomended - morcego
92 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
93
94 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
95
96 ## We need to change the man section internaly on the manpage
97 ## -- morcego (sugestion by Hal Burgiss)
98 #cp -f %{name}.1 %{buildroot}%{_mandir}/man8/%{name}.8
99
100 # do we need this???
101 #sed -e 's@^.TH JUNKBUSTER 1@.TH JUNKBUSTER 8@g' %{oldname}.1 > %{buildroot}%{_mandir}/man8/%{oldname}.8
102 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
103 cp -f *.action %{buildroot}%{privoxyconf}/
104 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
105 cp -f trust %{buildroot}%{privoxyconf}/trust
106 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
107 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
108 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
109 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
110
111 # verify all file locations, etc. in the config file
112 # don't start with ^ or commented lines are not replaced
113 ## Changing the sed paramter delimiter to @, so we don't have to
114 ## escape the slashes
115 cat config | \
116     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
117 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
118 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
119 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
120 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
121 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
122 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
123     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
124     %{buildroot}%{privoxyconf}/config
125 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
126     %{buildroot}%{privoxyconf}/default.action
127
128 ## Macros are expanded even on commentaries. So, we have to use %%
129 ## -- morcego
130 #%%makeinstall
131
132 %pre
133 # We check to see if the user privoxy exists.
134 # If it does, we do nothing
135 # If we don't, we check to see if the user junkbust exist and, in case it
136 # does, we change it do junkbuster. If it also does not exist, we create the
137 # privoxy user -- morcego
138 id privoxy > /dev/null 2>&1 
139 if [ $? -eq 1 ]; then
140         id privoxy > /dev/null 2>&1 
141         if [ $? -eq 0 ]; then
142                 /usr/sbin/usermod -l privoxy -d %{_sysconfdir}/%{name} -s "" privoxy  > /dev/null 2>&1
143         else
144                 /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" privoxy > /dev/null 2>&1 
145         fi
146 fi
147
148 %post
149 # for upgrade from 2.0.x
150 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
151  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
152 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
153  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
154 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
155 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
156 if [ "$1" = "1" ]; then
157 #     /sbin/chkconfig --add %{name}
158         /sbin/service %{name} condrestart > /dev/null 2>&1
159 fi
160 # 01/09/02 HB, getting rid of any user=junkbust
161 # Changed by morcego to use the id command.
162 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
163
164 %preun
165 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
166 /sbin/chkconfig --del %{oldname} ||:
167
168 if [ "$1" = "0" ]; then
169         /sbin/service %{name} stop > /dev/null 2>&1 ||:
170 fi
171
172 %postun
173 #if [ "$1" -ge "1" ]; then
174 #       /sbin/service %{name} condrestart > /dev/null 2>&1
175 #fi
176 # dont forget to remove user and group privoxy
177 id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
178
179 %clean
180 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
181
182 %files
183 %defattr(0644,root,root,0755)
184 %doc README AUTHORS ChangeLog
185 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
186 %doc doc/webserver/developer-manual
187 %doc doc/webserver/user-manual
188 %doc doc/webserver/ijb_docs.css
189 #%doc %{name}.weekly %{name}.monthly AUTHORS
190
191 %dir %{privoxyconf}
192 %dir %{privoxyconf}/templates
193 %attr(0744,privoxy,privoxy) %dir %{_localstatedir}/log/%{name}
194
195 %attr(0744,privoxy,privoxy)%{_sbindir}/%{name}
196
197 # We should not use wildchars here. This could mask missing files problems
198 # -- morcego
199 %config %{privoxyconf}/config
200 %config %{privoxyconf}/advanced.action
201 %config %{privoxyconf}/basic.action
202 %config %{privoxyconf}/intermediate.action
203 %config %{privoxyconf}/default.action
204 %config %{privoxyconf}/default.filter
205 %config %{privoxyconf}/trust
206
207 %config %{privoxyconf}/templates/blocked
208 %config %{privoxyconf}/templates/blocked-compact
209 %config %{privoxyconf}/templates/cgi-error-404
210 %config %{privoxyconf}/templates/cgi-error-bad-param
211 %config %{privoxyconf}/templates/cgi-error-disabled
212 %config %{privoxyconf}/templates/cgi-error-file
213 %config %{privoxyconf}/templates/cgi-error-modified
214 %config %{privoxyconf}/templates/cgi-error-parse
215 %config %{privoxyconf}/templates/connect-failed
216 %config %{privoxyconf}/templates/default
217 %config %{privoxyconf}/templates/edit-actions-add-url-form
218 %config %{privoxyconf}/templates/edit-actions-for-url
219 %config %{privoxyconf}/templates/edit-actions-list
220 %config %{privoxyconf}/templates/edit-actions-list-section
221 %config %{privoxyconf}/templates/edit-actions-list-url
222 %config %{privoxyconf}/templates/edit-actions-remove-url-form
223 %config %{privoxyconf}/templates/edit-actions-url-form
224 %config %{privoxyconf}/templates/no-such-domain
225 %config %{privoxyconf}/templates/show-request
226 %config %{privoxyconf}/templates/show-status
227 %config %{privoxyconf}/templates/show-status-file
228 %config %{privoxyconf}/templates/show-url-info
229 %config %{privoxyconf}/templates/show-version
230 %config %{privoxyconf}/templates/toggle
231 %config %{privoxyconf}/templates/toggle-mini
232 %config %{privoxyconf}/templates/untrusted
233
234 %config %{_sysconfdir}/logrotate.d/%{name}
235 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
236 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
237 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
238 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
239 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
240 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/S84%{name}
241 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
242 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/S84%{name}
243
244 %{_mandir}/man1/%{name}.*
245
246 %changelog
247 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
248 + junkbusterng-2.9.13-1
249   Added autoheader. Added autoconf to buildrequires.
250
251 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
252 + junkbusterng-2.9.13-1
253 - Fixed build problems re: name conflicts with man page and logrotate.
254 - Commented out rc?d/* configs for time being, which are causing a build 
255 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
256 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
257
258 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
259 + junkbusterng-2.9.13-1
260 - References to the expression ijb where changed where possible
261 - New package name: junkbusterng (all in lower case, acording to
262   the LSB recomendation)
263 - Version changed to: 2.9.13
264 - Release: 1
265 - Added: junkbuster to obsoletes and conflicts (Not sure this is
266   right. If it obsoletes, why conflict ? Have to check it later)
267 - Summary changed: Stefan, please check and aprove it
268 - Changes description to use the new name
269 - Sed string was NOT changed. Have to wait to the manpage to
270   change first
271 - Keeping the user junkbuster for now. It will require some aditional
272   changes on the script (scheduled for the next specfile release)
273 - Added post entry to move the old logfile to the new log directory
274 - Removing "chkconfig --add" entry (not good to have it automaticaly
275   added to the startup list).
276 - Added preun section to stop the service with the old name, as well
277   as remove it from the startup list
278 - Removed the chkconfig --del entry from the conditional block on
279   the preun scriptlet (now handled on the %files section)
280
281 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
282 - added ijb_docs.css to docs.
283
284 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
285 + junkbuster-2.9.11-8 
286 - Take out --enable-no-gifs, breaks some browsers.
287
288 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
289 + junkbuster-2.9.11-8 
290 - Add --enable-no-gifs to configure.
291
292 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
293 + junkbuster-2.9.11-7
294 - Added BuildRequires to libtool.
295
296 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
297 + junkbuster-2.9.11-6
298 - Changed the routined that handle the junkbust and junkbuster users on
299   %%pre and %%post to work in a smoother manner
300 - %%files now uses hardcoded usernames, to avoid problems with package
301   name changes in the future
302
303 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
304 + junkbuster-2.9.11-5
305 - Added "make redhat-dok" to the build process
306 - Added docbook-utils to BuildRequires
307
308 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
309 + junkbuster-2.9.11-4
310 - Changing man section in the manpage from 1 to 8
311 - We now require packages, not files, to avoid issues with apt
312
313 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
314 + junkbuster-2.9.11-3
315 - Fixing permissions of the init script
316
317 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
318 + junkbuster-2.9.11-2
319 - General specfile fixup, using the best recomended practices, including:
320         - Adding -q to %%setup
321         - Using macros whereever possible
322         - Not using wildchars on %%files section
323         - Doubling the percentage char on changelog and comments, to
324           avoid rpm expanding them
325
326 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
327 - /bin/false for shell causes init script to fail. Reverting.
328
329 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
330 - Removed UID 73. Included user-manual and developer-manual in docs.
331   Include other actions files. Default shell is now /bin/false.
332   Userdel user=junkbust. ChangeLog was not zipped. Removed 
333   RPM_OPT_FLAGS kludge.
334
335 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
336 - add paranoia check for 'rm -rf %%{buildroot}'
337 - add gzip to 'BuildRequires'
338
339 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
340 - actionsfile is now ijb.action.
341
342 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
343 - Compress manpage
344 - Add more documents for installation
345 - Add version string to name and source
346
347 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
348 - Back to user 'junkbuster' and fix configure macro.
349
350 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
351 - More changes for user 'junkbust'. Init script had 'junkbuster'.
352
353 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
354 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
355 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
356
357 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
358 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
359 - made sure no default shell exists for user junkbust.
360
361 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
362 - rework of RPM
363
364 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
365 - CLF Logging patch by davep@cyw.uklinux.net
366 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
367
368 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
369 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
370 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
371   numerous fixes and enhancements for Steve's patch.
372 - adamlock@netscape.com (Adam Lock) in the windows version:
373   - Taskbar activity spinner always spins even when logging is
374   turned off (which is the default) - people who don't
375   like the spinner can turn it off from a menu option.
376   - Taskbar popup menu has a options submenu - people can now
377   open the settings files for cookies, blockers etc.
378   without opening the JB window.
379   - Logging functionality works again
380   - Buffer overflow is fixed - new code uses a bigger buffer
381   and snprintf so it shouldn't overflow anymore.
382 - Fixed userid swa, group learning problem while installing.
383   root must build RPM.
384 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
385   core dump when there is no log file.
386 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
387 - Fixed man page to include imagefile and popupfile.
388 - Sanity check for the statistics function added.
389 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
390  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
391  With IIS/5, it appears to omit the trailing \r\n from http header
392  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
393  responds with a HTTP 302 redirect header.  However, this header
394  message is missing the trailing \r\n.  IIS/5 then closes the
395  connection.  Junkbuster, unfortunately, discards the header becomes
396  it thinks it is incomplete - and it is.  MS have transmitted an
397  incomplete header!
398 - Added bug reports and patch submission forms in the docs.
399
400 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
401        Andrew <anw@tirana.freewire.co.uk> extended the JB:
402        Display of statistics of the total number of requests and the number
403        of requests filtered by junkbuster, also the percentage of requests
404        filtered. Suppression of the listing of files on the proxy-args page.
405        All stuff optional and configurable.
406
407 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
408        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
409        code which prevented the JB from handling URLs of the form
410        user:password@www.foo.com. Fixed.
411
412 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
413         Blank images are no longer cached, thanks to a hint from Markus 
414         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
415         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
416         on the correct browser version nowadays. Incorporated many 
417         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
418         spec file. Fixed logging problem and since runlevel 2 does not 
419         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
420         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
421         <walker@netgate.net>. You should now be able to build this RPM as 
422         a non-root user (mathias@weidner.sem.lipsia.de).
423
424 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
425         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
426         to allow more sophisticated matching of blocked images. Logrotate
427         logfile. Added files for auto-updating the blocklist et al.
428
429 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
430         Configure blank version via config file. No separate blank
431         version anymore. Added Roland's <roland@spinnaker.rhein.de>
432         patch to show a logo instead of a blank area. Added a suggestion
433         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
434         More regexps in the blocklist. Prepared the forwardfile for
435         squid. Extended image regexp with help from gabriel 
436         <somlo@CS.ColoState.EDU>.
437
438 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
439         All RPMs now identify themselves in the show-proxy-args page.
440         Released Windoze version. Run junkbuster as nobody instead of
441         root. 
442
443 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
444         Newest version. First release (hence the little version number
445         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
446         security over 2.0.1; some multi-user sites will need to change 
447         the listen-address in the configuration file. The blank version of
448         the Internet Junkbuster has a more sophisticated way of replacing
449         images. All RPMs identify themselves in the show-proxy-args page.
450
451 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
452         Modified the blocking feature, so that only GIFs and JPEGs are
453         blocked and replaced but not HTML pages. Thanks to 
454         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
455         idea. Added numerous stuff to the blocklist. Keep patches in
456         seperate files and no longer in diffs (easier to maintain).
457
458 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
459         Moved config files to /etc/junkbuster directory, moved man page,
460         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
461         Made new version junkbuster-raw (which is only a stripped version of 
462         the junkuster rpm, i.e. without my blocklist, etc.)
463
464 * Tue Jun 16 1998 (2.0-1)
465         Uhm, not that much. Just a new junkbuster version that
466         fixes a couple of bugs ... and of course a bigger 
467         blocklist with the unique Now-less-ads-than-ever(SM)
468         feature.
469         Oh, one thing: I changed the default user agent to Linux -- no 
470         need anymore to support Apple.
471
472 * Tue Jun 16 1998 (2.0-0)
473         Now-less-ads-than-ever (SM)
474         compiled with gcc instead of cc
475         compiled with -O3, thus it should be a little faster
476         show-proxy-args now works
477         /etc/junkbuster.init wasn't necessary
478
479 * Tue Jun 16 1998 (1.4)
480         some more config files were put into /etc
481         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
482         displayed by Netscape instead of the blocked image.
483         Read http://www.waldherr.org/junkbuster/ for
484         further info.
485
486 * Tue Jun 16 1998 (1.3)
487         The program has been moved to /usr/sbin (from /usr/local/bin)
488         Init- and stopscripts (/etc/rc.d/rc*) have been added so
489         that the junkbuster starts automatically during bootup.
490         The /etc/blocklist file is much more sophisticated. Theoretically
491         one should e.g. browse all major US and German newspapers without
492         seeing one annoying ad.
493         junkbuster.init was modified. It now starts junkbuster with an
494         additional "-r @" flag.
495
496 # $Log: privoxy-rh.spec,v $
497 # Revision 1.6  2002/03/24 19:56:40  hal9
498 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
499 #
500 # Revision 1.4  2002/03/24 13:32:42  swa
501 # name change related issues
502 #
503 # Revision 1.3  2002/03/24 12:56:21  swa
504 # name change related issues.
505 #
506 # Revision 1.2  2002/03/24 11:40:14  swa
507 # name change
508 #
509 # Revision 1.1  2002/03/24 11:23:44  swa
510 # name change
511 #
512 # Revision 1.1  2002/03/22 20:53:03  morcego
513 # - Ongoing process to change name to JunkbusterNG
514 # - configure/configure.in: no change needed
515 # - GNUmakefile.in:
516 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
517 #         - PROGRAM    = jbng@EXEEXT@
518 #         - rh-spec now references as junkbusterng-rh.spec
519 #         - redhat-upload: references changed to junkbusterng-* (package names)
520 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
521 #         - tarball-src: now JunkbusterNG-*
522 #         - install: initscript now junkbusterng.init and junkbusterng (when
523 #                    installed)
524 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
525 # - junkbusterng.spec:
526 #         - References to the expression ijb where changed where possible
527 #         - New package name: junkbusterng (all in lower case, acording to
528 #           the LSB recomendation)
529 #         - Version changed to: 2.9.13
530 #         - Release: 1
531 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
532 #           right. If it obsoletes, why conflict ? Have to check it later)
533 #         - Summary changed: Stefan, please check and aprove it
534 #         - Changes description to use the new name
535 #         - Sed string was NOT changed. Have to wait to the manpage to
536 #           change first
537 #         - Keeping the user junkbuster for now. It will require some aditional
538 #           changes on the script (scheduled for the next specfile release)
539 #         - Added post entry to move the old logfile to the new log directory
540 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
541 #           added to the startup list).
542 #         - Added preun section to stop the service with the old name, as well
543 #           as remove it from the startup list
544 #         - Removed the chkconfig --del entry from the conditional block on
545 #           the preun scriptlet (now handled on the %files section)
546 # - junkbuster.init: renamed to junkbusterng.init
547 # - junkbusterng.init:
548 #         - Changed JB_BIN to jbng
549 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
550 #           be used where necessary (config dir)
551 #
552 # Aditional notes:
553 # - The config directory is /etc/junkbuster yet. Have to change it on the
554 # specfile, after it is changes on the code
555 # - The only files that got renamed on the cvs tree were the rh specfile and
556 # the init file. Some file references got changes on the makefile and on the
557 # rh-spec (as listed above)
558 #
559 # Revision 1.43  2002/03/21 16:04:10  hal9
560 # added ijb_docs.css to %doc
561 #
562 # Revision 1.42  2002/03/12 13:41:18  sarantis
563 # remove hard-coded "ijbswa" string in build phase
564 #
565 # Revision 1.41  2002/03/11 22:58:32  hal9
566 # Remove --enable-no-gifs
567 #
568 # Revision 1.39  2002/03/08 18:57:29  swa
569 # remove user junkbuster after de-installation.
570 #
571 # Revision 1.38  2002/03/08 13:45:27  morcego
572 # Adding libtool to Buildrequires
573 #
574 # Revision 1.37  2002/03/07 19:23:49  swa
575 # i hate to scroll. suse: wrong configdir.
576 #
577 # Revision 1.36  2002/03/07 05:06:54  morcego
578 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
579 #
580 # Revision 1.34  2002/03/07 00:11:57  morcego
581 # Few changes on the %pre and %post sections of the rh specfile to handle
582 # usernames more cleanly
583 #
584 # Revision 1.33  2002/03/05 13:13:57  morcego
585 # - Added "make redhat-dok" to the build phase
586 # - Added docbook-utils to BuildRequires
587 #
588 # Revision 1.32  2002/03/05 12:34:24  morcego
589 # - Changing section internaly on the manpage from 1 to 8
590 # - We now require packages, not files, to avoid issues with apt
591 #
592 # Revision 1.31  2002/03/04 18:06:09  morcego
593 # SPECFILE: fixing permissing of the init script (broken by the last change)
594 #
595 # Revision 1.30  2002/03/04 16:18:03  morcego
596 # General cleanup of the rh specfile.
597 #
598 # %changelog
599 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
600 # + junkbuster-2.9.11-2
601 # - General specfile fixup, using the best recomended practices, including:
602 #         - Adding -q to %%setup
603 #         - Using macros whereever possible
604 #         - Not using wildchars on %%files section
605 #         - Doubling the percentage char on changelog and comments, to
606 #           avoid rpm expanding them
607 #
608 # Revision 1.29  2002/03/03 19:21:22  hal9
609 # Init script fails if shell is /bin/false.
610 #
611 # Revision 1.28  2002/01/09 18:34:03  hal9
612 # nit.
613 #
614 # Revision 1.27  2002/01/09 18:32:02  hal9
615 # Removed RPM_OPT_FLAGS kludge.
616 #
617 # Revision 1.26  2002/01/09 18:21:10  hal9
618 # A few minor updates.
619 #
620 # Revision 1.25  2001/12/28 01:45:36  steudten
621 # Add paranoia check and BuildReq: gzip
622 #
623 # Revision 1.24  2001/12/01 21:43:14  hal9
624 # Allowed for new ijb.action file.
625 #
626 # Revision 1.23  2001/11/06 12:09:03  steudten
627 # Compress doc files. Install README and AUTHORS at last as document.
628 #
629 # Revision 1.22  2001/11/05 21:37:34  steudten
630 # Fix to include the actual version for name.
631 # Let the 'real' packager be included - sorry stefan.
632 #
633 # Revision 1.21  2001/10/31 19:27:27  swa
634 # consistent description. new name for suse since
635 # we had troubles with rpms of identical names
636 # on the webserver.
637 #
638 # Revision 1.20  2001/10/24 15:45:49  hal9
639 # To keep Thomas happy (aka correcting my  mistakes)
640 #
641 # Revision 1.19  2001/10/15 03:23:59  hal9
642 # Nits.
643 #
644 # Revision 1.17  2001/10/10 18:59:28  hal9
645 # Minor change for init script.
646 #
647 # Revision 1.16  2001/09/24 20:56:23  hal9
648 # Minor changes.
649 #
650 # Revision 1.13  2001/09/10 17:44:43  swa
651 # integrate three pieces of documentation. needs work.
652 # will not build cleanly under redhat.
653 #
654 # Revision 1.12  2001/09/10 16:25:04  swa
655 # copy all templates. version updated.
656 #
657 # Revision 1.11  2001/07/03 11:00:25  sarantis
658 # replaced permissionsfile with actionsfile
659 #
660 # Revision 1.10  2001/07/03 09:34:44  sarantis
661 # bumped up version number.
662 #
663 # Revision 1.9  2001/06/12 18:15:29  swa
664 # the %% in front of configure (see tag below) confused
665 # the rpm build process on 7.1.
666 #
667 # Revision 1.8  2001/06/12 17:15:56  swa
668 # fixes, because a clean build on rh6.1 was impossible.
669 # GZIP confuses make, %% configure confuses rpm, etc.
670 #
671 # Revision 1.7  2001/06/11 12:17:26  sarantis
672 # fix typo in %%post
673 #
674 # Revision 1.6  2001/06/11 11:28:25  sarantis
675 # Further optimizations and adaptations in the spec file.
676 #
677 # Revision 1.5  2001/06/09 09:14:11  swa
678 # shamelessly adapted RPM stuff from the newest rpm that
679 # RedHat provided for the JB.
680 #
681 # Revision 1.4  2001/06/08 20:54:18  swa
682 # type with status file. remove forward et. al from file list.
683 #
684 # Revision 1.3  2001/06/07 17:28:10  swa
685 # cosmetics
686 #
687 # Revision 1.2  2001/06/04 18:31:58  swa
688 # files are now prefixed with either `confdir' or `logdir'.
689 # `make redhat-dist' replaces both entries confdir and logdir
690 # with redhat values
691 #
692 # Revision 1.1  2001/06/04 10:44:57  swa
693 # `make redhatr-dist' now works. Except for the paths
694 # in the config file.
695 #
696 #
697 #