9163d8bf7986fdb1cd79509325cd32fd790d9aa5
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.11 2002/03/25 03:09:51 hal9 Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # PRIVOXY team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33
34 Name: privoxy
35 Version: 2.9.13
36 Release: 1
37 Summary: Privoxy - privacy enhancing proxy
38 License: GPL
39 Vendor: http://ijbswa.sourceforge.net
40 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
41 BuildRoot: %{_tmppath}/%{name}-%{version}-root
42 Group: Networking/Utilities
43 URL: http://ijbswa.sourceforge.net/
44 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
45 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
46 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
47 BuildRequires: perl gzip sed docbook-utils libtool autoconf
48 Conflicts: junkbuster-raw junkbuster-blank junkbuster
49
50 %description 
51 Privoxy is a web proxy with advanced filtering capabilities for
52 protecting privacy, filtering web page content, managing cookies,
53 controlling access, and removing ads, banners, pop-ups and other
54 obnoxious Internet junk. Privoxy has a very flexible configuration and
55 can be customized to suit individual needs and tastes. Internet
56 Privoxy has application for both stand-alone systems and multi-user
57 networks.
58
59 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
60 was originally written by JunkBusters Corporation, and was released as
61 free open-source software under the GNU GPL. Stefan Waldherr made many
62 improvements, and started the SourceForge project to continue
63 development. Several other developers are now contributing.
64
65 %prep
66 %setup -q -c
67
68 %build
69 autoheader
70 autoconf
71 %configure
72 make 
73 make redhat-dok
74
75 ## Explicitily stripping is not recomended.
76 ## This is handled altomaticaly by RPM, and can couse troubles if
77 ## anyone wants to build an unstriped version - morcego
78 #strip %{name}
79
80 %install
81 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
82 mkdir -p %{buildroot}%{_sbindir} \
83          %{buildroot}%{_mandir}/man1 \
84          %{buildroot}%{_localstatedir}/log/%{name} \
85          %{buildroot}%{privoxyconf}/templates \
86          %{buildroot}%{_sysconfdir}/logrotate.d \
87          %{buildroot}%{_sysconfdir}/rc.d/init.d 
88
89 ## Manual gziping of manpages should not be done, once it can
90 ## break the building on some distributions. Anyway, rpm does it
91 ## automagicaly these days
92 ## Gziping the documentation files is not recomended - morcego
93 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
94
95 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
96
97 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
98 cp -f *.action %{buildroot}%{privoxyconf}/
99 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
100 cp -f trust %{buildroot}%{privoxyconf}/trust
101 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
102 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
103 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
104 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
105
106 # verify all file locations, etc. in the config file
107 # don't start with ^ or commented lines are not replaced
108 ## Changing the sed paramter delimiter to @, so we don't have to
109 ## escape the slashes
110 cat config | \
111     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
112 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
113 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
114 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
115 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
116 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
117 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
118     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
119     %{buildroot}%{privoxyconf}/config
120 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
121     %{buildroot}%{privoxyconf}/default.action
122
123
124 # Creating ghost init files
125 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
126 for i in 0 1 4 6
127 do
128 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
129 done
130 for i in 2 3 5
131 do
132 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
133 done
134
135 ## Macros are expanded even on commentaries. So, we have to use %%
136 ## -- morcego
137 #%%makeinstall
138
139 %pre
140 # This is where we handle old usernames (junkbust and junkbuster)
141 # I'm not sure we should do that, but this is the way we have been
142 # doing it for some time now -- morcego
143 # We should do it for the group as well -- morcego
144 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
145
146 # Change the group name. Remove anything left behind.
147 groupmod -n %{name} %{oldname} > /dev/null 2>&1 ||:
148 groupmod -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
149 groupdel %{oldname} > /dev/null 2>&1 ||:
150 groupdel %{veryoldname} > /dev/null 2>&1 ||:
151
152 # Same for username
153 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
154 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
155 userdel %{oldname} > /dev/null 2>&1 ||:
156 userdel %{veryoldname} > /dev/null 2>&1 ||:
157
158 # Check to see if everything is okey. Create user if it still does not
159 # exist
160 id %{name} > /dev/null 2>&1
161 if [ $? -eq 1 ]; then
162         /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
163 fi
164
165 %post
166 # for upgrade from 2.0.x
167 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
168  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
169 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
170  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
171 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
172 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
173 if [ "$1" = "1" ]; then
174         /sbin/service %{name} condrestart > /dev/null 2>&1
175 fi
176
177 %preun
178 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
179 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
180
181 if [ "$1" = "0" ]; then
182         /sbin/service %{name} stop > /dev/null 2>&1 ||:
183         # No need to use chkconfig. The %%ghost files will handle it
184 fi
185
186 %postun
187 #if [ "$1" -ge "1" ]; then
188 #       /sbin/service %{name} condrestart > /dev/null 2>&1
189 #fi
190 # We only remove it we this is not an upgrade
191 if [ "$1" = "0" ]; then
192         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
193 fi
194
195 %clean
196 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
197
198 %files
199 %defattr(0644,root,root,0755)
200 %doc README AUTHORS ChangeLog
201 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
202 %doc doc/webserver/developer-manual
203 %doc doc/webserver/user-manual
204 %doc doc/webserver/faq
205 %doc doc/webserver/ijb_docs.css
206
207 %dir %{privoxyconf}
208 %dir %{privoxyconf}/templates
209 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
210
211 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
212
213 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
214 # We should not use wildchars here. This could mask missing files problems
215 # -- morcego
216 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
217 %config %{privoxyconf}/config
218 %config %{privoxyconf}/advanced.action
219 %config %{privoxyconf}/basic.action
220 %config %{privoxyconf}/intermediate.action
221 %config %{privoxyconf}/default.action
222 %config %{privoxyconf}/default.filter
223 %config %{privoxyconf}/trust
224
225 %config %{privoxyconf}/templates/blocked
226 %config %{privoxyconf}/templates/blocked-compact
227 %config %{privoxyconf}/templates/cgi-error-404
228 %config %{privoxyconf}/templates/cgi-error-bad-param
229 %config %{privoxyconf}/templates/cgi-error-disabled
230 %config %{privoxyconf}/templates/cgi-error-file
231 %config %{privoxyconf}/templates/cgi-error-modified
232 %config %{privoxyconf}/templates/cgi-error-parse
233 %config %{privoxyconf}/templates/connect-failed
234 %config %{privoxyconf}/templates/default
235 %config %{privoxyconf}/templates/edit-actions-add-url-form
236 %config %{privoxyconf}/templates/edit-actions-for-url
237 %config %{privoxyconf}/templates/edit-actions-list
238 %config %{privoxyconf}/templates/edit-actions-list-section
239 %config %{privoxyconf}/templates/edit-actions-list-url
240 %config %{privoxyconf}/templates/edit-actions-remove-url-form
241 %config %{privoxyconf}/templates/edit-actions-url-form
242 %config %{privoxyconf}/templates/no-such-domain
243 %config %{privoxyconf}/templates/show-request
244 %config %{privoxyconf}/templates/show-status
245 %config %{privoxyconf}/templates/show-status-file
246 %config %{privoxyconf}/templates/show-url-info
247 %config %{privoxyconf}/templates/show-version
248 %config %{privoxyconf}/templates/toggle
249 %config %{privoxyconf}/templates/toggle-mini
250 %config %{privoxyconf}/templates/untrusted
251
252 %config %{_sysconfdir}/logrotate.d/%{name}
253 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
254 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
255 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
256 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
257 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
258 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
259 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
260 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
261
262 %{_mandir}/man1/%{name}.*
263
264 %changelog
265 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
266 + privoxy-2.9.13-2
267 - Added faq to docs.
268
269 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
270 + privoxy-2.9.13-2
271 - Fixed the init files entries. Now we use %%ghost
272 - improved username (and groupname) handling on the %%pre section. By improved
273   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
274   got it right. No more Mr. Nice Guy.
275 - Removed the userdel call on %%post. No need, once it's complety handled on
276   the %%pre section
277
278 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
279 + junkbusterng-2.9.13-1
280   Added autoheader. Added autoconf to buildrequires.
281
282 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
283 + junkbusterng-2.9.13-1
284 - Fixed build problems re: name conflicts with man page and logrotate.
285 - Commented out rc?d/* configs for time being, which are causing a build 
286 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
287 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
288
289 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
290 + junkbusterng-2.9.13-1
291 - References to the expression ijb where changed where possible
292 - New package name: junkbusterng (all in lower case, acording to
293   the LSB recomendation)
294 - Version changed to: 2.9.13
295 - Release: 1
296 - Added: junkbuster to obsoletes and conflicts (Not sure this is
297   right. If it obsoletes, why conflict ? Have to check it later)
298 - Summary changed: Stefan, please check and aprove it
299 - Changes description to use the new name
300 - Sed string was NOT changed. Have to wait to the manpage to
301   change first
302 - Keeping the user junkbuster for now. It will require some aditional
303   changes on the script (scheduled for the next specfile release)
304 - Added post entry to move the old logfile to the new log directory
305 - Removing "chkconfig --add" entry (not good to have it automaticaly
306   added to the startup list).
307 - Added preun section to stop the service with the old name, as well
308   as remove it from the startup list
309 - Removed the chkconfig --del entry from the conditional block on
310   the preun scriptlet (now handled on the %files section)
311
312 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
313 - added ijb_docs.css to docs.
314
315 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
316 + junkbuster-2.9.11-8 
317 - Take out --enable-no-gifs, breaks some browsers.
318
319 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
320 + junkbuster-2.9.11-8 
321 - Add --enable-no-gifs to configure.
322
323 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
324 + junkbuster-2.9.11-7
325 - Added BuildRequires to libtool.
326
327 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
328 + junkbuster-2.9.11-6
329 - Changed the routined that handle the junkbust and junkbuster users on
330   %%pre and %%post to work in a smoother manner
331 - %%files now uses hardcoded usernames, to avoid problems with package
332   name changes in the future
333
334 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
335 + junkbuster-2.9.11-5
336 - Added "make redhat-dok" to the build process
337 - Added docbook-utils to BuildRequires
338
339 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
340 + junkbuster-2.9.11-4
341 - Changing man section in the manpage from 1 to 8
342 - We now require packages, not files, to avoid issues with apt
343
344 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
345 + junkbuster-2.9.11-3
346 - Fixing permissions of the init script
347
348 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
349 + junkbuster-2.9.11-2
350 - General specfile fixup, using the best recomended practices, including:
351         - Adding -q to %%setup
352         - Using macros whereever possible
353         - Not using wildchars on %%files section
354         - Doubling the percentage char on changelog and comments, to
355           avoid rpm expanding them
356
357 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
358 - /bin/false for shell causes init script to fail. Reverting.
359
360 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
361 - Removed UID 73. Included user-manual and developer-manual in docs.
362   Include other actions files. Default shell is now /bin/false.
363   Userdel user=junkbust. ChangeLog was not zipped. Removed 
364   RPM_OPT_FLAGS kludge.
365
366 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
367 - add paranoia check for 'rm -rf %%{buildroot}'
368 - add gzip to 'BuildRequires'
369
370 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
371 - actionsfile is now ijb.action.
372
373 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
374 - Compress manpage
375 - Add more documents for installation
376 - Add version string to name and source
377
378 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
379 - Back to user 'junkbuster' and fix configure macro.
380
381 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
382 - More changes for user 'junkbust'. Init script had 'junkbuster'.
383
384 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
385 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
386 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
387
388 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
389 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
390 - made sure no default shell exists for user junkbust.
391
392 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
393 - rework of RPM
394
395 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
396 - CLF Logging patch by davep@cyw.uklinux.net
397 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
398
399 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
400 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
401 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
402   numerous fixes and enhancements for Steve's patch.
403 - adamlock@netscape.com (Adam Lock) in the windows version:
404   - Taskbar activity spinner always spins even when logging is
405   turned off (which is the default) - people who don't
406   like the spinner can turn it off from a menu option.
407   - Taskbar popup menu has a options submenu - people can now
408   open the settings files for cookies, blockers etc.
409   without opening the JB window.
410   - Logging functionality works again
411   - Buffer overflow is fixed - new code uses a bigger buffer
412   and snprintf so it shouldn't overflow anymore.
413 - Fixed userid swa, group learning problem while installing.
414   root must build RPM.
415 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
416   core dump when there is no log file.
417 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
418 - Fixed man page to include imagefile and popupfile.
419 - Sanity check for the statistics function added.
420 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
421  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
422  With IIS/5, it appears to omit the trailing \r\n from http header
423  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
424  responds with a HTTP 302 redirect header.  However, this header
425  message is missing the trailing \r\n.  IIS/5 then closes the
426  connection.  Junkbuster, unfortunately, discards the header becomes
427  it thinks it is incomplete - and it is.  MS have transmitted an
428  incomplete header!
429 - Added bug reports and patch submission forms in the docs.
430
431 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
432        Andrew <anw@tirana.freewire.co.uk> extended the JB:
433        Display of statistics of the total number of requests and the number
434        of requests filtered by junkbuster, also the percentage of requests
435        filtered. Suppression of the listing of files on the proxy-args page.
436        All stuff optional and configurable.
437
438 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
439        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
440        code which prevented the JB from handling URLs of the form
441        user:password@www.foo.com. Fixed.
442
443 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
444         Blank images are no longer cached, thanks to a hint from Markus 
445         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
446         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
447         on the correct browser version nowadays. Incorporated many 
448         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
449         spec file. Fixed logging problem and since runlevel 2 does not 
450         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
451         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
452         <walker@netgate.net>. You should now be able to build this RPM as 
453         a non-root user (mathias@weidner.sem.lipsia.de).
454
455 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
456         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
457         to allow more sophisticated matching of blocked images. Logrotate
458         logfile. Added files for auto-updating the blocklist et al.
459
460 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
461         Configure blank version via config file. No separate blank
462         version anymore. Added Roland's <roland@spinnaker.rhein.de>
463         patch to show a logo instead of a blank area. Added a suggestion
464         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
465         More regexps in the blocklist. Prepared the forwardfile for
466         squid. Extended image regexp with help from gabriel 
467         <somlo@CS.ColoState.EDU>.
468
469 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
470         All RPMs now identify themselves in the show-proxy-args page.
471         Released Windoze version. Run junkbuster as nobody instead of
472         root. 
473
474 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
475         Newest version. First release (hence the little version number
476         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
477         security over 2.0.1; some multi-user sites will need to change 
478         the listen-address in the configuration file. The blank version of
479         the Internet Junkbuster has a more sophisticated way of replacing
480         images. All RPMs identify themselves in the show-proxy-args page.
481
482 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
483         Modified the blocking feature, so that only GIFs and JPEGs are
484         blocked and replaced but not HTML pages. Thanks to 
485         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
486         idea. Added numerous stuff to the blocklist. Keep patches in
487         seperate files and no longer in diffs (easier to maintain).
488
489 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
490         Moved config files to /etc/junkbuster directory, moved man page,
491         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
492         Made new version junkbuster-raw (which is only a stripped version of 
493         the junkuster rpm, i.e. without my blocklist, etc.)
494
495 * Tue Jun 16 1998 (2.0-1)
496         Uhm, not that much. Just a new junkbuster version that
497         fixes a couple of bugs ... and of course a bigger 
498         blocklist with the unique Now-less-ads-than-ever(SM)
499         feature.
500         Oh, one thing: I changed the default user agent to Linux -- no 
501         need anymore to support Apple.
502
503 * Tue Jun 16 1998 (2.0-0)
504         Now-less-ads-than-ever (SM)
505         compiled with gcc instead of cc
506         compiled with -O3, thus it should be a little faster
507         show-proxy-args now works
508         /etc/junkbuster.init wasn't necessary
509
510 * Tue Jun 16 1998 (1.4)
511         some more config files were put into /etc
512         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
513         displayed by Netscape instead of the blocked image.
514         Read http://www.waldherr.org/junkbuster/ for
515         further info.
516
517 * Tue Jun 16 1998 (1.3)
518         The program has been moved to /usr/sbin (from /usr/local/bin)
519         Init- and stopscripts (/etc/rc.d/rc*) have been added so
520         that the junkbuster starts automatically during bootup.
521         The /etc/blocklist file is much more sophisticated. Theoretically
522         one should e.g. browse all major US and German newspapers without
523         seeing one annoying ad.
524         junkbuster.init was modified. It now starts junkbuster with an
525         additional "-r @" flag.
526
527 # $Log: privoxy-rh.spec,v $
528 # Revision 1.11  2002/03/25 03:09:51  hal9
529 # Added faq to docs.
530 #
531 # Revision 1.10  2002/03/24 22:16:14  morcego
532 # Just removing some old commentaries.
533 #
534 # Revision 1.9  2002/03/24 22:03:22  morcego
535 # Should be working now. See %changelog for details
536 #
537 # Revision 1.8  2002/03/24 21:13:01  morcego
538 # Tis broken.
539 #
540 # Revision 1.7  2002/03/24 21:07:18  hal9
541 # Add autoheader, etc.
542 #
543 # Revision 1.6  2002/03/24 19:56:40  hal9
544 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
545 #
546 # Revision 1.4  2002/03/24 13:32:42  swa
547 # name change related issues
548 #
549 # Revision 1.3  2002/03/24 12:56:21  swa
550 # name change related issues.
551 #
552 # Revision 1.2  2002/03/24 11:40:14  swa
553 # name change
554 #
555 # Revision 1.1  2002/03/24 11:23:44  swa
556 # name change
557 #
558 # Revision 1.1  2002/03/22 20:53:03  morcego
559 # - Ongoing process to change name to JunkbusterNG
560 # - configure/configure.in: no change needed
561 # - GNUmakefile.in:
562 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
563 #         - PROGRAM    = jbng@EXEEXT@
564 #         - rh-spec now references as junkbusterng-rh.spec
565 #         - redhat-upload: references changed to junkbusterng-* (package names)
566 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
567 #         - tarball-src: now JunkbusterNG-*
568 #         - install: initscript now junkbusterng.init and junkbusterng (when
569 #                    installed)
570 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
571 # - junkbusterng.spec:
572 #         - References to the expression ijb where changed where possible
573 #         - New package name: junkbusterng (all in lower case, acording to
574 #           the LSB recomendation)
575 #         - Version changed to: 2.9.13
576 #         - Release: 1
577 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
578 #           right. If it obsoletes, why conflict ? Have to check it later)
579 #         - Summary changed: Stefan, please check and aprove it
580 #         - Changes description to use the new name
581 #         - Sed string was NOT changed. Have to wait to the manpage to
582 #           change first
583 #         - Keeping the user junkbuster for now. It will require some aditional
584 #           changes on the script (scheduled for the next specfile release)
585 #         - Added post entry to move the old logfile to the new log directory
586 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
587 #           added to the startup list).
588 #         - Added preun section to stop the service with the old name, as well
589 #           as remove it from the startup list
590 #         - Removed the chkconfig --del entry from the conditional block on
591 #           the preun scriptlet (now handled on the %files section)
592 # - junkbuster.init: renamed to junkbusterng.init
593 # - junkbusterng.init:
594 #         - Changed JB_BIN to jbng
595 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
596 #           be used where necessary (config dir)
597 #
598 # Aditional notes:
599 # - The config directory is /etc/junkbuster yet. Have to change it on the
600 # specfile, after it is changes on the code
601 # - The only files that got renamed on the cvs tree were the rh specfile and
602 # the init file. Some file references got changes on the makefile and on the
603 # rh-spec (as listed above)
604 #
605 # Revision 1.43  2002/03/21 16:04:10  hal9
606 # added ijb_docs.css to %doc
607 #
608 # Revision 1.42  2002/03/12 13:41:18  sarantis
609 # remove hard-coded "ijbswa" string in build phase
610 #
611 # Revision 1.41  2002/03/11 22:58:32  hal9
612 # Remove --enable-no-gifs
613 #
614 # Revision 1.39  2002/03/08 18:57:29  swa
615 # remove user junkbuster after de-installation.
616 #
617 # Revision 1.38  2002/03/08 13:45:27  morcego
618 # Adding libtool to Buildrequires
619 #
620 # Revision 1.37  2002/03/07 19:23:49  swa
621 # i hate to scroll. suse: wrong configdir.
622 #
623 # Revision 1.36  2002/03/07 05:06:54  morcego
624 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
625 #
626 # Revision 1.34  2002/03/07 00:11:57  morcego
627 # Few changes on the %pre and %post sections of the rh specfile to handle
628 # usernames more cleanly
629 #
630 # Revision 1.33  2002/03/05 13:13:57  morcego
631 # - Added "make redhat-dok" to the build phase
632 # - Added docbook-utils to BuildRequires
633 #
634 # Revision 1.32  2002/03/05 12:34:24  morcego
635 # - Changing section internaly on the manpage from 1 to 8
636 # - We now require packages, not files, to avoid issues with apt
637 #
638 # Revision 1.31  2002/03/04 18:06:09  morcego
639 # SPECFILE: fixing permissing of the init script (broken by the last change)
640 #
641 # Revision 1.30  2002/03/04 16:18:03  morcego
642 # General cleanup of the rh specfile.
643 #
644 # %changelog
645 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
646 # + junkbuster-2.9.11-2
647 # - General specfile fixup, using the best recomended practices, including:
648 #         - Adding -q to %%setup
649 #         - Using macros whereever possible
650 #         - Not using wildchars on %%files section
651 #         - Doubling the percentage char on changelog and comments, to
652 #           avoid rpm expanding them
653 #
654 # Revision 1.29  2002/03/03 19:21:22  hal9
655 # Init script fails if shell is /bin/false.
656 #
657 # Revision 1.28  2002/01/09 18:34:03  hal9
658 # nit.
659 #
660 # Revision 1.27  2002/01/09 18:32:02  hal9
661 # Removed RPM_OPT_FLAGS kludge.
662 #
663 # Revision 1.26  2002/01/09 18:21:10  hal9
664 # A few minor updates.
665 #
666 # Revision 1.25  2001/12/28 01:45:36  steudten
667 # Add paranoia check and BuildReq: gzip
668 #
669 # Revision 1.24  2001/12/01 21:43:14  hal9
670 # Allowed for new ijb.action file.
671 #
672 # Revision 1.23  2001/11/06 12:09:03  steudten
673 # Compress doc files. Install README and AUTHORS at last as document.
674 #
675 # Revision 1.22  2001/11/05 21:37:34  steudten
676 # Fix to include the actual version for name.
677 # Let the 'real' packager be included - sorry stefan.
678 #
679 # Revision 1.21  2001/10/31 19:27:27  swa
680 # consistent description. new name for suse since
681 # we had troubles with rpms of identical names
682 # on the webserver.
683 #
684 # Revision 1.20  2001/10/24 15:45:49  hal9
685 # To keep Thomas happy (aka correcting my  mistakes)
686 #
687 # Revision 1.19  2001/10/15 03:23:59  hal9
688 # Nits.
689 #
690 # Revision 1.17  2001/10/10 18:59:28  hal9
691 # Minor change for init script.
692 #
693 # Revision 1.16  2001/09/24 20:56:23  hal9
694 # Minor changes.
695 #
696 # Revision 1.13  2001/09/10 17:44:43  swa
697 # integrate three pieces of documentation. needs work.
698 # will not build cleanly under redhat.
699 #
700 # Revision 1.12  2001/09/10 16:25:04  swa
701 # copy all templates. version updated.
702 #
703 # Revision 1.11  2001/07/03 11:00:25  sarantis
704 # replaced permissionsfile with actionsfile
705 #
706 # Revision 1.10  2001/07/03 09:34:44  sarantis
707 # bumped up version number.
708 #
709 # Revision 1.9  2001/06/12 18:15:29  swa
710 # the %% in front of configure (see tag below) confused
711 # the rpm build process on 7.1.
712 #
713 # Revision 1.8  2001/06/12 17:15:56  swa
714 # fixes, because a clean build on rh6.1 was impossible.
715 # GZIP confuses make, %% configure confuses rpm, etc.
716 #
717 # Revision 1.7  2001/06/11 12:17:26  sarantis
718 # fix typo in %%post
719 #
720 # Revision 1.6  2001/06/11 11:28:25  sarantis
721 # Further optimizations and adaptations in the spec file.
722 #
723 # Revision 1.5  2001/06/09 09:14:11  swa
724 # shamelessly adapted RPM stuff from the newest rpm that
725 # RedHat provided for the JB.
726 #
727 # Revision 1.4  2001/06/08 20:54:18  swa
728 # type with status file. remove forward et. al from file list.
729 #
730 # Revision 1.3  2001/06/07 17:28:10  swa
731 # cosmetics
732 #
733 # Revision 1.2  2001/06/04 18:31:58  swa
734 # files are now prefixed with either `confdir' or `logdir'.
735 # `make redhat-dist' replaces both entries confdir and logdir
736 # with redhat values
737 #
738 # Revision 1.1  2001/06/04 10:44:57  swa
739 # `make redhatr-dist' now works. Except for the paths
740 # in the config file.
741 #
742 #
743 #