1 # $Id: junkbuster-suse.spec,v 1.7 2001/09/10 17:44:22 swa Exp $
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team. http://ijbswa.sourceforge.net
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and
8 # Junkbusters Corporation. http://www.junkbusters.com
10 # This program is free software; you can redistribute it
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE. See the GNU General Public
20 # License for more details.
22 # The GNU General Public License should be included with
23 # this file. If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA 02111-1307, USA.
28 # $Log: junkbuster-suse.spec,v $
29 # Revision 1.7 2001/09/10 17:44:22 swa
30 # integrate three pieces of documentation.
32 # Revision 1.6 2001/09/10 16:29:23 swa
33 # binary contained debug info.
34 # buildroot definition fucks up the build process under suse.
35 # program needs to write in varlogjunkbuster
36 # install all templates
37 # create varlogjunkbuster
39 # Revision 1.5 2001/06/09 09:13:29 swa
42 # Revision 1.4 2001/06/08 20:53:36 swa
43 # use buildroot, export init to separate file (better manageability)
45 # Revision 1.3 2001/06/07 17:28:10 swa
48 # Revision 1.2 2001/06/07 17:18:44 swa
53 # usedforbuild -ijb aaa_base aaa_dir autoconf automake base bash bindutil binutils bison bzip compress cpio cracklib db devs diffutils e2fsprogs file fileutils findutils flex gawk gcc gdbm gdbm-devel gettext glibc glibc-devel gpm gppshare groff gzip kbd less libtool libz lx_suse make mktemp modutils ncurses ncurses-devel net-tools netcfg nkitb pam pam-devel patch perl pgp ps rcs rpm sendmail sh-utils shadow strace syslogd sysvinit texinfo textutils timezone unzip util-linux vim xdevel xf86 xshared
55 Vendor: http://ijbswa.sourceforge.net
56 Distribution: defineme
58 Packager: Stefan Waldherr <stefan@waldherr.org>
61 # buildroot does not work under f*cking suse :-(
62 #BuildRoot: /tmp/junkbuster-rpmbuild
63 Group: Networking/Utilities
69 Summary: The Internet Junkbuster
70 Source: http://www.waldherr.org/junkbuster/ijbswa.tar.gz
73 # -----------------------------------------------------------------------------
76 The Internet Junkbuster is an application that provides privacy and
77 security to the user of the world wide web. It controls cookies,
78 removes advertisements or pop-up windows. You can actually modify the
79 content of web pages on-the-fly.
83 http://ijbswa.sourceforge.net
88 # -----------------------------------------------------------------------------
94 # -----------------------------------------------------------------------------
102 # -----------------------------------------------------------------------------
105 rm -rf $RPM_BUILD_ROOT
106 mkdir -p $RPM_BUILD_ROOT/{var/log/junkbuster,usr/{sbin,share/man/man1,share/doc/packages/junkbuster,share/doc/packages/junkbuster/user-manual,share/doc/packages/junkbuster/developer-manual,share/doc/packages/junkbuster/faq},etc/{junkbuster,junkbuster/templates,init.d}}
108 # make sure that we can write in the log directory
109 chown nobody.nogroup $RPM_BUILD_ROOT/var/log/junkbuster
110 install -m 755 junkbuster.init.suse $RPM_BUILD_ROOT/etc/init.d/junkbuster
111 # next line might require an additional rpm_build_root
112 ln -sf /etc/init.d/junkbuster $RPM_BUILD_ROOT/usr/sbin/rcjunkbuster
114 install -m 755 junkbuster $RPM_BUILD_ROOT/usr/sbin
115 install -d $RPM_BUILD_ROOT/etc/junkbuster
116 install -d $RPM_BUILD_ROOT/etc/junkbuster/templates
117 install -m 644 actionsfile $RPM_BUILD_ROOT/etc/junkbuster
118 install -m 644 re_filterfile $RPM_BUILD_ROOT/etc/junkbuster
119 # verify all file locations, etc. in the config file
120 # don't start with ^ or commented lines are not replaced
122 sed 's/^confdir.*/confdir \/etc\/junkbuster/g' | \
123 sed 's/^actionsfile.*/actionsfile \/etc\/junkbuster\/actionsfile/g' | \
124 # sed 's/^re_filterfile.*/re_filterfile \/etc\/junkbuster\/re_filterfile/g' | \
125 # sed 's/^logfile.*/logfile \/var\/log\/junkbuster\/logfile/g' | \
126 # sed 's/^jarfile.*/jarfile \/var\/log\/junkbuster\/jarfile/g' | \
127 # sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
128 # sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
129 sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
131 cp -f config.tmp config
132 install -m 644 config $RPM_BUILD_ROOT/etc/junkbuster
133 #install -m 644 forward $RPM_BUILD_ROOT/etc/junkbuster
134 install -m 644 trust $RPM_BUILD_ROOT/etc/junkbuster
135 install -m 644 templates/* $RPM_BUILD_ROOT/etc/junkbuster/templates
136 # install -m 644 junkbuster.1 $RPM_BUILD_ROOT/usr/share/man/man1
137 cp -r doc/webserver/user-manual $RPM_BUILD_ROOT/usr/share/doc/packages/junkbuster
138 cp -r doc/webserver/developer-manual $RPM_BUILD_ROOT/usr/share/doc/packages/junkbuster
139 cp -r doc/webserver/faq $RPM_BUILD_ROOT/usr/share/doc/packages/junkbuster
143 # -----------------------------------------------------------------------------
146 sbin/insserv etc/init.d/junkbuster
149 # -----------------------------------------------------------------------------
152 sbin/insserv etc/init.d/
155 # -----------------------------------------------------------------------------
158 %doc /usr/share/doc/packages/junkbuster/faq/
159 %doc /usr/share/doc/packages/junkbuster/user-manual/
160 %doc /usr/share/doc/packages/junkbuster/developer-manual/
162 #/usr/share/man/man1/junkbuster.1.gz
163 %config(noreplace) /etc/junkbuster
164 /etc/init.d/junkbuster
165 /usr/sbin/rcjunkbuster
169 # -----------------------------------------------------------------------------
171 %changelog -n junkbuster
172 * Sun Jun 3 2001 Stefan Waldherr <stefan@waldherr.org>
174 * Wed Feb 14 2001 - uli@suse.de
176 * Wed Dec 06 2000 - bjacke@suse.de
177 - renamed package to junkbuster
178 - fixed copyright tag
179 * Thu Nov 30 2000 - uli@suse.de
180 - moved init script to /etc/init.d
181 * Wed Feb 16 2000 - kukuk@suse.de
182 - Move /usr/man -> /usr/share/man
183 - Mark /etc/ijb as "config(noreplace)"
184 * Mon Sep 20 1999 - uli@suse.de
186 * Mon Sep 13 1999 - bs@suse.de
187 - ran old prepare_spec on spec file to switch to new prepare_spec.
188 * Thu Apr 01 1999 - daniel@suse.de
189 - do not start ijb as root (security)
190 * Tue Mar 30 1999 - daniel@suse.de
191 - don“t use saclfile.ini
192 * Tue Mar 30 1999 - daniel@suse.de
193 - small fix to whitelist-configuration,
194 version is and was 2.0.2 WITHOUT Stefan Waldherr's patches
195 (http://www.waldherr.org/junkbuster/)
196 * Mon Mar 01 1999 - daniel@suse.de
197 - new package: version 2.0