Tiny English fix: infos -> info
[privoxy.git] / privoxy-suse.spec
index d2df32b..a6bf9f8 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: privoxy-suse.spec,v 1.7 2002/03/27 00:49:39 hal9 Exp $
+# $Id: privoxy-suse.spec,v 1.13 2002/04/11 10:09:20 oes Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
 # Privoxy team. http://www.privoxy.org/
@@ -16,7 +16,7 @@
 # This program is distributed in the hope that it will
 # be useful, but WITHOUT ANY WARRANTY; without even the
 # implied warranty of MERCHANTABILITY or FITNESS FOR A
-# PARTICULAR PURPOSE.  See the GNU General Public
+# PARTICULAR PURPOSE.  See the GNU General Public 
 # License for more details.
 #
 # The GNU General Public License should be included with
 #
 
 # do not set to %{name}
-%define ijbconf %{_sysconfdir}/privoxy
+%define privoxyconf %{_sysconfdir}/privoxy
 
 Summary:      Privoxy - privacy enhancing proxy
 Vendor:       http://www.privoxy.org
 Name:         privoxy-suse
 Distribution: defineme
-Version: 2.9.13
+Version: 2.9.14
 Release: 1
-Source: http://www.waldherr.org/%{name}/privoxy-%{version}.tar.gz
+# Needs makefile change: Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}-%{status}-src.tar.gz
+Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}.tar.gz
 # not sure if this works
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Packager:     Stefan Waldherr <stefan@waldherr.org>
 Copyright:    GPL
 Group:        Networking/Utilities
 URL:          http://www.privoxy.org/
-Provides:     privoxy
-Obsoletes:    privoxy
 Autoreqprov:  on
-BuildRequires: perl gzip docbktls libtool
-Conflicts: junkbuster-raw junkbuster-blank junkbuster
+BuildRequires: perl gzip libtool autoconf
+Conflicts: junkbuster-raw junkbuster-blank junkbuster-suse junkbuster privoxy
 
 #
 # -----------------------------------------------------------------------------
@@ -59,11 +58,7 @@ obnoxious Internet junk. Privoxy has a very flexible configuration and
 can be customized to suit individual needs and tastes. Privoxy has 
 application for both stand-alone systems and multi-user networks.
 
-Privoxy is based on the code of the Internet Junkbuster. Junkbuster
-was originally written by JunkBusters Corporation, and was released as
-free open-source software under the GNU GPL. Stefan Waldherr made many
-improvements, and started the SourceForge project to continue
-development. Several other developers are now contributing.
+Privoxy is based on the  Internet Junkbuster.
 
 Authors:
 --------
@@ -85,7 +80,7 @@ autoheader
 autoconf
 ./configure
 make
-make dok
+
 
 ## Explicitily stripping is not recomended.
 ## This is handled altomaticaly by RPM, and can couse troubles if
@@ -100,16 +95,16 @@ make dok
 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
          ${RPM_BUILD_ROOT}%{_mandir}/man8 \
          ${RPM_BUILD_ROOT}/var/log/privoxy \
-         ${RPM_BUILD_ROOT}%{ijbconf}/templates \
+         ${RPM_BUILD_ROOT}%{privoxyconf}/templates \
          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
          ${RPM_BUILD_ROOT}%{_sysconfdir}/init.d
-gzip README AUTHORS ChangeLog privoxy.1 || /bin/true
+gzip README AUTHORS ChangeLog privoxy.1 LICENSE || /bin/true
 install -s -m 744 privoxy $RPM_BUILD_ROOT%{_sbindir}/privoxy
 cp -f privoxy.1.gz $RPM_BUILD_ROOT%{_mandir}/man8/privoxy.8.gz
-cp -f *.action $RPM_BUILD_ROOT%{ijbconf}/
-cp -f default.filter $RPM_BUILD_ROOT%{ijbconf}/default.filter
-cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
-cp -f templates/*  $RPM_BUILD_ROOT%{ijbconf}/templates/
+cp -f *.action $RPM_BUILD_ROOT%{privoxyconf}/
+cp -f default.filter $RPM_BUILD_ROOT%{privoxyconf}/default.filter
+cp -f trust $RPM_BUILD_ROOT%{privoxyconf}/trust
+cp -f templates/*  $RPM_BUILD_ROOT%{privoxyconf}/templates/
 cp -f privoxy.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/privoxy
 install -m 755 privoxy.init.suse $RPM_BUILD_ROOT%{_sysconfdir}/init.d/privoxy
 install -m 711 -d $RPM_BUILD_ROOT/var/log/privoxy
@@ -126,7 +121,7 @@ cat config | \
 #    sed 's/^forward.*/forward \/etc\/privoxy\/forward/g' | \
 #    sed 's/^aclfile.*/aclfile \/etc\/privoxy\/aclfile/g' > \
     sed 's/^logdir.*/logdir \/var\/log\/privoxy/g' > \
-    $RPM_BUILD_ROOT%{ijbconf}/config
+    $RPM_BUILD_ROOT%{privoxyconf}/config
 
 #
 # -----------------------------------------------------------------------------
@@ -195,14 +190,16 @@ id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
 #
 %files
 %defattr(-,root,root)
-%doc README.gz AUTHORS.gz ChangeLog.gz
-%doc doc/webserver/developer-manual doc/webserver/user-manual
+%doc README.gz AUTHORS.gz ChangeLog.gz LICENSE.gz
+%doc doc/webserver/developer-manual
 %doc doc/webserver/user-manual
 %doc doc/webserver/faq
 %doc doc/webserver/p_doc.css
+%doc doc/webserver/p_web.css
+%doc doc/webserver/index.html
 #%doc privoxy.weekly privoxy.monthly AUTHORS
-%dir %{ijbconf}
-%config %{ijbconf}/*
+%dir %{privoxyconf}
+%config %{privoxyconf}/*
 %attr(0744,privoxy,privoxy) %dir /var/log/privoxy
 %config %{_sysconfdir}/logrotate.d/privoxy
 %attr(0755,root,root)/usr/sbin/privoxy
@@ -214,6 +211,11 @@ id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
 # -----------------------------------------------------------------------------
 #
 %changelog
+* Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.13-4
+- Add LICENSE.gz, p_web.css, and index.html. Add autoconf
+- to Buildrequires.
+
 * Wed Mar 27 2002 Hal Burgiss <hal@foobox.net>
 + privoxy-2.9.13-3
 - Doc css has changed names.
@@ -294,6 +296,24 @@ id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
 - new package: version 2.0
 
 # $Log: privoxy-suse.spec,v $
+# Revision 1.13  2002/04/11 10:09:20  oes
+# Version 2.9.14
+#
+# Revision 1.12  2002/04/09 13:29:43  swa
+# build suse and gen-dist with html docs. do not generate docs while building rpm
+#
+# Revision 1.11  2002/04/09 03:12:37  hal9
+# Add LICENSE, p_web.css and index.html. Add autoconf to buildrequires.
+#
+# Revision 1.10  2002/04/08 20:24:13  swa
+# fixed JB spelling
+#
+# Revision 1.9  2002/03/30 09:01:52  swa
+# new release
+#
+# Revision 1.8  2002/03/27 23:46:41  hal9
+# ijb_docs.css to p_doc.css
+#
 # Revision 1.7  2002/03/27 00:49:39  hal9
 # Minor fix to description.
 #