Update for Georg.
[privoxy.git] / privoxy-suse.spec
index afdad96..93aa7aa 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: privoxy-suse.spec,v 1.16 2002/04/22 16:32:31 morcego Exp $
+# $Id: privoxy-suse.spec,v 1.20 2002/05/25 02:08:23 hal9 Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
 # Privoxy team. http://www.privoxy.org/
 
 # do not set to %{name}
 %define privoxyconf %{_sysconfdir}/privoxy
+%define privoxy_uid 73
+%define privoxy_gid 73
+
 
 Summary:      Privoxy - privacy enhancing proxy
 Vendor:       Privoxy.Org
 Name:         privoxy-suse
 Distribution: defineme
-Version: 2.9.14
-Release: 3
+Version: 2.9.15
+Release: 1
 # Needs makefile change: Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}-%{status}-src.tar.gz
 Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}.tar.gz
 # not sure if this works
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Packager:     Stefan Waldherr <stefan@waldherr.org>
-License:    GPL
+License:     GPL
 Group:        Networking/Utilities
 URL:          http://www.privoxy.org/
 Autoreqprov:  on
@@ -136,11 +139,11 @@ id privoxy > /dev/null 2>&1
 if [ $? -eq 1 ]; then
        id junkbust > /dev/null 2>&1 
        if [ $? -eq 0 ]; then
-               /usr/sbin/usermod -l privoxy -d %{_sysconfdir}/privoxy -s "" junkbust  > /dev/null 2>&1
+               /usr/sbin/usermod -u %{privoxy_uid} -g %{privoxy_gid} -l privoxy -d %{_sysconfdir}/privoxy -s "" junkbust  > /dev/null 2>&1
        else
 # -r does not work on suse.
-               /usr/sbin/groupadd privoxy
-               /usr/sbin/useradd -d %{_sysconfdir}/privoxy -g privoxy -s "" privoxy > /dev/null 2>&1 
+               /usr/sbin/groupadd -g %{privoxy_gid} privoxy
+               /usr/sbin/useradd -u %{privoxy_uid} -d %{_sysconfdir}/privoxy -g privoxy -s "" privoxy > /dev/null 2>&1 
        fi
 fi
 
@@ -196,7 +199,8 @@ id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
 %doc doc/webserver/faq
 %doc doc/webserver/p_doc.css
 %doc doc/webserver/p_web.css
-%doc doc/webserver/index.html
+%doc doc/webserver/privoxy-index.html
+%doc doc/webserver/images
 #%doc privoxy.weekly privoxy.monthly AUTHORS
 %dir %{privoxyconf}
 %config %{privoxyconf}/*
@@ -211,6 +215,18 @@ id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
 # -----------------------------------------------------------------------------
 #
 %changelog
+* Mon May 27 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.15-1
+- Index.html is now privoxy-index.html.
+
+* Fri May 24 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.15-1
+- Add doc/images directory.
+
+* Fri May 03 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
++ privoxy-suse-2.9.15-1
+- Version bump
+
 * Fri Apr 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
 + privoxy-suse-2.9.14-3
 - Changing Vendor to Privoxy.Org
@@ -307,6 +323,22 @@ id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
 - new package: version 2.0
 
 # $Log: privoxy-suse.spec,v $
+# Revision 1.20  2002/05/25 02:08:23  hal9
+# Add doc/images directory.
+# Redhat: alphabetized list of templates (and I think added one in the process)
+#
+# Revision 1.19  2002/05/03 17:14:36  morcego
+# *.spec: Version bump to 2.9.15
+# -rh.spec: noreplace for %%{privoxyconf}/config
+#           Will interrupt the build if versions from configure.in and
+#              specfile do not match
+#
+# Revision 1.18  2002/04/27 20:26:59  swa
+# uid, gui 73 incorporated
+#
+# Revision 1.17  2002/04/26 15:51:05  morcego
+# Changing Vendor value to Privoxy.Org
+#
 # Revision 1.16  2002/04/22 16:32:31  morcego
 # configure.in, *.spec: Bumping release to 2 (2.9.14-2)
 # -rh.spec: uid and gid are now macros