Update for Georg.
[privoxy.git] / privoxy-suse.spec
index a921b83..93aa7aa 100644 (file)
@@ -1,7 +1,7 @@
-# $Id: junkbuster-suse.spec,v 1.21 2002/03/21 16:04:33 hal9 Exp $
+# $Id: privoxy-suse.spec,v 1.20 2002/05/25 02:08:23 hal9 Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
-# IJBSWA team.  http://ijbswa.sourceforge.net
+# Privoxy team. http://www.privoxy.org/
 #
 # Based on the Internet Junkbuster originally written
 # by and Copyright (C) 1997 Anonymous Coders and 
@@ -16,7 +16,7 @@
 # This program is distributed in the hope that it will
 # be useful, but WITHOUT ANY WARRANTY; without even the
 # implied warranty of MERCHANTABILITY or FITNESS FOR A
-# PARTICULAR PURPOSE.  See the GNU General Public
+# PARTICULAR PURPOSE.  See the GNU General Public 
 # License for more details.
 #
 # The GNU General Public License should be included with
 #
 
 # do not set to %{name}
-%define ijbconf %{_sysconfdir}/junkbuster
+%define privoxyconf %{_sysconfdir}/privoxy
+%define privoxy_uid 73
+%define privoxy_gid 73
 
-Summary:      The Internet Junkbuster
-Vendor:       http://ijbswa.sourceforge.net
-Name:         junkbuster-suse
+
+Summary:      Privoxy - privacy enhancing proxy
+Vendor:       Privoxy.Org
+Name:         privoxy-suse
 Distribution: defineme
-Version: 2.9.11
-Release: 3
-Source: http://www.waldherr.org/%{name}/ijbswa-%{version}.tar.gz
+Version: 2.9.15
+Release: 1
+# Needs makefile change: Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}-%{status}-src.tar.gz
+Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}.tar.gz
 # not sure if this works
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Packager:     Stefan Waldherr <stefan@waldherr.org>
-Copyright:    GPL
+License:     GPL
 Group:        Networking/Utilities
-URL: http://ijbswa.sourceforge.net/
-Provides:     ijb
-Obsoletes:    ijb
+URL:          http://www.privoxy.org/
 Autoreqprov:  on
-BuildRequires: perl gzip docbktls libtool
+BuildRequires: perl gzip libtool autoconf
+Conflicts: junkbuster-raw junkbuster-blank junkbuster-suse junkbuster privoxy
 
 #
 # -----------------------------------------------------------------------------
 #
 %description
-Internet Junkbuster is a web proxy with advanced filtering
-capabilities for protecting privacy, filtering web page content,
-managing cookies, controlling access, and removing ads, banners,
-pop-ups and other obnoxious Internet Junk. Junkbuster has a very
-flexible configuration and can be customized to suit individual needs
-and tastes. Internet Junkbuster has application for both stand-alone
-systems and multi-user networks.
+Privoxy is a web proxy with advanced filtering capabilities for
+protecting privacy, filtering web page content, managing cookies,
+controlling access, and removing ads, banners, pop-ups and other
+obnoxious Internet junk. Privoxy has a very flexible configuration and
+can be customized to suit individual needs and tastes. Privoxy has 
+application for both stand-alone systems and multi-user networks.
+
+Privoxy is based on the  Internet Junkbuster.
 
 Authors:
 --------
-    http://ijbswa.sourceforge.net
+    http://www.privoxy.org/
 
 SuSE series: n
 
@@ -77,14 +81,14 @@ SuSE series: n
 %build
 autoheader
 autoconf
-./configure
+./configure --disable-dynamic-pcre
 make
-make dok
+
 
 ## Explicitily stripping is not recomended.
 ## This is handled altomaticaly by RPM, and can couse troubles if
 ## anyone wants to build an unstriped version - morcego
-#strip junkbuster
+#strip privoxy
 
 #
 # -----------------------------------------------------------------------------
@@ -93,53 +97,53 @@ make dok
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
          ${RPM_BUILD_ROOT}%{_mandir}/man8 \
-         ${RPM_BUILD_ROOT}/var/log/junkbuster \
-         ${RPM_BUILD_ROOT}%{ijbconf}/templates \
+         ${RPM_BUILD_ROOT}/var/log/privoxy \
+         ${RPM_BUILD_ROOT}%{privoxyconf}/templates \
          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
          ${RPM_BUILD_ROOT}%{_sysconfdir}/init.d
-gzip README AUTHORS ChangeLog junkbuster.1 || /bin/true
-install -s -m 744 junkbuster $RPM_BUILD_ROOT%{_sbindir}/junkbuster
-cp -f junkbuster.1.gz $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8.gz
-cp -f *.action $RPM_BUILD_ROOT%{ijbconf}/
-cp -f re_filterfile $RPM_BUILD_ROOT%{ijbconf}/re_filterfile
-cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
-cp -f templates/*  $RPM_BUILD_ROOT%{ijbconf}/templates/
-cp -f junkbuster.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/junkbuster
-install -m 755 junkbuster.init.suse $RPM_BUILD_ROOT%{_sysconfdir}/init.d/junkbuster
-install -m 711 -d $RPM_BUILD_ROOT/var/log/junkbuster
-ln -sf /etc/init.d/junkbuster $RPM_BUILD_ROOT/usr/sbin/rcjunkbuster
+gzip README AUTHORS ChangeLog privoxy.1 LICENSE || /bin/true
+install -s -m 744 privoxy $RPM_BUILD_ROOT%{_sbindir}/privoxy
+cp -f privoxy.1.gz $RPM_BUILD_ROOT%{_mandir}/man8/privoxy.8.gz
+cp -f *.action $RPM_BUILD_ROOT%{privoxyconf}/
+cp -f default.filter $RPM_BUILD_ROOT%{privoxyconf}/default.filter
+cp -f trust $RPM_BUILD_ROOT%{privoxyconf}/trust
+cp -f templates/*  $RPM_BUILD_ROOT%{privoxyconf}/templates/
+cp -f privoxy.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/privoxy
+install -m 755 privoxy.init.suse $RPM_BUILD_ROOT%{_sysconfdir}/init.d/privoxy
+install -m 711 -d $RPM_BUILD_ROOT/var/log/privoxy
+ln -sf /etc/init.d/privoxy $RPM_BUILD_ROOT/usr/sbin/rcprivoxy
 
 # verify all file locations, etc. in the config file
 # don't start with ^ or commented lines are not replaced
 cat config | \
-    sed 's/^confdir.*/confdir \/etc\/junkbuster/g' | \
-#    sed 's/^permissionsfile.*/permissionsfile \/etc\/junkbuster\/permissionsfile/g' | \
-#    sed 's/^re_filterfile.*/re_filterfile \/etc\/junkbuster\/re_filterfile/g' | \
-#    sed 's/^logfile.*/logfile \/var\/log\/junkbuster\/logfile/g' | \
-#    sed 's/^jarfile.*/jarfile \/var\/log\/junkbuster\/jarfile/g' | \
-#    sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
-#    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
-    sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
-    $RPM_BUILD_ROOT%{ijbconf}/config
+    sed 's/^confdir.*/confdir \/etc\/privoxy/g' | \
+#    sed 's/^permissionsfile.*/permissionsfile \/etc\/privoxy\/permissionsfile/g' | \
+#    sed 's/^filterfile.*/default.filter \/etc\/privoxy\/default.filter/g' | \
+#    sed 's/^logfile.*/logfile \/var\/log\/privoxy\/logfile/g' | \
+#    sed 's/^jarfile.*/jarfile \/var\/log\/privoxy\/jarfile/g' | \
+#    sed 's/^forward.*/forward \/etc\/privoxy\/forward/g' | \
+#    sed 's/^aclfile.*/aclfile \/etc\/privoxy\/aclfile/g' > \
+    sed 's/^logdir.*/logdir \/var\/log\/privoxy/g' > \
+    $RPM_BUILD_ROOT%{privoxyconf}/config
 
 #
 # -----------------------------------------------------------------------------
 #
 %pre
-# We check to see if the user junkbuster exists.
+# We check to see if the user privoxy exists.
 # If it does, we do nothing
 # If we don't, we check to see if the user junkbust exist and, in case it
-# does, we change it do junkbuster. If it also does not exist, we create the
-# junkbuster user -- morcego
-id junkbuster > /dev/null 2>&1 
+# does, we change it do privoxy. If it also does not exist, we create the
+# privoxy user -- morcego
+id privoxy > /dev/null 2>&1 
 if [ $? -eq 1 ]; then
        id junkbust > /dev/null 2>&1 
        if [ $? -eq 0 ]; then
-               /usr/sbin/usermod -l junkbuster -d %{_sysconfdir}/junkbuster -s "" junkbust  > /dev/null 2>&1
+               /usr/sbin/usermod -u %{privoxy_uid} -g %{privoxy_gid} -l privoxy -d %{_sysconfdir}/privoxy -s "" junkbust  > /dev/null 2>&1
        else
 # -r does not work on suse.
-               /usr/sbin/groupadd junkbuster
-               /usr/sbin/useradd -d %{_sysconfdir}/junkbuster -g junkbuster -s "" junkbuster > /dev/null 2>&1 
+               /usr/sbin/groupadd -g %{privoxy_gid} privoxy
+               /usr/sbin/useradd -u %{privoxy_uid} -d %{_sysconfdir}/privoxy -g privoxy -s "" privoxy > /dev/null 2>&1 
        fi
 fi
 
@@ -147,19 +151,19 @@ fi
 # -----------------------------------------------------------------------------
 #
 %post
-[ -f /var/log/junkbuster/junkbuster ] &&\
- mv -f /var/log/junkbuster/junkbuster /var/log/junkbuster/logfile || /bin/true
-chown -R junkbuster:junkbuster /var/log/junkbuster 2>/dev/null
-chown -R junkbuster:junkbuster /etc/junkbuster 2>/dev/null
+[ -f /var/log/privoxy/privoxy ] &&\
+ mv -f /var/log/privoxy/privoxy /var/log/privoxy/logfile || /bin/true
+chown -R privoxy:privoxy /var/log/privoxy 2>/dev/null
+chown -R privoxy:privoxy /etc/privoxy 2>/dev/null
 # not available on suse
 #if [ "$1" = "1" ]; then
-#     /sbin/chkconfig --add junkbuster
-#      /sbin/service junkbuster condrestart > /dev/null 2>&1
+#     /sbin/chkconfig --add privoxy
+#      /sbin/service privoxy condrestart > /dev/null 2>&1
 #fi
 # 01/09/02 HB, getting rid of any user=junkbust
 # Changed by morcego to use the id command.
 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
-sbin/insserv etc/init.d/junkbuster
+sbin/insserv etc/init.d/privoxy
 
 #
 # -----------------------------------------------------------------------------
@@ -167,7 +171,7 @@ sbin/insserv etc/init.d/junkbuster
 %preun
 # need to stop the service on suse. swa.
 #if [ "$1" = "0" ]; then
-#      /sbin/service junkbuster stop > /dev/null 2>&1 ||:
+#      /sbin/service privoxy stop > /dev/null 2>&1 ||:
 #fi
 
 #
@@ -175,8 +179,8 @@ sbin/insserv etc/init.d/junkbuster
 #
 %postun
 sbin/insserv etc/init.d/
-# dont forget to remove user and group junkbuster
-id junkbuster > /dev/null 2>&1 && /usr/sbin/userdel junkbuster || /bin/true
+# dont forget to remove user and group privoxy
+id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
 
 #
 # -----------------------------------------------------------------------------
@@ -189,24 +193,67 @@ id junkbuster > /dev/null 2>&1 && /usr/sbin/userdel junkbuster || /bin/true
 #
 %files
 %defattr(-,root,root)
-%doc README.gz AUTHORS.gz ChangeLog.gz
-%doc doc/webserver/developer-manual doc/webserver/user-manual
+%doc README.gz AUTHORS.gz ChangeLog.gz LICENSE.gz
+%doc doc/webserver/developer-manual
 %doc doc/webserver/user-manual
-%doc doc/webserver/ijb_docs.css
-#%doc junkbuster.weekly junkbuster.monthly AUTHORS
-%dir %{ijbconf}
-%config %{ijbconf}/*
-%attr(0744,junkbuster,junkbuster) %dir /var/log/junkbuster
-%config %{_sysconfdir}/logrotate.d/junkbuster
-%attr(0755,root,root)/usr/sbin/junkbuster
+%doc doc/webserver/faq
+%doc doc/webserver/p_doc.css
+%doc doc/webserver/p_web.css
+%doc doc/webserver/privoxy-index.html
+%doc doc/webserver/images
+#%doc privoxy.weekly privoxy.monthly AUTHORS
+%dir %{privoxyconf}
+%config %{privoxyconf}/*
+%attr(0744,privoxy,privoxy) %dir /var/log/privoxy
+%config %{_sysconfdir}/logrotate.d/privoxy
+%attr(0755,root,root)/usr/sbin/privoxy
 %{_mandir}/man8/*
-%config %{_sysconfdir}/init.d/junkbuster
-/usr/sbin/rcjunkbuster
+%config %{_sysconfdir}/init.d/privoxy
+/usr/sbin/rcprivoxy
 
 #
 # -----------------------------------------------------------------------------
 #
 %changelog
+* Mon May 27 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.15-1
+- Index.html is now privoxy-index.html.
+
+* Fri May 24 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.15-1
+- Add doc/images directory.
+
+* Fri May 03 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
++ privoxy-suse-2.9.15-1
+- Version bump
+
+* Fri Apr 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
++ privoxy-suse-2.9.14-3
+- Changing Vendor to Privoxy.Org
+
+* Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
++ privoxy-suse-2.9.14-2
+- Bumping release to reflect the new value on configure.in
+- Taking the oportunity to change the header Copyright to License. The
+  Copyright headers is deprecated, and after all, GPL is a license, not a
+  Copyright
+
+* Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.13-4
+- Add LICENSE.gz, p_web.css, and index.html. Add autoconf
+- to Buildrequires.
+
+* Wed Mar 27 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.13-3
+- Doc css has changed names.
+
+* Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.13-3
+- Minor fix to description.
+
+* Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
+- added faq to docs.
+
 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
 - added ijb_docs.css to docs.
 
@@ -275,7 +322,74 @@ id junkbuster > /dev/null 2>&1 && /usr/sbin/userdel junkbuster || /bin/true
 * Mon Mar 01 1999 - daniel@suse.de
 - new package: version 2.0
 
-# $Log: junkbuster-suse.spec,v $
+# $Log: privoxy-suse.spec,v $
+# Revision 1.20  2002/05/25 02:08:23  hal9
+# Add doc/images directory.
+# Redhat: alphabetized list of templates (and I think added one in the process)
+#
+# Revision 1.19  2002/05/03 17:14:36  morcego
+# *.spec: Version bump to 2.9.15
+# -rh.spec: noreplace for %%{privoxyconf}/config
+#           Will interrupt the build if versions from configure.in and
+#              specfile do not match
+#
+# Revision 1.18  2002/04/27 20:26:59  swa
+# uid, gui 73 incorporated
+#
+# Revision 1.17  2002/04/26 15:51:05  morcego
+# Changing Vendor value to Privoxy.Org
+#
+# Revision 1.16  2002/04/22 16:32:31  morcego
+# configure.in, *.spec: Bumping release to 2 (2.9.14-2)
+# -rh.spec: uid and gid are now macros
+# -suse.spec: Changing the header Copyright to License (Copyright is
+#             deprecable)
+#
+# Revision 1.15  2002/04/16 18:49:07  oes
+# Build with static built-in pcre
+#
+# Revision 1.14  2002/04/11 17:57:40  oes
+# Fixed(?) Conflicts: Provides: Obsoletes:
+#
+# Revision 1.13  2002/04/11 10:09:20  oes
+# Version 2.9.14
+#
+# Revision 1.12  2002/04/09 13:29:43  swa
+# build suse and gen-dist with html docs. do not generate docs while building rpm
+#
+# Revision 1.11  2002/04/09 03:12:37  hal9
+# Add LICENSE, p_web.css and index.html. Add autoconf to buildrequires.
+#
+# Revision 1.10  2002/04/08 20:24:13  swa
+# fixed JB spelling
+#
+# Revision 1.9  2002/03/30 09:01:52  swa
+# new release
+#
+# Revision 1.8  2002/03/27 23:46:41  hal9
+# ijb_docs.css to p_doc.css
+#
+# Revision 1.7  2002/03/27 00:49:39  hal9
+# Minor fix to description.
+#
+# Revision 1.6  2002/03/26 22:29:55  swa
+# we have a new homepage!
+#
+# Revision 1.5  2002/03/25 03:10:50  hal9
+# Added faq to docs.
+#
+# Revision 1.4  2002/03/24 12:56:21  swa
+# name change related issues.
+#
+# Revision 1.3  2002/03/24 12:44:31  swa
+# new version string
+#
+# Revision 1.2  2002/03/24 11:40:14  swa
+# name change
+#
+# Revision 1.1  2002/03/24 11:23:44  swa
+# name change
+#
 # Revision 1.21  2002/03/21 16:04:33  hal9
 # added ijb_docs.css to %%doc
 #