- (privoxy-rh.spec only) Relisting template files on the %%files section
[privoxy.git] / privoxy-rh.spec
index 39a7c1d..8ab4b31 100644 (file)
@@ -1,7 +1,7 @@
-# $Id: privoxy-rh.spec,v 1.9 2002/03/24 22:03:22 morcego Exp $
+# $Id: privoxy-rh.spec,v 1.22 2002/04/09 22:06:12 hal9 Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
-# PRIVOXY team.  http://ijbswa.sourceforge.net
+# Privoxy team. http://www.privoxy.org/
 #
 # Based on the Internet Junkbuster originally written
 # by and Copyright (C) 1997 Anonymous Coders and 
 %define privoxyconf %{_sysconfdir}/%{name}
 
 Name: privoxy
+# ATTENTION
+# Version and release should be updated acordingly on configure.in and
+# configure. Otherwise, the package can be build with the wrong value
 Version: 2.9.13
-Release: 2
+Release: 5
 Summary: Privoxy - privacy enhancing proxy
 License: GPL
-Vendor: http://ijbswa.sourceforge.net
+Vendor: http://www.privoxy.org
 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Group: Networking/Utilities
-URL: http://ijbswa.sourceforge.net/
+URL: http://www.privoxy.org/
 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
-BuildRequires: perl gzip sed docbook-utils libtool autoconf
+BuildRequires: perl gzip sed libtool autoconf 
 Conflicts: junkbuster-raw junkbuster-blank junkbuster
 
 %description 
@@ -52,12 +55,11 @@ Privoxy is a web proxy with advanced filtering capabilities for
 protecting privacy, filtering web page content, managing cookies,
 controlling access, and removing ads, banners, pop-ups and other
 obnoxious Internet junk. Privoxy has a very flexible configuration and
-can be customized to suit individual needs and tastes. Internet
-Privoxy has application for both stand-alone systems and multi-user
-networks.
+can be customized to suit individual needs and tastes. Privoxy has application
+for both stand-alone systems and multi-user networks.
 
 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
-was originally written by JunkBusters Corporation, and was released as
+was originally written by Junkbusters Corporation, and was released as
 free open-source software under the GNU GPL. Stefan Waldherr made many
 improvements, and started the SourceForge project to continue
 development. Several other developers are now contributing.
@@ -70,7 +72,8 @@ autoheader
 autoconf
 %configure
 make 
-make redhat-dok
+# Docs are in CVS and tarball now.
+#%%make dok
 
 ## Explicitily stripping is not recomended.
 ## This is handled altomaticaly by RPM, and can couse troubles if
@@ -197,11 +200,12 @@ fi
 
 %files
 %defattr(0644,root,root,0755)
-%doc README AUTHORS ChangeLog
-%doc doc/text/developer-manual.txt doc/text/user-manual.txt
+%doc README AUTHORS ChangeLog LICENSE 
+%doc doc/text/developer-manual.txt doc/text/user-manual.txt doc/text/faq.txt
 %doc doc/webserver/developer-manual
 %doc doc/webserver/user-manual
-%doc doc/webserver/ijb_docs.css
+%doc doc/webserver/faq
+%doc doc/webserver/p_doc.css doc/webserver/p_web.css doc/webserver/index.html
 
 %dir %{privoxyconf}
 %dir %{privoxyconf}/templates
@@ -221,32 +225,37 @@ fi
 %config %{privoxyconf}/default.filter
 %config %{privoxyconf}/trust
 
-%config %{privoxyconf}/templates/blocked
-%config %{privoxyconf}/templates/blocked-compact
-%config %{privoxyconf}/templates/cgi-error-404
+%config %{privoxyconf}/templates/untrusted
+%config %{privoxyconf}/templates/toggle-mini
+%config %{privoxyconf}/templates/default
+%config %{privoxyconf}/templates/connect-failed
+%config %{privoxyconf}/templates/show-status-file
 %config %{privoxyconf}/templates/cgi-error-bad-param
-%config %{privoxyconf}/templates/cgi-error-disabled
+%config %{privoxyconf}/templates/show-version
 %config %{privoxyconf}/templates/cgi-error-file
-%config %{privoxyconf}/templates/cgi-error-modified
+%config %{privoxyconf}/templates/cgi-error-404
 %config %{privoxyconf}/templates/cgi-error-parse
-%config %{privoxyconf}/templates/connect-failed
-%config %{privoxyconf}/templates/default
+%config %{privoxyconf}/templates/edit-actions-url-form
+%config %{privoxyconf}/templates/no-such-domain
 %config %{privoxyconf}/templates/edit-actions-add-url-form
-%config %{privoxyconf}/templates/edit-actions-for-url
+%config %{privoxyconf}/templates/cgi-style.css
+%config %{privoxyconf}/templates/edit-actions-for-url-filter
+%config %{privoxyconf}/templates/cgi-error-disabled
+%config %{privoxyconf}/templates/edit-actions-remove-url-form
+%config %{privoxyconf}/templates/show-request
+%config %{privoxyconf}/templates/cgi-error-modified
+%config %{privoxyconf}/templates/mod-unstable-warning
 %config %{privoxyconf}/templates/edit-actions-list
+%config %{privoxyconf}/templates/toggle
 %config %{privoxyconf}/templates/edit-actions-list-section
+%config %{privoxyconf}/templates/mod-title
 %config %{privoxyconf}/templates/edit-actions-list-url
-%config %{privoxyconf}/templates/edit-actions-remove-url-form
-%config %{privoxyconf}/templates/edit-actions-url-form
-%config %{privoxyconf}/templates/no-such-domain
-%config %{privoxyconf}/templates/show-request
 %config %{privoxyconf}/templates/show-status
-%config %{privoxyconf}/templates/show-status-file
+%config %{privoxyconf}/templates/blocked
+%config %{privoxyconf}/templates/mod-support-and-service
+%config %{privoxyconf}/templates/mod-local-help
 %config %{privoxyconf}/templates/show-url-info
-%config %{privoxyconf}/templates/show-version
-%config %{privoxyconf}/templates/toggle
-%config %{privoxyconf}/templates/toggle-mini
-%config %{privoxyconf}/templates/untrusted
+%config %{privoxyconf}/templates/edit-actions-for-url
 
 %config %{_sysconfdir}/logrotate.d/%{name}
 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
@@ -261,6 +270,45 @@ fi
 %{_mandir}/man1/%{name}.*
 
 %changelog
+* Wed Apr 10 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
++ privoxy-2.9.13-5
+- Relisting template files on the %%files section
+
+* Tue Apr 09 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.13-4
+- Removed 'make dok'. Docs are all maintained in CVS (and tarball) now.
+
+* Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.13-4
+- Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
+- Remove templates/blocked-compact.
+- Add more docbook stuff to Builderquires.
+
+* Thu Mar 28 2002 Sarantis Paskalis <sarantis@cnl.di.uoa.gr>
++ privoxy-2.9.13-3
+- Include correct documentation file.
+
+* Tue Mar 26 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.13-3
+- Fix typo in Description.
+
+* Tue Mar 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
++ privoxy-2.9.13-3
+- Added commentary asking to update the release value on the configure
+  script
+
+* Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.13-3
+- Added the missing edit-actions-for-url-filter to templates.
+
+* Mon Mar 25 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
++ privoxy-2.9.13-2
+- Fixing Release number
+
+* Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.13-2
+- Added faq to docs.
+
 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
 + privoxy-2.9.13-2
 - Fixed the init files entries. Now we use %%ghost
@@ -520,6 +568,48 @@ fi
        additional "-r @" flag.
 
 # $Log: privoxy-rh.spec,v $
+# Revision 1.22  2002/04/09 22:06:12  hal9
+# Remove 'make dok'.
+#
+# Revision 1.21  2002/04/09 02:52:26  hal9
+# - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
+# - Remove templates/blocked-compact.
+# - Add more docbook stuff to Buildrequires.
+#
+# Revision 1.20  2002/04/08 20:27:45  swa
+# fixed JB spelling
+#
+# Revision 1.19  2002/03/27 22:44:59  sarantis
+# Include correct documentation file.
+#
+# Revision 1.18  2002/03/27 22:10:14  sarantis
+# bumped Hal's last commit 1 day to the future to make rpm build again.
+#
+# Revision 1.17  2002/03/27 00:48:23  hal9
+# Fix up descrition.
+#
+# Revision 1.16  2002/03/26 22:29:55  swa
+# we have a new homepage!
+#
+# Revision 1.15  2002/03/26 17:39:54  morcego
+# Adding comment on the specfile to remember the packager to update
+# the release number on the configure script
+#
+# Revision 1.14  2002/03/26 14:25:15  hal9
+# Added edit-actions-for-url-filter to templates in %%config
+#
+# Revision 1.13  2002/03/25 13:31:04  morcego
+# Bumping Release tag.
+#
+# Revision 1.12  2002/03/25 03:11:40  hal9
+# Do it right way this time :/
+#
+# Revision 1.11  2002/03/25 03:09:51  hal9
+# Added faq to docs.
+#
+# Revision 1.10  2002/03/24 22:16:14  morcego
+# Just removing some old commentaries.
+#
 # Revision 1.9  2002/03/24 22:03:22  morcego
 # Should be working now. See %changelog for details
 #