Add %config lines for regression-tests.action and forwarding-failed.
[privoxy.git] / privoxy-rh.spec
index ed02875..5270fbe 100644 (file)
@@ -1,6 +1,6 @@
-# $Id: privoxy-rh.spec,v 1.43 2002/07/05 17:15:56 morcego Exp $
+# $Id: privoxy-rh.spec,v 1.55 2008/03/02 17:36:43 fabiankeil Exp $
 #
-# Written by and Copyright (C) 2001, 2002 the SourceForge
+# Written by and Copyright (C) 2001-2006 the SourceForge
 # Privoxy team. http://www.privoxy.org/
 #
 # Based on the Internet Junkbuster originally written
@@ -37,11 +37,11 @@ Name: privoxy
 # ATTENTION
 # Version and release should be updated acordingly on configure.in and
 # configure. Otherwise, the package can be build with the wrong value
-Version: 3.1.1
+Version: 3.0.9
 Release: 1
 Summary: Privoxy - privacy enhancing proxy
 License: GPL
-Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
+Source0: http://dl.sf.net/ijbswa/%{name}-%{version}-stable-src.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Group: System Environment/Daemons
 URL: http://www.privoxy.org/
@@ -53,7 +53,7 @@ Conflicts: junkbuster-raw junkbuster-blank junkbuster
 
 %description 
 Privoxy is a web proxy with advanced filtering capabilities for
-protecting privacy, filtering web page content, managing cookies,
+protecting privacy, filtering web page data, managing cookies,
 controlling access, and removing ads, banners, pop-ups and other
 obnoxious Internet junk. Privoxy has a very flexible configuration and
 can be customized to suit individual needs and tastes. Privoxy has application
@@ -62,14 +62,18 @@ for both stand-alone systems and multi-user networks.
 Privoxy is based on the Internet Junkbuster.
 
 %prep
-%setup -q -c
+#%setup -q -c
+%setup -q -n "%{name}-%{version}-stable"
 
 %build
 
 # We check to see if versions match
 VERSION_MAJOR=3
-VERSION_MINOR=1
-VERSION_POINT=1
+VERSION_MINOR=0
+VERSION_POINT=9
+
+# find CVS files and remove it.
+find -name CVS | xargs rm -rf
 
 CONFIG_VERSION=`cat configure.in | sed -n -e 's/^VERSION_MAJOR=\([0-9]*\)/\1./p' -e 's/^VERSION_MINOR=\([0-9]*\)/\1./p' -e 's/^VERSION_POINT=\([0-9]*\)/\1/p' | awk '{printf $1}'`
 if [ "%{version}" != "${CONFIG_VERSION}" ]; then
@@ -116,6 +120,7 @@ do
        cat $i | sed -e 's/[[:cntrl:]]*$//' > %{buildroot}%{privoxyconf}/$i
 done
 cat default.filter | sed -e 's/[[:cntrl:]]*$//' > %{buildroot}%{privoxyconf}/default.filter
+cat user.filter | sed -e 's/[[:cntrl:]]*$//' > %{buildroot}%{privoxyconf}/user.filter
 cat trust | sed -e 's/[[:cntrl:]]*$//' > %{buildroot}%{privoxyconf}/trust
 (
 cd templates
@@ -143,6 +148,7 @@ cat config | \
 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' | \
+    sed 's@#user-manual http://www.privoxy.org/user-manual/@user-manual %{_docdir}/%{name}-%{version}/user-manual/@g' | \
     sed -e 's/[[:cntrl:]]*$//' > \
     %{buildroot}%{privoxyconf}/config
 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
@@ -248,7 +254,7 @@ fi
 %doc doc/webserver/developer-manual
 %doc doc/webserver/user-manual
 %doc doc/webserver/faq
-%doc doc/webserver/p_doc.css doc/webserver/p_web.css doc/webserver/privoxy-index.html
+%doc doc/webserver/p_doc.css doc/webserver/privoxy-index.html
 %doc doc/webserver/images
 %doc doc/webserver/man-page
 
@@ -270,7 +276,9 @@ fi
 %config(noreplace) %{privoxyconf}/user.action
 %config %{privoxyconf}/default.action
 %config %{privoxyconf}/default.filter
-%config %{privoxyconf}/trust
+%config %{privoxyconf}/regression-tests.action
+%config(noreplace) %{privoxyconf}/user.filter
+%config(noreplace) %{privoxyconf}/trust
 
 # Please keep these alphabetized so its easier to find one that 
 # is not included.
@@ -285,6 +293,7 @@ fi
 %config %{privoxyconf}/templates/cgi-style.css
 %config %{privoxyconf}/templates/connect-failed
 %config %{privoxyconf}/templates/default
+%config %{privoxyconf}/templates/forwarding-failed
 %config %{privoxyconf}/templates/edit-actions-add-url-form
 %config %{privoxyconf}/templates/edit-actions-for-url
 %config %{privoxyconf}/templates/edit-actions-for-url-filter
@@ -316,10 +325,43 @@ fi
 
 %{_mandir}/man1/%{name}.*
 
-
 %changelog
-* Thu Sep 05 2002 Hal Burgiss <hal@foobox.net>
-- Import changes from 3.0.0 to main trunk.
+* Sat Oct 18 2006 Hal Burgiss <hal@foobox.net>
+- Bump version to 3.0.6
+
+* Sat Sep 23 2006 Jochen Schlick <j.schlick_at_decagon_de> 3.0.5-1
+- let user-manual point to local documentation
+
+* Thu Sep 21 2006 Hal Burgiss <hal@foobox.net>
+- Fix user.filter install section and clean up CVS cruft in tarball.
+
+* Wed Sep 20 2006 Hal Burgiss <hal@foobox.net>
+- Bump version to 3.0.5
+
+* Fri Sep 08 2006 Hal Burgiss <hal@foobox.net>
+- Bump version to 3.0.4
+
+* Sat Sep 02 2006 Hal Burgiss <hal@foobox.net>
+- Include new file, user.filter. Do not overwrite "trust" file 
+  (does anyone use this?).
+
+* Wed Mar 26 2003 Andreas Oesterhelt <andreas@oesterhelt.org>
+- Bump version for 3.0.2.
+
+* Wed Mar 19 2003 Hal Burgiss <hal@foobox.net>
+- Bump version for 3.0.1.
+
+* Tue Aug 25 2002 Hal Burgiss <hal@foobox.net>
+- Bump version for 3.0.0 :)
+
+* Tue Aug 06 2002 Hal Burgiss <hal@foobox.net>
+- Reset version for 2.9.20.
+
+* Tue Jul 30 2002 Hal Burgiss <hal@foobox.net>
+- Reset version for 2.9.18.
+
+* Sat Jul 27 2002 Hal Burgiss <hal@foobox.net>
+- Reset version and release for 2.9.16.
 
 * Fri Jul 12 2002 Karsten Hopp <karsten@redhat.de>
 - don't use ghost files for rcX.d/*, using chkconfig is the 
@@ -327,7 +369,7 @@ fi
 
 * Fri Jul 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
 + privoxy-2.9.15-8
-- Changing delete order for groups and users (users should be first) 
+- Changing delete order for groups and users (users should be first)
 
 * Wed Jul 03 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
 + privoxy-2.9.15-7
@@ -341,6 +383,11 @@ fi
 
 * Tue Jul 02 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
 + privoxy-2.9.15-5
+- Bumping Release number (which should be changed every time the specfile
+  is)
+
+* Tue Jul 02 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.15-4
 - Fix typo in templates creation.
 
 * Wed Jun 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
@@ -715,6 +762,49 @@ fi
        additional "-r @" flag.
 
 # $Log: privoxy-rh.spec,v $
+# Revision 1.55  2008/03/02 17:36:43  fabiankeil
+# Set version to 3.0.9.
+#
+# Revision 1.54  2008/01/20 14:30:59  fabiankeil
+# Set version to 3.0.8.
+#
+# Revision 1.53  2006/11/28 11:34:35  hal9
+# Fix the prep section per Support request so it actually builds.
+#
+# Revision 1.52  2006/11/18 17:36:53  hal9
+# Ooops, bumping version to 3.0.6
+#
+# Revision 1.51  2006/11/18 14:37:12  fabiankeil
+# Bump version to 3.0.6.
+#
+# Revision 1.50  2006/09/24 01:19:03  hal9
+# Add changes for user-manual directive by nfopd submitted via SF.
+#
+# Revision 1.49  2006/09/22 01:02:08  hal9
+# Fix user.filter installation and CVS files cruft per support request.
+#
+# Revision 1.48  2006/09/20 23:51:26  hal9
+# Bump versions to 3.0.5
+#
+# Revision 1.47  2006/09/09 00:35:10  hal9
+# Bumped versions to 3.0.4. Both files should be checked further.
+#
+# Revision 1.46  2006/09/02 22:22:59  hal9
+# Include user.filter, and do not overwrite trust file on updates.
+#
+# Revision 1.45  2006/07/18 14:48:47  david__schmidt
+# Reorganizing the repository: swapping out what was HEAD (the old 3.1 branch)
+# with what was really the latest development (the v_3_0_branch branch)
+#
+# Revision 1.33.2.22  2004/01/30 17:09:29  oes
+# Bumped version for 3.0.3
+#
+# Revision 1.33.2.21  2003/03/26 00:25:00  oes
+# Bump version for 3.0.2
+#
+# Revision 1.33.2.20  2003/03/20 03:27:11  hal9
+# Bump version for 3.0.1 pending release.
+#
 # Revision 1.33.2.19  2002/08/25 23:36:03  hal9
 # Bump version for 3.0.0.
 #
@@ -745,25 +835,25 @@ fi
 # Revision 1.33.2.10  2002/07/12 09:14:26  kick_
 # don't use ghost files for rcX.d/*, chkconfig is available to do this job. Enable translation of error messge
 #
-# Revision 1.43  2002/07/05 17:15:56  morcego
+# Revision 1.33.2.9  2002/07/05 17:16:19  morcego
 # - Changing delete order for groups and users (users should be first)
 #
-# Revision 1.42  2002/07/03 20:46:38  morcego
+# Revision 1.33.2.8  2002/07/03 20:46:24  morcego
 # - Changing sed expression that removed CR from the end of the lines. This
 #   new one removes any control caracter, and should work with older versions
 #   of sed
 #
-# Revision 1.41  2002/07/02 18:16:28  morcego
+# Revision 1.33.2.7  2002/07/02 18:16:48  morcego
 # - Fixing defattr values. File and directory modes where swapped
 #
-# Revision 1.40  2002/07/02 17:37:24  morcego
-# Fix typo in templates creation.
+# Revision 1.33.2.6  2002/07/02 17:38:10  morcego
+# Bumping Release number
 #
-# Revision 1.39  2002/06/26 17:32:04  morcego
-# Fixing issues created by sync between the branches
+# Revision 1.33.2.5  2002/07/02 11:43:20  hal9
+# Fix typo in templates creation.
 #
-# Revision 1.38  2002/06/24 21:44:44  hal9
-# Sync with Karsten's update in 3.0 branch. See changelog.
+# Revision 1.33.2.4  2002/06/26 17:32:45  morcego
+# Integrating fixed from the main branch.
 #
 # Revision 1.33.2.3  2002/06/24 12:13:34  kick_
 # shut up rpmlint. btw: The vendor tag should be set in you .rpmmacros file, not in the spec file!