Add %config lines for regression-tests.action and forwarding-failed.
[privoxy.git] / privoxy-rh.spec
index 87818c6..5270fbe 100644 (file)
@@ -1,6 +1,6 @@
-# $Id: privoxy-rh.spec,v 1.47 2006/09/09 00:35:10 hal9 Exp $
+# $Id: privoxy-rh.spec,v 1.55 2008/03/02 17:36:43 fabiankeil Exp $
 #
-# Written by and Copyright (C) 2001 the SourceForge
+# Written by and Copyright (C) 2001-2006 the SourceForge
 # Privoxy team. http://www.privoxy.org/
 #
 # Based on the Internet Junkbuster originally written
@@ -37,11 +37,11 @@ Name: privoxy
 # ATTENTION
 # Version and release should be updated acordingly on configure.in and
 # configure. Otherwise, the package can be build with the wrong value
-Version: 3.0.5
+Version: 3.0.9
 Release: 1
 Summary: Privoxy - privacy enhancing proxy
 License: GPL
-Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
+Source0: http://dl.sf.net/ijbswa/%{name}-%{version}-stable-src.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Group: System Environment/Daemons
 URL: http://www.privoxy.org/
@@ -62,14 +62,18 @@ for both stand-alone systems and multi-user networks.
 Privoxy is based on the Internet Junkbuster.
 
 %prep
-%setup -q -c
+#%setup -q -c
+%setup -q -n "%{name}-%{version}-stable"
 
 %build
 
 # We check to see if versions match
 VERSION_MAJOR=3
 VERSION_MINOR=0
-VERSION_POINT=5
+VERSION_POINT=9
+
+# find CVS files and remove it.
+find -name CVS | xargs rm -rf
 
 CONFIG_VERSION=`cat configure.in | sed -n -e 's/^VERSION_MAJOR=\([0-9]*\)/\1./p' -e 's/^VERSION_MINOR=\([0-9]*\)/\1./p' -e 's/^VERSION_POINT=\([0-9]*\)/\1/p' | awk '{printf $1}'`
 if [ "%{version}" != "${CONFIG_VERSION}" ]; then
@@ -116,6 +120,7 @@ do
        cat $i | sed -e 's/[[:cntrl:]]*$//' > %{buildroot}%{privoxyconf}/$i
 done
 cat default.filter | sed -e 's/[[:cntrl:]]*$//' > %{buildroot}%{privoxyconf}/default.filter
+cat user.filter | sed -e 's/[[:cntrl:]]*$//' > %{buildroot}%{privoxyconf}/user.filter
 cat trust | sed -e 's/[[:cntrl:]]*$//' > %{buildroot}%{privoxyconf}/trust
 (
 cd templates
@@ -143,6 +148,7 @@ cat config | \
 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' | \
+    sed 's@#user-manual http://www.privoxy.org/user-manual/@user-manual %{_docdir}/%{name}-%{version}/user-manual/@g' | \
     sed -e 's/[[:cntrl:]]*$//' > \
     %{buildroot}%{privoxyconf}/config
 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
@@ -248,7 +254,7 @@ fi
 %doc doc/webserver/developer-manual
 %doc doc/webserver/user-manual
 %doc doc/webserver/faq
-%doc doc/webserver/p_doc.css doc/webserver/p_web.css doc/webserver/privoxy-index.html
+%doc doc/webserver/p_doc.css doc/webserver/privoxy-index.html
 %doc doc/webserver/images
 %doc doc/webserver/man-page
 
@@ -270,6 +276,7 @@ fi
 %config(noreplace) %{privoxyconf}/user.action
 %config %{privoxyconf}/default.action
 %config %{privoxyconf}/default.filter
+%config %{privoxyconf}/regression-tests.action
 %config(noreplace) %{privoxyconf}/user.filter
 %config(noreplace) %{privoxyconf}/trust
 
@@ -286,6 +293,7 @@ fi
 %config %{privoxyconf}/templates/cgi-style.css
 %config %{privoxyconf}/templates/connect-failed
 %config %{privoxyconf}/templates/default
+%config %{privoxyconf}/templates/forwarding-failed
 %config %{privoxyconf}/templates/edit-actions-add-url-form
 %config %{privoxyconf}/templates/edit-actions-for-url
 %config %{privoxyconf}/templates/edit-actions-for-url-filter
@@ -318,6 +326,15 @@ fi
 %{_mandir}/man1/%{name}.*
 
 %changelog
+* Sat Oct 18 2006 Hal Burgiss <hal@foobox.net>
+- Bump version to 3.0.6
+
+* Sat Sep 23 2006 Jochen Schlick <j.schlick_at_decagon_de> 3.0.5-1
+- let user-manual point to local documentation
+
+* Thu Sep 21 2006 Hal Burgiss <hal@foobox.net>
+- Fix user.filter install section and clean up CVS cruft in tarball.
+
 * Wed Sep 20 2006 Hal Burgiss <hal@foobox.net>
 - Bump version to 3.0.5
 
@@ -745,6 +762,30 @@ fi
        additional "-r @" flag.
 
 # $Log: privoxy-rh.spec,v $
+# Revision 1.55  2008/03/02 17:36:43  fabiankeil
+# Set version to 3.0.9.
+#
+# Revision 1.54  2008/01/20 14:30:59  fabiankeil
+# Set version to 3.0.8.
+#
+# Revision 1.53  2006/11/28 11:34:35  hal9
+# Fix the prep section per Support request so it actually builds.
+#
+# Revision 1.52  2006/11/18 17:36:53  hal9
+# Ooops, bumping version to 3.0.6
+#
+# Revision 1.51  2006/11/18 14:37:12  fabiankeil
+# Bump version to 3.0.6.
+#
+# Revision 1.50  2006/09/24 01:19:03  hal9
+# Add changes for user-manual directive by nfopd submitted via SF.
+#
+# Revision 1.49  2006/09/22 01:02:08  hal9
+# Fix user.filter installation and CVS files cruft per support request.
+#
+# Revision 1.48  2006/09/20 23:51:26  hal9
+# Bump versions to 3.0.5
+#
 # Revision 1.47  2006/09/09 00:35:10  hal9
 # Bumped versions to 3.0.4. Both files should be checked further.
 #