Fix typo in templates creation.
[privoxy.git] / privoxy-rh.spec
index 2499555..2ebdd12 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: privoxy-rh.spec,v 1.36 2002/05/30 07:52:34 morcego Exp $
+# $Id: privoxy-rh.spec,v 1.39 2002/06/26 17:32:04 morcego Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
 # Privoxy team. http://www.privoxy.org/
@@ -38,13 +38,12 @@ Name: privoxy
 # Version and release should be updated acordingly on configure.in and
 # configure. Otherwise, the package can be build with the wrong value
 Version: 2.9.15
-Release: 3
+Release: 5
 Summary: Privoxy - privacy enhancing proxy
 License: GPL
-Vendor: Privoxy.Org
 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
-Group: Networking/Utilities
+Group: System Environment/Daemons
 URL: http://www.privoxy.org/
 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
@@ -106,24 +105,27 @@ mkdir -p %{buildroot}%{_sbindir} \
 ## Gziping the documentation files is not recomended - morcego
 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
 
-# Using sed to "convert" from DOS format to UNIX
-
 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
 
-cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
+# Using sed to "convert" from DOS format to UNIX
+# This is important behaviour, and should not be removed without some
+# other assurance that these files don't get packed in the the
+# wrong format
 for i in `ls *.action`
 do
-       cat $i | sed -e 's/\r$//' > %{buildroot}%{privoxyconf}/$i
+       cat $i | sed -e 's/\r$//' > %{buildroot}%{privoxyconf}/$i
 done
-cat default.filter | sed -e 's/\r$//' >  %{buildroot}%{privoxyconf}/default.filter
+cat default.filter | sed -e 's/\r$//' > %{buildroot}%{privoxyconf}/default.filter
 cat trust | sed -e 's/\r$//' > %{buildroot}%{privoxyconf}/trust
 (
 cd templates
 for i in `ls`
 do
-cat $i | sed -e 's/\r$//' > buildroot}%{privoxyconf}/templates/$i
+       cat $i | sed -e 's/\r$//' > %{buildroot}%{privoxyconf}/templates/$i
 done
 )
+
+cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
@@ -258,9 +260,12 @@ fi
 %doc doc/webserver/images
 %doc doc/webserver/man-page
 
-%attr(0755,%{name},%{name}) %dir %{privoxyconf}
-%attr(0755,%{name},%{name}) %dir %{privoxyconf}/templates
-%attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
+# ATTENTION FOR defattr change here !
+%defattr(0755,%{name},%{name},0644)
+
+%dir %{privoxyconf}
+%dir %{privoxyconf}/templates
+%dir %{_localstatedir}/log/%{name}
 
 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
 
@@ -268,51 +273,54 @@ fi
 # We should not use wildchars here. This could mask missing files problems
 # -- morcego
 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
-%attr(0644,%{name},%{name}) %config(noreplace) %{privoxyconf}/config
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/standard.action
-%attr(0644,%{name},%{name}) %config(noreplace) %{privoxyconf}/user.action
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/default.action
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/default.filter
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/trust
+%config(noreplace) %{privoxyconf}/config
+%config %{privoxyconf}/standard.action
+%config(noreplace) %{privoxyconf}/user.action
+%config %{privoxyconf}/default.action
+%config %{privoxyconf}/default.filter
+%config %{privoxyconf}/trust
 
 # Please keep these alphabetized so its easier to find one that 
 # is not included.
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/blocked
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/cgi-error-404
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/cgi-error-bad-param
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/cgi-error-disabled
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/cgi-error-file
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/cgi-error-file-read-only
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/cgi-error-modified
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/cgi-error-parse
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/cgi-style.css
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/connect-failed
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/default
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/edit-actions-add-url-form
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/edit-actions-for-url
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/edit-actions-for-url-filter
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/edit-actions-list
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/edit-actions-list-button
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/edit-actions-list-section
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/edit-actions-list-url
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/edit-actions-remove-url-form
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/edit-actions-url-form
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/mod-local-help
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/mod-support-and-service
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/mod-title
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/mod-unstable-warning
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/no-such-domain
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/show-request
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/show-status
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/show-status-file
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/show-url-info
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/show-version
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/toggle
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/toggle-mini
-%attr(0644,%{name},%{name}) %config %{privoxyconf}/templates/untrusted
-
-%config %{_sysconfdir}/logrotate.d/%{name}
-%config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
+%config %{privoxyconf}/templates/blocked
+%config %{privoxyconf}/templates/cgi-error-404
+%config %{privoxyconf}/templates/cgi-error-bad-param
+%config %{privoxyconf}/templates/cgi-error-disabled
+%config %{privoxyconf}/templates/cgi-error-file
+%config %{privoxyconf}/templates/cgi-error-file-read-only
+%config %{privoxyconf}/templates/cgi-error-modified
+%config %{privoxyconf}/templates/cgi-error-parse
+%config %{privoxyconf}/templates/cgi-style.css
+%config %{privoxyconf}/templates/connect-failed
+%config %{privoxyconf}/templates/default
+%config %{privoxyconf}/templates/edit-actions-add-url-form
+%config %{privoxyconf}/templates/edit-actions-for-url
+%config %{privoxyconf}/templates/edit-actions-for-url-filter
+%config %{privoxyconf}/templates/edit-actions-list
+%config %{privoxyconf}/templates/edit-actions-list-button
+%config %{privoxyconf}/templates/edit-actions-list-section
+%config %{privoxyconf}/templates/edit-actions-list-url
+%config %{privoxyconf}/templates/edit-actions-remove-url-form
+%config %{privoxyconf}/templates/edit-actions-url-form
+%config %{privoxyconf}/templates/mod-local-help
+%config %{privoxyconf}/templates/mod-support-and-service
+%config %{privoxyconf}/templates/mod-title
+%config %{privoxyconf}/templates/mod-unstable-warning
+%config %{privoxyconf}/templates/no-such-domain
+%config %{privoxyconf}/templates/show-request
+%config %{privoxyconf}/templates/show-status
+%config %{privoxyconf}/templates/show-status-file
+%config %{privoxyconf}/templates/show-url-info
+%config %{privoxyconf}/templates/show-version
+%config %{privoxyconf}/templates/toggle
+%config %{privoxyconf}/templates/toggle-mini
+%config %{privoxyconf}/templates/untrusted
+
+# Attention, new defattr change here !
+%defattr(0755,root,root,0644)
+
+%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
+%config(noreplace) %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
@@ -324,18 +332,34 @@ fi
 %{_mandir}/man1/%{name}.*
 
 %changelog
-* Sat Jun 15 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
-+ privoxy-2.9.15-3
-- Changing remaining absolute paths to rpm macros
-- Fixing files ownership on the %%files section, so verify can work
-
-* Thu May 30 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
-+ privoxy-2.9.15-2
-- Using sed to convert files from DOS to UNIX format (BUG: #562174)
+* Tue Jul 02 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
++ privoxy-2.9.15-5
+- Fix typo in templates creation.
+
+* Wed Jun 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
++ privoxy-2.9.15-4
+- Fixing issues created by specfile sync between branches
+  - Correcting the release number (WARNING)
+  - Reintroducing text file conversion (dos -> unix)
+  - Reconverting hardcoded directories to macros
+  - Refixing ownership of privoxy files (now using multiple defattr
+    definitions)
+
+* Thu Jun 20 2002 Karsten Hopp <karsten@redhat.de>
+- fix several .spec file issues to shut up rpmlint
+  - non-standard-dir-perm /var/log/privoxy 0744
+  - invalid-vendor Privoxy.Org (This is ok for binaries compiled by privoxy
+    members, but not for packages from Red Hat)
+  - non-standard-group Networking/Utilities
+  - logrotate and init scripts should be noreplace
 
 * Mon May 27 2002 Hal Burgiss <hal@foobox.net>
 + privoxy-2.9.15-1
-- Index.html is now privoxy-index.html.
+- Index.html is now privoxy-index.html for doc usage.
+
+* Sat May 25 2002 Hal Burgiss <hal@foobox.net>
++ privoxy-2.9.15-1
+- Add html man page so index.html does not 404.
 
 * Fri May 24 2002 Hal Burgiss <hal@foobox.net>
 + privoxy-2.9.15-1
@@ -466,7 +490,7 @@ fi
 - Added preun section to stop the service with the old name, as well
   as remove it from the startup list
 - Removed the chkconfig --del entry from the conditional block on
-  the preun scriptlet (now handled on the %%files section)
+  the preun scriptlet (now handled on the %files section)
 
 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
 - added ijb_docs.css to docs.
@@ -684,14 +708,20 @@ fi
        additional "-r @" flag.
 
 # $Log: privoxy-rh.spec,v $
-# Revision 1.36  2002/05/30 07:52:34  morcego
-# Using sed to confert from DOS to UNIX formats (BUG: #562174)
+# Revision 1.39  2002/06/26 17:32:04  morcego
+# Fixing issues created by sync between the branches
+#
+# Revision 1.38  2002/06/24 21:44:44  hal9
+# Sync with Karsten's update in 3.0 branch. See changelog.
+#
+# Revision 1.33.2.3  2002/06/24 12:13:34  kick_
+# shut up rpmlint. btw: The vendor tag should be set in you .rpmmacros file, not in the spec file!
 #
-# Revision 1.35  2002/05/28 03:56:59  hal9
-# Index.html re-vamped as privoxy-index.html for docs.
+# Revision 1.33.2.2  2002/05/28 02:39:38  hal9
+# Replace index.html with privoxy-index.html for docs.
 #
-# Revision 1.34  2002/05/25 22:09:58  hal9
-# Add html man page to keep index.html from breaking (untested).
+# Revision 1.33.2.1  2002/05/26 17:20:23  hal9
+# Add images to doc dirs.
 #
 # Revision 1.33  2002/05/25 02:08:23  hal9
 # Add doc/images directory.