consistent description. new name for suse since
[privoxy.git] / junkbuster-rh.spec
index e5d80f1..b3da1e1 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: junkbuster-rh.spec,v 1.12 2001/09/10 16:25:04 swa Exp $
+# $Id: junkbuster-rh.spec,v 1.20 2001/10/24 15:45:49 hal9 Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
 # IJBSWA team.  http://ijbswa.sourceforge.net
 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 #
 # $Log: junkbuster-rh.spec,v $
+# Revision 1.20  2001/10/24 15:45:49  hal9
+# To keep Thomas happy (aka correcting my  mistakes)
+#
+# Revision 1.19  2001/10/15 03:23:59  hal9
+# Nits.
+#
+# Revision 1.17  2001/10/10 18:59:28  hal9
+# Minor change for init script.
+#
+# Revision 1.16  2001/09/24 20:56:23  hal9
+# Minor changes.
+#
+# Revision 1.13  2001/09/10 17:44:43  swa
+# integrate three pieces of documentation. needs work.
+# will not build cleanly under redhat.
+#
 # Revision 1.12  2001/09/10 16:25:04  swa
 # copy all templates. version updated.
 #
@@ -73,7 +89,7 @@
 Summary: The Internet Junkbuster
 Vendor: http://ijbswa.sourceforge.net
 Name: junkbuster
-Version: 2.9.8
+Version: 2.9.9
 Release: 1
 Source0: http://www.waldherr.org/junkbuster/ijbswa.tar.gz
 Copyright: GPL
@@ -83,13 +99,17 @@ URL: http://ijbswa.sourceforge.net/
 Packager: Stefan Waldherr <stefan@waldherr.org>
 Obsoletes: junkbuster-raw junkbuster-blank
 Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
+BuildRequires: perl
 Conflicts: junkbuster-raw junkbuster-blank
 
 %description
-The Internet Junkbuster stops your browser from displaying the
-advertisement images that pervade many commercial web pages.  Since
-your browser has to download fewer images, surfing the web should be
-faster.
+Internet Junkbuster is a web proxy with advanced filtering
+capabilities for protecting privacy, filtering web page content,
+managing cookies, controlling access, and removing ads, banners,
+pop-ups and other obnoxious Internet Junk. Junkbuster has a very
+flexible configuration and can be customized to suit individual needs
+and tastes. Internet Junkbuster has application for both stand-alone
+systems and multi-user networks.
 
 %define ijbconf %{_sysconfdir}/junkbuster
 
@@ -97,12 +117,12 @@ faster.
 %setup -c -n ijbswa
 
 %build
-./configure
-make
+%configure
+make "CFLAGS=$RPM_OPT_FLAGS -Ipcre -Wall"
 strip junkbuster
 
 %pre
-/usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust > /dev/null 2>&1 || /bin/true
+/usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbuster -s "" > /dev/null 2>&1 || /bin/true
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -111,9 +131,10 @@ mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
          ${RPM_BUILD_ROOT}/var/log/junkbuster \
          ${RPM_BUILD_ROOT}%{ijbconf}/templates \
          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
-         ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
+         ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d 
 
 install -s -m 744 junkbuster $RPM_BUILD_ROOT%{_sbindir}/junkbuster
+# Out temporarily
 cp -f junkbuster.1 $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8
 cp -f actionsfile $RPM_BUILD_ROOT%{ijbconf}/actionsfile
 cp -f re_filterfile $RPM_BUILD_ROOT%{ijbconf}/re_filterfile
@@ -135,10 +156,18 @@ cat config | \
 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
     $RPM_BUILD_ROOT%{ijbconf}/config
+perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' actionsfile >\
+    $RPM_BUILD_ROOT%{ijbconf}/actionsfile
 
 %post
+# for upgrade from 2.0.x
+[ -f /var/log/junkbuster/junkbuster ] &&\
+ mv -f /var/log/junkbuster/junkbuster /var/log/junkbuster/logfile || /bin/true
+chown -R junkbuster:junkbuster /var/log/junkbuster 2>/dev/null
+chown -R junkbuster:junkbuster /etc/junkbuster 2>/dev/null
 if [ "$1" = "1" ]; then
-        /sbin/chkconfig --add junkbuster
+     /sbin/chkconfig --add junkbuster
+       /sbin/service junkbuster condrestart > /dev/null 2>&1
 fi
 
 %preun
@@ -148,27 +177,40 @@ if [ "$1" = "0" ]; then
 fi
 
 %postun
-if [ "$1" -ge "1" ]; then
-       /sbin/service junkbuster condrestart > /dev/null 2>&1
-fi
+#if [ "$1" -ge "1" ]; then
+#      /sbin/service junkbuster condrestart > /dev/null 2>&1
+#fi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%doc faq.html user-manual.html developer-manual.html
-%doc junkbuster.weekly junkbuster.monthly
+%doc doc/webserver/developer-manual doc/webserver/user-manual README 
+%doc junkbuster.weekly junkbuster.monthly AUTHORS
 %dir %{ijbconf}
 %config %{ijbconf}/*
-%attr(0744,junkbust,junkbust) %dir /var/log/junkbuster
+%attr(0744,junkbuster,junkbuster) %dir /var/log/junkbuster
 %config %{_sysconfdir}/logrotate.d/junkbuster
-%attr(0744,junkbust,junkbust)/usr/sbin/junkbuster
+%attr(0744,junkbuster,junkbuster)/usr/sbin/junkbuster
 %{_mandir}/man8/*
 %config %{_sysconfdir}/rc.d/init.d/junkbuster
 
 
 %changelog
+* Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
+- Back to user 'junkbuster' and fix configure macro.
+
+* Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
+- More changes for user 'junkbust'. Init script had 'junkbuster'.
+
+* Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
+- Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
+- Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
+
+* Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
+- Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
+- made sure no default shell exists for user junkbust.
 
 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
 - rework of RPM