Renaming #define STATIC to STATIC_PCRE
[privoxy.git] / junkbuster-rh.spec
index 8b78a26..a20194f 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: junkbuster-rh.spec,v 1.6 2001/06/11 11:28:25 sarantis Exp $
+# $Id: junkbuster-rh.spec,v 1.10 2001/07/03 09:34:44 sarantis Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
 # IJBSWA team.  http://ijbswa.sourceforge.net
 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 #
 # $Log: junkbuster-rh.spec,v $
+# Revision 1.10  2001/07/03 09:34:44  sarantis
+# bumped up version number.
+#
+# Revision 1.9  2001/06/12 18:15:29  swa
+# the % in front of configure (see tag below) confused
+# the rpm build process on 7.1.
+#
+# Revision 1.8  2001/06/12 17:15:56  swa
+# fixes, because a clean build on rh6.1 was impossible.
+# GZIP confuses make, % configure confuses rpm, etc.
+#
+# Revision 1.7  2001/06/11 12:17:26  sarantis
+# fix typo in %post
+#
 # Revision 1.6  2001/06/11 11:28:25  sarantis
 # Further optimizations and adaptations in the spec file.
 #
@@ -53,7 +67,7 @@
 Summary: The Internet Junkbuster
 Vendor: http://ijbswa.sourceforge.net
 Name: junkbuster
-Version: 2.9.4
+Version: 2.9.5
 Release: 1
 Source0: http://www.waldherr.org/junkbuster/ijbswa.tar.gz
 Copyright: GPL
@@ -74,9 +88,10 @@ faster.
 %define ijbconf %{_sysconfdir}/junkbuster
 
 %prep
-%setup -c -n %{name}-%{version}-%{release}
+%setup -c -n ijbswa
+
 %build
-%configure
+./configure
 make
 strip junkbuster
 
@@ -94,14 +109,14 @@ mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
 
 install -s -m 744 junkbuster $RPM_BUILD_ROOT%{_sbindir}/junkbuster
 cp -f junkbuster.1 $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8
-cp -f permissionsfile $RPM_BUILD_ROOT%{ijbconf}/permissionsfile
+cp -f actionsfile $RPM_BUILD_ROOT%{ijbconf}/actionsfile
 cp -f re_filterfile $RPM_BUILD_ROOT%{ijbconf}/re_filterfile
 cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
 cp -f templates/default $RPM_BUILD_ROOT%{ijbconf}/templates/
 cp -f templates/show-status  $RPM_BUILD_ROOT%{ijbconf}/templates/
 cp -f templates/show-status-file  $RPM_BUILD_ROOT%{ijbconf}/templates/
-cp -f junkbuster.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/junkbuster
-install -m 755 junkbuster.init $RPM_BUILD_ROOT/etc/rc.d/init.d/junkbuster
+cp -f junkbuster.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/junkbuster
+install -m 755 junkbuster.init $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/junkbuster
 install -m 744 -d $RPM_BUILD_ROOT/var/log/junkbuster
 
 # verify all file locations, etc. in the config file
@@ -115,7 +130,7 @@ cat config | \
 #    sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
-    $RPM_BUILD_ROOT/etc/junkbuster/config
+    $RPM_BUILD_ROOT%{ijbconf}/config
 
 %post
 if [ "$1" = "1" ]; then
@@ -146,7 +161,7 @@ rm -rf $RPM_BUILD_ROOT
 %config %{_sysconfdir}/logrotate.d/junkbuster
 %attr(0744,junkbust,junkbust)/usr/sbin/junkbuster
 %{_mandir}/man8/*
-%config /etc/rc.d/init.d/junkbuster
+%config %{_sysconfdir}/rc.d/init.d/junkbuster
 
 
 %changelog