Removed client_host, (was only required for the old 2.0.2-11 http://noijb.
[privoxy.git] / junkbuster-rh.spec
index 796c4d8..90dd76c 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: junkbuster-rh.spec,v 1.13 2001/09/10 17:44:43 swa Exp $
+# $Id: junkbuster-rh.spec,v 1.16 2001/09/24 20:56:23 hal9 Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
 # IJBSWA team.  http://ijbswa.sourceforge.net
@@ -26,6 +26,9 @@
 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 #
 # $Log: junkbuster-rh.spec,v $
+# Revision 1.16  2001/09/24 20:56:23  hal9
+# Minor changes.
+#
 # Revision 1.13  2001/09/10 17:44:43  swa
 # integrate three pieces of documentation. needs work.
 # will not build cleanly under redhat.
@@ -90,10 +93,10 @@ Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service
 Conflicts: junkbuster-raw junkbuster-blank
 
 %description
-The Internet Junkbuster is an application that provides privacy and
-security to the user of the world wide web. It controls cookies,
-removes advertisements or pop-up windows. You can actually modify the
-content of web pages on-the-fly.
+The Internet Junkbuster stops your browser from displaying the
+advertisement images that pervade many commercial web pages.  Since
+your browser has to download fewer images, surfing the web should be
+faster.
 
 %define ijbconf %{_sysconfdir}/junkbuster
 
@@ -101,12 +104,13 @@ content of web pages on-the-fly.
 %setup -c -n ijbswa
 
 %build
+OPT_FLAGS="$RPM_OPT_FLAGS -Ipcre -Wall"
 ./configure
-make
+make "CFLAGS=$OPT_FLAGS"
 strip junkbuster
 
 %pre
-/usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust > /dev/null 2>&1 || /bin/true
+/usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust -s "" > /dev/null 2>&1 || /bin/true
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -118,7 +122,8 @@ mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
          ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
 
 install -s -m 744 junkbuster $RPM_BUILD_ROOT%{_sbindir}/junkbuster
-# cp -f junkbuster.1 $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8
+# Out temporarily
+#cp -f junkbuster.1 $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8
 cp -f actionsfile $RPM_BUILD_ROOT%{ijbconf}/actionsfile
 cp -f re_filterfile $RPM_BUILD_ROOT%{ijbconf}/re_filterfile
 cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
@@ -139,11 +144,20 @@ cat config | \
 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
     $RPM_BUILD_ROOT%{ijbconf}/config
+perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' actionsfile >\
+    $RPM_BUILD_ROOT%{ijbconf}/actionsfile
+perl -pi -e 's/JB_USER=\"junkbuster\"/JB_USER=\"junkbust\"/' \
+    $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/junkbuster
 
 %post
 if [ "$1" = "1" ]; then
         /sbin/chkconfig --add junkbuster
 fi
+# for upgrade from 2.0.x
+chown junkbust:junkbust /var/log/junkbuster/* 2>/dev/null
+chown junkbust:junkbust /etc/junkbuster 2>/dev/null
+[ -f /var/log/junkbuster/junkbuster ] &&\
+ mv -f /var/log/junkbuster/junkbuster /var/log/junkbuster/logfile || /bin/true
 
 %preun
 if [ "$1" = "0" ]; then
@@ -161,18 +175,29 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%doc faq.html user-manual.html developer-manual.html
+%doc doc/webserver/developer-manual doc/webserver/user-manual README
 %doc junkbuster.weekly junkbuster.monthly
 %dir %{ijbconf}
 %config %{ijbconf}/*
 %attr(0744,junkbust,junkbust) %dir /var/log/junkbuster
 %config %{_sysconfdir}/logrotate.d/junkbuster
 %attr(0744,junkbust,junkbust)/usr/sbin/junkbuster
-# %{_mandir}/man8/*
+#temporarily out until it is updated.
+#%{_mandir}/man8/*
 %config %{_sysconfdir}/rc.d/init.d/junkbuster
 
 
 %changelog
+* Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
+- More changes for user 'junkbust'. Init script had 'junkbuster'.
+
+* Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
+- Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
+- Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
+
+* Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
+- Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
+- made sure no default shell exists for user junkbust.
 
 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
 - rework of RPM