Adding proper license
[privoxy.git] / junkbuster-rh.spec
index 939d536..8e8d7d9 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: junkbuster-rh.spec,v 1.11 2001/07/03 11:00:25 sarantis Exp $
+# $Id: junkbuster-rh.spec,v 1.13 2001/09/10 17:44:43 swa Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
 # IJBSWA team.  http://ijbswa.sourceforge.net
 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 #
 # $Log: junkbuster-rh.spec,v $
+# Revision 1.13  2001/09/10 17:44:43  swa
+# integrate three pieces of documentation. needs work.
+# will not build cleanly under redhat.
+#
+# Revision 1.12  2001/09/10 16:25:04  swa
+# copy all templates. version updated.
+#
 # Revision 1.11  2001/07/03 11:00:25  sarantis
 # replaced permissionsfile with actionsfile
 #
@@ -94,12 +101,13 @@ faster.
 %setup -c -n ijbswa
 
 %build
+OPT_FLAGS="$RPM_OPT_FLAGS -Ipcre -Wall"
 ./configure
-make
+make "CFLAGS=$OPT_FLAGS"
 strip junkbuster
 
 %pre
-/usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust > /dev/null 2>&1 || /bin/true
+/usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust -s "" > /dev/null 2>&1 || /bin/true
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -137,6 +145,10 @@ cat config | \
 if [ "$1" = "1" ]; then
         /sbin/chkconfig --add junkbuster
 fi
+# for upgrade from 2.0.x
+chown junkbust:junkbust /var/log/junkbuster/* 2>/dev/null
+[ -f /var/log/junkbuster/junkbuster ] &&\
+ mv -f /var/log/junkbuster/junkbuster /var/log/junkbuster/logfile || true
 
 %preun
 if [ "$1" = "0" ]; then
@@ -154,7 +166,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-# %doc ijbfaq.html ijbman.html README README.TOO gpl.html
+%doc faq.html user-manual.html developer-manual.html
 %doc junkbuster.weekly junkbuster.monthly
 %dir %{ijbconf}
 %config %{ijbconf}/*
@@ -166,6 +178,9 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
+- Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
+- made sure no default shell exists for user junkbust.
 
 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
 - rework of RPM