Replacing with a page containing links to the other pages on this
[privoxy.git] / junkbuster-rh.spec
index 1b9d1d4..8e8d7d9 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: junkbuster-rh.spec,v 1.7 2001/06/11 12:17:26 sarantis Exp $
+# $Id: junkbuster-rh.spec,v 1.13 2001/09/10 17:44:43 swa Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
 # IJBSWA team.  http://ijbswa.sourceforge.net
 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 #
 # $Log: junkbuster-rh.spec,v $
+# Revision 1.13  2001/09/10 17:44:43  swa
+# integrate three pieces of documentation. needs work.
+# will not build cleanly under redhat.
+#
+# Revision 1.12  2001/09/10 16:25:04  swa
+# copy all templates. version updated.
+#
+# Revision 1.11  2001/07/03 11:00:25  sarantis
+# replaced permissionsfile with actionsfile
+#
+# Revision 1.10  2001/07/03 09:34:44  sarantis
+# bumped up version number.
+#
+# Revision 1.9  2001/06/12 18:15:29  swa
+# the % in front of configure (see tag below) confused
+# the rpm build process on 7.1.
+#
+# Revision 1.8  2001/06/12 17:15:56  swa
+# fixes, because a clean build on rh6.1 was impossible.
+# GZIP confuses make, % configure confuses rpm, etc.
+#
 # Revision 1.7  2001/06/11 12:17:26  sarantis
 # fix typo in %post
 #
@@ -56,7 +77,7 @@
 Summary: The Internet Junkbuster
 Vendor: http://ijbswa.sourceforge.net
 Name: junkbuster
-Version: 2.9.4
+Version: 2.9.8
 Release: 1
 Source0: http://www.waldherr.org/junkbuster/ijbswa.tar.gz
 Copyright: GPL
@@ -80,12 +101,13 @@ faster.
 %setup -c -n ijbswa
 
 %build
+OPT_FLAGS="$RPM_OPT_FLAGS -Ipcre -Wall"
 ./configure
-make
+make "CFLAGS=$OPT_FLAGS"
 strip junkbuster
 
 %pre
-/usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust > /dev/null 2>&1 || /bin/true
+/usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust -s "" > /dev/null 2>&1 || /bin/true
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -98,12 +120,10 @@ mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
 
 install -s -m 744 junkbuster $RPM_BUILD_ROOT%{_sbindir}/junkbuster
 cp -f junkbuster.1 $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8
-cp -f permissionsfile $RPM_BUILD_ROOT%{ijbconf}/permissionsfile
+cp -f actionsfile $RPM_BUILD_ROOT%{ijbconf}/actionsfile
 cp -f re_filterfile $RPM_BUILD_ROOT%{ijbconf}/re_filterfile
 cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
-cp -f templates/default $RPM_BUILD_ROOT%{ijbconf}/templates/
-cp -f templates/show-status  $RPM_BUILD_ROOT%{ijbconf}/templates/
-cp -f templates/show-status-file  $RPM_BUILD_ROOT%{ijbconf}/templates/
+cp -f templates/*  $RPM_BUILD_ROOT%{ijbconf}/templates/
 cp -f junkbuster.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/junkbuster
 install -m 755 junkbuster.init $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/junkbuster
 install -m 744 -d $RPM_BUILD_ROOT/var/log/junkbuster
@@ -125,6 +145,10 @@ cat config | \
 if [ "$1" = "1" ]; then
         /sbin/chkconfig --add junkbuster
 fi
+# for upgrade from 2.0.x
+chown junkbust:junkbust /var/log/junkbuster/* 2>/dev/null
+[ -f /var/log/junkbuster/junkbuster ] &&\
+ mv -f /var/log/junkbuster/junkbuster /var/log/junkbuster/logfile || true
 
 %preun
 if [ "$1" = "0" ]; then
@@ -142,7 +166,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-# %doc ijbfaq.html ijbman.html README README.TOO gpl.html
+%doc faq.html user-manual.html developer-manual.html
 %doc junkbuster.weekly junkbuster.monthly
 %dir %{ijbconf}
 %config %{ijbconf}/*
@@ -154,6 +178,9 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
+- Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
+- made sure no default shell exists for user junkbust.
 
 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
 - rework of RPM