Making action_spec->flags into an unsigned long rather than just an
[privoxy.git] / junkbuster-rh.spec
index 90dd76c..38e7e45 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: junkbuster-rh.spec,v 1.16 2001/09/24 20:56:23 hal9 Exp $
+# $Id: junkbuster-rh.spec,v 1.22 2001/11/05 21:37:34 steudten Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
 # IJBSWA team.  http://ijbswa.sourceforge.net
 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 #
 # $Log: junkbuster-rh.spec,v $
+# Revision 1.22  2001/11/05 21:37:34  steudten
+# Fix to include the actual version for name.
+# Let the 'real' packager be included - sorry stefan.
+#
+# Revision 1.21  2001/10/31 19:27:27  swa
+# consistent description. new name for suse since
+# we had troubles with rpms of identical names
+# on the webserver.
+#
+# Revision 1.20  2001/10/24 15:45:49  hal9
+# To keep Thomas happy (aka correcting my  mistakes)
+#
+# Revision 1.19  2001/10/15 03:23:59  hal9
+# Nits.
+#
+# Revision 1.17  2001/10/10 18:59:28  hal9
+# Minor change for init script.
+#
 # Revision 1.16  2001/09/24 20:56:23  hal9
 # Minor changes.
 #
 Summary: The Internet Junkbuster
 Vendor: http://ijbswa.sourceforge.net
 Name: junkbuster
-Version: 2.9.8
+Version: 2.9.9
 Release: 1
-Source0: http://www.waldherr.org/junkbuster/ijbswa.tar.gz
+Source0: http://www.waldherr.org/junkbuster/ijbswa-%{version}.tar.gz
 Copyright: GPL
-BuildRoot: %{_tmppath}/%{name}-root
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Group: Networking/Utilities
 URL: http://ijbswa.sourceforge.net/
-Packager: Stefan Waldherr <stefan@waldherr.org>
 Obsoletes: junkbuster-raw junkbuster-blank
 Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
+BuildRequires: perl
 Conflicts: junkbuster-raw junkbuster-blank
 
 %description
-The Internet Junkbuster stops your browser from displaying the
-advertisement images that pervade many commercial web pages.  Since
-your browser has to download fewer images, surfing the web should be
-faster.
+Internet Junkbuster is a web proxy with advanced filtering
+capabilities for protecting privacy, filtering web page content,
+managing cookies, controlling access, and removing ads, banners,
+pop-ups and other obnoxious Internet Junk. Junkbuster has a very
+flexible configuration and can be customized to suit individual needs
+and tastes. Internet Junkbuster has application for both stand-alone
+systems and multi-user networks.
 
 %define ijbconf %{_sysconfdir}/junkbuster
 
@@ -104,13 +125,12 @@ faster.
 %setup -c -n ijbswa
 
 %build
-OPT_FLAGS="$RPM_OPT_FLAGS -Ipcre -Wall"
-./configure
-make "CFLAGS=$OPT_FLAGS"
+%configure
+make "CFLAGS=$RPM_OPT_FLAGS -Ipcre -Wall"
 strip junkbuster
 
 %pre
-/usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust -s "" > /dev/null 2>&1 || /bin/true
+/usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbuster -s "" > /dev/null 2>&1 || /bin/true
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -119,18 +139,18 @@ mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
          ${RPM_BUILD_ROOT}/var/log/junkbuster \
          ${RPM_BUILD_ROOT}%{ijbconf}/templates \
          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
-         ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
+         ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d 
 
+gzip README AUTHORS junkbuster.1
 install -s -m 744 junkbuster $RPM_BUILD_ROOT%{_sbindir}/junkbuster
-# Out temporarily
-#cp -f junkbuster.1 $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8
+cp -f junkbuster.1.gz $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8.gz
 cp -f actionsfile $RPM_BUILD_ROOT%{ijbconf}/actionsfile
 cp -f re_filterfile $RPM_BUILD_ROOT%{ijbconf}/re_filterfile
 cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
 cp -f templates/*  $RPM_BUILD_ROOT%{ijbconf}/templates/
 cp -f junkbuster.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/junkbuster
 install -m 755 junkbuster.init $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/junkbuster
-install -m 744 -d $RPM_BUILD_ROOT/var/log/junkbuster
+install -m 711 -d $RPM_BUILD_ROOT/var/log/junkbuster
 
 # verify all file locations, etc. in the config file
 # don't start with ^ or commented lines are not replaced
@@ -146,18 +166,17 @@ cat config | \
     $RPM_BUILD_ROOT%{ijbconf}/config
 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' actionsfile >\
     $RPM_BUILD_ROOT%{ijbconf}/actionsfile
-perl -pi -e 's/JB_USER=\"junkbuster\"/JB_USER=\"junkbust\"/' \
-    $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/junkbuster
 
 %post
-if [ "$1" = "1" ]; then
-        /sbin/chkconfig --add junkbuster
-fi
 # for upgrade from 2.0.x
-chown junkbust:junkbust /var/log/junkbuster/* 2>/dev/null
-chown junkbust:junkbust /etc/junkbuster 2>/dev/null
 [ -f /var/log/junkbuster/junkbuster ] &&\
  mv -f /var/log/junkbuster/junkbuster /var/log/junkbuster/logfile || /bin/true
+chown -R junkbuster:junkbuster /var/log/junkbuster 2>/dev/null
+chown -R junkbuster:junkbuster /etc/junkbuster 2>/dev/null
+if [ "$1" = "1" ]; then
+     /sbin/chkconfig --add junkbuster
+       /sbin/service junkbuster condrestart > /dev/null 2>&1
+fi
 
 %preun
 if [ "$1" = "0" ]; then
@@ -166,28 +185,36 @@ if [ "$1" = "0" ]; then
 fi
 
 %postun
-if [ "$1" -ge "1" ]; then
-       /sbin/service junkbuster condrestart > /dev/null 2>&1
-fi
+#if [ "$1" -ge "1" ]; then
+#      /sbin/service junkbuster condrestart > /dev/null 2>&1
+#fi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%doc doc/webserver/developer-manual doc/webserver/user-manual README
-%doc junkbuster.weekly junkbuster.monthly
+%doc README.gz AUTHORS.gz 
+#%doc doc/webserver/developer-manual doc/webserver/user-manual README 
+#%doc junkbuster.weekly junkbuster.monthly AUTHORS
 %dir %{ijbconf}
 %config %{ijbconf}/*
-%attr(0744,junkbust,junkbust) %dir /var/log/junkbuster
+%attr(0744,junkbuster,junkbuster) %dir /var/log/junkbuster
 %config %{_sysconfdir}/logrotate.d/junkbuster
-%attr(0744,junkbust,junkbust)/usr/sbin/junkbuster
-#temporarily out until it is updated.
-#%{_mandir}/man8/*
+%attr(0744,junkbuster,junkbuster)/usr/sbin/junkbuster
+%{_mandir}/man8/*
 %config %{_sysconfdir}/rc.d/init.d/junkbuster
 
 
 %changelog
+* Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
+- Compress manpage
+- Add more documents for installation
+- Add version string to name and source
+
+* Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
+- Back to user 'junkbuster' and fix configure macro.
+
 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
 - More changes for user 'junkbust'. Init script had 'junkbuster'.