updated files from SGML code.
[privoxy.git] / junkbuster-rh.spec
index ae93128..298bfa8 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: junkbuster-rh.spec,v 1.4 2001/06/08 20:54:18 swa Exp $
+# $Id: junkbuster-rh.spec,v 1.19 2001/10/15 03:23:59 hal9 Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
 # IJBSWA team.  http://ijbswa.sourceforge.net
 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 #
 # $Log: junkbuster-rh.spec,v $
+# Revision 1.19  2001/10/15 03:23:59  hal9
+# Nits.
+#
+# Revision 1.17  2001/10/10 18:59:28  hal9
+# Minor change for init script.
+#
+# Revision 1.16  2001/09/24 20:56:23  hal9
+# Minor changes.
+#
+# Revision 1.13  2001/09/10 17:44:43  swa
+# integrate three pieces of documentation. needs work.
+# will not build cleanly under redhat.
+#
+# Revision 1.12  2001/09/10 16:25:04  swa
+# copy all templates. version updated.
+#
+# Revision 1.11  2001/07/03 11:00:25  sarantis
+# replaced permissionsfile with actionsfile
+#
+# Revision 1.10  2001/07/03 09:34:44  sarantis
+# bumped up version number.
+#
+# Revision 1.9  2001/06/12 18:15:29  swa
+# the % in front of configure (see tag below) confused
+# the rpm build process on 7.1.
+#
+# Revision 1.8  2001/06/12 17:15:56  swa
+# fixes, because a clean build on rh6.1 was impossible.
+# GZIP confuses make, % configure confuses rpm, etc.
+#
+# Revision 1.7  2001/06/11 12:17:26  sarantis
+# fix typo in %post
+#
+# Revision 1.6  2001/06/11 11:28:25  sarantis
+# Further optimizations and adaptations in the spec file.
+#
+# Revision 1.5  2001/06/09 09:14:11  swa
+# shamelessly adapted RPM stuff from the newest rpm that
+# RedHat provided for the JB.
+#
 # Revision 1.4  2001/06/08 20:54:18  swa
 # type with status file. remove forward et. al from file list.
 #
 #
 #
 #
-%define PACKAGE_NAME junkbuster
-%define PACKAGE_URL http://ijbswa.sourceforge.net
 Summary: The Internet Junkbuster
 Vendor: http://ijbswa.sourceforge.net
-Name: %PACKAGE_NAME
-Version: 2.9
-Release: 4
+Name: junkbuster
+Version: 2.9.9
+Release: 1
 Source0: http://www.waldherr.org/junkbuster/ijbswa.tar.gz
 Copyright: GPL
 BuildRoot: %{_tmppath}/%{name}-root
 Group: Networking/Utilities
-URL: %PACKAGE_URL
+URL: http://ijbswa.sourceforge.net/
 Packager: Stefan Waldherr <stefan@waldherr.org>
-Distribution: defineme
 Obsoletes: junkbuster-raw junkbuster-blank
 Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
+BuildRequires: perl
 Conflicts: junkbuster-raw junkbuster-blank
 
-#
-# -----------------------------------------------------------------------------
-#
 %description
 The Internet Junkbuster stops your browser from displaying the
 advertisement images that pervade many commercial web pages.  Since
 your browser has to download fewer images, surfing the web should be
-faster.
+faster. 
 
-#
-# -----------------------------------------------------------------------------
-#
-%prep
+%define ijbconf %{_sysconfdir}/junkbuster
 
-#
-# -----------------------------------------------------------------------------
-#
-
-# 
+%prep
 %setup -c -n ijbswa
 
-#
-# -----------------------------------------------------------------------------
-#
 %build
-#export DISTNAME='\"%PACKAGE_NAME-%PACKAGE_VERSION-%PACKAGE_RELEASE\"'
-#export DISTURL='\"%PACKAGE_URL\"'
-#make MORE_CFLAGS="$RPM_OPT_FLAGS"' -D_DISTNAME="$(DISTNAME)" -D_DISTURL="$(DISTURL)"'
-# adds 486 optimization and stuff => bad
-#make MORE_CFLAGS=' -D_DISTNAME="DDD" -D_DISTURL="UUU"'
-./configure
-make
+%configure
+make "CFLAGS=$RPM_OPT_FLAGS -Ipcre -Wall"
 strip junkbuster
 
-#
-# -----------------------------------------------------------------------------
-#
 %pre
-/usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust > /dev/null 2>&1 || /bin/true
+/usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbuster -s "" > /dev/null 2>&1 || /bin/true
 
-#
-# -----------------------------------------------------------------------------
-#
 %install
 rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT/var/log/junkbuster \
-       $RPM_BUILD_ROOT%{_sbindir} \
-       $RPM_BUILD_ROOT%{_mandir}/man8 \
-       $RPM_BUILD_ROOT/etc/{junkbuster,junkbuster/templates,logrotate.d,cron.weekly,cron.monthly,rc.d/init.d}
-install -s -m 744 junkbuster $RPM_BUILD_ROOT/usr/sbin/junkbuster
+mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
+         ${RPM_BUILD_ROOT}%{_mandir}/man8 \
+         ${RPM_BUILD_ROOT}/var/log/junkbuster \
+         ${RPM_BUILD_ROOT}%{ijbconf}/templates \
+         ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
+         ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d 
+
+install -s -m 744 junkbuster $RPM_BUILD_ROOT%{_sbindir}/junkbuster
+# Out temporarily
 cp -f junkbuster.1 $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8
-cp -f permissionsfile $RPM_BUILD_ROOT/etc/junkbuster/permissionsfile
-cp -f re_filterfile $RPM_BUILD_ROOT/etc/junkbuster/re_filterfile
-# cp -f blocklist $RPM_BUILD_ROOT/etc/junkbuster/blocklist
-# cp -f imagelist $RPM_BUILD_ROOT/etc/junkbuster/imagelist
-# cp -f cookiefile $RPM_BUILD_ROOT/etc/junkbuster/cookiefile
-#cp -f aclfile $RPM_BUILD_ROOT/etc/junkbuster/aclfile
+cp -f actionsfile $RPM_BUILD_ROOT%{ijbconf}/actionsfile
+cp -f re_filterfile $RPM_BUILD_ROOT%{ijbconf}/re_filterfile
+cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
+cp -f templates/*  $RPM_BUILD_ROOT%{ijbconf}/templates/
+cp -f junkbuster.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/junkbuster
+install -m 755 junkbuster.init $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/junkbuster
+install -m 744 -d $RPM_BUILD_ROOT/var/log/junkbuster
+
 # verify all file locations, etc. in the config file
 # don't start with ^ or commented lines are not replaced
 cat config | \
@@ -129,73 +149,62 @@ cat config | \
 #    sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
-    $RPM_BUILD_ROOT/etc/junkbuster/config
-#cp -f forward $RPM_BUILD_ROOT/etc/junkbuster/forward
-cp -f trust $RPM_BUILD_ROOT/etc/junkbuster/trust
-# cp -f popup $RPM_BUILD_ROOT/etc/junkbuster/popup
-cp -f templates/default $RPM_BUILD_ROOT/etc/junkbuster/templates/
-cp -f templates/show-status  $RPM_BUILD_ROOT/etc/junkbuster/templates/
-cp -f templates/show-status-file  $RPM_BUILD_ROOT/etc/junkbuster/templates/
-cp -f junkbuster.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/junkbuster
-install -m 755 junkbuster.init $RPM_BUILD_ROOT/etc/rc.d/init.d/junkbuster
-install -m 744 -d $RPM_BUILD_ROOT/var/log/junkbuster
+    $RPM_BUILD_ROOT%{ijbconf}/config
+perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' actionsfile >\
+    $RPM_BUILD_ROOT%{ijbconf}/actionsfile
+
+%post
+# for upgrade from 2.0.x
+[ -f /var/log/junkbuster/junkbuster ] &&\
+ mv -f /var/log/junkbuster/junkbuster /var/log/junkbuster/logfile || /bin/true
+chown -R junkbuster:junkbuster /var/log/junkbuster 2>/dev/null
+chown -R junkbuster:junkbuster /etc/junkbuster 2>/dev/null
+if [ "$1" = "1" ]; then
+     /sbin/chkconfig --add junkbuster
+       /sbin/service junkbuster condrestart > /dev/null 2>&1
+fi
 
-#
-# -----------------------------------------------------------------------------
-#
 %preun
 if [ "$1" = "0" ]; then
-       /sbin/service junkbuster stop > /dev/null 2>&1
+       /sbin/service junkbuster stop > /dev/null 2>&1 ||:
        /sbin/chkconfig --del junkbuster
 fi
 
-#
-# -----------------------------------------------------------------------------
-#
 %postun
-if [ "$1" -ge "1" ]; then
-       /sbin/service junkbuster condrestart > /dev/null 2>&1
-fi
+#if [ "$1" -ge "1" ]; then
+#      /sbin/service junkbuster condrestart > /dev/null 2>&1
+#fi
 
-#
-# -----------------------------------------------------------------------------
-#
-%post
-/sbin/chkconfig --add junkbuster
-
-#
-# -----------------------------------------------------------------------------
-#
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-#
-# -----------------------------------------------------------------------------
-#
 %files
 %defattr(-,root,root)
-# %doc ijbfaq.html ijbman.html README README.TOO gpl.html 
-%doc junkbuster.weekly junkbuster.monthly
-%dir /etc/junkbuster
-%config /etc/junkbuster/config
-%config /etc/junkbuster/permissionsfile
-%config /etc/junkbuster/re_filterfile
-%config /etc/junkbuster/trust
-%dir /etc/junkbuster/templates
-%config /etc/junkbuster/templates/default
-%config /etc/junkbuster/templates/show-status
-%config /etc/junkbuster/templates/show-status-file
-%attr(0744,junkbust,junkbust) %dir /var/log/junkbuster
-%config /etc/logrotate.d/junkbuster
-%attr(0744,junkbust,junkbust)/usr/sbin/junkbuster
-%{_mandir}/*/*
-%config /etc/rc.d/init.d/junkbuster
+%doc doc/webserver/developer-manual doc/webserver/user-manual README 
+%doc junkbuster.weekly junkbuster.monthly AUTHORS
+%dir %{ijbconf}
+%config %{ijbconf}/*
+%attr(0744,junkbuster,junkbuster) %dir /var/log/junkbuster
+%config %{_sysconfdir}/logrotate.d/junkbuster
+%attr(0744,junkbuster,junkbuster)/usr/sbin/junkbuster
+%{_mandir}/man8/*
+%config %{_sysconfdir}/rc.d/init.d/junkbuster
 
-#
-# -----------------------------------------------------------------------------
-#
 
 %changelog
+* Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
+- Back to user 'junkbuster' and fix configure macro.
+
+* Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
+- More changes for user 'junkbust'. Init script had 'junkbuster'.
+
+* Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
+- Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
+- Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
+
+* Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
+- Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
+- made sure no default shell exists for user junkbust.
 
 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
 - rework of RPM