Merge in changes from Debian packages 3.0.0-3 to 3.0.0-5
[privoxy.git] / debian / rules
index 63e4111..ad7116a 100755 (executable)
@@ -5,9 +5,6 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=3
-
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -15,17 +12,11 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 DEBDIR=`pwd`/debian/privoxy
 
-CFLAGS="-O2"
-WITHDEBUG=""
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -g
-       WITHDEBUG="--with-debug"
-endif
-
-# hppa doesn't support -pthread option, so we complety disable pthread
-# on hppa until there is a better solution in configure.
-ifeq "$(DEB_HOST_GNU_TYPE)" "hppa-linux"
-       WITHOUTPTHREAD="--disable-pthread"
+OPTIMIZE=
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+        OPTIMIZE=-O0
+else
+        OPTIMIZE=-O2
 endif
 
 configure: configure-stamp
@@ -34,9 +25,9 @@ configure-stamp:
 
        autoheader
        autoconf
-       env CFLAGS=$(CFLAGS) \
+       env CFLAGS="$(OPTIMIZE) -g" \
                ./configure --prefix=/usr --sysconfdir=/etc \
-               --mandir=/usr/share/man $(WITHDEBUG) $(WITHOUTPTHREAD) \
+               --mandir=/usr/share/man $(WITHDEBUG) \
                --with-docbook=no
 
        touch configure-stamp
@@ -71,9 +62,10 @@ install: build
        install -m 0755 privoxy $(DEBDIR)/usr/sbin/privoxy
 
        sed -e 's/^\(\(trust\|proxy\)-info-url\|admin-address\)/#\1/'  \
-           -e 's/^\(enable-\(edit-actions\|remote-toggle\)\)/#\1/' \
+           -e 's/^\(enable-\(edit-actions\|remote-toggle\)\)[  ]*1/\1 0/' \
            -e 's#^confdir \.#confdir /etc/privoxy#' \
            -e 's#^logdir \.#logdir /var/log/privoxy#' \
+           -e 's%^#\(user-manual\).*%\1 /usr/share/doc/privoxy/user-manual%' \
            -e 's/\(Sample Configuration File for Privoxy\).*/\1/' \
            -e 's/Id: config,v.*/Id: config,v $$/' \
                < config > $(DEBDIR)/etc/privoxy/config