Merge changes from Debian revision 3.0.6-4.
[privoxy.git] / debian / rules
index 8f6c4a5..a842236 100755 (executable)
@@ -1,6 +1,6 @@
 #!/usr/bin/make -f
 #
-# (C) 2002-2006 Roland Rosenfeld <roland@debian.org>, based on
+# (C) 2002-2007 Roland Rosenfeld <roland@debian.org>, based on
 # Sample debian/rules that uses debhelper.
 # This file is public domain software, originally written by Joey Hess. 
 
@@ -33,6 +33,7 @@ build-stamp: patch-stamp
        env CFLAGS="$(OPTIMIZE) -g" \
                ./configure --prefix=/usr --sysconfdir=/etc \
                --mandir=/usr/share/man $(WITHDEBUG) \
+               --enable-zlib \
                --with-docbook=/usr/share/sgml/docbook/stylesheet/dsssl/modular
        $(MAKE)
 #       create missing doc/pdf directory if necessary:
@@ -56,8 +57,8 @@ clean1:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       -$(MAKE) clean
-       -$(MAKE) distclean
+       [ ! -f GNUmakefile ] || $(MAKE) clean
+       [ ! -f GNUmakefile ] || $(MAKE) distclean
        rm -f configure config.h GNUmakefile
        rm -f privoxy.8