Updated Makefile with 3.0 changes (pdf and man targets, etc). Revise comments
[privoxy.git] / debian / rules
index 06fb8a2..8ec4a57 100755 (executable)
@@ -28,11 +28,9 @@ configure-stamp:
 
        autoheader
        autoconf
-       env CFLAGS=$(CFLAGS) WDUMP=w3m \
+       env CFLAGS=$(CFLAGS) \
                ./configure --prefix=/usr --sysconfdir=/etc \
-               --mandir=/usr/share/man $(WITHDEBUG) \
-               --with-docbook=/usr/share/sgml/docbook/stylesheet/dsssl/modular
-
+               --mandir=/usr/share/man $(WITHDEBUG)
        touch configure-stamp
 
 build: build-stamp
@@ -40,8 +38,6 @@ build-stamp: configure-stamp
        dh_testdir
 
        $(MAKE)
-       $(MAKE) dok-devel dok-user dok-faq
-
        touch build-stamp
 
 clean:
@@ -115,5 +111,9 @@ binary-arch: build install
        dh_md5sums
        dh_builddeb
 
+# Single step doc building on debian
+debian-dok: configure-stamp
+       $(MAKE) dok
+
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: build clean binary-indep binary-arch binary install configure debian-dok