merge Debian changes from 3.0.7 to 3.0.10
[privoxy.git] / debian / rules
index badf9c5..75ec21f 100755 (executable)
@@ -1,6 +1,6 @@
 #!/usr/bin/make -f
 #
-# (C) 2002-2006 Roland Rosenfeld <roland@debian.org>, based on
+# (C) 2002-2008 Roland Rosenfeld <roland@debian.org>, based on
 # Sample debian/rules that uses debhelper.
 # This file is public domain software, originally written by Joey Hess. 
 
@@ -14,6 +14,9 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 DEBDIR=`pwd`/debian/privoxy
 
+# Include dpatch stuff.
+include /usr/share/dpatch/dpatch.make
+
 OPTIMIZE=
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         OPTIMIZE=-O0
@@ -30,21 +33,13 @@ build-stamp: patch-stamp
        env CFLAGS="$(OPTIMIZE) -g" \
                ./configure --prefix=/usr --sysconfdir=/etc \
                --mandir=/usr/share/man $(WITHDEBUG) \
+               --enable-zlib \
                --with-docbook=/usr/share/sgml/docbook/stylesheet/dsssl/modular
        $(MAKE)
-#       create missing doc/pdf directory if necessary:
-       [ -d doc/pdf ] || mkdir doc/pdf
-       $(MAKE) dok-pdf
        $(MAKE) dok
        env -u LANG $(MAKE) man
        $(MAKE) man2html
 
-#      remove trailing whitespaces:
-       for x in developer-manual user-manual faq; do \
-               sed -e 's/[     ]*$$//' < doc/text/$$x.txt > doc/text/$$x.nws;\
-               mv -f doc/text/$$x.nws doc/text/$$x.txt; \
-       done
-
        touch build-stamp
 
 clean: clean1 unpatch
@@ -53,8 +48,8 @@ clean1:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       -$(MAKE) clean
-       -$(MAKE) distclean
+       [ ! -f GNUmakefile ] || $(MAKE) clean
+       [ ! -f GNUmakefile ] || $(MAKE) distclean
        rm -f configure config.h GNUmakefile
        rm -f privoxy.8
 
@@ -64,25 +59,30 @@ clean1:
 
        rm -f doc/source/ldp.dsl
        rm -rf doc/source/temp
-#      rm -rf doc/pdf
 
        dh_clean -Xrc.privoxy.orig
 
 install: build-stamp
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_clean -k -Xrc.privoxy.orig
        dh_installdirs
 
        install -m 0755 privoxy $(DEBDIR)/usr/sbin/privoxy
 
        install -m 644 config $(DEBDIR)/etc/privoxy/config
        install -m 0644 default.action $(DEBDIR)/etc/privoxy/default.action
+       install -m 0644 global.action $(DEBDIR)/etc/privoxy/global.action
        install -m 0644 standard.action $(DEBDIR)/etc/privoxy/standard.action
        install -m 0644 user.action $(DEBDIR)/etc/privoxy/user.action
        install -m 0644 default.filter $(DEBDIR)/etc/privoxy/default.filter
        install -m 0644 trust $(DEBDIR)/etc/privoxy/trust
 
+       install -m 0755 tools/privoxy-log-parser.pl \
+               $(DEBDIR)/usr/bin/privoxy-log-parser
+       pod2man tools/privoxy-log-parser.pl \
+               > $(DEBDIR)/usr/share/man/man1/privoxy-log-parser.1
+
        cp -r templates $(DEBDIR)/etc/privoxy/
        rm -f $(DEBDIR)/etc/privoxy/templates/*~
        rm -rf $(DEBDIR)/etc/privoxy/templates/CVS
@@ -124,26 +124,16 @@ binary-arch: build-stamp install
        dh_installchangelogs ChangeLog
        dh_link
        dh_strip
-       dh_compress -Xpdf
+       dh_compress
        dh_fixperms
 #      dh_makeshlibs
        dh_installdeb
-#      dh_perl
+       dh_perl
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-patch: patch-stamp
-patch-stamp:
-       dpatch apply-all
-       touch patch-stamp
-       #dpatch call-all -a=pkg-info >patch-stamp
-
-unpatch:
-       dpatch deapply-all
-       rm -rf patch-stamp debian/patched
-
 binary: binary-indep binary-arch
 
 .PHONY: build clean binary-indep binary-arch binary install patch unpatch \