Add changes from 3.0.6-2, 3.0.6-3 and several unreleased changes
[privoxy.git] / debian / rules
index d30d495..6e7ada5 100755 (executable)
@@ -14,6 +14,9 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 DEBDIR=`pwd`/debian/privoxy
 
+# Include dpatch stuff.
+include /usr/share/dpatch/dpatch.make
+
 OPTIMIZE=
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         OPTIMIZE=-O0
@@ -30,6 +33,7 @@ build-stamp: patch-stamp
        env CFLAGS="$(OPTIMIZE) -g" \
                ./configure --prefix=/usr --sysconfdir=/etc \
                --mandir=/usr/share/man $(WITHDEBUG) \
+               --enable-zlib \
                --with-docbook=/usr/share/sgml/docbook/stylesheet/dsssl/modular
        $(MAKE)
 #       create missing doc/pdf directory if necessary:
@@ -135,16 +139,6 @@ binary-arch: build-stamp install
        dh_md5sums
        dh_builddeb
 
-patch: patch-stamp
-patch-stamp:
-       dpatch apply-all
-       touch patch-stamp
-       #dpatch call-all -a=pkg-info >patch-stamp
-
-unpatch:
-       dpatch deapply-all
-       rm -rf patch-stamp debian/patched
-
 binary: binary-indep binary-arch
 
 .PHONY: build clean binary-indep binary-arch binary install patch unpatch \