This is most of Al's patch for --with-user and --with-group which tests that
[privoxy.git] / debian / rules
index 06fb8a2..63e4111 100755 (executable)
@@ -22,16 +22,22 @@ ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        WITHDEBUG="--with-debug"
 endif
 
+# hppa doesn't support -pthread option, so we complety disable pthread
+# on hppa until there is a better solution in configure.
+ifeq "$(DEB_HOST_GNU_TYPE)" "hppa-linux"
+       WITHOUTPTHREAD="--disable-pthread"
+endif
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
 
        autoheader
        autoconf
-       env CFLAGS=$(CFLAGS) WDUMP=w3m \
+       env CFLAGS=$(CFLAGS) \
                ./configure --prefix=/usr --sysconfdir=/etc \
-               --mandir=/usr/share/man $(WITHDEBUG) \
-               --with-docbook=/usr/share/sgml/docbook/stylesheet/dsssl/modular
+               --mandir=/usr/share/man $(WITHDEBUG) $(WITHOUTPTHREAD) \
+               --with-docbook=no
 
        touch configure-stamp
 
@@ -40,7 +46,6 @@ build-stamp: configure-stamp
        dh_testdir
 
        $(MAKE)
-       $(MAKE) dok-devel dok-user dok-faq
 
        touch build-stamp
 
@@ -69,6 +74,8 @@ install: build
            -e 's/^\(enable-\(edit-actions\|remote-toggle\)\)/#\1/' \
            -e 's#^confdir \.#confdir /etc/privoxy#' \
            -e 's#^logdir \.#logdir /var/log/privoxy#' \
+           -e 's/\(Sample Configuration File for Privoxy\).*/\1/' \
+           -e 's/Id: config,v.*/Id: config,v $$/' \
                < config > $(DEBDIR)/etc/privoxy/config
        install -m 0644 default.action $(DEBDIR)/etc/privoxy/default.action
        install -m 0644 standard.action $(DEBDIR)/etc/privoxy/standard.action