Don't compress PDF files.
[privoxy.git] / debian / rules
index 6fecafd..5490b5d 100755 (executable)
@@ -5,9 +5,6 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=3
-
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -15,11 +12,11 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 DEBDIR=`pwd`/debian/privoxy
 
-CFLAGS="-O2"
-WITHDEBUG=""
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -g
-       WITHDEBUG="--with-debug"
+OPTIMIZE=
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+        OPTIMIZE=-O0
+else
+        OPTIMIZE=-O2
 endif
 
 configure: configure-stamp
@@ -28,20 +25,33 @@ configure-stamp:
 
        autoheader
        autoconf
-       env CFLAGS=$(CFLAGS) \
+       env CFLAGS="$(OPTIMIZE) -g" \
                ./configure --prefix=/usr --sysconfdir=/etc \
-                       --mandir=/usr/share/man --with-docbook=no \
-                       $(WITHDEBUG)
+               --mandir=/usr/share/man $(WITHDEBUG)
 
        touch configure-stamp
 
 build: build-stamp
-
 build-stamp: configure-stamp 
        dh_testdir
 
        $(MAKE)
 
+#      backup formatted upstream documentation:
+       for x in text webserver pdf; do \
+               if [ ! -d doc/$$x.dist ]; then \
+                       cp -a doc/$$x doc/$$x.dist; \
+               fi; \
+       done
+       for x in INSTALL README privoxy.1; do \
+               if [ ! -f $$x.dist ]; then \
+                       cp -a $$x $$x.dist; \
+               fi; \
+       done
+
+       (cd doc/source; $(MAKE) pdf)
+       (cd doc/source; $(MAKE) all)
+
        touch build-stamp
 
 clean:
@@ -50,9 +60,27 @@ clean:
        rm -f build-stamp configure-stamp
 
        -$(MAKE) clean
+       -$(MAKE) distclean
        rm -f privoxy 
-       rm -f configure config.h config.h.in config.log config.cache \
-               config.status GNUmakefile
+       rm -f configure config.h GNUmakefile 
+       rm -f doc/source/ldp.dsl
+       rm -rf obj
+       rm -f ActivityConsole.jar
+       rm -f src/java/org/privoxy/activityconsole/*.class
+
+#      restore formatted upstream documentation:
+       for x in text webserver pdf; do \
+               if [ -d doc/$$x.dist ]; then \
+                       rm -rf doc/$$x; \
+                       mv doc/$$x.dist doc/$$x; \
+               fi; \
+       done
+       for x in INSTALL README privoxy.1; do \
+               if [ -f $$x.dist ]; then \
+                       rm -f $$x; \
+                       mv $$x.dist $$x; \
+               fi; \
+       done
 
        dh_clean
 
@@ -65,10 +93,16 @@ install: build
        install -m 0755 privoxy $(DEBDIR)/usr/sbin/privoxy
 
        sed -e 's/^\(\(trust\|proxy\)-info-url\|admin-address\)/#\1/'  \
-           -e 's#^confdir \.#confdir /etc/privoxy#' \
-           -e 's#^logdir \.#logdir /var/log/privoxy#' \
+           -e 's/^\(enable-\(edit-actions\|remote-toggle\)\)[  ]*1/\1 0/' \
+           -e 's#^confdir .*#confdir /etc/privoxy#' \
+           -e 's#^logdir .*#logdir /var/log/privoxy#' \
+           -e 's%^#\(user-manual\).*%\1 /usr/share/doc/privoxy/user-manual%' \
+           -e 's/\(Sample Configuration File for Privoxy\).*/\1/' \
+           -e 's/Id: config,v.*/Id: config,v $$/' \
                < config > $(DEBDIR)/etc/privoxy/config
        install -m 0644 default.action $(DEBDIR)/etc/privoxy/default.action
+       install -m 0644 standard.action $(DEBDIR)/etc/privoxy/standard.action
+       install -m 0644 user.action $(DEBDIR)/etc/privoxy/user.action
        install -m 0644 default.filter $(DEBDIR)/etc/privoxy/default.filter
        install -m 0644 trust $(DEBDIR)/etc/privoxy/trust
 
@@ -76,10 +110,6 @@ install: build
        rm -f $(DEBDIR)/etc/privoxy/templates/*~
        rm -rf $(DEBDIR)/etc/privoxy/templates/CVS
 
-       cp -r doc/webserver/user-manual $(DEBDIR)/usr/share/doc/privoxy/
-       cp -r doc/webserver/faq $(DEBDIR)/usr/share/doc/privoxy/
-       cp -r doc/webserver/developer-manual $(DEBDIR)/usr/share/doc/privoxy/
-
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -90,7 +120,9 @@ binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
-       dh_installdocs
+       dh_installdocs -XCVS
+       (cd $(DEBDIR)/usr/share/doc/privoxy/; \
+        mv privoxy-index.html index.html)
        dh_installexamples
        dh_installmenu
        dh_installlogrotate
@@ -105,7 +137,7 @@ binary-arch: build install
        dh_installchangelogs ChangeLog
        dh_link
        dh_strip
-       dh_compress
+       dh_compress -Xpdf
        dh_fixperms
 #      dh_makeshlibs
        dh_installdeb