Don't compress PDF files.
[privoxy.git] / debian / rules
index 06fb8a2..5490b5d 100755 (executable)
@@ -5,9 +5,6 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=3
-
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -15,11 +12,11 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 DEBDIR=`pwd`/debian/privoxy
 
-CFLAGS="-O2"
-WITHDEBUG=""
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -g
-       WITHDEBUG="--with-debug"
+OPTIMIZE=
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+        OPTIMIZE=-O0
+else
+        OPTIMIZE=-O2
 endif
 
 configure: configure-stamp
@@ -28,10 +25,9 @@ configure-stamp:
 
        autoheader
        autoconf
-       env CFLAGS=$(CFLAGS) WDUMP=w3m \
+       env CFLAGS="$(OPTIMIZE) -g" \
                ./configure --prefix=/usr --sysconfdir=/etc \
-               --mandir=/usr/share/man $(WITHDEBUG) \
-               --with-docbook=/usr/share/sgml/docbook/stylesheet/dsssl/modular
+               --mandir=/usr/share/man $(WITHDEBUG)
 
        touch configure-stamp
 
@@ -40,7 +36,21 @@ build-stamp: configure-stamp
        dh_testdir
 
        $(MAKE)
-       $(MAKE) dok-devel dok-user dok-faq
+
+#      backup formatted upstream documentation:
+       for x in text webserver pdf; do \
+               if [ ! -d doc/$$x.dist ]; then \
+                       cp -a doc/$$x doc/$$x.dist; \
+               fi; \
+       done
+       for x in INSTALL README privoxy.1; do \
+               if [ ! -f $$x.dist ]; then \
+                       cp -a $$x $$x.dist; \
+               fi; \
+       done
+
+       (cd doc/source; $(MAKE) pdf)
+       (cd doc/source; $(MAKE) all)
 
        touch build-stamp
 
@@ -54,6 +64,23 @@ clean:
        rm -f privoxy 
        rm -f configure config.h GNUmakefile 
        rm -f doc/source/ldp.dsl
+       rm -rf obj
+       rm -f ActivityConsole.jar
+       rm -f src/java/org/privoxy/activityconsole/*.class
+
+#      restore formatted upstream documentation:
+       for x in text webserver pdf; do \
+               if [ -d doc/$$x.dist ]; then \
+                       rm -rf doc/$$x; \
+                       mv doc/$$x.dist doc/$$x; \
+               fi; \
+       done
+       for x in INSTALL README privoxy.1; do \
+               if [ -f $$x.dist ]; then \
+                       rm -f $$x; \
+                       mv $$x.dist $$x; \
+               fi; \
+       done
 
        dh_clean
 
@@ -66,9 +93,12 @@ install: build
        install -m 0755 privoxy $(DEBDIR)/usr/sbin/privoxy
 
        sed -e 's/^\(\(trust\|proxy\)-info-url\|admin-address\)/#\1/'  \
-           -e 's/^\(enable-\(edit-actions\|remote-toggle\)\)/#\1/' \
-           -e 's#^confdir \.#confdir /etc/privoxy#' \
-           -e 's#^logdir \.#logdir /var/log/privoxy#' \
+           -e 's/^\(enable-\(edit-actions\|remote-toggle\)\)[  ]*1/\1 0/' \
+           -e 's#^confdir .*#confdir /etc/privoxy#' \
+           -e 's#^logdir .*#logdir /var/log/privoxy#' \
+           -e 's%^#\(user-manual\).*%\1 /usr/share/doc/privoxy/user-manual%' \
+           -e 's/\(Sample Configuration File for Privoxy\).*/\1/' \
+           -e 's/Id: config,v.*/Id: config,v $$/' \
                < config > $(DEBDIR)/etc/privoxy/config
        install -m 0644 default.action $(DEBDIR)/etc/privoxy/default.action
        install -m 0644 standard.action $(DEBDIR)/etc/privoxy/standard.action
@@ -91,6 +121,8 @@ binary-arch: build install
        dh_testroot
 #      dh_installdebconf       
        dh_installdocs -XCVS
+       (cd $(DEBDIR)/usr/share/doc/privoxy/; \
+        mv privoxy-index.html index.html)
        dh_installexamples
        dh_installmenu
        dh_installlogrotate
@@ -105,7 +137,7 @@ binary-arch: build install
        dh_installchangelogs ChangeLog
        dh_link
        dh_strip
-       dh_compress
+       dh_compress -Xpdf
        dh_fixperms
 #      dh_makeshlibs
        dh_installdeb