Fixed(?) Conflicts: Provides: Obsoletes:
[privoxy.git] / privoxy-suse.spec
1 # $Id: privoxy-suse.spec,v 1.13 2002/04/11 10:09:20 oes Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public 
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # do not set to %{name}
30 %define privoxyconf %{_sysconfdir}/privoxy
31
32 Summary:      Privoxy - privacy enhancing proxy
33 Vendor:       http://www.privoxy.org
34 Name:         privoxy-suse
35 Distribution: defineme
36 Version: 2.9.14
37 Release: 1
38 # Needs makefile change: Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}-%{status}-src.tar.gz
39 Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}.tar.gz
40 # not sure if this works
41 BuildRoot: %{_tmppath}/%{name}-%{version}-root
42 Packager:     Stefan Waldherr <stefan@waldherr.org>
43 Copyright:    GPL
44 Group:        Networking/Utilities
45 URL:          http://www.privoxy.org/
46 Autoreqprov:  on
47 BuildRequires: perl gzip libtool autoconf
48 Conflicts: junkbuster-raw junkbuster-blank junkbuster-suse junkbuster privoxy
49
50 #
51 # -----------------------------------------------------------------------------
52 #
53 %description
54 Privoxy is a web proxy with advanced filtering capabilities for
55 protecting privacy, filtering web page content, managing cookies,
56 controlling access, and removing ads, banners, pop-ups and other
57 obnoxious Internet junk. Privoxy has a very flexible configuration and
58 can be customized to suit individual needs and tastes. Privoxy has 
59 application for both stand-alone systems and multi-user networks.
60
61 Privoxy is based on the  Internet Junkbuster.
62
63 Authors:
64 --------
65     http://www.privoxy.org/
66
67 SuSE series: n
68
69 #
70 # -----------------------------------------------------------------------------
71 #
72 %prep
73 %setup -c
74
75 #
76 # -----------------------------------------------------------------------------
77 #
78 %build
79 autoheader
80 autoconf
81 ./configure
82 make
83
84
85 ## Explicitily stripping is not recomended.
86 ## This is handled altomaticaly by RPM, and can couse troubles if
87 ## anyone wants to build an unstriped version - morcego
88 #strip privoxy
89
90 #
91 # -----------------------------------------------------------------------------
92 #
93 %install
94 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
95 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
96          ${RPM_BUILD_ROOT}%{_mandir}/man8 \
97          ${RPM_BUILD_ROOT}/var/log/privoxy \
98          ${RPM_BUILD_ROOT}%{privoxyconf}/templates \
99          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
100          ${RPM_BUILD_ROOT}%{_sysconfdir}/init.d
101 gzip README AUTHORS ChangeLog privoxy.1 LICENSE || /bin/true
102 install -s -m 744 privoxy $RPM_BUILD_ROOT%{_sbindir}/privoxy
103 cp -f privoxy.1.gz $RPM_BUILD_ROOT%{_mandir}/man8/privoxy.8.gz
104 cp -f *.action $RPM_BUILD_ROOT%{privoxyconf}/
105 cp -f default.filter $RPM_BUILD_ROOT%{privoxyconf}/default.filter
106 cp -f trust $RPM_BUILD_ROOT%{privoxyconf}/trust
107 cp -f templates/*  $RPM_BUILD_ROOT%{privoxyconf}/templates/
108 cp -f privoxy.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/privoxy
109 install -m 755 privoxy.init.suse $RPM_BUILD_ROOT%{_sysconfdir}/init.d/privoxy
110 install -m 711 -d $RPM_BUILD_ROOT/var/log/privoxy
111 ln -sf /etc/init.d/privoxy $RPM_BUILD_ROOT/usr/sbin/rcprivoxy
112
113 # verify all file locations, etc. in the config file
114 # don't start with ^ or commented lines are not replaced
115 cat config | \
116     sed 's/^confdir.*/confdir \/etc\/privoxy/g' | \
117 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/privoxy\/permissionsfile/g' | \
118 #    sed 's/^filterfile.*/default.filter \/etc\/privoxy\/default.filter/g' | \
119 #    sed 's/^logfile.*/logfile \/var\/log\/privoxy\/logfile/g' | \
120 #    sed 's/^jarfile.*/jarfile \/var\/log\/privoxy\/jarfile/g' | \
121 #    sed 's/^forward.*/forward \/etc\/privoxy\/forward/g' | \
122 #    sed 's/^aclfile.*/aclfile \/etc\/privoxy\/aclfile/g' > \
123     sed 's/^logdir.*/logdir \/var\/log\/privoxy/g' > \
124     $RPM_BUILD_ROOT%{privoxyconf}/config
125
126 #
127 # -----------------------------------------------------------------------------
128 #
129 %pre
130 # We check to see if the user privoxy exists.
131 # If it does, we do nothing
132 # If we don't, we check to see if the user junkbust exist and, in case it
133 # does, we change it do privoxy. If it also does not exist, we create the
134 # privoxy user -- morcego
135 id privoxy > /dev/null 2>&1 
136 if [ $? -eq 1 ]; then
137         id junkbust > /dev/null 2>&1 
138         if [ $? -eq 0 ]; then
139                 /usr/sbin/usermod -l privoxy -d %{_sysconfdir}/privoxy -s "" junkbust  > /dev/null 2>&1
140         else
141 # -r does not work on suse.
142                 /usr/sbin/groupadd privoxy
143                 /usr/sbin/useradd -d %{_sysconfdir}/privoxy -g privoxy -s "" privoxy > /dev/null 2>&1 
144         fi
145 fi
146
147 #
148 # -----------------------------------------------------------------------------
149 #
150 %post
151 [ -f /var/log/privoxy/privoxy ] &&\
152  mv -f /var/log/privoxy/privoxy /var/log/privoxy/logfile || /bin/true
153 chown -R privoxy:privoxy /var/log/privoxy 2>/dev/null
154 chown -R privoxy:privoxy /etc/privoxy 2>/dev/null
155 # not available on suse
156 #if [ "$1" = "1" ]; then
157 #     /sbin/chkconfig --add privoxy
158 #       /sbin/service privoxy condrestart > /dev/null 2>&1
159 #fi
160 # 01/09/02 HB, getting rid of any user=junkbust
161 # Changed by morcego to use the id command.
162 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
163 sbin/insserv etc/init.d/privoxy
164
165 #
166 # -----------------------------------------------------------------------------
167 #
168 %preun
169 # need to stop the service on suse. swa.
170 #if [ "$1" = "0" ]; then
171 #       /sbin/service privoxy stop > /dev/null 2>&1 ||:
172 #fi
173
174 #
175 # -----------------------------------------------------------------------------
176 #
177 %postun
178 sbin/insserv etc/init.d/
179 # dont forget to remove user and group privoxy
180 id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
181
182 #
183 # -----------------------------------------------------------------------------
184 #
185 %clean
186 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
187
188 #
189 # -----------------------------------------------------------------------------
190 #
191 %files
192 %defattr(-,root,root)
193 %doc README.gz AUTHORS.gz ChangeLog.gz LICENSE.gz
194 %doc doc/webserver/developer-manual
195 %doc doc/webserver/user-manual
196 %doc doc/webserver/faq
197 %doc doc/webserver/p_doc.css
198 %doc doc/webserver/p_web.css
199 %doc doc/webserver/index.html
200 #%doc privoxy.weekly privoxy.monthly AUTHORS
201 %dir %{privoxyconf}
202 %config %{privoxyconf}/*
203 %attr(0744,privoxy,privoxy) %dir /var/log/privoxy
204 %config %{_sysconfdir}/logrotate.d/privoxy
205 %attr(0755,root,root)/usr/sbin/privoxy
206 %{_mandir}/man8/*
207 %config %{_sysconfdir}/init.d/privoxy
208 /usr/sbin/rcprivoxy
209
210 #
211 # -----------------------------------------------------------------------------
212 #
213 %changelog
214 * Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
215 + privoxy-2.9.13-4
216 - Add LICENSE.gz, p_web.css, and index.html. Add autoconf
217 - to Buildrequires.
218
219 * Wed Mar 27 2002 Hal Burgiss <hal@foobox.net>
220 + privoxy-2.9.13-3
221 - Doc css has changed names.
222
223 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
224 + privoxy-2.9.13-3
225 - Minor fix to description.
226
227 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
228 - added faq to docs.
229
230 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
231 - added ijb_docs.css to docs.
232
233 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
234 - Remove --enable-no-gifs from configure.
235
236 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
237 - /bin/false for shell causes init script to fail. Reverting.
238
239 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
240 - Removed UID 73. Included user-manual and developer-manual in docs.
241   Include other actions files. Default shell is now /bin/false.
242   Userdel user=junkbust. ChangeLog was not zipped. Removed
243   RPM_OPT_FLAGS kludge.
244
245 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
246 - add paranoia check for 'rm -rf $RPM_BUILD_ROOT'
247 - add gzip to 'BuildRequires'
248
249 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
250 - actionsfile is now ijb.action.
251
252 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
253 - Compress manpage
254 - Add more documents for installation
255 - Add version string to name and source
256
257 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
258 - Back to user 'junkbuster' and fix configure macro.
259
260 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
261 - More changes for user 'junkbust'. Init script had 'junkbuster'.
262
263 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
264 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
265 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
266
267 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
268 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and
269 - made sure no default shell exists for user junkbust.
270
271 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
272 - rework of RPM
273 * Wed Feb 14 2001 - uli@suse.de
274 - fixed init script
275 * Wed Dec 06 2000 - bjacke@suse.de
276 - renamed package to junkbuster
277 - fixed copyright tag
278 * Thu Nov 30 2000 - uli@suse.de
279 - moved init script to /etc/init.d
280 * Wed Feb 16 2000 - kukuk@suse.de
281 - Move /usr/man -> /usr/share/man
282 - Mark /etc/ijb as "config(noreplace)"
283 * Mon Sep 20 1999 - uli@suse.de
284 - fixed init script
285 * Mon Sep 13 1999 - bs@suse.de
286 - ran old prepare_spec on spec file to switch to new prepare_spec.
287 * Thu Apr 01 1999 - daniel@suse.de
288 - do not start ijb as root (security)
289 * Tue Mar 30 1999 - daniel@suse.de
290 - donĀ“t use saclfile.ini
291 * Tue Mar 30 1999 - daniel@suse.de
292 - small fix to whitelist-configuration,
293   version is and was 2.0.2 WITHOUT Stefan Waldherr's patches
294   (http://www.waldherr.org/junkbuster/)
295 * Mon Mar 01 1999 - daniel@suse.de
296 - new package: version 2.0
297
298 # $Log: privoxy-suse.spec,v $
299 # Revision 1.13  2002/04/11 10:09:20  oes
300 # Version 2.9.14
301 #
302 # Revision 1.12  2002/04/09 13:29:43  swa
303 # build suse and gen-dist with html docs. do not generate docs while building rpm
304 #
305 # Revision 1.11  2002/04/09 03:12:37  hal9
306 # Add LICENSE, p_web.css and index.html. Add autoconf to buildrequires.
307 #
308 # Revision 1.10  2002/04/08 20:24:13  swa
309 # fixed JB spelling
310 #
311 # Revision 1.9  2002/03/30 09:01:52  swa
312 # new release
313 #
314 # Revision 1.8  2002/03/27 23:46:41  hal9
315 # ijb_docs.css to p_doc.css
316 #
317 # Revision 1.7  2002/03/27 00:49:39  hal9
318 # Minor fix to description.
319 #
320 # Revision 1.6  2002/03/26 22:29:55  swa
321 # we have a new homepage!
322 #
323 # Revision 1.5  2002/03/25 03:10:50  hal9
324 # Added faq to docs.
325 #
326 # Revision 1.4  2002/03/24 12:56:21  swa
327 # name change related issues.
328 #
329 # Revision 1.3  2002/03/24 12:44:31  swa
330 # new version string
331 #
332 # Revision 1.2  2002/03/24 11:40:14  swa
333 # name change
334 #
335 # Revision 1.1  2002/03/24 11:23:44  swa
336 # name change
337 #
338 # Revision 1.21  2002/03/21 16:04:33  hal9
339 # added ijb_docs.css to %%doc
340 #
341 # Revision 1.20  2002/03/12 13:42:14  sarantis
342 # remove hardcoded "ijbswa" from build phase
343 #
344 # Revision 1.19  2002/03/11 22:59:05  hal9
345 # Remove --enable-no-gifs
346 #
347 # Revision 1.18  2002/03/11 12:30:31  swa
348 # be consistent with rh spec file
349 #
350 # Revision 1.17  2002/03/08 19:30:23  swa
351 # remove user junkbuster after de-installation.
352 # synced suse with rh-specfile. installation
353 # and de-installation seem to work.
354 #
355 # Revision 1.16  2002/03/08 18:40:44  swa
356 # build requires tools. useradd and del works
357 # now.
358 #
359 # Revision 1.15  2002/03/07 19:23:50  swa
360 # i hate to scroll. suse: wrong configdir.
361 #
362 # Revision 1.14  2002/03/07 19:10:21  swa
363 # builds cleanly. thanks to kukuk@suse.de
364 # not yet tested.
365 #
366 # Revision 1.13  2002/03/07 18:25:56  swa
367 # synced redhat and suse build process
368 #
369 # Revision 1.12  2002/03/02 15:50:04  swa
370 # 2.9.11 version. more input for docs.
371 #
372 # Revision 1.11  2001/12/02 10:29:26  swa
373 # New version made these changes necessary.
374 #
375 # Revision 1.10  2001/10/31 19:27:27  swa
376 # consistent description. new name for suse since
377 # we had troubles with rpms of identical names
378 # on the webserver.
379 #
380 # Revision 1.9  2001/10/26 18:17:23  swa
381 # new version string
382 #
383 # Revision 1.8  2001/09/13 16:22:42  swa
384 # man page is legacy. suse rpm now contains html
385 # documentation.
386 #
387 # Revision 1.7  2001/09/10 17:44:22  swa
388 # integrate three pieces of documentation.
389 #
390 # Revision 1.6  2001/09/10 16:29:23  swa
391 # binary contained debug info.
392 # buildroot definition fucks up the build process under suse.
393 # program needs to write in varlogjunkbuster
394 # install all templates
395 # create varlogjunkbuster
396 #
397 # Revision 1.5  2001/06/09 09:13:29  swa
398 # description shorter
399 #
400 # Revision 1.4  2001/06/08 20:53:36  swa
401 # use buildroot, export init to separate file (better manageability)
402 #
403 # Revision 1.3  2001/06/07 17:28:10  swa
404 # cosmetics
405 #
406 # Revision 1.2  2001/06/07 17:18:44  swa
407 # header fixed
408 #
409 #