Rename load_actions_file() and load_re_filterfile()
[privoxy.git] / privoxy-suse.spec
1 # $Id: privoxy-suse.spec,v 1.28 2008/01/20 14:30:59 fabiankeil Exp $
2 #
3 # Written by and Copyright (C) 2001-2006 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public 
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # do not set to %{name}
30 %define privoxyconf %{_sysconfdir}/privoxy
31 %define privoxy_uid 73
32 %define privoxy_gid 73
33
34
35 Summary:      Privoxy - privacy enhancing proxy
36 Vendor:       Privoxy.Org
37 Name:         privoxy-suse
38 Distribution: defineme
39 Version: 3.0.9
40 Release: 1
41 # Needs makefile change: Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}-%{status}-src.tar.gz
42 Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}.tar.gz
43 # not sure if this works
44 BuildRoot: %{_tmppath}/%{name}-%{version}-root
45 Packager:     http://www.privoxy.org/
46 License:     GPL
47 Group:        Networking/Utilities
48 URL:          http://www.privoxy.org/
49 Autoreqprov:  on
50 BuildRequires: perl gzip libtool autoconf
51 Conflicts: junkbuster-raw junkbuster-blank junkbuster-suse junkbuster privoxy
52
53 #
54 # -----------------------------------------------------------------------------
55 #
56 %description
57 Privoxy is a web proxy with advanced filtering capabilities for
58 protecting privacy, modifying web page data, managing cookies,
59 controlling access, and removing ads, banners, pop-ups and other
60 obnoxious Internet junk. Privoxy has a very flexible configuration and
61 can be customized to suit individual needs and tastes. Privoxy has 
62 application for both stand-alone systems and multi-user networks.
63
64 Privoxy is based on the Internet Junkbuster.
65
66 Authors:
67 --------
68     http://www.privoxy.org/
69
70 SuSE series: n
71
72 #
73 # -----------------------------------------------------------------------------
74 #
75 %prep
76 %setup -c
77
78 #
79 # -----------------------------------------------------------------------------
80 #
81 %build
82 autoheader
83 autoconf
84 ./configure --disable-dynamic-pcre
85 make
86
87
88 ## Explicitily stripping is not recomended.
89 ## This is handled altomaticaly by RPM, and can couse troubles if
90 ## anyone wants to build an unstriped version - morcego
91 #strip privoxy
92
93 #
94 # -----------------------------------------------------------------------------
95 #
96 %install
97 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
98 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
99          ${RPM_BUILD_ROOT}%{_mandir}/man8 \
100          ${RPM_BUILD_ROOT}/var/log/privoxy \
101          ${RPM_BUILD_ROOT}%{privoxyconf}/templates \
102          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
103          ${RPM_BUILD_ROOT}%{_sysconfdir}/init.d
104 gzip README AUTHORS ChangeLog privoxy.1 LICENSE || /bin/true
105 install -s -m 744 privoxy $RPM_BUILD_ROOT%{_sbindir}/privoxy
106 cp -f privoxy.1.gz $RPM_BUILD_ROOT%{_mandir}/man8/privoxy.8.gz
107 cp -f *.action $RPM_BUILD_ROOT%{privoxyconf}/
108 cp -f default.filter $RPM_BUILD_ROOT%{privoxyconf}/default.filter
109 cp -f trust $RPM_BUILD_ROOT%{privoxyconf}/trust
110 cp -f templates/*  $RPM_BUILD_ROOT%{privoxyconf}/templates/
111 cp -f privoxy.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/privoxy
112 install -m 755 privoxy.init.suse $RPM_BUILD_ROOT%{_sysconfdir}/init.d/privoxy
113 install -m 711 -d $RPM_BUILD_ROOT/var/log/privoxy
114 ln -sf /etc/init.d/privoxy $RPM_BUILD_ROOT/usr/sbin/rcprivoxy
115
116 # verify all file locations, etc. in the config file
117 # don't start with ^ or commented lines are not replaced
118 cat config | \
119     sed 's/^confdir.*/confdir \/etc\/privoxy/g' | \
120 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/privoxy\/permissionsfile/g' | \
121 #    sed 's/^filterfile.*/default.filter \/etc\/privoxy\/default.filter/g' | \
122 #    sed 's/^logfile.*/logfile \/var\/log\/privoxy\/logfile/g' | \
123 #    sed 's/^jarfile.*/jarfile \/var\/log\/privoxy\/jarfile/g' | \
124 #    sed 's/^forward.*/forward \/etc\/privoxy\/forward/g' | \
125 #    sed 's/^aclfile.*/aclfile \/etc\/privoxy\/aclfile/g' > \
126     sed 's/^logdir.*/logdir \/var\/log\/privoxy/g' > \
127     $RPM_BUILD_ROOT%{privoxyconf}/config
128
129 #
130 # -----------------------------------------------------------------------------
131 #
132 %pre
133 # We check to see if the user privoxy exists.
134 # If it does, we do nothing
135 # If we don't, we check to see if the user junkbust exist and, in case it
136 # does, we change it do privoxy. If it also does not exist, we create the
137 # privoxy user -- morcego
138 id privoxy > /dev/null 2>&1 
139 if [ $? -eq 1 ]; then
140         id junkbust > /dev/null 2>&1 
141         if [ $? -eq 0 ]; then
142                 /usr/sbin/usermod -u %{privoxy_uid} -g %{privoxy_gid} -l privoxy -d %{_sysconfdir}/privoxy -s "" junkbust  > /dev/null 2>&1
143         else
144 # -r does not work on suse.
145                 /usr/sbin/groupadd -g %{privoxy_gid} privoxy
146                 /usr/sbin/useradd -u %{privoxy_uid} -d %{_sysconfdir}/privoxy -g privoxy -s "" privoxy > /dev/null 2>&1 
147         fi
148 fi
149
150 #
151 # -----------------------------------------------------------------------------
152 #
153 %post
154 [ -f /var/log/privoxy/privoxy ] &&\
155  mv -f /var/log/privoxy/privoxy /var/log/privoxy/logfile || /bin/true
156 chown -R privoxy:privoxy /var/log/privoxy 2>/dev/null
157 chown -R privoxy:privoxy /etc/privoxy 2>/dev/null
158 # not available on suse
159 #if [ "$1" = "1" ]; then
160 #     /sbin/chkconfig --add privoxy
161 #       /sbin/service privoxy condrestart > /dev/null 2>&1
162 #fi
163 # 01/09/02 HB, getting rid of any user=junkbust
164 # Changed by morcego to use the id command.
165 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
166 sbin/insserv etc/init.d/privoxy
167
168 #
169 # -----------------------------------------------------------------------------
170 #
171 %preun
172 # need to stop the service on suse. swa.
173 #if [ "$1" = "0" ]; then
174 #       /sbin/service privoxy stop > /dev/null 2>&1 ||:
175 #fi
176
177 #
178 # -----------------------------------------------------------------------------
179 #
180 %postun
181 sbin/insserv etc/init.d/
182 # dont forget to remove user and group privoxy
183 id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
184
185 #
186 # -----------------------------------------------------------------------------
187 #
188 %clean
189 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
190
191 #
192 # -----------------------------------------------------------------------------
193 #
194 %files
195 %defattr(-,root,root)
196 %doc README.gz AUTHORS.gz ChangeLog.gz LICENSE.gz
197 %doc doc/webserver/developer-manual
198 %doc doc/webserver/user-manual
199 %doc doc/webserver/faq
200 %doc doc/webserver/p_doc.css
201 %doc doc/webserver/privoxy-index.html
202 %doc doc/webserver/images
203 %doc doc/webserver/man-page
204
205 %dir %{privoxyconf}
206 %config %{privoxyconf}/*
207 %attr(0740,privoxy,privoxy) %dir /var/log/privoxy
208 %config %{_sysconfdir}/logrotate.d/privoxy
209 %attr(0755,root,root)/usr/sbin/privoxy
210 %{_mandir}/man8/*
211 %config %{_sysconfdir}/init.d/privoxy
212 /usr/sbin/rcprivoxy
213
214 #
215 # -----------------------------------------------------------------------------
216 #
217 %changelog
218 * Wed Sep 20 2006 Hal Burgiss <hal@foobox.net>
219 - Bump version for 3.0.5.
220
221 * Fri Sep 08 2006 Hal Burgiss <hal@foobox.net>
222 - Bump version for 3.0.4.
223
224 * Wed Mar 26 2003 Andreas Oesterhelt <andreas@oesterhelt.org>
225 - Bump version for 3.0.2.
226
227 * Wed Mar 19 2003 Hal Burgiss <hal@foobox.net>
228 - Bump version for 3.0.1.
229
230 * Tue Aug 25 2002 Hal Burgiss <hal@foobox.net>
231 - Bump version for 3.0.0 :) 
232
233 * Tue Aug 06 2002 Hal Burgiss <hal@foobox.net>
234 - Reset version for 2.9.18. 
235
236 * Wed Jul 30 2002 Hal Burgiss <hal@foobox.net>
237 - Reset version for 2.9.17.
238
239 * Sat Jul 27 2002 Hal Burgiss <hal@foobox.net>
240 - Reset version and release for 2.9.16.
241
242 * Mon May 27 2002 Hal Burgiss <hal@foobox.net>
243 + privoxy-2.9.15-1
244 - Index.html is now privoxy-index.html for doc usage.
245
246 * Mon May 27 2002 Hal Burgiss <hal@foobox.net>
247 + privoxy-2.9.15-1
248 - Index.html is now privoxy-index.html for doc usage.
249
250 * Sat May 25 2002 Hal Burgiss <hal@foobox.net>
251 + privoxy-2.9.15-1
252 - Add html man page so index.html does not 404.
253
254 * Fri May 24 2002 Hal Burgiss <hal@foobox.net>
255 + privoxy-2.9.15-1
256 - Add doc/images directory.
257
258 * Fri May 03 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
259 + privoxy-suse-2.9.15-1
260 - Version bump
261
262 * Fri Apr 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
263 + privoxy-suse-2.9.14-3
264 - Changing Vendor to Privoxy.Org
265
266 * Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
267 + privoxy-suse-2.9.14-2
268 - Bumping release to reflect the new value on configure.in
269 - Taking the oportunity to change the header Copyright to License. The
270   Copyright headers is deprecated, and after all, GPL is a license, not a
271   Copyright
272
273 * Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
274 + privoxy-2.9.13-4
275 - Add LICENSE.gz, p_web.css, and index.html. Add autoconf
276 - to Buildrequires.
277
278 * Wed Mar 27 2002 Hal Burgiss <hal@foobox.net>
279 + privoxy-2.9.13-3
280 - Doc css has changed names.
281
282 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
283 + privoxy-2.9.13-3
284 - Minor fix to description.
285
286 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
287 - added faq to docs.
288
289 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
290 - added ijb_docs.css to docs.
291
292 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
293 - Remove --enable-no-gifs from configure.
294
295 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
296 - /bin/false for shell causes init script to fail. Reverting.
297
298 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
299 - Removed UID 73. Included user-manual and developer-manual in docs.
300   Include other actions files. Default shell is now /bin/false.
301   Userdel user=junkbust. ChangeLog was not zipped. Removed
302   RPM_OPT_FLAGS kludge.
303
304 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
305 - add paranoia check for 'rm -rf $RPM_BUILD_ROOT'
306 - add gzip to 'BuildRequires'
307
308 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
309 - actionsfile is now ijb.action.
310
311 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
312 - Compress manpage
313 - Add more documents for installation
314 - Add version string to name and source
315
316 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
317 - Back to user 'junkbuster' and fix configure macro.
318
319 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
320 - More changes for user 'junkbust'. Init script had 'junkbuster'.
321
322 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
323 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
324 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
325
326 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
327 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and
328 - made sure no default shell exists for user junkbust.
329
330 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
331 - rework of RPM
332 * Wed Feb 14 2001 - uli@suse.de
333 - fixed init script
334 * Wed Dec 06 2000 - bjacke@suse.de
335 - renamed package to junkbuster
336 - fixed copyright tag
337 * Thu Nov 30 2000 - uli@suse.de
338 - moved init script to /etc/init.d
339 * Wed Feb 16 2000 - kukuk@suse.de
340 - Move /usr/man -> /usr/share/man
341 - Mark /etc/ijb as "config(noreplace)"
342 * Mon Sep 20 1999 - uli@suse.de
343 - fixed init script
344 * Mon Sep 13 1999 - bs@suse.de
345 - ran old prepare_spec on spec file to switch to new prepare_spec.
346 * Thu Apr 01 1999 - daniel@suse.de
347 - do not start ijb as root (security)
348 * Tue Mar 30 1999 - daniel@suse.de
349 - donĀ“t use saclfile.ini
350 * Tue Mar 30 1999 - daniel@suse.de
351 - small fix to whitelist-configuration,
352   version is and was 2.0.2 WITHOUT Stefan Waldherr's patches
353   (http://www.waldherr.org/junkbuster/)
354 * Mon Mar 01 1999 - daniel@suse.de
355 - new package: version 2.0
356
357 # $Log: privoxy-suse.spec,v $
358 # Revision 1.28  2008/01/20 14:30:59  fabiankeil
359 # Set version to 3.0.8.
360 #
361 # Revision 1.27  2006/11/18 14:37:12  fabiankeil
362 # Bump version to 3.0.6.
363 #
364 # Revision 1.26  2006/09/20 23:51:26  hal9
365 # Bump versions to 3.0.5
366 #
367 # Revision 1.25  2006/09/09 00:35:10  hal9
368 # Bumped versions to 3.0.4. Both files should be checked further.
369 #
370 # Revision 1.24  2006/07/18 14:48:47  david__schmidt
371 # Reorganizing the repository: swapping out what was HEAD (the old 3.1 branch)
372 # with what was really the latest development (the v_3_0_branch branch)
373 #
374 # Revision 1.20.2.10  2004/01/30 17:09:29  oes
375 # Bumped version for 3.0.3
376 #
377 # Revision 1.20.2.9  2003/03/26 00:24:58  oes
378 # Bump version for 3.0.2
379 #
380 # Revision 1.20.2.8  2003/03/20 03:27:11  hal9
381 # Bump version for 3.0.1 pending release.
382 #
383 # Revision 1.20.2.7  2002/08/25 23:36:03  hal9
384 # Bump version for 3.0.0.
385 #
386 # Revision 1.20.2.6  2002/08/10 11:28:50  oes
387 # Bumped version
388 #
389 # Revision 1.20.2.5  2002/08/07 01:08:49  hal9
390 # Bumped version to 2.9.18.
391 #
392 # Revision 1.20.2.4  2002/07/30 21:51:19  hal9
393 # Bump version to 2.9.17.
394 #
395 # Revision 1.20.2.3  2002/07/27 15:47:10  hal9
396 # Reset version and release for 2.9.16.
397 #
398 # Revision 1.20.2.2  2002/05/28 02:39:38  hal9
399 # Replace index.html with privoxy-index.html for docs.
400 #
401 # Revision 1.20.2.1  2002/05/26 17:20:23  hal9
402 # Add images to doc dirs.
403 #
404 # Revision 1.20  2002/05/25 02:08:23  hal9
405 # Add doc/images directory.
406 # Redhat: alphabetized list of templates (and I think added one in the process)
407 #
408 # Revision 1.19  2002/05/03 17:14:36  morcego
409 # *.spec: Version bump to 2.9.15
410 # -rh.spec: noreplace for %%{privoxyconf}/config
411 #           Will interrupt the build if versions from configure.in and
412 #               specfile do not match
413 #
414 # Revision 1.18  2002/04/27 20:26:59  swa
415 # uid, gui 73 incorporated
416 #
417 # Revision 1.17  2002/04/26 15:51:05  morcego
418 # Changing Vendor value to Privoxy.Org
419 #
420 # Revision 1.16  2002/04/22 16:32:31  morcego
421 # configure.in, *.spec: Bumping release to 2 (2.9.14-2)
422 # -rh.spec: uid and gid are now macros
423 # -suse.spec: Changing the header Copyright to License (Copyright is
424 #             deprecable)
425 #
426 # Revision 1.15  2002/04/16 18:49:07  oes
427 # Build with static built-in pcre
428 #
429 # Revision 1.14  2002/04/11 17:57:40  oes
430 # Fixed(?) Conflicts: Provides: Obsoletes:
431 #
432 # Revision 1.13  2002/04/11 10:09:20  oes
433 # Version 2.9.14
434 #
435 # Revision 1.12  2002/04/09 13:29:43  swa
436 # build suse and gen-dist with html docs. do not generate docs while building rpm
437 #
438 # Revision 1.11  2002/04/09 03:12:37  hal9
439 # Add LICENSE, p_web.css and index.html. Add autoconf to buildrequires.
440 #
441 # Revision 1.10  2002/04/08 20:24:13  swa
442 # fixed JB spelling
443 #
444 # Revision 1.9  2002/03/30 09:01:52  swa
445 # new release
446 #
447 # Revision 1.8  2002/03/27 23:46:41  hal9
448 # ijb_docs.css to p_doc.css
449 #
450 # Revision 1.7  2002/03/27 00:49:39  hal9
451 # Minor fix to description.
452 #
453 # Revision 1.6  2002/03/26 22:29:55  swa
454 # we have a new homepage!
455 #
456 # Revision 1.5  2002/03/25 03:10:50  hal9
457 # Added faq to docs.
458 #
459 # Revision 1.4  2002/03/24 12:56:21  swa
460 # name change related issues.
461 #
462 # Revision 1.3  2002/03/24 12:44:31  swa
463 # new version string
464 #
465 # Revision 1.2  2002/03/24 11:40:14  swa
466 # name change
467 #
468 # Revision 1.1  2002/03/24 11:23:44  swa
469 # name change
470 #
471 # Revision 1.21  2002/03/21 16:04:33  hal9
472 # added ijb_docs.css to %%doc
473 #
474 # Revision 1.20  2002/03/12 13:42:14  sarantis
475 # remove hardcoded "ijbswa" from build phase
476 #
477 # Revision 1.19  2002/03/11 22:59:05  hal9
478 # Remove --enable-no-gifs
479 #
480 # Revision 1.18  2002/03/11 12:30:31  swa
481 # be consistent with rh spec file
482 #
483 # Revision 1.17  2002/03/08 19:30:23  swa
484 # remove user junkbuster after de-installation.
485 # synced suse with rh-specfile. installation
486 # and de-installation seem to work.
487 #
488 # Revision 1.16  2002/03/08 18:40:44  swa
489 # build requires tools. useradd and del works
490 # now.
491 #
492 # Revision 1.15  2002/03/07 19:23:50  swa
493 # i hate to scroll. suse: wrong configdir.
494 #
495 # Revision 1.14  2002/03/07 19:10:21  swa
496 # builds cleanly. thanks to kukuk@suse.de
497 # not yet tested.
498 #
499 # Revision 1.13  2002/03/07 18:25:56  swa
500 # synced redhat and suse build process
501 #
502 # Revision 1.12  2002/03/02 15:50:04  swa
503 # 2.9.11 version. more input for docs.
504 #
505 # Revision 1.11  2001/12/02 10:29:26  swa
506 # New version made these changes necessary.
507 #
508 # Revision 1.10  2001/10/31 19:27:27  swa
509 # consistent description. new name for suse since
510 # we had troubles with rpms of identical names
511 # on the webserver.
512 #
513 # Revision 1.9  2001/10/26 18:17:23  swa
514 # new version string
515 #
516 # Revision 1.8  2001/09/13 16:22:42  swa
517 # man page is legacy. suse rpm now contains html
518 # documentation.
519 #
520 # Revision 1.7  2001/09/10 17:44:22  swa
521 # integrate three pieces of documentation.
522 #
523 # Revision 1.6  2001/09/10 16:29:23  swa
524 # binary contained debug info.
525 # buildroot definition fucks up the build process under suse.
526 # program needs to write in varlogjunkbuster
527 # install all templates
528 # create varlogjunkbuster
529 #
530 # Revision 1.5  2001/06/09 09:13:29  swa
531 # description shorter
532 #
533 # Revision 1.4  2001/06/08 20:53:36  swa
534 # use buildroot, export init to separate file (better manageability)
535 #
536 # Revision 1.3  2001/06/07 17:28:10  swa
537 # cosmetics
538 #
539 # Revision 1.2  2001/06/07 17:18:44  swa
540 # header fixed
541 #
542 #