Made templates modular
[privoxy.git] / privoxy-suse.spec
1 # $Id: privoxy-suse.spec,v 1.11 2002/04/09 03:12:37 hal9 Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # do not set to %{name}
30 %define ijbconf %{_sysconfdir}/privoxy
31
32 Summary:      Privoxy - privacy enhancing proxy
33 Vendor:       http://www.privoxy.org
34 Name:         privoxy-suse
35 Distribution: defineme
36 Version: 2.9.13
37 Release: 3
38 Source: http://www.waldherr.org/%{name}/privoxy-%{version}.tar.gz
39 # not sure if this works
40 BuildRoot: %{_tmppath}/%{name}-%{version}-root
41 Packager:     Stefan Waldherr <stefan@waldherr.org>
42 Copyright:    GPL
43 Group:        Networking/Utilities
44 URL:          http://www.privoxy.org/
45 Provides:     privoxy
46 Obsoletes:    privoxy
47 Autoreqprov:  on
48 BuildRequires: perl gzip libtool autoconf
49 Conflicts: junkbuster-raw junkbuster-blank junkbuster
50
51 #
52 # -----------------------------------------------------------------------------
53 #
54 %description
55 Privoxy is a web proxy with advanced filtering capabilities for
56 protecting privacy, filtering web page content, managing cookies,
57 controlling access, and removing ads, banners, pop-ups and other
58 obnoxious Internet junk. Privoxy has a very flexible configuration and
59 can be customized to suit individual needs and tastes. Privoxy has 
60 application for both stand-alone systems and multi-user networks.
61
62 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
63 was originally written by Junkbusters Corporation, and was released as
64 free open-source software under the GNU GPL. Stefan Waldherr made many
65 improvements, and started the SourceForge project to continue
66 development. Several other developers are now contributing.
67
68 Authors:
69 --------
70     http://www.privoxy.org/
71
72 SuSE series: n
73
74 #
75 # -----------------------------------------------------------------------------
76 #
77 %prep
78 %setup -c
79
80 #
81 # -----------------------------------------------------------------------------
82 #
83 %build
84 autoheader
85 autoconf
86 ./configure
87 make
88
89
90 ## Explicitily stripping is not recomended.
91 ## This is handled altomaticaly by RPM, and can couse troubles if
92 ## anyone wants to build an unstriped version - morcego
93 #strip privoxy
94
95 #
96 # -----------------------------------------------------------------------------
97 #
98 %install
99 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
100 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
101          ${RPM_BUILD_ROOT}%{_mandir}/man8 \
102          ${RPM_BUILD_ROOT}/var/log/privoxy \
103          ${RPM_BUILD_ROOT}%{ijbconf}/templates \
104          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
105          ${RPM_BUILD_ROOT}%{_sysconfdir}/init.d
106 gzip README AUTHORS ChangeLog privoxy.1 LICENSE || /bin/true
107 install -s -m 744 privoxy $RPM_BUILD_ROOT%{_sbindir}/privoxy
108 cp -f privoxy.1.gz $RPM_BUILD_ROOT%{_mandir}/man8/privoxy.8.gz
109 cp -f *.action $RPM_BUILD_ROOT%{ijbconf}/
110 cp -f default.filter $RPM_BUILD_ROOT%{ijbconf}/default.filter
111 cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
112 cp -f templates/*  $RPM_BUILD_ROOT%{ijbconf}/templates/
113 cp -f privoxy.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/privoxy
114 install -m 755 privoxy.init.suse $RPM_BUILD_ROOT%{_sysconfdir}/init.d/privoxy
115 install -m 711 -d $RPM_BUILD_ROOT/var/log/privoxy
116 ln -sf /etc/init.d/privoxy $RPM_BUILD_ROOT/usr/sbin/rcprivoxy
117
118 # verify all file locations, etc. in the config file
119 # don't start with ^ or commented lines are not replaced
120 cat config | \
121     sed 's/^confdir.*/confdir \/etc\/privoxy/g' | \
122 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/privoxy\/permissionsfile/g' | \
123 #    sed 's/^filterfile.*/default.filter \/etc\/privoxy\/default.filter/g' | \
124 #    sed 's/^logfile.*/logfile \/var\/log\/privoxy\/logfile/g' | \
125 #    sed 's/^jarfile.*/jarfile \/var\/log\/privoxy\/jarfile/g' | \
126 #    sed 's/^forward.*/forward \/etc\/privoxy\/forward/g' | \
127 #    sed 's/^aclfile.*/aclfile \/etc\/privoxy\/aclfile/g' > \
128     sed 's/^logdir.*/logdir \/var\/log\/privoxy/g' > \
129     $RPM_BUILD_ROOT%{ijbconf}/config
130
131 #
132 # -----------------------------------------------------------------------------
133 #
134 %pre
135 # We check to see if the user privoxy exists.
136 # If it does, we do nothing
137 # If we don't, we check to see if the user junkbust exist and, in case it
138 # does, we change it do privoxy. If it also does not exist, we create the
139 # privoxy user -- morcego
140 id privoxy > /dev/null 2>&1 
141 if [ $? -eq 1 ]; then
142         id junkbust > /dev/null 2>&1 
143         if [ $? -eq 0 ]; then
144                 /usr/sbin/usermod -l privoxy -d %{_sysconfdir}/privoxy -s "" junkbust  > /dev/null 2>&1
145         else
146 # -r does not work on suse.
147                 /usr/sbin/groupadd privoxy
148                 /usr/sbin/useradd -d %{_sysconfdir}/privoxy -g privoxy -s "" privoxy > /dev/null 2>&1 
149         fi
150 fi
151
152 #
153 # -----------------------------------------------------------------------------
154 #
155 %post
156 [ -f /var/log/privoxy/privoxy ] &&\
157  mv -f /var/log/privoxy/privoxy /var/log/privoxy/logfile || /bin/true
158 chown -R privoxy:privoxy /var/log/privoxy 2>/dev/null
159 chown -R privoxy:privoxy /etc/privoxy 2>/dev/null
160 # not available on suse
161 #if [ "$1" = "1" ]; then
162 #     /sbin/chkconfig --add privoxy
163 #       /sbin/service privoxy condrestart > /dev/null 2>&1
164 #fi
165 # 01/09/02 HB, getting rid of any user=junkbust
166 # Changed by morcego to use the id command.
167 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
168 sbin/insserv etc/init.d/privoxy
169
170 #
171 # -----------------------------------------------------------------------------
172 #
173 %preun
174 # need to stop the service on suse. swa.
175 #if [ "$1" = "0" ]; then
176 #       /sbin/service privoxy stop > /dev/null 2>&1 ||:
177 #fi
178
179 #
180 # -----------------------------------------------------------------------------
181 #
182 %postun
183 sbin/insserv etc/init.d/
184 # dont forget to remove user and group privoxy
185 id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
186
187 #
188 # -----------------------------------------------------------------------------
189 #
190 %clean
191 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
192
193 #
194 # -----------------------------------------------------------------------------
195 #
196 %files
197 %defattr(-,root,root)
198 %doc README.gz AUTHORS.gz ChangeLog.gz LICENSE.gz
199 %doc doc/webserver/developer-manual
200 %doc doc/webserver/user-manual
201 %doc doc/webserver/faq
202 %doc doc/webserver/p_doc.css
203 %doc doc/webserver/p_web.css
204 %doc doc/webserver/index.html
205 #%doc privoxy.weekly privoxy.monthly AUTHORS
206 %dir %{ijbconf}
207 %config %{ijbconf}/*
208 %attr(0744,privoxy,privoxy) %dir /var/log/privoxy
209 %config %{_sysconfdir}/logrotate.d/privoxy
210 %attr(0755,root,root)/usr/sbin/privoxy
211 %{_mandir}/man8/*
212 %config %{_sysconfdir}/init.d/privoxy
213 /usr/sbin/rcprivoxy
214
215 #
216 # -----------------------------------------------------------------------------
217 #
218 %changelog
219 * Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
220 + privoxy-2.9.13-4
221 - Add LICENSE.gz, p_web.css, and index.html. Add autoconf
222 - to Buildrequires.
223
224 * Wed Mar 27 2002 Hal Burgiss <hal@foobox.net>
225 + privoxy-2.9.13-3
226 - Doc css has changed names.
227
228 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
229 + privoxy-2.9.13-3
230 - Minor fix to description.
231
232 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
233 - added faq to docs.
234
235 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
236 - added ijb_docs.css to docs.
237
238 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
239 - Remove --enable-no-gifs from configure.
240
241 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
242 - /bin/false for shell causes init script to fail. Reverting.
243
244 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
245 - Removed UID 73. Included user-manual and developer-manual in docs.
246   Include other actions files. Default shell is now /bin/false.
247   Userdel user=junkbust. ChangeLog was not zipped. Removed
248   RPM_OPT_FLAGS kludge.
249
250 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
251 - add paranoia check for 'rm -rf $RPM_BUILD_ROOT'
252 - add gzip to 'BuildRequires'
253
254 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
255 - actionsfile is now ijb.action.
256
257 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
258 - Compress manpage
259 - Add more documents for installation
260 - Add version string to name and source
261
262 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
263 - Back to user 'junkbuster' and fix configure macro.
264
265 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
266 - More changes for user 'junkbust'. Init script had 'junkbuster'.
267
268 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
269 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
270 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
271
272 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
273 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and
274 - made sure no default shell exists for user junkbust.
275
276 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
277 - rework of RPM
278 * Wed Feb 14 2001 - uli@suse.de
279 - fixed init script
280 * Wed Dec 06 2000 - bjacke@suse.de
281 - renamed package to junkbuster
282 - fixed copyright tag
283 * Thu Nov 30 2000 - uli@suse.de
284 - moved init script to /etc/init.d
285 * Wed Feb 16 2000 - kukuk@suse.de
286 - Move /usr/man -> /usr/share/man
287 - Mark /etc/ijb as "config(noreplace)"
288 * Mon Sep 20 1999 - uli@suse.de
289 - fixed init script
290 * Mon Sep 13 1999 - bs@suse.de
291 - ran old prepare_spec on spec file to switch to new prepare_spec.
292 * Thu Apr 01 1999 - daniel@suse.de
293 - do not start ijb as root (security)
294 * Tue Mar 30 1999 - daniel@suse.de
295 - donĀ“t use saclfile.ini
296 * Tue Mar 30 1999 - daniel@suse.de
297 - small fix to whitelist-configuration,
298   version is and was 2.0.2 WITHOUT Stefan Waldherr's patches
299   (http://www.waldherr.org/junkbuster/)
300 * Mon Mar 01 1999 - daniel@suse.de
301 - new package: version 2.0
302
303 # $Log: privoxy-suse.spec,v $
304 # Revision 1.11  2002/04/09 03:12:37  hal9
305 # Add LICENSE, p_web.css and index.html. Add autoconf to buildrequires.
306 #
307 # Revision 1.10  2002/04/08 20:24:13  swa
308 # fixed JB spelling
309 #
310 # Revision 1.9  2002/03/30 09:01:52  swa
311 # new release
312 #
313 # Revision 1.8  2002/03/27 23:46:41  hal9
314 # ijb_docs.css to p_doc.css
315 #
316 # Revision 1.7  2002/03/27 00:49:39  hal9
317 # Minor fix to description.
318 #
319 # Revision 1.6  2002/03/26 22:29:55  swa
320 # we have a new homepage!
321 #
322 # Revision 1.5  2002/03/25 03:10:50  hal9
323 # Added faq to docs.
324 #
325 # Revision 1.4  2002/03/24 12:56:21  swa
326 # name change related issues.
327 #
328 # Revision 1.3  2002/03/24 12:44:31  swa
329 # new version string
330 #
331 # Revision 1.2  2002/03/24 11:40:14  swa
332 # name change
333 #
334 # Revision 1.1  2002/03/24 11:23:44  swa
335 # name change
336 #
337 # Revision 1.21  2002/03/21 16:04:33  hal9
338 # added ijb_docs.css to %%doc
339 #
340 # Revision 1.20  2002/03/12 13:42:14  sarantis
341 # remove hardcoded "ijbswa" from build phase
342 #
343 # Revision 1.19  2002/03/11 22:59:05  hal9
344 # Remove --enable-no-gifs
345 #
346 # Revision 1.18  2002/03/11 12:30:31  swa
347 # be consistent with rh spec file
348 #
349 # Revision 1.17  2002/03/08 19:30:23  swa
350 # remove user junkbuster after de-installation.
351 # synced suse with rh-specfile. installation
352 # and de-installation seem to work.
353 #
354 # Revision 1.16  2002/03/08 18:40:44  swa
355 # build requires tools. useradd and del works
356 # now.
357 #
358 # Revision 1.15  2002/03/07 19:23:50  swa
359 # i hate to scroll. suse: wrong configdir.
360 #
361 # Revision 1.14  2002/03/07 19:10:21  swa
362 # builds cleanly. thanks to kukuk@suse.de
363 # not yet tested.
364 #
365 # Revision 1.13  2002/03/07 18:25:56  swa
366 # synced redhat and suse build process
367 #
368 # Revision 1.12  2002/03/02 15:50:04  swa
369 # 2.9.11 version. more input for docs.
370 #
371 # Revision 1.11  2001/12/02 10:29:26  swa
372 # New version made these changes necessary.
373 #
374 # Revision 1.10  2001/10/31 19:27:27  swa
375 # consistent description. new name for suse since
376 # we had troubles with rpms of identical names
377 # on the webserver.
378 #
379 # Revision 1.9  2001/10/26 18:17:23  swa
380 # new version string
381 #
382 # Revision 1.8  2001/09/13 16:22:42  swa
383 # man page is legacy. suse rpm now contains html
384 # documentation.
385 #
386 # Revision 1.7  2001/09/10 17:44:22  swa
387 # integrate three pieces of documentation.
388 #
389 # Revision 1.6  2001/09/10 16:29:23  swa
390 # binary contained debug info.
391 # buildroot definition fucks up the build process under suse.
392 # program needs to write in varlogjunkbuster
393 # install all templates
394 # create varlogjunkbuster
395 #
396 # Revision 1.5  2001/06/09 09:13:29  swa
397 # description shorter
398 #
399 # Revision 1.4  2001/06/08 20:53:36  swa
400 # use buildroot, export init to separate file (better manageability)
401 #
402 # Revision 1.3  2001/06/07 17:28:10  swa
403 # cosmetics
404 #
405 # Revision 1.2  2001/06/07 17:18:44  swa
406 # header fixed
407 #
408 #