New actions files changes.
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.28 2002/04/22 18:51:33 morcego Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33 %define privoxy_uid 73
34 %define privoxy_gid 73
35
36 Name: privoxy
37 # ATTENTION
38 # Version and release should be updated acordingly on configure.in and
39 # configure. Otherwise, the package can be build with the wrong value
40 Version: 2.9.14
41 Release: 2
42 Summary: Privoxy - privacy enhancing proxy
43 License: GPL
44 Vendor: http://www.privoxy.org
45 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
46 BuildRoot: %{_tmppath}/%{name}-%{version}-root
47 Group: Networking/Utilities
48 URL: http://www.privoxy.org/
49 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
50 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
51 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
52 BuildRequires: perl gzip sed libtool autoconf 
53 Conflicts: junkbuster-raw junkbuster-blank junkbuster
54
55 %description 
56 Privoxy is a web proxy with advanced filtering capabilities for
57 protecting privacy, filtering web page content, managing cookies,
58 controlling access, and removing ads, banners, pop-ups and other
59 obnoxious Internet junk. Privoxy has a very flexible configuration and
60 can be customized to suit individual needs and tastes. Privoxy has application
61 for both stand-alone systems and multi-user networks.
62
63 Privoxy is based on the Internet Junkbuster.
64
65 %prep
66 %setup -q -c
67
68 %build
69 autoheader
70 autoconf
71 %configure --disable-dynamic-pcre
72 make 
73 # Docs are in CVS and tarball now.
74 #%%make dok
75
76 ## Explicitily stripping is not recomended.
77 ## This is handled altomaticaly by RPM, and can couse troubles if
78 ## anyone wants to build an unstriped version - morcego
79 #strip %{name}
80
81 %install
82 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
83 mkdir -p %{buildroot}%{_sbindir} \
84          %{buildroot}%{_mandir}/man1 \
85          %{buildroot}%{_localstatedir}/log/%{name} \
86          %{buildroot}%{privoxyconf}/templates \
87          %{buildroot}%{_sysconfdir}/logrotate.d \
88          %{buildroot}%{_sysconfdir}/rc.d/init.d 
89
90 ## Manual gziping of manpages should not be done, once it can
91 ## break the building on some distributions. Anyway, rpm does it
92 ## automagicaly these days
93 ## Gziping the documentation files is not recomended - morcego
94 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
95
96 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
97
98 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
99 cp -f *.action %{buildroot}%{privoxyconf}/
100 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
101 cp -f trust %{buildroot}%{privoxyconf}/trust
102 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
103 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
104 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
105 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
106
107 # verify all file locations, etc. in the config file
108 # don't start with ^ or commented lines are not replaced
109 ## Changing the sed paramter delimiter to @, so we don't have to
110 ## escape the slashes
111 cat config | \
112     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
113 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
114 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
115 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
116 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
117 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
118 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
119     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
120     %{buildroot}%{privoxyconf}/config
121 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
122     %{buildroot}%{privoxyconf}/default.action
123
124
125 # Creating ghost init files
126 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
127 for i in 0 1 4 6
128 do
129 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
130 done
131 for i in 2 3 5
132 do
133 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
134 done
135
136 ## Macros are expanded even on commentaries. So, we have to use %%
137 ## -- morcego
138 #%%makeinstall
139
140 %pre
141 # This is where we handle old usernames (junkbust and junkbuster)
142 # I'm not sure we should do that, but this is the way we have been
143 # doing it for some time now -- morcego
144 # We should do it for the group as well -- morcego
145 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
146
147 # Change the group name. Remove anything left behind.
148 groupmod -g %{privoxy_gid} -n %{name} %{oldname} > /dev/null 2>&1 ||:
149 groupmod -g %{privoxy_gid} -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
150 groupdel %{oldname} > /dev/null 2>&1 ||:
151 groupdel %{veryoldname} > /dev/null 2>&1 ||:
152
153 # Same for username
154 usermod -u %{privoxy_uid} -g %{privoxy_gid} -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
155 usermod -u %{privoxy_uid} -g %{privoxy_gid} -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
156 userdel %{oldname} > /dev/null 2>&1 ||:
157 userdel %{veryoldname} > /dev/null 2>&1 ||:
158
159 # Doublecheck to see if the group exist, and that it has the correct gid
160 /bin/grep -E '^%{name}:' /etc/group > /dev/null 2>&1
161 if [ $? -eq 1 ]; then
162         # Looks like it does not exist. Create it
163         groupadd -g %{privoxy_gid} %{name} > /dev/null 2>&1
164 else
165         /bin/grep -E '^%{name}:[^:]*:%{privoxy_gid}:' /etc/group > /dev/null 2>&1
166         if [ $? -eq 1 ]; then
167                 # The group exists, but does not have the correct gid
168                 groupmod -g %{privoxy_gid} %{name} > /dev/null 2>&1
169         fi
170 fi
171
172 # Check to see if everything is okey. Create user if it still does not
173 # exist
174 id %{name} > /dev/null 2>&1
175 if [ $? -eq 1 ]; then
176         /usr/sbin/useradd -u %{privoxy_uid} -g %{privoxy_gid} -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
177 fi
178
179 # Double check that the group has the correct uid
180 P_UID=`id -u %{name} 2>/dev/null`
181 if [ $P_UID -ne %{privoxy_uid} ]; then
182         /usr/sbin/usermod -u %{privoxy_uid} %{name}
183 fi
184
185 # The same for the gid
186 P_GID=`id -g %{name} 2>/dev/null`
187 if [ $P_GID -ne %{privoxy_gid} ]; then
188         /usr/sbin/usermod -g %{privoxy_gid} %{name}
189 fi
190
191 %post
192 # for upgrade from 2.0.x
193 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
194  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
195 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
196  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
197 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
198 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
199 if [ "$1" = "1" ]; then
200         /sbin/service %{name} condrestart > /dev/null 2>&1
201 fi
202
203 %preun
204 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
205 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
206
207 if [ "$1" = "0" ]; then
208         /sbin/service %{name} stop > /dev/null 2>&1 ||:
209         # No need to use chkconfig. The %%ghost files will handle it
210 fi
211
212 %postun
213 #if [ "$1" -ge "1" ]; then
214 #       /sbin/service %{name} condrestart > /dev/null 2>&1
215 #fi
216 # We only remove it we this is not an upgrade
217 if [ "$1" = "0" ]; then
218         /bin/grep -E '^%{name}:' /etc/group > /dev/null && /usr/sbin/groupdel %{name} || /bin/true
219         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
220 fi
221
222 %clean
223 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
224
225 %files
226 %defattr(0644,root,root,0755)
227 %doc README AUTHORS ChangeLog LICENSE 
228 %doc doc/text/developer-manual.txt doc/text/user-manual.txt doc/text/faq.txt
229 %doc doc/webserver/developer-manual
230 %doc doc/webserver/user-manual
231 %doc doc/webserver/faq
232 %doc doc/webserver/p_doc.css doc/webserver/p_web.css doc/webserver/index.html
233
234 %dir %{privoxyconf}
235 %dir %{privoxyconf}/templates
236 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
237
238 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
239
240 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
241 # We should not use wildchars here. This could mask missing files problems
242 # -- morcego
243 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
244 %config %{privoxyconf}/config
245 %config %{privoxyconf}/standard.action
246 %config(noreplace) %{privoxyconf}/user.action
247 %config %{privoxyconf}/default.action
248 %config %{privoxyconf}/default.filter
249 %config %{privoxyconf}/trust
250
251 %config %{privoxyconf}/templates/untrusted
252 %config %{privoxyconf}/templates/toggle-mini
253 %config %{privoxyconf}/templates/default
254 %config %{privoxyconf}/templates/connect-failed
255 %config %{privoxyconf}/templates/show-status-file
256 %config %{privoxyconf}/templates/cgi-error-bad-param
257 %config %{privoxyconf}/templates/show-version
258 %config %{privoxyconf}/templates/cgi-error-file
259 %config %{privoxyconf}/templates/cgi-error-404
260 %config %{privoxyconf}/templates/cgi-error-parse
261 %config %{privoxyconf}/templates/edit-actions-url-form
262 %config %{privoxyconf}/templates/no-such-domain
263 %config %{privoxyconf}/templates/edit-actions-add-url-form
264 %config %{privoxyconf}/templates/cgi-style.css
265 %config %{privoxyconf}/templates/edit-actions-for-url-filter
266 %config %{privoxyconf}/templates/cgi-error-disabled
267 %config %{privoxyconf}/templates/edit-actions-remove-url-form
268 %config %{privoxyconf}/templates/show-request
269 %config %{privoxyconf}/templates/cgi-error-modified
270 %config %{privoxyconf}/templates/mod-unstable-warning
271 %config %{privoxyconf}/templates/edit-actions-list
272 %config %{privoxyconf}/templates/toggle
273 %config %{privoxyconf}/templates/edit-actions-list-section
274 %config %{privoxyconf}/templates/mod-title
275 %config %{privoxyconf}/templates/edit-actions-list-url
276 %config %{privoxyconf}/templates/show-status
277 %config %{privoxyconf}/templates/blocked
278 %config %{privoxyconf}/templates/mod-support-and-service
279 %config %{privoxyconf}/templates/mod-local-help
280 %config %{privoxyconf}/templates/show-url-info
281 %config %{privoxyconf}/templates/edit-actions-for-url
282
283 %config %{_sysconfdir}/logrotate.d/%{name}
284 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
285 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
286 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
287 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
288 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
289 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
290 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
291 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
292
293 %{_mandir}/man1/%{name}.*
294
295 %changelog
296 * Tue Apr 23 2002 Hal Burgiss <hal@foobox.net>
297 + privoxy-2.9.14-2
298 - Adjust for new *actions files.
299
300 * Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
301 + privoxy-2.9.14-2
302 - Removed the redhat hack that prevented the user and group from
303   being dealocated. That was a misundestanding of my part regarding
304   redhat policy.
305
306 * Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
307 + privoxy-2.9.14-2
308 - Using macros to define uid and gid values
309 - Bumping release
310
311 * Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
312 + privoxy-2.9.14-1
313 - Changes to fixate the uid and gid values as (both) 73. This is a 
314   value we hope to standarize for all distributions. RedHat already
315   uses it, and Conectiva should start as soon as I find where the heck
316   I left my cluebat :-)
317 - Only remove the user and group on uninstall if this is not redhat, once
318   redhat likes to have the values allocated even if the package is not 
319   installed
320
321 * Tue Apr 16 2002 Hal Burgiss <hal@foobox.net>
322 + privoxy-2.9.13-6
323 - Add --disable-dynamic-pcre to configure.
324
325 * Wed Apr 10 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
326 + privoxy-2.9.13-5
327 - Relisting template files on the %%files section
328
329 * Tue Apr 09 2002 Hal Burgiss <hal@foobox.net>
330 + privoxy-2.9.13-4
331 - Removed 'make dok'. Docs are all maintained in CVS (and tarball) now.
332
333 * Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
334 + privoxy-2.9.13-4
335 - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
336 - Remove templates/blocked-compact.
337 - Add more docbook stuff to Builderquires.
338
339 * Thu Mar 28 2002 Sarantis Paskalis <sarantis@cnl.di.uoa.gr>
340 + privoxy-2.9.13-3
341 - Include correct documentation file.
342
343 * Tue Mar 26 2002 Hal Burgiss <hal@foobox.net>
344 + privoxy-2.9.13-3
345 - Fix typo in Description.
346
347 * Tue Mar 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
348 + privoxy-2.9.13-3
349 - Added commentary asking to update the release value on the configure
350   script
351
352 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
353 + privoxy-2.9.13-3
354 - Added the missing edit-actions-for-url-filter to templates.
355
356 * Mon Mar 25 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
357 + privoxy-2.9.13-2
358 - Fixing Release number
359
360 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
361 + privoxy-2.9.13-2
362 - Added faq to docs.
363
364 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
365 + privoxy-2.9.13-2
366 - Fixed the init files entries. Now we use %%ghost
367 - improved username (and groupname) handling on the %%pre section. By improved
368   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
369   got it right. No more Mr. Nice Guy.
370 - Removed the userdel call on %%post. No need, once it's complety handled on
371   the %%pre section
372
373 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
374 + junkbusterng-2.9.13-1
375   Added autoheader. Added autoconf to buildrequires.
376
377 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
378 + junkbusterng-2.9.13-1
379 - Fixed build problems re: name conflicts with man page and logrotate.
380 - Commented out rc?d/* configs for time being, which are causing a build 
381 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
382 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
383
384 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
385 + junkbusterng-2.9.13-1
386 - References to the expression ijb where changed where possible
387 - New package name: junkbusterng (all in lower case, acording to
388   the LSB recomendation)
389 - Version changed to: 2.9.13
390 - Release: 1
391 - Added: junkbuster to obsoletes and conflicts (Not sure this is
392   right. If it obsoletes, why conflict ? Have to check it later)
393 - Summary changed: Stefan, please check and aprove it
394 - Changes description to use the new name
395 - Sed string was NOT changed. Have to wait to the manpage to
396   change first
397 - Keeping the user junkbuster for now. It will require some aditional
398   changes on the script (scheduled for the next specfile release)
399 - Added post entry to move the old logfile to the new log directory
400 - Removing "chkconfig --add" entry (not good to have it automaticaly
401   added to the startup list).
402 - Added preun section to stop the service with the old name, as well
403   as remove it from the startup list
404 - Removed the chkconfig --del entry from the conditional block on
405   the preun scriptlet (now handled on the %files section)
406
407 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
408 - added ijb_docs.css to docs.
409
410 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
411 + junkbuster-2.9.11-8 
412 - Take out --enable-no-gifs, breaks some browsers.
413
414 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
415 + junkbuster-2.9.11-8 
416 - Add --enable-no-gifs to configure.
417
418 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
419 + junkbuster-2.9.11-7
420 - Added BuildRequires to libtool.
421
422 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
423 + junkbuster-2.9.11-6
424 - Changed the routined that handle the junkbust and junkbuster users on
425   %%pre and %%post to work in a smoother manner
426 - %%files now uses hardcoded usernames, to avoid problems with package
427   name changes in the future
428
429 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
430 + junkbuster-2.9.11-5
431 - Added "make redhat-dok" to the build process
432 - Added docbook-utils to BuildRequires
433
434 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
435 + junkbuster-2.9.11-4
436 - Changing man section in the manpage from 1 to 8
437 - We now require packages, not files, to avoid issues with apt
438
439 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
440 + junkbuster-2.9.11-3
441 - Fixing permissions of the init script
442
443 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
444 + junkbuster-2.9.11-2
445 - General specfile fixup, using the best recomended practices, including:
446         - Adding -q to %%setup
447         - Using macros whereever possible
448         - Not using wildchars on %%files section
449         - Doubling the percentage char on changelog and comments, to
450           avoid rpm expanding them
451
452 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
453 - /bin/false for shell causes init script to fail. Reverting.
454
455 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
456 - Removed UID 73. Included user-manual and developer-manual in docs.
457   Include other actions files. Default shell is now /bin/false.
458   Userdel user=junkbust. ChangeLog was not zipped. Removed 
459   RPM_OPT_FLAGS kludge.
460
461 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
462 - add paranoia check for 'rm -rf %%{buildroot}'
463 - add gzip to 'BuildRequires'
464
465 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
466 - actionsfile is now ijb.action.
467
468 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
469 - Compress manpage
470 - Add more documents for installation
471 - Add version string to name and source
472
473 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
474 - Back to user 'junkbuster' and fix configure macro.
475
476 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
477 - More changes for user 'junkbust'. Init script had 'junkbuster'.
478
479 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
480 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
481 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
482
483 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
484 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
485 - made sure no default shell exists for user junkbust.
486
487 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
488 - rework of RPM
489
490 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
491 - CLF Logging patch by davep@cyw.uklinux.net
492 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
493
494 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
495 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
496 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
497   numerous fixes and enhancements for Steve's patch.
498 - adamlock@netscape.com (Adam Lock) in the windows version:
499   - Taskbar activity spinner always spins even when logging is
500   turned off (which is the default) - people who don't
501   like the spinner can turn it off from a menu option.
502   - Taskbar popup menu has a options submenu - people can now
503   open the settings files for cookies, blockers etc.
504   without opening the JB window.
505   - Logging functionality works again
506   - Buffer overflow is fixed - new code uses a bigger buffer
507   and snprintf so it shouldn't overflow anymore.
508 - Fixed userid swa, group learning problem while installing.
509   root must build RPM.
510 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
511   core dump when there is no log file.
512 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
513 - Fixed man page to include imagefile and popupfile.
514 - Sanity check for the statistics function added.
515 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
516  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
517  With IIS/5, it appears to omit the trailing \r\n from http header
518  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
519  responds with a HTTP 302 redirect header.  However, this header
520  message is missing the trailing \r\n.  IIS/5 then closes the
521  connection.  Junkbuster, unfortunately, discards the header becomes
522  it thinks it is incomplete - and it is.  MS have transmitted an
523  incomplete header!
524 - Added bug reports and patch submission forms in the docs.
525
526 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
527        Andrew <anw@tirana.freewire.co.uk> extended the JB:
528        Display of statistics of the total number of requests and the number
529        of requests filtered by junkbuster, also the percentage of requests
530        filtered. Suppression of the listing of files on the proxy-args page.
531        All stuff optional and configurable.
532
533 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
534        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
535        code which prevented the JB from handling URLs of the form
536        user:password@www.foo.com. Fixed.
537
538 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
539         Blank images are no longer cached, thanks to a hint from Markus 
540         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
541         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
542         on the correct browser version nowadays. Incorporated many 
543         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
544         spec file. Fixed logging problem and since runlevel 2 does not 
545         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
546         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
547         <walker@netgate.net>. You should now be able to build this RPM as 
548         a non-root user (mathias@weidner.sem.lipsia.de).
549
550 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
551         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
552         to allow more sophisticated matching of blocked images. Logrotate
553         logfile. Added files for auto-updating the blocklist et al.
554
555 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
556         Configure blank version via config file. No separate blank
557         version anymore. Added Roland's <roland@spinnaker.rhein.de>
558         patch to show a logo instead of a blank area. Added a suggestion
559         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
560         More regexps in the blocklist. Prepared the forwardfile for
561         squid. Extended image regexp with help from gabriel 
562         <somlo@CS.ColoState.EDU>.
563
564 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
565         All RPMs now identify themselves in the show-proxy-args page.
566         Released Windoze version. Run junkbuster as nobody instead of
567         root. 
568
569 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
570         Newest version. First release (hence the little version number
571         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
572         security over 2.0.1; some multi-user sites will need to change 
573         the listen-address in the configuration file. The blank version of
574         the Internet Junkbuster has a more sophisticated way of replacing
575         images. All RPMs identify themselves in the show-proxy-args page.
576
577 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
578         Modified the blocking feature, so that only GIFs and JPEGs are
579         blocked and replaced but not HTML pages. Thanks to 
580         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
581         idea. Added numerous stuff to the blocklist. Keep patches in
582         seperate files and no longer in diffs (easier to maintain).
583
584 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
585         Moved config files to /etc/junkbuster directory, moved man page,
586         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
587         Made new version junkbuster-raw (which is only a stripped version of 
588         the junkuster rpm, i.e. without my blocklist, etc.)
589
590 * Tue Jun 16 1998 (2.0-1)
591         Uhm, not that much. Just a new junkbuster version that
592         fixes a couple of bugs ... and of course a bigger 
593         blocklist with the unique Now-less-ads-than-ever(SM)
594         feature.
595         Oh, one thing: I changed the default user agent to Linux -- no 
596         need anymore to support Apple.
597
598 * Tue Jun 16 1998 (2.0-0)
599         Now-less-ads-than-ever (SM)
600         compiled with gcc instead of cc
601         compiled with -O3, thus it should be a little faster
602         show-proxy-args now works
603         /etc/junkbuster.init wasn't necessary
604
605 * Tue Jun 16 1998 (1.4)
606         some more config files were put into /etc
607         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
608         displayed by Netscape instead of the blocked image.
609         Read http://www.waldherr.org/junkbuster/ for
610         further info.
611
612 * Tue Jun 16 1998 (1.3)
613         The program has been moved to /usr/sbin (from /usr/local/bin)
614         Init- and stopscripts (/etc/rc.d/rc*) have been added so
615         that the junkbuster starts automatically during bootup.
616         The /etc/blocklist file is much more sophisticated. Theoretically
617         one should e.g. browse all major US and German newspapers without
618         seeing one annoying ad.
619         junkbuster.init was modified. It now starts junkbuster with an
620         additional "-r @" flag.
621
622 # $Log: privoxy-rh.spec,v $
623 # Revision 1.28  2002/04/22 18:51:33  morcego
624 # user and group now get removed on rh too.
625 #
626 # Revision 1.27  2002/04/22 16:32:31  morcego
627 # configure.in, *.spec: Bumping release to 2 (2.9.14-2)
628 # -rh.spec: uid and gid are now macros
629 # -suse.spec: Changing the header Copyright to License (Copyright is
630 #             deprecable)
631 #
632 # Revision 1.26  2002/04/22 16:24:36  morcego
633 # - Changes to fixate the uid and gid values as (both) 73. This is a
634 #   value we hope to standarize for all distributions. RedHat already
635 #   uses it, and Conectiva should start as soon as I find where the heck
636 #   I left my cluebat :-)
637 # - Only remove the user and group on uninstall if this is not redhat, once
638 #   redhat likes to have the values allocated even if the package is not
639 #   installed
640 #
641 # Revision 1.25  2002/04/17 01:59:12  hal9
642 # Add --disable-dynamic-pcre.
643 #
644 # Revision 1.24  2002/04/11 10:09:20  oes
645 # Version 2.9.14
646 #
647 # Revision 1.23  2002/04/10 18:14:45  morcego
648 # - (privoxy-rh.spec only) Relisting template files on the %%files section
649 # - (configure.in, privoxy-rh.spec) Bumped package release to 5
650 #
651 # Revision 1.22  2002/04/09 22:06:12  hal9
652 # Remove 'make dok'.
653 #
654 # Revision 1.21  2002/04/09 02:52:26  hal9
655 # - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
656 # - Remove templates/blocked-compact.
657 # - Add more docbook stuff to Buildrequires.
658 #
659 # Revision 1.20  2002/04/08 20:27:45  swa
660 # fixed JB spelling
661 #
662 # Revision 1.19  2002/03/27 22:44:59  sarantis
663 # Include correct documentation file.
664 #
665 # Revision 1.18  2002/03/27 22:10:14  sarantis
666 # bumped Hal's last commit 1 day to the future to make rpm build again.
667 #
668 # Revision 1.17  2002/03/27 00:48:23  hal9
669 # Fix up descrition.
670 #
671 # Revision 1.16  2002/03/26 22:29:55  swa
672 # we have a new homepage!
673 #
674 # Revision 1.15  2002/03/26 17:39:54  morcego
675 # Adding comment on the specfile to remember the packager to update
676 # the release number on the configure script
677 #
678 # Revision 1.14  2002/03/26 14:25:15  hal9
679 # Added edit-actions-for-url-filter to templates in %%config
680 #
681 # Revision 1.13  2002/03/25 13:31:04  morcego
682 # Bumping Release tag.
683 #
684 # Revision 1.12  2002/03/25 03:11:40  hal9
685 # Do it right way this time :/
686 #
687 # Revision 1.11  2002/03/25 03:09:51  hal9
688 # Added faq to docs.
689 #
690 # Revision 1.10  2002/03/24 22:16:14  morcego
691 # Just removing some old commentaries.
692 #
693 # Revision 1.9  2002/03/24 22:03:22  morcego
694 # Should be working now. See %changelog for details
695 #
696 # Revision 1.8  2002/03/24 21:13:01  morcego
697 # Tis broken.
698 #
699 # Revision 1.7  2002/03/24 21:07:18  hal9
700 # Add autoheader, etc.
701 #
702 # Revision 1.6  2002/03/24 19:56:40  hal9
703 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
704 #
705 # Revision 1.4  2002/03/24 13:32:42  swa
706 # name change related issues
707 #
708 # Revision 1.3  2002/03/24 12:56:21  swa
709 # name change related issues.
710 #
711 # Revision 1.2  2002/03/24 11:40:14  swa
712 # name change
713 #
714 # Revision 1.1  2002/03/24 11:23:44  swa
715 # name change
716 #
717 # Revision 1.1  2002/03/22 20:53:03  morcego
718 # - Ongoing process to change name to JunkbusterNG
719 # - configure/configure.in: no change needed
720 # - GNUmakefile.in:
721 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
722 #         - PROGRAM    = jbng@EXEEXT@
723 #         - rh-spec now references as junkbusterng-rh.spec
724 #         - redhat-upload: references changed to junkbusterng-* (package names)
725 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
726 #         - tarball-src: now JunkbusterNG-*
727 #         - install: initscript now junkbusterng.init and junkbusterng (when
728 #                    installed)
729 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
730 # - junkbusterng.spec:
731 #         - References to the expression ijb where changed where possible
732 #         - New package name: junkbusterng (all in lower case, acording to
733 #           the LSB recomendation)
734 #         - Version changed to: 2.9.13
735 #         - Release: 1
736 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
737 #           right. If it obsoletes, why conflict ? Have to check it later)
738 #         - Summary changed: Stefan, please check and aprove it
739 #         - Changes description to use the new name
740 #         - Sed string was NOT changed. Have to wait to the manpage to
741 #           change first
742 #         - Keeping the user junkbuster for now. It will require some aditional
743 #           changes on the script (scheduled for the next specfile release)
744 #         - Added post entry to move the old logfile to the new log directory
745 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
746 #           added to the startup list).
747 #         - Added preun section to stop the service with the old name, as well
748 #           as remove it from the startup list
749 #         - Removed the chkconfig --del entry from the conditional block on
750 #           the preun scriptlet (now handled on the %files section)
751 # - junkbuster.init: renamed to junkbusterng.init
752 # - junkbusterng.init:
753 #         - Changed JB_BIN to jbng
754 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
755 #           be used where necessary (config dir)
756 #
757 # Aditional notes:
758 # - The config directory is /etc/junkbuster yet. Have to change it on the
759 # specfile, after it is changes on the code
760 # - The only files that got renamed on the cvs tree were the rh specfile and
761 # the init file. Some file references got changes on the makefile and on the
762 # rh-spec (as listed above)
763 #
764 # Revision 1.43  2002/03/21 16:04:10  hal9
765 # added ijb_docs.css to %doc
766 #
767 # Revision 1.42  2002/03/12 13:41:18  sarantis
768 # remove hard-coded "ijbswa" string in build phase
769 #
770 # Revision 1.41  2002/03/11 22:58:32  hal9
771 # Remove --enable-no-gifs
772 #
773 # Revision 1.39  2002/03/08 18:57:29  swa
774 # remove user junkbuster after de-installation.
775 #
776 # Revision 1.38  2002/03/08 13:45:27  morcego
777 # Adding libtool to Buildrequires
778 #
779 # Revision 1.37  2002/03/07 19:23:49  swa
780 # i hate to scroll. suse: wrong configdir.
781 #
782 # Revision 1.36  2002/03/07 05:06:54  morcego
783 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
784 #
785 # Revision 1.34  2002/03/07 00:11:57  morcego
786 # Few changes on the %pre and %post sections of the rh specfile to handle
787 # usernames more cleanly
788 #
789 # Revision 1.33  2002/03/05 13:13:57  morcego
790 # - Added "make redhat-dok" to the build phase
791 # - Added docbook-utils to BuildRequires
792 #
793 # Revision 1.32  2002/03/05 12:34:24  morcego
794 # - Changing section internaly on the manpage from 1 to 8
795 # - We now require packages, not files, to avoid issues with apt
796 #
797 # Revision 1.31  2002/03/04 18:06:09  morcego
798 # SPECFILE: fixing permissing of the init script (broken by the last change)
799 #
800 # Revision 1.30  2002/03/04 16:18:03  morcego
801 # General cleanup of the rh specfile.
802 #
803 # %changelog
804 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
805 # + junkbuster-2.9.11-2
806 # - General specfile fixup, using the best recomended practices, including:
807 #         - Adding -q to %%setup
808 #         - Using macros whereever possible
809 #         - Not using wildchars on %%files section
810 #         - Doubling the percentage char on changelog and comments, to
811 #           avoid rpm expanding them
812 #
813 # Revision 1.29  2002/03/03 19:21:22  hal9
814 # Init script fails if shell is /bin/false.
815 #
816 # Revision 1.28  2002/01/09 18:34:03  hal9
817 # nit.
818 #
819 # Revision 1.27  2002/01/09 18:32:02  hal9
820 # Removed RPM_OPT_FLAGS kludge.
821 #
822 # Revision 1.26  2002/01/09 18:21:10  hal9
823 # A few minor updates.
824 #
825 # Revision 1.25  2001/12/28 01:45:36  steudten
826 # Add paranoia check and BuildReq: gzip
827 #
828 # Revision 1.24  2001/12/01 21:43:14  hal9
829 # Allowed for new ijb.action file.
830 #
831 # Revision 1.23  2001/11/06 12:09:03  steudten
832 # Compress doc files. Install README and AUTHORS at last as document.
833 #
834 # Revision 1.22  2001/11/05 21:37:34  steudten
835 # Fix to include the actual version for name.
836 # Let the 'real' packager be included - sorry stefan.
837 #
838 # Revision 1.21  2001/10/31 19:27:27  swa
839 # consistent description. new name for suse since
840 # we had troubles with rpms of identical names
841 # on the webserver.
842 #
843 # Revision 1.20  2001/10/24 15:45:49  hal9
844 # To keep Thomas happy (aka correcting my  mistakes)
845 #
846 # Revision 1.19  2001/10/15 03:23:59  hal9
847 # Nits.
848 #
849 # Revision 1.17  2001/10/10 18:59:28  hal9
850 # Minor change for init script.
851 #
852 # Revision 1.16  2001/09/24 20:56:23  hal9
853 # Minor changes.
854 #
855 # Revision 1.13  2001/09/10 17:44:43  swa
856 # integrate three pieces of documentation. needs work.
857 # will not build cleanly under redhat.
858 #
859 # Revision 1.12  2001/09/10 16:25:04  swa
860 # copy all templates. version updated.
861 #
862 # Revision 1.11  2001/07/03 11:00:25  sarantis
863 # replaced permissionsfile with actionsfile
864 #
865 # Revision 1.10  2001/07/03 09:34:44  sarantis
866 # bumped up version number.
867 #
868 # Revision 1.9  2001/06/12 18:15:29  swa
869 # the %% in front of configure (see tag below) confused
870 # the rpm build process on 7.1.
871 #
872 # Revision 1.8  2001/06/12 17:15:56  swa
873 # fixes, because a clean build on rh6.1 was impossible.
874 # GZIP confuses make, %% configure confuses rpm, etc.
875 #
876 # Revision 1.7  2001/06/11 12:17:26  sarantis
877 # fix typo in %%post
878 #
879 # Revision 1.6  2001/06/11 11:28:25  sarantis
880 # Further optimizations and adaptations in the spec file.
881 #
882 # Revision 1.5  2001/06/09 09:14:11  swa
883 # shamelessly adapted RPM stuff from the newest rpm that
884 # RedHat provided for the JB.
885 #
886 # Revision 1.4  2001/06/08 20:54:18  swa
887 # type with status file. remove forward et. al from file list.
888 #
889 # Revision 1.3  2001/06/07 17:28:10  swa
890 # cosmetics
891 #
892 # Revision 1.2  2001/06/04 18:31:58  swa
893 # files are now prefixed with either `confdir' or `logdir'.
894 # `make redhat-dist' replaces both entries confdir and logdir
895 # with redhat values
896 #
897 # Revision 1.1  2001/06/04 10:44:57  swa
898 # `make redhatr-dist' now works. Except for the paths
899 # in the config file.
900 #
901 #
902 #