- Changes to fixate the uid and gid values as (both) 73. This is a
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.25 2002/04/17 01:59:12 hal9 Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33
34 Name: privoxy
35 # ATTENTION
36 # Version and release should be updated acordingly on configure.in and
37 # configure. Otherwise, the package can be build with the wrong value
38 Version: 2.9.14
39 Release: 1
40 Summary: Privoxy - privacy enhancing proxy
41 License: GPL
42 Vendor: http://www.privoxy.org
43 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
44 BuildRoot: %{_tmppath}/%{name}-%{version}-root
45 Group: Networking/Utilities
46 URL: http://www.privoxy.org/
47 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
48 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
49 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
50 BuildRequires: perl gzip sed libtool autoconf 
51 Conflicts: junkbuster-raw junkbuster-blank junkbuster
52
53 %description 
54 Privoxy is a web proxy with advanced filtering capabilities for
55 protecting privacy, filtering web page content, managing cookies,
56 controlling access, and removing ads, banners, pop-ups and other
57 obnoxious Internet junk. Privoxy has a very flexible configuration and
58 can be customized to suit individual needs and tastes. Privoxy has application
59 for both stand-alone systems and multi-user networks.
60
61 Privoxy is based on the Internet Junkbuster.
62
63 %prep
64 %setup -q -c
65
66 %build
67 autoheader
68 autoconf
69 %configure --disable-dynamic-pcre
70 make 
71 # Docs are in CVS and tarball now.
72 #%%make dok
73
74 ## Explicitily stripping is not recomended.
75 ## This is handled altomaticaly by RPM, and can couse troubles if
76 ## anyone wants to build an unstriped version - morcego
77 #strip %{name}
78
79 %install
80 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
81 mkdir -p %{buildroot}%{_sbindir} \
82          %{buildroot}%{_mandir}/man1 \
83          %{buildroot}%{_localstatedir}/log/%{name} \
84          %{buildroot}%{privoxyconf}/templates \
85          %{buildroot}%{_sysconfdir}/logrotate.d \
86          %{buildroot}%{_sysconfdir}/rc.d/init.d 
87
88 ## Manual gziping of manpages should not be done, once it can
89 ## break the building on some distributions. Anyway, rpm does it
90 ## automagicaly these days
91 ## Gziping the documentation files is not recomended - morcego
92 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
93
94 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
95
96 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
97 cp -f *.action %{buildroot}%{privoxyconf}/
98 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
99 cp -f trust %{buildroot}%{privoxyconf}/trust
100 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
101 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
102 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
103 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
104
105 # verify all file locations, etc. in the config file
106 # don't start with ^ or commented lines are not replaced
107 ## Changing the sed paramter delimiter to @, so we don't have to
108 ## escape the slashes
109 cat config | \
110     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
111 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
112 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
113 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
114 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
115 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
116 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
117     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
118     %{buildroot}%{privoxyconf}/config
119 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
120     %{buildroot}%{privoxyconf}/default.action
121
122
123 # Creating ghost init files
124 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
125 for i in 0 1 4 6
126 do
127 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
128 done
129 for i in 2 3 5
130 do
131 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
132 done
133
134 ## Macros are expanded even on commentaries. So, we have to use %%
135 ## -- morcego
136 #%%makeinstall
137
138 %pre
139 # This is where we handle old usernames (junkbust and junkbuster)
140 # I'm not sure we should do that, but this is the way we have been
141 # doing it for some time now -- morcego
142 # We should do it for the group as well -- morcego
143 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
144
145 # Change the group name. Remove anything left behind.
146 groupmod -g 73 -n %{name} %{oldname} > /dev/null 2>&1 ||:
147 groupmod -g 73 -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
148 groupdel %{oldname} > /dev/null 2>&1 ||:
149 groupdel %{veryoldname} > /dev/null 2>&1 ||:
150
151 # Same for username
152 usermod -u 73 -g 73 -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
153 usermod -u 73 -g 73 -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
154 userdel %{oldname} > /dev/null 2>&1 ||:
155 userdel %{veryoldname} > /dev/null 2>&1 ||:
156
157 # Doublecheck to see if the group exist, and that it has the correct gid
158 /bin/grep -E '^%{name}:' /etc/group > /dev/null 2>&1
159 if [ $? -eq 1 ]; then
160         # Looks like it does not exist. Create it
161         groupadd -g 73 %{name} > /dev/null 2>&1
162 else
163         /bin/grep -E '^%{name}:[^:]*:73:' /etc/group > /dev/null 2>&1
164         if [ $? -eq 1 ]; then
165                 # The group exists, but does not have the correct gid
166                 groupmod -g 73 %{name} > /dev/null 2>&1
167         fi
168 fi
169
170 # Check to see if everything is okey. Create user if it still does not
171 # exist
172 id %{name} > /dev/null 2>&1
173 if [ $? -eq 1 ]; then
174         /usr/sbin/useradd -u 73 -g 73 -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
175 fi
176
177 # Double check that the group has the correct uid
178 P_UID=`id -u %{name} 2>/dev/null`
179 if [ $P_UID -ne 73 ]; then
180         /usr/sbin/usermod -u 73 %{name}
181 fi
182
183 # The same for the gid
184 P_GID=`id -g %{name} 2>/dev/null`
185 if [ $P_GID -ne 73 ]; then
186         /usr/sbin/usermod -g 73 %{name}
187 fi
188
189 %post
190 # for upgrade from 2.0.x
191 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
192  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
193 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
194  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
195 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
196 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
197 if [ "$1" = "1" ]; then
198         /sbin/service %{name} condrestart > /dev/null 2>&1
199 fi
200
201 %preun
202 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
203 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
204
205 if [ "$1" = "0" ]; then
206         /sbin/service %{name} stop > /dev/null 2>&1 ||:
207         # No need to use chkconfig. The %%ghost files will handle it
208 fi
209
210 %postun
211 #if [ "$1" -ge "1" ]; then
212 #       /sbin/service %{name} condrestart > /dev/null 2>&1
213 #fi
214 # We only remove it we this is not an upgrade
215 if [ "$1" = "0" ]; then
216         # And only if this is not redhat, once redhat likes to have
217         # the uid and gid allocated even if the package is not
218         # installed
219         if [ ! -r /etc/redhat-release ]; then
220                 /bin/grep -E '^%{name}:' /etc/group > /dev/null && /usr/sbin/groupdel %{name} || /bin/true
221                 id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
222         fi
223 fi
224
225 %clean
226 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
227
228 %files
229 %defattr(0644,root,root,0755)
230 %doc README AUTHORS ChangeLog LICENSE 
231 %doc doc/text/developer-manual.txt doc/text/user-manual.txt doc/text/faq.txt
232 %doc doc/webserver/developer-manual
233 %doc doc/webserver/user-manual
234 %doc doc/webserver/faq
235 %doc doc/webserver/p_doc.css doc/webserver/p_web.css doc/webserver/index.html
236
237 %dir %{privoxyconf}
238 %dir %{privoxyconf}/templates
239 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
240
241 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
242
243 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
244 # We should not use wildchars here. This could mask missing files problems
245 # -- morcego
246 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
247 %config %{privoxyconf}/config
248 %config %{privoxyconf}/advanced.action
249 %config %{privoxyconf}/basic.action
250 %config %{privoxyconf}/intermediate.action
251 %config %{privoxyconf}/default.action
252 %config %{privoxyconf}/default.filter
253 %config %{privoxyconf}/trust
254
255 %config %{privoxyconf}/templates/untrusted
256 %config %{privoxyconf}/templates/toggle-mini
257 %config %{privoxyconf}/templates/default
258 %config %{privoxyconf}/templates/connect-failed
259 %config %{privoxyconf}/templates/show-status-file
260 %config %{privoxyconf}/templates/cgi-error-bad-param
261 %config %{privoxyconf}/templates/show-version
262 %config %{privoxyconf}/templates/cgi-error-file
263 %config %{privoxyconf}/templates/cgi-error-404
264 %config %{privoxyconf}/templates/cgi-error-parse
265 %config %{privoxyconf}/templates/edit-actions-url-form
266 %config %{privoxyconf}/templates/no-such-domain
267 %config %{privoxyconf}/templates/edit-actions-add-url-form
268 %config %{privoxyconf}/templates/cgi-style.css
269 %config %{privoxyconf}/templates/edit-actions-for-url-filter
270 %config %{privoxyconf}/templates/cgi-error-disabled
271 %config %{privoxyconf}/templates/edit-actions-remove-url-form
272 %config %{privoxyconf}/templates/show-request
273 %config %{privoxyconf}/templates/cgi-error-modified
274 %config %{privoxyconf}/templates/mod-unstable-warning
275 %config %{privoxyconf}/templates/edit-actions-list
276 %config %{privoxyconf}/templates/toggle
277 %config %{privoxyconf}/templates/edit-actions-list-section
278 %config %{privoxyconf}/templates/mod-title
279 %config %{privoxyconf}/templates/edit-actions-list-url
280 %config %{privoxyconf}/templates/show-status
281 %config %{privoxyconf}/templates/blocked
282 %config %{privoxyconf}/templates/mod-support-and-service
283 %config %{privoxyconf}/templates/mod-local-help
284 %config %{privoxyconf}/templates/show-url-info
285 %config %{privoxyconf}/templates/edit-actions-for-url
286
287 %config %{_sysconfdir}/logrotate.d/%{name}
288 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
289 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
290 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
291 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
292 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
293 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
294 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
295 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
296
297 %{_mandir}/man1/%{name}.*
298
299 %changelog
300 * Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
301 + privoxy-2.9.14-1
302 - Changes to fixate the uid and gid values as (both) 73. This is a 
303   value we hope to standarize for all distributions. RedHat already
304   uses it, and Conectiva should start as soon as I find where the heck
305   I left my cluebat :-)
306 - Only remove the user and group on uninstall if this is not redhat, once
307   redhat likes to have the values allocated even if the package is not 
308   installed
309
310 * Tue Apr 16 2002 Hal Burgiss <hal@foobox.net>
311 + privoxy-2.9.13-6
312 - Add --disable-dynamic-pcre to configure.
313
314 * Wed Apr 10 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
315 + privoxy-2.9.13-5
316 - Relisting template files on the %%files section
317
318 * Tue Apr 09 2002 Hal Burgiss <hal@foobox.net>
319 + privoxy-2.9.13-4
320 - Removed 'make dok'. Docs are all maintained in CVS (and tarball) now.
321
322 * Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
323 + privoxy-2.9.13-4
324 - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
325 - Remove templates/blocked-compact.
326 - Add more docbook stuff to Builderquires.
327
328 * Thu Mar 28 2002 Sarantis Paskalis <sarantis@cnl.di.uoa.gr>
329 + privoxy-2.9.13-3
330 - Include correct documentation file.
331
332 * Tue Mar 26 2002 Hal Burgiss <hal@foobox.net>
333 + privoxy-2.9.13-3
334 - Fix typo in Description.
335
336 * Tue Mar 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
337 + privoxy-2.9.13-3
338 - Added commentary asking to update the release value on the configure
339   script
340
341 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
342 + privoxy-2.9.13-3
343 - Added the missing edit-actions-for-url-filter to templates.
344
345 * Mon Mar 25 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
346 + privoxy-2.9.13-2
347 - Fixing Release number
348
349 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
350 + privoxy-2.9.13-2
351 - Added faq to docs.
352
353 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
354 + privoxy-2.9.13-2
355 - Fixed the init files entries. Now we use %%ghost
356 - improved username (and groupname) handling on the %%pre section. By improved
357   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
358   got it right. No more Mr. Nice Guy.
359 - Removed the userdel call on %%post. No need, once it's complety handled on
360   the %%pre section
361
362 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
363 + junkbusterng-2.9.13-1
364   Added autoheader. Added autoconf to buildrequires.
365
366 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
367 + junkbusterng-2.9.13-1
368 - Fixed build problems re: name conflicts with man page and logrotate.
369 - Commented out rc?d/* configs for time being, which are causing a build 
370 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
371 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
372
373 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
374 + junkbusterng-2.9.13-1
375 - References to the expression ijb where changed where possible
376 - New package name: junkbusterng (all in lower case, acording to
377   the LSB recomendation)
378 - Version changed to: 2.9.13
379 - Release: 1
380 - Added: junkbuster to obsoletes and conflicts (Not sure this is
381   right. If it obsoletes, why conflict ? Have to check it later)
382 - Summary changed: Stefan, please check and aprove it
383 - Changes description to use the new name
384 - Sed string was NOT changed. Have to wait to the manpage to
385   change first
386 - Keeping the user junkbuster for now. It will require some aditional
387   changes on the script (scheduled for the next specfile release)
388 - Added post entry to move the old logfile to the new log directory
389 - Removing "chkconfig --add" entry (not good to have it automaticaly
390   added to the startup list).
391 - Added preun section to stop the service with the old name, as well
392   as remove it from the startup list
393 - Removed the chkconfig --del entry from the conditional block on
394   the preun scriptlet (now handled on the %files section)
395
396 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
397 - added ijb_docs.css to docs.
398
399 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
400 + junkbuster-2.9.11-8 
401 - Take out --enable-no-gifs, breaks some browsers.
402
403 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
404 + junkbuster-2.9.11-8 
405 - Add --enable-no-gifs to configure.
406
407 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
408 + junkbuster-2.9.11-7
409 - Added BuildRequires to libtool.
410
411 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
412 + junkbuster-2.9.11-6
413 - Changed the routined that handle the junkbust and junkbuster users on
414   %%pre and %%post to work in a smoother manner
415 - %%files now uses hardcoded usernames, to avoid problems with package
416   name changes in the future
417
418 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
419 + junkbuster-2.9.11-5
420 - Added "make redhat-dok" to the build process
421 - Added docbook-utils to BuildRequires
422
423 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
424 + junkbuster-2.9.11-4
425 - Changing man section in the manpage from 1 to 8
426 - We now require packages, not files, to avoid issues with apt
427
428 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
429 + junkbuster-2.9.11-3
430 - Fixing permissions of the init script
431
432 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
433 + junkbuster-2.9.11-2
434 - General specfile fixup, using the best recomended practices, including:
435         - Adding -q to %%setup
436         - Using macros whereever possible
437         - Not using wildchars on %%files section
438         - Doubling the percentage char on changelog and comments, to
439           avoid rpm expanding them
440
441 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
442 - /bin/false for shell causes init script to fail. Reverting.
443
444 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
445 - Removed UID 73. Included user-manual and developer-manual in docs.
446   Include other actions files. Default shell is now /bin/false.
447   Userdel user=junkbust. ChangeLog was not zipped. Removed 
448   RPM_OPT_FLAGS kludge.
449
450 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
451 - add paranoia check for 'rm -rf %%{buildroot}'
452 - add gzip to 'BuildRequires'
453
454 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
455 - actionsfile is now ijb.action.
456
457 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
458 - Compress manpage
459 - Add more documents for installation
460 - Add version string to name and source
461
462 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
463 - Back to user 'junkbuster' and fix configure macro.
464
465 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
466 - More changes for user 'junkbust'. Init script had 'junkbuster'.
467
468 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
469 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
470 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
471
472 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
473 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
474 - made sure no default shell exists for user junkbust.
475
476 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
477 - rework of RPM
478
479 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
480 - CLF Logging patch by davep@cyw.uklinux.net
481 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
482
483 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
484 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
485 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
486   numerous fixes and enhancements for Steve's patch.
487 - adamlock@netscape.com (Adam Lock) in the windows version:
488   - Taskbar activity spinner always spins even when logging is
489   turned off (which is the default) - people who don't
490   like the spinner can turn it off from a menu option.
491   - Taskbar popup menu has a options submenu - people can now
492   open the settings files for cookies, blockers etc.
493   without opening the JB window.
494   - Logging functionality works again
495   - Buffer overflow is fixed - new code uses a bigger buffer
496   and snprintf so it shouldn't overflow anymore.
497 - Fixed userid swa, group learning problem while installing.
498   root must build RPM.
499 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
500   core dump when there is no log file.
501 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
502 - Fixed man page to include imagefile and popupfile.
503 - Sanity check for the statistics function added.
504 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
505  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
506  With IIS/5, it appears to omit the trailing \r\n from http header
507  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
508  responds with a HTTP 302 redirect header.  However, this header
509  message is missing the trailing \r\n.  IIS/5 then closes the
510  connection.  Junkbuster, unfortunately, discards the header becomes
511  it thinks it is incomplete - and it is.  MS have transmitted an
512  incomplete header!
513 - Added bug reports and patch submission forms in the docs.
514
515 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
516        Andrew <anw@tirana.freewire.co.uk> extended the JB:
517        Display of statistics of the total number of requests and the number
518        of requests filtered by junkbuster, also the percentage of requests
519        filtered. Suppression of the listing of files on the proxy-args page.
520        All stuff optional and configurable.
521
522 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
523        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
524        code which prevented the JB from handling URLs of the form
525        user:password@www.foo.com. Fixed.
526
527 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
528         Blank images are no longer cached, thanks to a hint from Markus 
529         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
530         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
531         on the correct browser version nowadays. Incorporated many 
532         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
533         spec file. Fixed logging problem and since runlevel 2 does not 
534         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
535         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
536         <walker@netgate.net>. You should now be able to build this RPM as 
537         a non-root user (mathias@weidner.sem.lipsia.de).
538
539 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
540         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
541         to allow more sophisticated matching of blocked images. Logrotate
542         logfile. Added files for auto-updating the blocklist et al.
543
544 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
545         Configure blank version via config file. No separate blank
546         version anymore. Added Roland's <roland@spinnaker.rhein.de>
547         patch to show a logo instead of a blank area. Added a suggestion
548         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
549         More regexps in the blocklist. Prepared the forwardfile for
550         squid. Extended image regexp with help from gabriel 
551         <somlo@CS.ColoState.EDU>.
552
553 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
554         All RPMs now identify themselves in the show-proxy-args page.
555         Released Windoze version. Run junkbuster as nobody instead of
556         root. 
557
558 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
559         Newest version. First release (hence the little version number
560         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
561         security over 2.0.1; some multi-user sites will need to change 
562         the listen-address in the configuration file. The blank version of
563         the Internet Junkbuster has a more sophisticated way of replacing
564         images. All RPMs identify themselves in the show-proxy-args page.
565
566 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
567         Modified the blocking feature, so that only GIFs and JPEGs are
568         blocked and replaced but not HTML pages. Thanks to 
569         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
570         idea. Added numerous stuff to the blocklist. Keep patches in
571         seperate files and no longer in diffs (easier to maintain).
572
573 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
574         Moved config files to /etc/junkbuster directory, moved man page,
575         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
576         Made new version junkbuster-raw (which is only a stripped version of 
577         the junkuster rpm, i.e. without my blocklist, etc.)
578
579 * Tue Jun 16 1998 (2.0-1)
580         Uhm, not that much. Just a new junkbuster version that
581         fixes a couple of bugs ... and of course a bigger 
582         blocklist with the unique Now-less-ads-than-ever(SM)
583         feature.
584         Oh, one thing: I changed the default user agent to Linux -- no 
585         need anymore to support Apple.
586
587 * Tue Jun 16 1998 (2.0-0)
588         Now-less-ads-than-ever (SM)
589         compiled with gcc instead of cc
590         compiled with -O3, thus it should be a little faster
591         show-proxy-args now works
592         /etc/junkbuster.init wasn't necessary
593
594 * Tue Jun 16 1998 (1.4)
595         some more config files were put into /etc
596         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
597         displayed by Netscape instead of the blocked image.
598         Read http://www.waldherr.org/junkbuster/ for
599         further info.
600
601 * Tue Jun 16 1998 (1.3)
602         The program has been moved to /usr/sbin (from /usr/local/bin)
603         Init- and stopscripts (/etc/rc.d/rc*) have been added so
604         that the junkbuster starts automatically during bootup.
605         The /etc/blocklist file is much more sophisticated. Theoretically
606         one should e.g. browse all major US and German newspapers without
607         seeing one annoying ad.
608         junkbuster.init was modified. It now starts junkbuster with an
609         additional "-r @" flag.
610
611 # $Log: privoxy-rh.spec,v $
612 # Revision 1.25  2002/04/17 01:59:12  hal9
613 # Add --disable-dynamic-pcre.
614 #
615 # Revision 1.24  2002/04/11 10:09:20  oes
616 # Version 2.9.14
617 #
618 # Revision 1.23  2002/04/10 18:14:45  morcego
619 # - (privoxy-rh.spec only) Relisting template files on the %%files section
620 # - (configure.in, privoxy-rh.spec) Bumped package release to 5
621 #
622 # Revision 1.22  2002/04/09 22:06:12  hal9
623 # Remove 'make dok'.
624 #
625 # Revision 1.21  2002/04/09 02:52:26  hal9
626 # - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
627 # - Remove templates/blocked-compact.
628 # - Add more docbook stuff to Buildrequires.
629 #
630 # Revision 1.20  2002/04/08 20:27:45  swa
631 # fixed JB spelling
632 #
633 # Revision 1.19  2002/03/27 22:44:59  sarantis
634 # Include correct documentation file.
635 #
636 # Revision 1.18  2002/03/27 22:10:14  sarantis
637 # bumped Hal's last commit 1 day to the future to make rpm build again.
638 #
639 # Revision 1.17  2002/03/27 00:48:23  hal9
640 # Fix up descrition.
641 #
642 # Revision 1.16  2002/03/26 22:29:55  swa
643 # we have a new homepage!
644 #
645 # Revision 1.15  2002/03/26 17:39:54  morcego
646 # Adding comment on the specfile to remember the packager to update
647 # the release number on the configure script
648 #
649 # Revision 1.14  2002/03/26 14:25:15  hal9
650 # Added edit-actions-for-url-filter to templates in %%config
651 #
652 # Revision 1.13  2002/03/25 13:31:04  morcego
653 # Bumping Release tag.
654 #
655 # Revision 1.12  2002/03/25 03:11:40  hal9
656 # Do it right way this time :/
657 #
658 # Revision 1.11  2002/03/25 03:09:51  hal9
659 # Added faq to docs.
660 #
661 # Revision 1.10  2002/03/24 22:16:14  morcego
662 # Just removing some old commentaries.
663 #
664 # Revision 1.9  2002/03/24 22:03:22  morcego
665 # Should be working now. See %changelog for details
666 #
667 # Revision 1.8  2002/03/24 21:13:01  morcego
668 # Tis broken.
669 #
670 # Revision 1.7  2002/03/24 21:07:18  hal9
671 # Add autoheader, etc.
672 #
673 # Revision 1.6  2002/03/24 19:56:40  hal9
674 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
675 #
676 # Revision 1.4  2002/03/24 13:32:42  swa
677 # name change related issues
678 #
679 # Revision 1.3  2002/03/24 12:56:21  swa
680 # name change related issues.
681 #
682 # Revision 1.2  2002/03/24 11:40:14  swa
683 # name change
684 #
685 # Revision 1.1  2002/03/24 11:23:44  swa
686 # name change
687 #
688 # Revision 1.1  2002/03/22 20:53:03  morcego
689 # - Ongoing process to change name to JunkbusterNG
690 # - configure/configure.in: no change needed
691 # - GNUmakefile.in:
692 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
693 #         - PROGRAM    = jbng@EXEEXT@
694 #         - rh-spec now references as junkbusterng-rh.spec
695 #         - redhat-upload: references changed to junkbusterng-* (package names)
696 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
697 #         - tarball-src: now JunkbusterNG-*
698 #         - install: initscript now junkbusterng.init and junkbusterng (when
699 #                    installed)
700 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
701 # - junkbusterng.spec:
702 #         - References to the expression ijb where changed where possible
703 #         - New package name: junkbusterng (all in lower case, acording to
704 #           the LSB recomendation)
705 #         - Version changed to: 2.9.13
706 #         - Release: 1
707 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
708 #           right. If it obsoletes, why conflict ? Have to check it later)
709 #         - Summary changed: Stefan, please check and aprove it
710 #         - Changes description to use the new name
711 #         - Sed string was NOT changed. Have to wait to the manpage to
712 #           change first
713 #         - Keeping the user junkbuster for now. It will require some aditional
714 #           changes on the script (scheduled for the next specfile release)
715 #         - Added post entry to move the old logfile to the new log directory
716 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
717 #           added to the startup list).
718 #         - Added preun section to stop the service with the old name, as well
719 #           as remove it from the startup list
720 #         - Removed the chkconfig --del entry from the conditional block on
721 #           the preun scriptlet (now handled on the %files section)
722 # - junkbuster.init: renamed to junkbusterng.init
723 # - junkbusterng.init:
724 #         - Changed JB_BIN to jbng
725 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
726 #           be used where necessary (config dir)
727 #
728 # Aditional notes:
729 # - The config directory is /etc/junkbuster yet. Have to change it on the
730 # specfile, after it is changes on the code
731 # - The only files that got renamed on the cvs tree were the rh specfile and
732 # the init file. Some file references got changes on the makefile and on the
733 # rh-spec (as listed above)
734 #
735 # Revision 1.43  2002/03/21 16:04:10  hal9
736 # added ijb_docs.css to %doc
737 #
738 # Revision 1.42  2002/03/12 13:41:18  sarantis
739 # remove hard-coded "ijbswa" string in build phase
740 #
741 # Revision 1.41  2002/03/11 22:58:32  hal9
742 # Remove --enable-no-gifs
743 #
744 # Revision 1.39  2002/03/08 18:57:29  swa
745 # remove user junkbuster after de-installation.
746 #
747 # Revision 1.38  2002/03/08 13:45:27  morcego
748 # Adding libtool to Buildrequires
749 #
750 # Revision 1.37  2002/03/07 19:23:49  swa
751 # i hate to scroll. suse: wrong configdir.
752 #
753 # Revision 1.36  2002/03/07 05:06:54  morcego
754 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
755 #
756 # Revision 1.34  2002/03/07 00:11:57  morcego
757 # Few changes on the %pre and %post sections of the rh specfile to handle
758 # usernames more cleanly
759 #
760 # Revision 1.33  2002/03/05 13:13:57  morcego
761 # - Added "make redhat-dok" to the build phase
762 # - Added docbook-utils to BuildRequires
763 #
764 # Revision 1.32  2002/03/05 12:34:24  morcego
765 # - Changing section internaly on the manpage from 1 to 8
766 # - We now require packages, not files, to avoid issues with apt
767 #
768 # Revision 1.31  2002/03/04 18:06:09  morcego
769 # SPECFILE: fixing permissing of the init script (broken by the last change)
770 #
771 # Revision 1.30  2002/03/04 16:18:03  morcego
772 # General cleanup of the rh specfile.
773 #
774 # %changelog
775 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
776 # + junkbuster-2.9.11-2
777 # - General specfile fixup, using the best recomended practices, including:
778 #         - Adding -q to %%setup
779 #         - Using macros whereever possible
780 #         - Not using wildchars on %%files section
781 #         - Doubling the percentage char on changelog and comments, to
782 #           avoid rpm expanding them
783 #
784 # Revision 1.29  2002/03/03 19:21:22  hal9
785 # Init script fails if shell is /bin/false.
786 #
787 # Revision 1.28  2002/01/09 18:34:03  hal9
788 # nit.
789 #
790 # Revision 1.27  2002/01/09 18:32:02  hal9
791 # Removed RPM_OPT_FLAGS kludge.
792 #
793 # Revision 1.26  2002/01/09 18:21:10  hal9
794 # A few minor updates.
795 #
796 # Revision 1.25  2001/12/28 01:45:36  steudten
797 # Add paranoia check and BuildReq: gzip
798 #
799 # Revision 1.24  2001/12/01 21:43:14  hal9
800 # Allowed for new ijb.action file.
801 #
802 # Revision 1.23  2001/11/06 12:09:03  steudten
803 # Compress doc files. Install README and AUTHORS at last as document.
804 #
805 # Revision 1.22  2001/11/05 21:37:34  steudten
806 # Fix to include the actual version for name.
807 # Let the 'real' packager be included - sorry stefan.
808 #
809 # Revision 1.21  2001/10/31 19:27:27  swa
810 # consistent description. new name for suse since
811 # we had troubles with rpms of identical names
812 # on the webserver.
813 #
814 # Revision 1.20  2001/10/24 15:45:49  hal9
815 # To keep Thomas happy (aka correcting my  mistakes)
816 #
817 # Revision 1.19  2001/10/15 03:23:59  hal9
818 # Nits.
819 #
820 # Revision 1.17  2001/10/10 18:59:28  hal9
821 # Minor change for init script.
822 #
823 # Revision 1.16  2001/09/24 20:56:23  hal9
824 # Minor changes.
825 #
826 # Revision 1.13  2001/09/10 17:44:43  swa
827 # integrate three pieces of documentation. needs work.
828 # will not build cleanly under redhat.
829 #
830 # Revision 1.12  2001/09/10 16:25:04  swa
831 # copy all templates. version updated.
832 #
833 # Revision 1.11  2001/07/03 11:00:25  sarantis
834 # replaced permissionsfile with actionsfile
835 #
836 # Revision 1.10  2001/07/03 09:34:44  sarantis
837 # bumped up version number.
838 #
839 # Revision 1.9  2001/06/12 18:15:29  swa
840 # the %% in front of configure (see tag below) confused
841 # the rpm build process on 7.1.
842 #
843 # Revision 1.8  2001/06/12 17:15:56  swa
844 # fixes, because a clean build on rh6.1 was impossible.
845 # GZIP confuses make, %% configure confuses rpm, etc.
846 #
847 # Revision 1.7  2001/06/11 12:17:26  sarantis
848 # fix typo in %%post
849 #
850 # Revision 1.6  2001/06/11 11:28:25  sarantis
851 # Further optimizations and adaptations in the spec file.
852 #
853 # Revision 1.5  2001/06/09 09:14:11  swa
854 # shamelessly adapted RPM stuff from the newest rpm that
855 # RedHat provided for the JB.
856 #
857 # Revision 1.4  2001/06/08 20:54:18  swa
858 # type with status file. remove forward et. al from file list.
859 #
860 # Revision 1.3  2001/06/07 17:28:10  swa
861 # cosmetics
862 #
863 # Revision 1.2  2001/06/04 18:31:58  swa
864 # files are now prefixed with either `confdir' or `logdir'.
865 # `make redhat-dist' replaces both entries confdir and logdir
866 # with redhat values
867 #
868 # Revision 1.1  2001/06/04 10:44:57  swa
869 # `make redhatr-dist' now works. Except for the paths
870 # in the config file.
871 #
872 #
873 #