configure.in, *.spec: Bumping release to 2 (2.9.14-2)
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.26 2002/04/22 16:24:36 morcego Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33 %define privoxy_uid 73
34 %define privoxy_gid 73
35
36 Name: privoxy
37 # ATTENTION
38 # Version and release should be updated acordingly on configure.in and
39 # configure. Otherwise, the package can be build with the wrong value
40 Version: 2.9.14
41 Release: 2
42 Summary: Privoxy - privacy enhancing proxy
43 License: GPL
44 Vendor: http://www.privoxy.org
45 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
46 BuildRoot: %{_tmppath}/%{name}-%{version}-root
47 Group: Networking/Utilities
48 URL: http://www.privoxy.org/
49 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
50 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
51 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
52 BuildRequires: perl gzip sed libtool autoconf 
53 Conflicts: junkbuster-raw junkbuster-blank junkbuster
54
55 %description 
56 Privoxy is a web proxy with advanced filtering capabilities for
57 protecting privacy, filtering web page content, managing cookies,
58 controlling access, and removing ads, banners, pop-ups and other
59 obnoxious Internet junk. Privoxy has a very flexible configuration and
60 can be customized to suit individual needs and tastes. Privoxy has application
61 for both stand-alone systems and multi-user networks.
62
63 Privoxy is based on the Internet Junkbuster.
64
65 %prep
66 %setup -q -c
67
68 %build
69 autoheader
70 autoconf
71 %configure --disable-dynamic-pcre
72 make 
73 # Docs are in CVS and tarball now.
74 #%%make dok
75
76 ## Explicitily stripping is not recomended.
77 ## This is handled altomaticaly by RPM, and can couse troubles if
78 ## anyone wants to build an unstriped version - morcego
79 #strip %{name}
80
81 %install
82 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
83 mkdir -p %{buildroot}%{_sbindir} \
84          %{buildroot}%{_mandir}/man1 \
85          %{buildroot}%{_localstatedir}/log/%{name} \
86          %{buildroot}%{privoxyconf}/templates \
87          %{buildroot}%{_sysconfdir}/logrotate.d \
88          %{buildroot}%{_sysconfdir}/rc.d/init.d 
89
90 ## Manual gziping of manpages should not be done, once it can
91 ## break the building on some distributions. Anyway, rpm does it
92 ## automagicaly these days
93 ## Gziping the documentation files is not recomended - morcego
94 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
95
96 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
97
98 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
99 cp -f *.action %{buildroot}%{privoxyconf}/
100 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
101 cp -f trust %{buildroot}%{privoxyconf}/trust
102 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
103 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
104 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
105 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
106
107 # verify all file locations, etc. in the config file
108 # don't start with ^ or commented lines are not replaced
109 ## Changing the sed paramter delimiter to @, so we don't have to
110 ## escape the slashes
111 cat config | \
112     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
113 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
114 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
115 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
116 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
117 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
118 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
119     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
120     %{buildroot}%{privoxyconf}/config
121 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
122     %{buildroot}%{privoxyconf}/default.action
123
124
125 # Creating ghost init files
126 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
127 for i in 0 1 4 6
128 do
129 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
130 done
131 for i in 2 3 5
132 do
133 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
134 done
135
136 ## Macros are expanded even on commentaries. So, we have to use %%
137 ## -- morcego
138 #%%makeinstall
139
140 %pre
141 # This is where we handle old usernames (junkbust and junkbuster)
142 # I'm not sure we should do that, but this is the way we have been
143 # doing it for some time now -- morcego
144 # We should do it for the group as well -- morcego
145 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
146
147 # Change the group name. Remove anything left behind.
148 groupmod -g %{privoxy_gid} -n %{name} %{oldname} > /dev/null 2>&1 ||:
149 groupmod -g %{privoxy_gid} -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
150 groupdel %{oldname} > /dev/null 2>&1 ||:
151 groupdel %{veryoldname} > /dev/null 2>&1 ||:
152
153 # Same for username
154 usermod -u %{privoxy_uid} -g %{privoxy_gid} -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
155 usermod -u %{privoxy_uid} -g %{privoxy_gid} -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
156 userdel %{oldname} > /dev/null 2>&1 ||:
157 userdel %{veryoldname} > /dev/null 2>&1 ||:
158
159 # Doublecheck to see if the group exist, and that it has the correct gid
160 /bin/grep -E '^%{name}:' /etc/group > /dev/null 2>&1
161 if [ $? -eq 1 ]; then
162         # Looks like it does not exist. Create it
163         groupadd -g %{privoxy_gid} %{name} > /dev/null 2>&1
164 else
165         /bin/grep -E '^%{name}:[^:]*:%{privoxy_gid}:' /etc/group > /dev/null 2>&1
166         if [ $? -eq 1 ]; then
167                 # The group exists, but does not have the correct gid
168                 groupmod -g %{privoxy_gid} %{name} > /dev/null 2>&1
169         fi
170 fi
171
172 # Check to see if everything is okey. Create user if it still does not
173 # exist
174 id %{name} > /dev/null 2>&1
175 if [ $? -eq 1 ]; then
176         /usr/sbin/useradd -u %{privoxy_uid} -g %{privoxy_gid} -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
177 fi
178
179 # Double check that the group has the correct uid
180 P_UID=`id -u %{name} 2>/dev/null`
181 if [ $P_UID -ne %{privoxy_uid} ]; then
182         /usr/sbin/usermod -u %{privoxy_uid} %{name}
183 fi
184
185 # The same for the gid
186 P_GID=`id -g %{name} 2>/dev/null`
187 if [ $P_GID -ne %{privoxy_gid} ]; then
188         /usr/sbin/usermod -g %{privoxy_gid} %{name}
189 fi
190
191 %post
192 # for upgrade from 2.0.x
193 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
194  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
195 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
196  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
197 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
198 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
199 if [ "$1" = "1" ]; then
200         /sbin/service %{name} condrestart > /dev/null 2>&1
201 fi
202
203 %preun
204 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
205 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
206
207 if [ "$1" = "0" ]; then
208         /sbin/service %{name} stop > /dev/null 2>&1 ||:
209         # No need to use chkconfig. The %%ghost files will handle it
210 fi
211
212 %postun
213 #if [ "$1" -ge "1" ]; then
214 #       /sbin/service %{name} condrestart > /dev/null 2>&1
215 #fi
216 # We only remove it we this is not an upgrade
217 if [ "$1" = "0" ]; then
218         # And only if this is not redhat, once redhat likes to have
219         # the uid and gid allocated even if the package is not
220         # installed
221         if [ ! -r /etc/redhat-release ]; then
222                 /bin/grep -E '^%{name}:' /etc/group > /dev/null && /usr/sbin/groupdel %{name} || /bin/true
223                 id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
224         fi
225 fi
226
227 %clean
228 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
229
230 %files
231 %defattr(0644,root,root,0755)
232 %doc README AUTHORS ChangeLog LICENSE 
233 %doc doc/text/developer-manual.txt doc/text/user-manual.txt doc/text/faq.txt
234 %doc doc/webserver/developer-manual
235 %doc doc/webserver/user-manual
236 %doc doc/webserver/faq
237 %doc doc/webserver/p_doc.css doc/webserver/p_web.css doc/webserver/index.html
238
239 %dir %{privoxyconf}
240 %dir %{privoxyconf}/templates
241 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
242
243 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
244
245 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
246 # We should not use wildchars here. This could mask missing files problems
247 # -- morcego
248 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
249 %config %{privoxyconf}/config
250 %config %{privoxyconf}/advanced.action
251 %config %{privoxyconf}/basic.action
252 %config %{privoxyconf}/intermediate.action
253 %config %{privoxyconf}/default.action
254 %config %{privoxyconf}/default.filter
255 %config %{privoxyconf}/trust
256
257 %config %{privoxyconf}/templates/untrusted
258 %config %{privoxyconf}/templates/toggle-mini
259 %config %{privoxyconf}/templates/default
260 %config %{privoxyconf}/templates/connect-failed
261 %config %{privoxyconf}/templates/show-status-file
262 %config %{privoxyconf}/templates/cgi-error-bad-param
263 %config %{privoxyconf}/templates/show-version
264 %config %{privoxyconf}/templates/cgi-error-file
265 %config %{privoxyconf}/templates/cgi-error-404
266 %config %{privoxyconf}/templates/cgi-error-parse
267 %config %{privoxyconf}/templates/edit-actions-url-form
268 %config %{privoxyconf}/templates/no-such-domain
269 %config %{privoxyconf}/templates/edit-actions-add-url-form
270 %config %{privoxyconf}/templates/cgi-style.css
271 %config %{privoxyconf}/templates/edit-actions-for-url-filter
272 %config %{privoxyconf}/templates/cgi-error-disabled
273 %config %{privoxyconf}/templates/edit-actions-remove-url-form
274 %config %{privoxyconf}/templates/show-request
275 %config %{privoxyconf}/templates/cgi-error-modified
276 %config %{privoxyconf}/templates/mod-unstable-warning
277 %config %{privoxyconf}/templates/edit-actions-list
278 %config %{privoxyconf}/templates/toggle
279 %config %{privoxyconf}/templates/edit-actions-list-section
280 %config %{privoxyconf}/templates/mod-title
281 %config %{privoxyconf}/templates/edit-actions-list-url
282 %config %{privoxyconf}/templates/show-status
283 %config %{privoxyconf}/templates/blocked
284 %config %{privoxyconf}/templates/mod-support-and-service
285 %config %{privoxyconf}/templates/mod-local-help
286 %config %{privoxyconf}/templates/show-url-info
287 %config %{privoxyconf}/templates/edit-actions-for-url
288
289 %config %{_sysconfdir}/logrotate.d/%{name}
290 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
291 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
292 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
293 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
294 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
295 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
296 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
297 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
298
299 %{_mandir}/man1/%{name}.*
300
301 %changelog
302 * Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
303 + privoxy-2.9.14-2
304 - Using macros to define uid and gid values
305 - Bumping release
306
307 * Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
308 + privoxy-2.9.14-1
309 - Changes to fixate the uid and gid values as (both) 73. This is a 
310   value we hope to standarize for all distributions. RedHat already
311   uses it, and Conectiva should start as soon as I find where the heck
312   I left my cluebat :-)
313 - Only remove the user and group on uninstall if this is not redhat, once
314   redhat likes to have the values allocated even if the package is not 
315   installed
316
317 * Tue Apr 16 2002 Hal Burgiss <hal@foobox.net>
318 + privoxy-2.9.13-6
319 - Add --disable-dynamic-pcre to configure.
320
321 * Wed Apr 10 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
322 + privoxy-2.9.13-5
323 - Relisting template files on the %%files section
324
325 * Tue Apr 09 2002 Hal Burgiss <hal@foobox.net>
326 + privoxy-2.9.13-4
327 - Removed 'make dok'. Docs are all maintained in CVS (and tarball) now.
328
329 * Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
330 + privoxy-2.9.13-4
331 - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
332 - Remove templates/blocked-compact.
333 - Add more docbook stuff to Builderquires.
334
335 * Thu Mar 28 2002 Sarantis Paskalis <sarantis@cnl.di.uoa.gr>
336 + privoxy-2.9.13-3
337 - Include correct documentation file.
338
339 * Tue Mar 26 2002 Hal Burgiss <hal@foobox.net>
340 + privoxy-2.9.13-3
341 - Fix typo in Description.
342
343 * Tue Mar 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
344 + privoxy-2.9.13-3
345 - Added commentary asking to update the release value on the configure
346   script
347
348 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
349 + privoxy-2.9.13-3
350 - Added the missing edit-actions-for-url-filter to templates.
351
352 * Mon Mar 25 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
353 + privoxy-2.9.13-2
354 - Fixing Release number
355
356 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
357 + privoxy-2.9.13-2
358 - Added faq to docs.
359
360 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
361 + privoxy-2.9.13-2
362 - Fixed the init files entries. Now we use %%ghost
363 - improved username (and groupname) handling on the %%pre section. By improved
364   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
365   got it right. No more Mr. Nice Guy.
366 - Removed the userdel call on %%post. No need, once it's complety handled on
367   the %%pre section
368
369 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
370 + junkbusterng-2.9.13-1
371   Added autoheader. Added autoconf to buildrequires.
372
373 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
374 + junkbusterng-2.9.13-1
375 - Fixed build problems re: name conflicts with man page and logrotate.
376 - Commented out rc?d/* configs for time being, which are causing a build 
377 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
378 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
379
380 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
381 + junkbusterng-2.9.13-1
382 - References to the expression ijb where changed where possible
383 - New package name: junkbusterng (all in lower case, acording to
384   the LSB recomendation)
385 - Version changed to: 2.9.13
386 - Release: 1
387 - Added: junkbuster to obsoletes and conflicts (Not sure this is
388   right. If it obsoletes, why conflict ? Have to check it later)
389 - Summary changed: Stefan, please check and aprove it
390 - Changes description to use the new name
391 - Sed string was NOT changed. Have to wait to the manpage to
392   change first
393 - Keeping the user junkbuster for now. It will require some aditional
394   changes on the script (scheduled for the next specfile release)
395 - Added post entry to move the old logfile to the new log directory
396 - Removing "chkconfig --add" entry (not good to have it automaticaly
397   added to the startup list).
398 - Added preun section to stop the service with the old name, as well
399   as remove it from the startup list
400 - Removed the chkconfig --del entry from the conditional block on
401   the preun scriptlet (now handled on the %files section)
402
403 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
404 - added ijb_docs.css to docs.
405
406 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
407 + junkbuster-2.9.11-8 
408 - Take out --enable-no-gifs, breaks some browsers.
409
410 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
411 + junkbuster-2.9.11-8 
412 - Add --enable-no-gifs to configure.
413
414 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
415 + junkbuster-2.9.11-7
416 - Added BuildRequires to libtool.
417
418 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
419 + junkbuster-2.9.11-6
420 - Changed the routined that handle the junkbust and junkbuster users on
421   %%pre and %%post to work in a smoother manner
422 - %%files now uses hardcoded usernames, to avoid problems with package
423   name changes in the future
424
425 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
426 + junkbuster-2.9.11-5
427 - Added "make redhat-dok" to the build process
428 - Added docbook-utils to BuildRequires
429
430 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
431 + junkbuster-2.9.11-4
432 - Changing man section in the manpage from 1 to 8
433 - We now require packages, not files, to avoid issues with apt
434
435 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
436 + junkbuster-2.9.11-3
437 - Fixing permissions of the init script
438
439 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
440 + junkbuster-2.9.11-2
441 - General specfile fixup, using the best recomended practices, including:
442         - Adding -q to %%setup
443         - Using macros whereever possible
444         - Not using wildchars on %%files section
445         - Doubling the percentage char on changelog and comments, to
446           avoid rpm expanding them
447
448 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
449 - /bin/false for shell causes init script to fail. Reverting.
450
451 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
452 - Removed UID 73. Included user-manual and developer-manual in docs.
453   Include other actions files. Default shell is now /bin/false.
454   Userdel user=junkbust. ChangeLog was not zipped. Removed 
455   RPM_OPT_FLAGS kludge.
456
457 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
458 - add paranoia check for 'rm -rf %%{buildroot}'
459 - add gzip to 'BuildRequires'
460
461 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
462 - actionsfile is now ijb.action.
463
464 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
465 - Compress manpage
466 - Add more documents for installation
467 - Add version string to name and source
468
469 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
470 - Back to user 'junkbuster' and fix configure macro.
471
472 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
473 - More changes for user 'junkbust'. Init script had 'junkbuster'.
474
475 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
476 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
477 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
478
479 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
480 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
481 - made sure no default shell exists for user junkbust.
482
483 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
484 - rework of RPM
485
486 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
487 - CLF Logging patch by davep@cyw.uklinux.net
488 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
489
490 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
491 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
492 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
493   numerous fixes and enhancements for Steve's patch.
494 - adamlock@netscape.com (Adam Lock) in the windows version:
495   - Taskbar activity spinner always spins even when logging is
496   turned off (which is the default) - people who don't
497   like the spinner can turn it off from a menu option.
498   - Taskbar popup menu has a options submenu - people can now
499   open the settings files for cookies, blockers etc.
500   without opening the JB window.
501   - Logging functionality works again
502   - Buffer overflow is fixed - new code uses a bigger buffer
503   and snprintf so it shouldn't overflow anymore.
504 - Fixed userid swa, group learning problem while installing.
505   root must build RPM.
506 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
507   core dump when there is no log file.
508 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
509 - Fixed man page to include imagefile and popupfile.
510 - Sanity check for the statistics function added.
511 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
512  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
513  With IIS/5, it appears to omit the trailing \r\n from http header
514  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
515  responds with a HTTP 302 redirect header.  However, this header
516  message is missing the trailing \r\n.  IIS/5 then closes the
517  connection.  Junkbuster, unfortunately, discards the header becomes
518  it thinks it is incomplete - and it is.  MS have transmitted an
519  incomplete header!
520 - Added bug reports and patch submission forms in the docs.
521
522 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
523        Andrew <anw@tirana.freewire.co.uk> extended the JB:
524        Display of statistics of the total number of requests and the number
525        of requests filtered by junkbuster, also the percentage of requests
526        filtered. Suppression of the listing of files on the proxy-args page.
527        All stuff optional and configurable.
528
529 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
530        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
531        code which prevented the JB from handling URLs of the form
532        user:password@www.foo.com. Fixed.
533
534 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
535         Blank images are no longer cached, thanks to a hint from Markus 
536         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
537         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
538         on the correct browser version nowadays. Incorporated many 
539         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
540         spec file. Fixed logging problem and since runlevel 2 does not 
541         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
542         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
543         <walker@netgate.net>. You should now be able to build this RPM as 
544         a non-root user (mathias@weidner.sem.lipsia.de).
545
546 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
547         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
548         to allow more sophisticated matching of blocked images. Logrotate
549         logfile. Added files for auto-updating the blocklist et al.
550
551 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
552         Configure blank version via config file. No separate blank
553         version anymore. Added Roland's <roland@spinnaker.rhein.de>
554         patch to show a logo instead of a blank area. Added a suggestion
555         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
556         More regexps in the blocklist. Prepared the forwardfile for
557         squid. Extended image regexp with help from gabriel 
558         <somlo@CS.ColoState.EDU>.
559
560 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
561         All RPMs now identify themselves in the show-proxy-args page.
562         Released Windoze version. Run junkbuster as nobody instead of
563         root. 
564
565 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
566         Newest version. First release (hence the little version number
567         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
568         security over 2.0.1; some multi-user sites will need to change 
569         the listen-address in the configuration file. The blank version of
570         the Internet Junkbuster has a more sophisticated way of replacing
571         images. All RPMs identify themselves in the show-proxy-args page.
572
573 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
574         Modified the blocking feature, so that only GIFs and JPEGs are
575         blocked and replaced but not HTML pages. Thanks to 
576         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
577         idea. Added numerous stuff to the blocklist. Keep patches in
578         seperate files and no longer in diffs (easier to maintain).
579
580 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
581         Moved config files to /etc/junkbuster directory, moved man page,
582         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
583         Made new version junkbuster-raw (which is only a stripped version of 
584         the junkuster rpm, i.e. without my blocklist, etc.)
585
586 * Tue Jun 16 1998 (2.0-1)
587         Uhm, not that much. Just a new junkbuster version that
588         fixes a couple of bugs ... and of course a bigger 
589         blocklist with the unique Now-less-ads-than-ever(SM)
590         feature.
591         Oh, one thing: I changed the default user agent to Linux -- no 
592         need anymore to support Apple.
593
594 * Tue Jun 16 1998 (2.0-0)
595         Now-less-ads-than-ever (SM)
596         compiled with gcc instead of cc
597         compiled with -O3, thus it should be a little faster
598         show-proxy-args now works
599         /etc/junkbuster.init wasn't necessary
600
601 * Tue Jun 16 1998 (1.4)
602         some more config files were put into /etc
603         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
604         displayed by Netscape instead of the blocked image.
605         Read http://www.waldherr.org/junkbuster/ for
606         further info.
607
608 * Tue Jun 16 1998 (1.3)
609         The program has been moved to /usr/sbin (from /usr/local/bin)
610         Init- and stopscripts (/etc/rc.d/rc*) have been added so
611         that the junkbuster starts automatically during bootup.
612         The /etc/blocklist file is much more sophisticated. Theoretically
613         one should e.g. browse all major US and German newspapers without
614         seeing one annoying ad.
615         junkbuster.init was modified. It now starts junkbuster with an
616         additional "-r @" flag.
617
618 # $Log: privoxy-rh.spec,v $
619 # Revision 1.26  2002/04/22 16:24:36  morcego
620 # - Changes to fixate the uid and gid values as (both) 73. This is a
621 #   value we hope to standarize for all distributions. RedHat already
622 #   uses it, and Conectiva should start as soon as I find where the heck
623 #   I left my cluebat :-)
624 # - Only remove the user and group on uninstall if this is not redhat, once
625 #   redhat likes to have the values allocated even if the package is not
626 #   installed
627 #
628 # Revision 1.25  2002/04/17 01:59:12  hal9
629 # Add --disable-dynamic-pcre.
630 #
631 # Revision 1.24  2002/04/11 10:09:20  oes
632 # Version 2.9.14
633 #
634 # Revision 1.23  2002/04/10 18:14:45  morcego
635 # - (privoxy-rh.spec only) Relisting template files on the %%files section
636 # - (configure.in, privoxy-rh.spec) Bumped package release to 5
637 #
638 # Revision 1.22  2002/04/09 22:06:12  hal9
639 # Remove 'make dok'.
640 #
641 # Revision 1.21  2002/04/09 02:52:26  hal9
642 # - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
643 # - Remove templates/blocked-compact.
644 # - Add more docbook stuff to Buildrequires.
645 #
646 # Revision 1.20  2002/04/08 20:27:45  swa
647 # fixed JB spelling
648 #
649 # Revision 1.19  2002/03/27 22:44:59  sarantis
650 # Include correct documentation file.
651 #
652 # Revision 1.18  2002/03/27 22:10:14  sarantis
653 # bumped Hal's last commit 1 day to the future to make rpm build again.
654 #
655 # Revision 1.17  2002/03/27 00:48:23  hal9
656 # Fix up descrition.
657 #
658 # Revision 1.16  2002/03/26 22:29:55  swa
659 # we have a new homepage!
660 #
661 # Revision 1.15  2002/03/26 17:39:54  morcego
662 # Adding comment on the specfile to remember the packager to update
663 # the release number on the configure script
664 #
665 # Revision 1.14  2002/03/26 14:25:15  hal9
666 # Added edit-actions-for-url-filter to templates in %%config
667 #
668 # Revision 1.13  2002/03/25 13:31:04  morcego
669 # Bumping Release tag.
670 #
671 # Revision 1.12  2002/03/25 03:11:40  hal9
672 # Do it right way this time :/
673 #
674 # Revision 1.11  2002/03/25 03:09:51  hal9
675 # Added faq to docs.
676 #
677 # Revision 1.10  2002/03/24 22:16:14  morcego
678 # Just removing some old commentaries.
679 #
680 # Revision 1.9  2002/03/24 22:03:22  morcego
681 # Should be working now. See %changelog for details
682 #
683 # Revision 1.8  2002/03/24 21:13:01  morcego
684 # Tis broken.
685 #
686 # Revision 1.7  2002/03/24 21:07:18  hal9
687 # Add autoheader, etc.
688 #
689 # Revision 1.6  2002/03/24 19:56:40  hal9
690 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
691 #
692 # Revision 1.4  2002/03/24 13:32:42  swa
693 # name change related issues
694 #
695 # Revision 1.3  2002/03/24 12:56:21  swa
696 # name change related issues.
697 #
698 # Revision 1.2  2002/03/24 11:40:14  swa
699 # name change
700 #
701 # Revision 1.1  2002/03/24 11:23:44  swa
702 # name change
703 #
704 # Revision 1.1  2002/03/22 20:53:03  morcego
705 # - Ongoing process to change name to JunkbusterNG
706 # - configure/configure.in: no change needed
707 # - GNUmakefile.in:
708 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
709 #         - PROGRAM    = jbng@EXEEXT@
710 #         - rh-spec now references as junkbusterng-rh.spec
711 #         - redhat-upload: references changed to junkbusterng-* (package names)
712 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
713 #         - tarball-src: now JunkbusterNG-*
714 #         - install: initscript now junkbusterng.init and junkbusterng (when
715 #                    installed)
716 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
717 # - junkbusterng.spec:
718 #         - References to the expression ijb where changed where possible
719 #         - New package name: junkbusterng (all in lower case, acording to
720 #           the LSB recomendation)
721 #         - Version changed to: 2.9.13
722 #         - Release: 1
723 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
724 #           right. If it obsoletes, why conflict ? Have to check it later)
725 #         - Summary changed: Stefan, please check and aprove it
726 #         - Changes description to use the new name
727 #         - Sed string was NOT changed. Have to wait to the manpage to
728 #           change first
729 #         - Keeping the user junkbuster for now. It will require some aditional
730 #           changes on the script (scheduled for the next specfile release)
731 #         - Added post entry to move the old logfile to the new log directory
732 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
733 #           added to the startup list).
734 #         - Added preun section to stop the service with the old name, as well
735 #           as remove it from the startup list
736 #         - Removed the chkconfig --del entry from the conditional block on
737 #           the preun scriptlet (now handled on the %files section)
738 # - junkbuster.init: renamed to junkbusterng.init
739 # - junkbusterng.init:
740 #         - Changed JB_BIN to jbng
741 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
742 #           be used where necessary (config dir)
743 #
744 # Aditional notes:
745 # - The config directory is /etc/junkbuster yet. Have to change it on the
746 # specfile, after it is changes on the code
747 # - The only files that got renamed on the cvs tree were the rh specfile and
748 # the init file. Some file references got changes on the makefile and on the
749 # rh-spec (as listed above)
750 #
751 # Revision 1.43  2002/03/21 16:04:10  hal9
752 # added ijb_docs.css to %doc
753 #
754 # Revision 1.42  2002/03/12 13:41:18  sarantis
755 # remove hard-coded "ijbswa" string in build phase
756 #
757 # Revision 1.41  2002/03/11 22:58:32  hal9
758 # Remove --enable-no-gifs
759 #
760 # Revision 1.39  2002/03/08 18:57:29  swa
761 # remove user junkbuster after de-installation.
762 #
763 # Revision 1.38  2002/03/08 13:45:27  morcego
764 # Adding libtool to Buildrequires
765 #
766 # Revision 1.37  2002/03/07 19:23:49  swa
767 # i hate to scroll. suse: wrong configdir.
768 #
769 # Revision 1.36  2002/03/07 05:06:54  morcego
770 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
771 #
772 # Revision 1.34  2002/03/07 00:11:57  morcego
773 # Few changes on the %pre and %post sections of the rh specfile to handle
774 # usernames more cleanly
775 #
776 # Revision 1.33  2002/03/05 13:13:57  morcego
777 # - Added "make redhat-dok" to the build phase
778 # - Added docbook-utils to BuildRequires
779 #
780 # Revision 1.32  2002/03/05 12:34:24  morcego
781 # - Changing section internaly on the manpage from 1 to 8
782 # - We now require packages, not files, to avoid issues with apt
783 #
784 # Revision 1.31  2002/03/04 18:06:09  morcego
785 # SPECFILE: fixing permissing of the init script (broken by the last change)
786 #
787 # Revision 1.30  2002/03/04 16:18:03  morcego
788 # General cleanup of the rh specfile.
789 #
790 # %changelog
791 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
792 # + junkbuster-2.9.11-2
793 # - General specfile fixup, using the best recomended practices, including:
794 #         - Adding -q to %%setup
795 #         - Using macros whereever possible
796 #         - Not using wildchars on %%files section
797 #         - Doubling the percentage char on changelog and comments, to
798 #           avoid rpm expanding them
799 #
800 # Revision 1.29  2002/03/03 19:21:22  hal9
801 # Init script fails if shell is /bin/false.
802 #
803 # Revision 1.28  2002/01/09 18:34:03  hal9
804 # nit.
805 #
806 # Revision 1.27  2002/01/09 18:32:02  hal9
807 # Removed RPM_OPT_FLAGS kludge.
808 #
809 # Revision 1.26  2002/01/09 18:21:10  hal9
810 # A few minor updates.
811 #
812 # Revision 1.25  2001/12/28 01:45:36  steudten
813 # Add paranoia check and BuildReq: gzip
814 #
815 # Revision 1.24  2001/12/01 21:43:14  hal9
816 # Allowed for new ijb.action file.
817 #
818 # Revision 1.23  2001/11/06 12:09:03  steudten
819 # Compress doc files. Install README and AUTHORS at last as document.
820 #
821 # Revision 1.22  2001/11/05 21:37:34  steudten
822 # Fix to include the actual version for name.
823 # Let the 'real' packager be included - sorry stefan.
824 #
825 # Revision 1.21  2001/10/31 19:27:27  swa
826 # consistent description. new name for suse since
827 # we had troubles with rpms of identical names
828 # on the webserver.
829 #
830 # Revision 1.20  2001/10/24 15:45:49  hal9
831 # To keep Thomas happy (aka correcting my  mistakes)
832 #
833 # Revision 1.19  2001/10/15 03:23:59  hal9
834 # Nits.
835 #
836 # Revision 1.17  2001/10/10 18:59:28  hal9
837 # Minor change for init script.
838 #
839 # Revision 1.16  2001/09/24 20:56:23  hal9
840 # Minor changes.
841 #
842 # Revision 1.13  2001/09/10 17:44:43  swa
843 # integrate three pieces of documentation. needs work.
844 # will not build cleanly under redhat.
845 #
846 # Revision 1.12  2001/09/10 16:25:04  swa
847 # copy all templates. version updated.
848 #
849 # Revision 1.11  2001/07/03 11:00:25  sarantis
850 # replaced permissionsfile with actionsfile
851 #
852 # Revision 1.10  2001/07/03 09:34:44  sarantis
853 # bumped up version number.
854 #
855 # Revision 1.9  2001/06/12 18:15:29  swa
856 # the %% in front of configure (see tag below) confused
857 # the rpm build process on 7.1.
858 #
859 # Revision 1.8  2001/06/12 17:15:56  swa
860 # fixes, because a clean build on rh6.1 was impossible.
861 # GZIP confuses make, %% configure confuses rpm, etc.
862 #
863 # Revision 1.7  2001/06/11 12:17:26  sarantis
864 # fix typo in %%post
865 #
866 # Revision 1.6  2001/06/11 11:28:25  sarantis
867 # Further optimizations and adaptations in the spec file.
868 #
869 # Revision 1.5  2001/06/09 09:14:11  swa
870 # shamelessly adapted RPM stuff from the newest rpm that
871 # RedHat provided for the JB.
872 #
873 # Revision 1.4  2001/06/08 20:54:18  swa
874 # type with status file. remove forward et. al from file list.
875 #
876 # Revision 1.3  2001/06/07 17:28:10  swa
877 # cosmetics
878 #
879 # Revision 1.2  2001/06/04 18:31:58  swa
880 # files are now prefixed with either `confdir' or `logdir'.
881 # `make redhat-dist' replaces both entries confdir and logdir
882 # with redhat values
883 #
884 # Revision 1.1  2001/06/04 10:44:57  swa
885 # `make redhatr-dist' now works. Except for the paths
886 # in the config file.
887 #
888 #
889 #