we have a new homepage!
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.15 2002/03/26 17:39:54 morcego Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33
34 Name: privoxy
35 # ATTENTION
36 # Version and release should be updated acordingly on configure.in and
37 # configure. Otherwise, the package can be build with the wrong value
38 Version: 2.9.13
39 Release: 3
40 Summary: Privoxy - privacy enhancing proxy
41 License: GPL
42 Vendor: http://www.privoxy.org
43 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
44 BuildRoot: %{_tmppath}/%{name}-%{version}-root
45 Group: Networking/Utilities
46 URL: http://www.privoxy.org/
47 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
48 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
49 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
50 BuildRequires: perl gzip sed docbook-utils libtool autoconf
51 Conflicts: junkbuster-raw junkbuster-blank junkbuster
52
53 %description 
54 Privoxy is a web proxy with advanced filtering capabilities for
55 protecting privacy, filtering web page content, managing cookies,
56 controlling access, and removing ads, banners, pop-ups and other
57 obnoxious Internet junk. Privoxy has a very flexible configuration and
58 can be customized to suit individual needs and tastes. Internet
59 Privoxy has application for both stand-alone systems and multi-user
60 networks.
61
62 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
63 was originally written by JunkBusters Corporation, and was released as
64 free open-source software under the GNU GPL. Stefan Waldherr made many
65 improvements, and started the SourceForge project to continue
66 development. Several other developers are now contributing.
67
68 %prep
69 %setup -q -c
70
71 %build
72 autoheader
73 autoconf
74 %configure
75 make 
76 make redhat-dok
77
78 ## Explicitily stripping is not recomended.
79 ## This is handled altomaticaly by RPM, and can couse troubles if
80 ## anyone wants to build an unstriped version - morcego
81 #strip %{name}
82
83 %install
84 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
85 mkdir -p %{buildroot}%{_sbindir} \
86          %{buildroot}%{_mandir}/man1 \
87          %{buildroot}%{_localstatedir}/log/%{name} \
88          %{buildroot}%{privoxyconf}/templates \
89          %{buildroot}%{_sysconfdir}/logrotate.d \
90          %{buildroot}%{_sysconfdir}/rc.d/init.d 
91
92 ## Manual gziping of manpages should not be done, once it can
93 ## break the building on some distributions. Anyway, rpm does it
94 ## automagicaly these days
95 ## Gziping the documentation files is not recomended - morcego
96 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
97
98 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
99
100 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
101 cp -f *.action %{buildroot}%{privoxyconf}/
102 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
103 cp -f trust %{buildroot}%{privoxyconf}/trust
104 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
105 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
106 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
107 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
108
109 # verify all file locations, etc. in the config file
110 # don't start with ^ or commented lines are not replaced
111 ## Changing the sed paramter delimiter to @, so we don't have to
112 ## escape the slashes
113 cat config | \
114     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
115 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
116 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
117 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
118 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
119 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
120 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
121     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
122     %{buildroot}%{privoxyconf}/config
123 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
124     %{buildroot}%{privoxyconf}/default.action
125
126
127 # Creating ghost init files
128 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
129 for i in 0 1 4 6
130 do
131 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
132 done
133 for i in 2 3 5
134 do
135 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
136 done
137
138 ## Macros are expanded even on commentaries. So, we have to use %%
139 ## -- morcego
140 #%%makeinstall
141
142 %pre
143 # This is where we handle old usernames (junkbust and junkbuster)
144 # I'm not sure we should do that, but this is the way we have been
145 # doing it for some time now -- morcego
146 # We should do it for the group as well -- morcego
147 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
148
149 # Change the group name. Remove anything left behind.
150 groupmod -n %{name} %{oldname} > /dev/null 2>&1 ||:
151 groupmod -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
152 groupdel %{oldname} > /dev/null 2>&1 ||:
153 groupdel %{veryoldname} > /dev/null 2>&1 ||:
154
155 # Same for username
156 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
157 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
158 userdel %{oldname} > /dev/null 2>&1 ||:
159 userdel %{veryoldname} > /dev/null 2>&1 ||:
160
161 # Check to see if everything is okey. Create user if it still does not
162 # exist
163 id %{name} > /dev/null 2>&1
164 if [ $? -eq 1 ]; then
165         /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
166 fi
167
168 %post
169 # for upgrade from 2.0.x
170 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
171  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
172 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
173  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
174 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
175 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
176 if [ "$1" = "1" ]; then
177         /sbin/service %{name} condrestart > /dev/null 2>&1
178 fi
179
180 %preun
181 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
182 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
183
184 if [ "$1" = "0" ]; then
185         /sbin/service %{name} stop > /dev/null 2>&1 ||:
186         # No need to use chkconfig. The %%ghost files will handle it
187 fi
188
189 %postun
190 #if [ "$1" -ge "1" ]; then
191 #       /sbin/service %{name} condrestart > /dev/null 2>&1
192 #fi
193 # We only remove it we this is not an upgrade
194 if [ "$1" = "0" ]; then
195         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
196 fi
197
198 %clean
199 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
200
201 %files
202 %defattr(0644,root,root,0755)
203 %doc README AUTHORS ChangeLog
204 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
205 %doc doc/webserver/developer-manual
206 %doc doc/webserver/user-manual
207 %doc doc/webserver/faq
208 %doc doc/webserver/ijb_docs.css
209
210 %dir %{privoxyconf}
211 %dir %{privoxyconf}/templates
212 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
213
214 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
215
216 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
217 # We should not use wildchars here. This could mask missing files problems
218 # -- morcego
219 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
220 %config %{privoxyconf}/config
221 %config %{privoxyconf}/advanced.action
222 %config %{privoxyconf}/basic.action
223 %config %{privoxyconf}/intermediate.action
224 %config %{privoxyconf}/default.action
225 %config %{privoxyconf}/default.filter
226 %config %{privoxyconf}/trust
227
228 %config %{privoxyconf}/templates/blocked
229 %config %{privoxyconf}/templates/blocked-compact
230 %config %{privoxyconf}/templates/cgi-error-404
231 %config %{privoxyconf}/templates/cgi-error-bad-param
232 %config %{privoxyconf}/templates/cgi-error-disabled
233 %config %{privoxyconf}/templates/cgi-error-file
234 %config %{privoxyconf}/templates/cgi-error-modified
235 %config %{privoxyconf}/templates/cgi-error-parse
236 %config %{privoxyconf}/templates/connect-failed
237 %config %{privoxyconf}/templates/default
238 %config %{privoxyconf}/templates/edit-actions-add-url-form
239 %config %{privoxyconf}/templates/edit-actions-for-url
240 %config %{privoxyconf}/templates/edit-actions-list
241 %config %{privoxyconf}/templates/edit-actions-list-section
242 %config %{privoxyconf}/templates/edit-actions-list-url
243 %config %{privoxyconf}/templates/edit-actions-remove-url-form
244 %config %{privoxyconf}/templates/edit-actions-url-form
245 %config %{privoxyconf}/templates/no-such-domain
246 %config %{privoxyconf}/templates/show-request
247 %config %{privoxyconf}/templates/show-status
248 %config %{privoxyconf}/templates/show-status-file
249 %config %{privoxyconf}/templates/show-url-info
250 %config %{privoxyconf}/templates/show-version
251 %config %{privoxyconf}/templates/toggle
252 %config %{privoxyconf}/templates/toggle-mini
253 %config %{privoxyconf}/templates/untrusted
254 %config %{privoxyconf}/templates/edit-actions-for-url-filter
255 %config %{_sysconfdir}/logrotate.d/%{name}
256 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
257 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
258 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
259 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
260 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
261 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
262 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
263 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
264
265 %{_mandir}/man1/%{name}.*
266
267 %changelog
268 * Tue Mar 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
269 + privoxy-2.9.13-3
270 - Added commentary asking to update the release value on the configure
271   script
272
273 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
274 + privoxy-2.9.13-3
275 - Added the missing edit-actions-for-url-filter to templates.
276
277 * Mon Mar 25 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
278 + privoxy-2.9.13-2
279 - Fixing Release number
280
281 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
282 + privoxy-2.9.13-2
283 - Added faq to docs.
284
285 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
286 + privoxy-2.9.13-2
287 - Fixed the init files entries. Now we use %%ghost
288 - improved username (and groupname) handling on the %%pre section. By improved
289   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
290   got it right. No more Mr. Nice Guy.
291 - Removed the userdel call on %%post. No need, once it's complety handled on
292   the %%pre section
293
294 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
295 + junkbusterng-2.9.13-1
296   Added autoheader. Added autoconf to buildrequires.
297
298 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
299 + junkbusterng-2.9.13-1
300 - Fixed build problems re: name conflicts with man page and logrotate.
301 - Commented out rc?d/* configs for time being, which are causing a build 
302 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
303 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
304
305 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
306 + junkbusterng-2.9.13-1
307 - References to the expression ijb where changed where possible
308 - New package name: junkbusterng (all in lower case, acording to
309   the LSB recomendation)
310 - Version changed to: 2.9.13
311 - Release: 1
312 - Added: junkbuster to obsoletes and conflicts (Not sure this is
313   right. If it obsoletes, why conflict ? Have to check it later)
314 - Summary changed: Stefan, please check and aprove it
315 - Changes description to use the new name
316 - Sed string was NOT changed. Have to wait to the manpage to
317   change first
318 - Keeping the user junkbuster for now. It will require some aditional
319   changes on the script (scheduled for the next specfile release)
320 - Added post entry to move the old logfile to the new log directory
321 - Removing "chkconfig --add" entry (not good to have it automaticaly
322   added to the startup list).
323 - Added preun section to stop the service with the old name, as well
324   as remove it from the startup list
325 - Removed the chkconfig --del entry from the conditional block on
326   the preun scriptlet (now handled on the %files section)
327
328 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
329 - added ijb_docs.css to docs.
330
331 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
332 + junkbuster-2.9.11-8 
333 - Take out --enable-no-gifs, breaks some browsers.
334
335 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
336 + junkbuster-2.9.11-8 
337 - Add --enable-no-gifs to configure.
338
339 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
340 + junkbuster-2.9.11-7
341 - Added BuildRequires to libtool.
342
343 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
344 + junkbuster-2.9.11-6
345 - Changed the routined that handle the junkbust and junkbuster users on
346   %%pre and %%post to work in a smoother manner
347 - %%files now uses hardcoded usernames, to avoid problems with package
348   name changes in the future
349
350 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
351 + junkbuster-2.9.11-5
352 - Added "make redhat-dok" to the build process
353 - Added docbook-utils to BuildRequires
354
355 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
356 + junkbuster-2.9.11-4
357 - Changing man section in the manpage from 1 to 8
358 - We now require packages, not files, to avoid issues with apt
359
360 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
361 + junkbuster-2.9.11-3
362 - Fixing permissions of the init script
363
364 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
365 + junkbuster-2.9.11-2
366 - General specfile fixup, using the best recomended practices, including:
367         - Adding -q to %%setup
368         - Using macros whereever possible
369         - Not using wildchars on %%files section
370         - Doubling the percentage char on changelog and comments, to
371           avoid rpm expanding them
372
373 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
374 - /bin/false for shell causes init script to fail. Reverting.
375
376 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
377 - Removed UID 73. Included user-manual and developer-manual in docs.
378   Include other actions files. Default shell is now /bin/false.
379   Userdel user=junkbust. ChangeLog was not zipped. Removed 
380   RPM_OPT_FLAGS kludge.
381
382 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
383 - add paranoia check for 'rm -rf %%{buildroot}'
384 - add gzip to 'BuildRequires'
385
386 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
387 - actionsfile is now ijb.action.
388
389 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
390 - Compress manpage
391 - Add more documents for installation
392 - Add version string to name and source
393
394 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
395 - Back to user 'junkbuster' and fix configure macro.
396
397 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
398 - More changes for user 'junkbust'. Init script had 'junkbuster'.
399
400 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
401 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
402 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
403
404 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
405 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
406 - made sure no default shell exists for user junkbust.
407
408 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
409 - rework of RPM
410
411 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
412 - CLF Logging patch by davep@cyw.uklinux.net
413 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
414
415 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
416 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
417 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
418   numerous fixes and enhancements for Steve's patch.
419 - adamlock@netscape.com (Adam Lock) in the windows version:
420   - Taskbar activity spinner always spins even when logging is
421   turned off (which is the default) - people who don't
422   like the spinner can turn it off from a menu option.
423   - Taskbar popup menu has a options submenu - people can now
424   open the settings files for cookies, blockers etc.
425   without opening the JB window.
426   - Logging functionality works again
427   - Buffer overflow is fixed - new code uses a bigger buffer
428   and snprintf so it shouldn't overflow anymore.
429 - Fixed userid swa, group learning problem while installing.
430   root must build RPM.
431 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
432   core dump when there is no log file.
433 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
434 - Fixed man page to include imagefile and popupfile.
435 - Sanity check for the statistics function added.
436 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
437  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
438  With IIS/5, it appears to omit the trailing \r\n from http header
439  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
440  responds with a HTTP 302 redirect header.  However, this header
441  message is missing the trailing \r\n.  IIS/5 then closes the
442  connection.  Junkbuster, unfortunately, discards the header becomes
443  it thinks it is incomplete - and it is.  MS have transmitted an
444  incomplete header!
445 - Added bug reports and patch submission forms in the docs.
446
447 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
448        Andrew <anw@tirana.freewire.co.uk> extended the JB:
449        Display of statistics of the total number of requests and the number
450        of requests filtered by junkbuster, also the percentage of requests
451        filtered. Suppression of the listing of files on the proxy-args page.
452        All stuff optional and configurable.
453
454 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
455        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
456        code which prevented the JB from handling URLs of the form
457        user:password@www.foo.com. Fixed.
458
459 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
460         Blank images are no longer cached, thanks to a hint from Markus 
461         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
462         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
463         on the correct browser version nowadays. Incorporated many 
464         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
465         spec file. Fixed logging problem and since runlevel 2 does not 
466         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
467         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
468         <walker@netgate.net>. You should now be able to build this RPM as 
469         a non-root user (mathias@weidner.sem.lipsia.de).
470
471 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
472         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
473         to allow more sophisticated matching of blocked images. Logrotate
474         logfile. Added files for auto-updating the blocklist et al.
475
476 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
477         Configure blank version via config file. No separate blank
478         version anymore. Added Roland's <roland@spinnaker.rhein.de>
479         patch to show a logo instead of a blank area. Added a suggestion
480         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
481         More regexps in the blocklist. Prepared the forwardfile for
482         squid. Extended image regexp with help from gabriel 
483         <somlo@CS.ColoState.EDU>.
484
485 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
486         All RPMs now identify themselves in the show-proxy-args page.
487         Released Windoze version. Run junkbuster as nobody instead of
488         root. 
489
490 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
491         Newest version. First release (hence the little version number
492         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
493         security over 2.0.1; some multi-user sites will need to change 
494         the listen-address in the configuration file. The blank version of
495         the Internet Junkbuster has a more sophisticated way of replacing
496         images. All RPMs identify themselves in the show-proxy-args page.
497
498 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
499         Modified the blocking feature, so that only GIFs and JPEGs are
500         blocked and replaced but not HTML pages. Thanks to 
501         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
502         idea. Added numerous stuff to the blocklist. Keep patches in
503         seperate files and no longer in diffs (easier to maintain).
504
505 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
506         Moved config files to /etc/junkbuster directory, moved man page,
507         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
508         Made new version junkbuster-raw (which is only a stripped version of 
509         the junkuster rpm, i.e. without my blocklist, etc.)
510
511 * Tue Jun 16 1998 (2.0-1)
512         Uhm, not that much. Just a new junkbuster version that
513         fixes a couple of bugs ... and of course a bigger 
514         blocklist with the unique Now-less-ads-than-ever(SM)
515         feature.
516         Oh, one thing: I changed the default user agent to Linux -- no 
517         need anymore to support Apple.
518
519 * Tue Jun 16 1998 (2.0-0)
520         Now-less-ads-than-ever (SM)
521         compiled with gcc instead of cc
522         compiled with -O3, thus it should be a little faster
523         show-proxy-args now works
524         /etc/junkbuster.init wasn't necessary
525
526 * Tue Jun 16 1998 (1.4)
527         some more config files were put into /etc
528         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
529         displayed by Netscape instead of the blocked image.
530         Read http://www.waldherr.org/junkbuster/ for
531         further info.
532
533 * Tue Jun 16 1998 (1.3)
534         The program has been moved to /usr/sbin (from /usr/local/bin)
535         Init- and stopscripts (/etc/rc.d/rc*) have been added so
536         that the junkbuster starts automatically during bootup.
537         The /etc/blocklist file is much more sophisticated. Theoretically
538         one should e.g. browse all major US and German newspapers without
539         seeing one annoying ad.
540         junkbuster.init was modified. It now starts junkbuster with an
541         additional "-r @" flag.
542
543 # $Log: privoxy-rh.spec,v $
544 # Revision 1.15  2002/03/26 17:39:54  morcego
545 # Adding comment on the specfile to remember the packager to update
546 # the release number on the configure script
547 #
548 # Revision 1.14  2002/03/26 14:25:15  hal9
549 # Added edit-actions-for-url-filter to templates in %%config
550 #
551 # Revision 1.13  2002/03/25 13:31:04  morcego
552 # Bumping Release tag.
553 #
554 # Revision 1.12  2002/03/25 03:11:40  hal9
555 # Do it right way this time :/
556 #
557 # Revision 1.11  2002/03/25 03:09:51  hal9
558 # Added faq to docs.
559 #
560 # Revision 1.10  2002/03/24 22:16:14  morcego
561 # Just removing some old commentaries.
562 #
563 # Revision 1.9  2002/03/24 22:03:22  morcego
564 # Should be working now. See %changelog for details
565 #
566 # Revision 1.8  2002/03/24 21:13:01  morcego
567 # Tis broken.
568 #
569 # Revision 1.7  2002/03/24 21:07:18  hal9
570 # Add autoheader, etc.
571 #
572 # Revision 1.6  2002/03/24 19:56:40  hal9
573 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
574 #
575 # Revision 1.4  2002/03/24 13:32:42  swa
576 # name change related issues
577 #
578 # Revision 1.3  2002/03/24 12:56:21  swa
579 # name change related issues.
580 #
581 # Revision 1.2  2002/03/24 11:40:14  swa
582 # name change
583 #
584 # Revision 1.1  2002/03/24 11:23:44  swa
585 # name change
586 #
587 # Revision 1.1  2002/03/22 20:53:03  morcego
588 # - Ongoing process to change name to JunkbusterNG
589 # - configure/configure.in: no change needed
590 # - GNUmakefile.in:
591 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
592 #         - PROGRAM    = jbng@EXEEXT@
593 #         - rh-spec now references as junkbusterng-rh.spec
594 #         - redhat-upload: references changed to junkbusterng-* (package names)
595 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
596 #         - tarball-src: now JunkbusterNG-*
597 #         - install: initscript now junkbusterng.init and junkbusterng (when
598 #                    installed)
599 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
600 # - junkbusterng.spec:
601 #         - References to the expression ijb where changed where possible
602 #         - New package name: junkbusterng (all in lower case, acording to
603 #           the LSB recomendation)
604 #         - Version changed to: 2.9.13
605 #         - Release: 1
606 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
607 #           right. If it obsoletes, why conflict ? Have to check it later)
608 #         - Summary changed: Stefan, please check and aprove it
609 #         - Changes description to use the new name
610 #         - Sed string was NOT changed. Have to wait to the manpage to
611 #           change first
612 #         - Keeping the user junkbuster for now. It will require some aditional
613 #           changes on the script (scheduled for the next specfile release)
614 #         - Added post entry to move the old logfile to the new log directory
615 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
616 #           added to the startup list).
617 #         - Added preun section to stop the service with the old name, as well
618 #           as remove it from the startup list
619 #         - Removed the chkconfig --del entry from the conditional block on
620 #           the preun scriptlet (now handled on the %files section)
621 # - junkbuster.init: renamed to junkbusterng.init
622 # - junkbusterng.init:
623 #         - Changed JB_BIN to jbng
624 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
625 #           be used where necessary (config dir)
626 #
627 # Aditional notes:
628 # - The config directory is /etc/junkbuster yet. Have to change it on the
629 # specfile, after it is changes on the code
630 # - The only files that got renamed on the cvs tree were the rh specfile and
631 # the init file. Some file references got changes on the makefile and on the
632 # rh-spec (as listed above)
633 #
634 # Revision 1.43  2002/03/21 16:04:10  hal9
635 # added ijb_docs.css to %doc
636 #
637 # Revision 1.42  2002/03/12 13:41:18  sarantis
638 # remove hard-coded "ijbswa" string in build phase
639 #
640 # Revision 1.41  2002/03/11 22:58:32  hal9
641 # Remove --enable-no-gifs
642 #
643 # Revision 1.39  2002/03/08 18:57:29  swa
644 # remove user junkbuster after de-installation.
645 #
646 # Revision 1.38  2002/03/08 13:45:27  morcego
647 # Adding libtool to Buildrequires
648 #
649 # Revision 1.37  2002/03/07 19:23:49  swa
650 # i hate to scroll. suse: wrong configdir.
651 #
652 # Revision 1.36  2002/03/07 05:06:54  morcego
653 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
654 #
655 # Revision 1.34  2002/03/07 00:11:57  morcego
656 # Few changes on the %pre and %post sections of the rh specfile to handle
657 # usernames more cleanly
658 #
659 # Revision 1.33  2002/03/05 13:13:57  morcego
660 # - Added "make redhat-dok" to the build phase
661 # - Added docbook-utils to BuildRequires
662 #
663 # Revision 1.32  2002/03/05 12:34:24  morcego
664 # - Changing section internaly on the manpage from 1 to 8
665 # - We now require packages, not files, to avoid issues with apt
666 #
667 # Revision 1.31  2002/03/04 18:06:09  morcego
668 # SPECFILE: fixing permissing of the init script (broken by the last change)
669 #
670 # Revision 1.30  2002/03/04 16:18:03  morcego
671 # General cleanup of the rh specfile.
672 #
673 # %changelog
674 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
675 # + junkbuster-2.9.11-2
676 # - General specfile fixup, using the best recomended practices, including:
677 #         - Adding -q to %%setup
678 #         - Using macros whereever possible
679 #         - Not using wildchars on %%files section
680 #         - Doubling the percentage char on changelog and comments, to
681 #           avoid rpm expanding them
682 #
683 # Revision 1.29  2002/03/03 19:21:22  hal9
684 # Init script fails if shell is /bin/false.
685 #
686 # Revision 1.28  2002/01/09 18:34:03  hal9
687 # nit.
688 #
689 # Revision 1.27  2002/01/09 18:32:02  hal9
690 # Removed RPM_OPT_FLAGS kludge.
691 #
692 # Revision 1.26  2002/01/09 18:21:10  hal9
693 # A few minor updates.
694 #
695 # Revision 1.25  2001/12/28 01:45:36  steudten
696 # Add paranoia check and BuildReq: gzip
697 #
698 # Revision 1.24  2001/12/01 21:43:14  hal9
699 # Allowed for new ijb.action file.
700 #
701 # Revision 1.23  2001/11/06 12:09:03  steudten
702 # Compress doc files. Install README and AUTHORS at last as document.
703 #
704 # Revision 1.22  2001/11/05 21:37:34  steudten
705 # Fix to include the actual version for name.
706 # Let the 'real' packager be included - sorry stefan.
707 #
708 # Revision 1.21  2001/10/31 19:27:27  swa
709 # consistent description. new name for suse since
710 # we had troubles with rpms of identical names
711 # on the webserver.
712 #
713 # Revision 1.20  2001/10/24 15:45:49  hal9
714 # To keep Thomas happy (aka correcting my  mistakes)
715 #
716 # Revision 1.19  2001/10/15 03:23:59  hal9
717 # Nits.
718 #
719 # Revision 1.17  2001/10/10 18:59:28  hal9
720 # Minor change for init script.
721 #
722 # Revision 1.16  2001/09/24 20:56:23  hal9
723 # Minor changes.
724 #
725 # Revision 1.13  2001/09/10 17:44:43  swa
726 # integrate three pieces of documentation. needs work.
727 # will not build cleanly under redhat.
728 #
729 # Revision 1.12  2001/09/10 16:25:04  swa
730 # copy all templates. version updated.
731 #
732 # Revision 1.11  2001/07/03 11:00:25  sarantis
733 # replaced permissionsfile with actionsfile
734 #
735 # Revision 1.10  2001/07/03 09:34:44  sarantis
736 # bumped up version number.
737 #
738 # Revision 1.9  2001/06/12 18:15:29  swa
739 # the %% in front of configure (see tag below) confused
740 # the rpm build process on 7.1.
741 #
742 # Revision 1.8  2001/06/12 17:15:56  swa
743 # fixes, because a clean build on rh6.1 was impossible.
744 # GZIP confuses make, %% configure confuses rpm, etc.
745 #
746 # Revision 1.7  2001/06/11 12:17:26  sarantis
747 # fix typo in %%post
748 #
749 # Revision 1.6  2001/06/11 11:28:25  sarantis
750 # Further optimizations and adaptations in the spec file.
751 #
752 # Revision 1.5  2001/06/09 09:14:11  swa
753 # shamelessly adapted RPM stuff from the newest rpm that
754 # RedHat provided for the JB.
755 #
756 # Revision 1.4  2001/06/08 20:54:18  swa
757 # type with status file. remove forward et. al from file list.
758 #
759 # Revision 1.3  2001/06/07 17:28:10  swa
760 # cosmetics
761 #
762 # Revision 1.2  2001/06/04 18:31:58  swa
763 # files are now prefixed with either `confdir' or `logdir'.
764 # `make redhat-dist' replaces both entries confdir and logdir
765 # with redhat values
766 #
767 # Revision 1.1  2001/06/04 10:44:57  swa
768 # `make redhatr-dist' now works. Except for the paths
769 # in the config file.
770 #
771 #
772 #