Should be working now. See %changelog for details
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.8 2002/03/24 21:13:01 morcego Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # PRIVOXY team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33
34 Name: privoxy
35 Version: 2.9.13
36 Release: 2
37 Summary: Privoxy - privacy enhancing proxy
38 License: GPL
39 Vendor: http://ijbswa.sourceforge.net
40 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
41 BuildRoot: %{_tmppath}/%{name}-%{version}-root
42 Group: Networking/Utilities
43 URL: http://ijbswa.sourceforge.net/
44 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
45 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
46 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
47 BuildRequires: perl gzip sed docbook-utils libtool autoconf
48 Conflicts: junkbuster-raw junkbuster-blank junkbuster
49
50 %description 
51 Privoxy is a web proxy with advanced filtering capabilities for
52 protecting privacy, filtering web page content, managing cookies,
53 controlling access, and removing ads, banners, pop-ups and other
54 obnoxious Internet junk. Privoxy has a very flexible configuration and
55 can be customized to suit individual needs and tastes. Internet
56 Privoxy has application for both stand-alone systems and multi-user
57 networks.
58
59 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
60 was originally written by JunkBusters Corporation, and was released as
61 free open-source software under the GNU GPL. Stefan Waldherr made many
62 improvements, and started the SourceForge project to continue
63 development. Several other developers are now contributing.
64
65 %prep
66 %setup -q -c
67
68 %build
69 autoheader
70 autoconf
71 %configure
72 make 
73 make redhat-dok
74
75 ## Explicitily stripping is not recomended.
76 ## This is handled altomaticaly by RPM, and can couse troubles if
77 ## anyone wants to build an unstriped version - morcego
78 #strip %{name}
79
80 %install
81 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
82 mkdir -p %{buildroot}%{_sbindir} \
83          %{buildroot}%{_mandir}/man1 \
84          %{buildroot}%{_localstatedir}/log/%{name} \
85          %{buildroot}%{privoxyconf}/templates \
86          %{buildroot}%{_sysconfdir}/logrotate.d \
87          %{buildroot}%{_sysconfdir}/rc.d/init.d 
88
89 ## Manual gziping of manpages should not be done, once it can
90 ## break the building on some distributions. Anyway, rpm does it
91 ## automagicaly these days
92 ## Gziping the documentation files is not recomended - morcego
93 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
94
95 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
96
97 ## We need to change the man section internaly on the manpage
98 ## -- morcego (sugestion by Hal Burgiss)
99 #cp -f %{name}.1 %{buildroot}%{_mandir}/man8/%{name}.8
100
101 # do we need this???
102 #sed -e 's@^.TH JUNKBUSTER 1@.TH JUNKBUSTER 8@g' %{oldname}.1 > %{buildroot}%{_mandir}/man8/%{oldname}.8
103 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
104 cp -f *.action %{buildroot}%{privoxyconf}/
105 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
106 cp -f trust %{buildroot}%{privoxyconf}/trust
107 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
108 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
109 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
110 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
111
112 # verify all file locations, etc. in the config file
113 # don't start with ^ or commented lines are not replaced
114 ## Changing the sed paramter delimiter to @, so we don't have to
115 ## escape the slashes
116 cat config | \
117     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
118 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
119 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
120 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
121 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
122 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
123 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
124     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
125     %{buildroot}%{privoxyconf}/config
126 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
127     %{buildroot}%{privoxyconf}/default.action
128
129
130 # Creating ghost init files
131 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
132 for i in 0 1 4 6
133 do
134 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
135 done
136 for i in 2 3 5
137 do
138 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
139 done
140
141 ## Macros are expanded even on commentaries. So, we have to use %%
142 ## -- morcego
143 #%%makeinstall
144
145 %pre
146 # This is where we handle old usernames (junkbust and junkbuster)
147 # I'm not sure we should do that, but this is the way we have been
148 # doing it for some time now -- morcego
149 # We should do it for the group as well -- morcego
150 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
151
152 # Change the group name. Remove anything left behind.
153 groupmod -n %{name} %{oldname} > /dev/null 2>&1 ||:
154 groupmod -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
155 groupdel %{oldname} > /dev/null 2>&1 ||:
156 groupdel %{veryoldname} > /dev/null 2>&1 ||:
157
158 # Same for username
159 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
160 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
161 userdel %{oldname} > /dev/null 2>&1 ||:
162 userdel %{veryoldname} > /dev/null 2>&1 ||:
163
164 # Check to see if everything is okey. Create user if it still does not
165 # exist
166 id %{name} > /dev/null 2>&1
167 if [ $? -eq 1 ]; then
168         /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
169 fi
170
171 %post
172 # for upgrade from 2.0.x
173 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
174  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
175 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
176  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
177 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
178 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
179 if [ "$1" = "1" ]; then
180         /sbin/service %{name} condrestart > /dev/null 2>&1
181 fi
182
183 %preun
184 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
185 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
186
187 if [ "$1" = "0" ]; then
188         /sbin/service %{name} stop > /dev/null 2>&1 ||:
189         # No need to use chkconfig. The %%ghost files will handle it
190 fi
191
192 %postun
193 #if [ "$1" -ge "1" ]; then
194 #       /sbin/service %{name} condrestart > /dev/null 2>&1
195 #fi
196 # We only remove it we this is not an upgrade
197 if [ "$1" = "0" ]; then
198         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
199 fi
200
201 %clean
202 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
203
204 %files
205 %defattr(0644,root,root,0755)
206 %doc README AUTHORS ChangeLog
207 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
208 %doc doc/webserver/developer-manual
209 %doc doc/webserver/user-manual
210 %doc doc/webserver/ijb_docs.css
211
212 %dir %{privoxyconf}
213 %dir %{privoxyconf}/templates
214 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
215
216 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
217
218 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
219 # We should not use wildchars here. This could mask missing files problems
220 # -- morcego
221 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
222 %config %{privoxyconf}/config
223 %config %{privoxyconf}/advanced.action
224 %config %{privoxyconf}/basic.action
225 %config %{privoxyconf}/intermediate.action
226 %config %{privoxyconf}/default.action
227 %config %{privoxyconf}/default.filter
228 %config %{privoxyconf}/trust
229
230 %config %{privoxyconf}/templates/blocked
231 %config %{privoxyconf}/templates/blocked-compact
232 %config %{privoxyconf}/templates/cgi-error-404
233 %config %{privoxyconf}/templates/cgi-error-bad-param
234 %config %{privoxyconf}/templates/cgi-error-disabled
235 %config %{privoxyconf}/templates/cgi-error-file
236 %config %{privoxyconf}/templates/cgi-error-modified
237 %config %{privoxyconf}/templates/cgi-error-parse
238 %config %{privoxyconf}/templates/connect-failed
239 %config %{privoxyconf}/templates/default
240 %config %{privoxyconf}/templates/edit-actions-add-url-form
241 %config %{privoxyconf}/templates/edit-actions-for-url
242 %config %{privoxyconf}/templates/edit-actions-list
243 %config %{privoxyconf}/templates/edit-actions-list-section
244 %config %{privoxyconf}/templates/edit-actions-list-url
245 %config %{privoxyconf}/templates/edit-actions-remove-url-form
246 %config %{privoxyconf}/templates/edit-actions-url-form
247 %config %{privoxyconf}/templates/no-such-domain
248 %config %{privoxyconf}/templates/show-request
249 %config %{privoxyconf}/templates/show-status
250 %config %{privoxyconf}/templates/show-status-file
251 %config %{privoxyconf}/templates/show-url-info
252 %config %{privoxyconf}/templates/show-version
253 %config %{privoxyconf}/templates/toggle
254 %config %{privoxyconf}/templates/toggle-mini
255 %config %{privoxyconf}/templates/untrusted
256
257 %config %{_sysconfdir}/logrotate.d/%{name}
258 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
259 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
260 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
261 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
262 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
263 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
264 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
265 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
266
267 %{_mandir}/man1/%{name}.*
268
269 %changelog
270 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
271 + privoxy-2.9.13-2
272 - Fixed the init files entries. Now we use %%ghost
273 - improved username (and groupname) handling on the %%pre section. By improved
274   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
275   got it right. No more Mr. Nice Guy.
276 - Removed the userdel call on %%post. No need, once it's complety handled on
277   the %%pre section
278
279 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
280 + junkbusterng-2.9.13-1
281   Added autoheader. Added autoconf to buildrequires.
282
283 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
284 + junkbusterng-2.9.13-1
285 - Fixed build problems re: name conflicts with man page and logrotate.
286 - Commented out rc?d/* configs for time being, which are causing a build 
287 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
288 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
289
290 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
291 + junkbusterng-2.9.13-1
292 - References to the expression ijb where changed where possible
293 - New package name: junkbusterng (all in lower case, acording to
294   the LSB recomendation)
295 - Version changed to: 2.9.13
296 - Release: 1
297 - Added: junkbuster to obsoletes and conflicts (Not sure this is
298   right. If it obsoletes, why conflict ? Have to check it later)
299 - Summary changed: Stefan, please check and aprove it
300 - Changes description to use the new name
301 - Sed string was NOT changed. Have to wait to the manpage to
302   change first
303 - Keeping the user junkbuster for now. It will require some aditional
304   changes on the script (scheduled for the next specfile release)
305 - Added post entry to move the old logfile to the new log directory
306 - Removing "chkconfig --add" entry (not good to have it automaticaly
307   added to the startup list).
308 - Added preun section to stop the service with the old name, as well
309   as remove it from the startup list
310 - Removed the chkconfig --del entry from the conditional block on
311   the preun scriptlet (now handled on the %files section)
312
313 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
314 - added ijb_docs.css to docs.
315
316 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
317 + junkbuster-2.9.11-8 
318 - Take out --enable-no-gifs, breaks some browsers.
319
320 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
321 + junkbuster-2.9.11-8 
322 - Add --enable-no-gifs to configure.
323
324 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
325 + junkbuster-2.9.11-7
326 - Added BuildRequires to libtool.
327
328 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
329 + junkbuster-2.9.11-6
330 - Changed the routined that handle the junkbust and junkbuster users on
331   %%pre and %%post to work in a smoother manner
332 - %%files now uses hardcoded usernames, to avoid problems with package
333   name changes in the future
334
335 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
336 + junkbuster-2.9.11-5
337 - Added "make redhat-dok" to the build process
338 - Added docbook-utils to BuildRequires
339
340 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
341 + junkbuster-2.9.11-4
342 - Changing man section in the manpage from 1 to 8
343 - We now require packages, not files, to avoid issues with apt
344
345 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
346 + junkbuster-2.9.11-3
347 - Fixing permissions of the init script
348
349 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
350 + junkbuster-2.9.11-2
351 - General specfile fixup, using the best recomended practices, including:
352         - Adding -q to %%setup
353         - Using macros whereever possible
354         - Not using wildchars on %%files section
355         - Doubling the percentage char on changelog and comments, to
356           avoid rpm expanding them
357
358 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
359 - /bin/false for shell causes init script to fail. Reverting.
360
361 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
362 - Removed UID 73. Included user-manual and developer-manual in docs.
363   Include other actions files. Default shell is now /bin/false.
364   Userdel user=junkbust. ChangeLog was not zipped. Removed 
365   RPM_OPT_FLAGS kludge.
366
367 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
368 - add paranoia check for 'rm -rf %%{buildroot}'
369 - add gzip to 'BuildRequires'
370
371 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
372 - actionsfile is now ijb.action.
373
374 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
375 - Compress manpage
376 - Add more documents for installation
377 - Add version string to name and source
378
379 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
380 - Back to user 'junkbuster' and fix configure macro.
381
382 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
383 - More changes for user 'junkbust'. Init script had 'junkbuster'.
384
385 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
386 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
387 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
388
389 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
390 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
391 - made sure no default shell exists for user junkbust.
392
393 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
394 - rework of RPM
395
396 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
397 - CLF Logging patch by davep@cyw.uklinux.net
398 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
399
400 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
401 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
402 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
403   numerous fixes and enhancements for Steve's patch.
404 - adamlock@netscape.com (Adam Lock) in the windows version:
405   - Taskbar activity spinner always spins even when logging is
406   turned off (which is the default) - people who don't
407   like the spinner can turn it off from a menu option.
408   - Taskbar popup menu has a options submenu - people can now
409   open the settings files for cookies, blockers etc.
410   without opening the JB window.
411   - Logging functionality works again
412   - Buffer overflow is fixed - new code uses a bigger buffer
413   and snprintf so it shouldn't overflow anymore.
414 - Fixed userid swa, group learning problem while installing.
415   root must build RPM.
416 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
417   core dump when there is no log file.
418 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
419 - Fixed man page to include imagefile and popupfile.
420 - Sanity check for the statistics function added.
421 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
422  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
423  With IIS/5, it appears to omit the trailing \r\n from http header
424  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
425  responds with a HTTP 302 redirect header.  However, this header
426  message is missing the trailing \r\n.  IIS/5 then closes the
427  connection.  Junkbuster, unfortunately, discards the header becomes
428  it thinks it is incomplete - and it is.  MS have transmitted an
429  incomplete header!
430 - Added bug reports and patch submission forms in the docs.
431
432 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
433        Andrew <anw@tirana.freewire.co.uk> extended the JB:
434        Display of statistics of the total number of requests and the number
435        of requests filtered by junkbuster, also the percentage of requests
436        filtered. Suppression of the listing of files on the proxy-args page.
437        All stuff optional and configurable.
438
439 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
440        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
441        code which prevented the JB from handling URLs of the form
442        user:password@www.foo.com. Fixed.
443
444 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
445         Blank images are no longer cached, thanks to a hint from Markus 
446         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
447         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
448         on the correct browser version nowadays. Incorporated many 
449         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
450         spec file. Fixed logging problem and since runlevel 2 does not 
451         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
452         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
453         <walker@netgate.net>. You should now be able to build this RPM as 
454         a non-root user (mathias@weidner.sem.lipsia.de).
455
456 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
457         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
458         to allow more sophisticated matching of blocked images. Logrotate
459         logfile. Added files for auto-updating the blocklist et al.
460
461 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
462         Configure blank version via config file. No separate blank
463         version anymore. Added Roland's <roland@spinnaker.rhein.de>
464         patch to show a logo instead of a blank area. Added a suggestion
465         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
466         More regexps in the blocklist. Prepared the forwardfile for
467         squid. Extended image regexp with help from gabriel 
468         <somlo@CS.ColoState.EDU>.
469
470 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
471         All RPMs now identify themselves in the show-proxy-args page.
472         Released Windoze version. Run junkbuster as nobody instead of
473         root. 
474
475 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
476         Newest version. First release (hence the little version number
477         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
478         security over 2.0.1; some multi-user sites will need to change 
479         the listen-address in the configuration file. The blank version of
480         the Internet Junkbuster has a more sophisticated way of replacing
481         images. All RPMs identify themselves in the show-proxy-args page.
482
483 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
484         Modified the blocking feature, so that only GIFs and JPEGs are
485         blocked and replaced but not HTML pages. Thanks to 
486         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
487         idea. Added numerous stuff to the blocklist. Keep patches in
488         seperate files and no longer in diffs (easier to maintain).
489
490 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
491         Moved config files to /etc/junkbuster directory, moved man page,
492         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
493         Made new version junkbuster-raw (which is only a stripped version of 
494         the junkuster rpm, i.e. without my blocklist, etc.)
495
496 * Tue Jun 16 1998 (2.0-1)
497         Uhm, not that much. Just a new junkbuster version that
498         fixes a couple of bugs ... and of course a bigger 
499         blocklist with the unique Now-less-ads-than-ever(SM)
500         feature.
501         Oh, one thing: I changed the default user agent to Linux -- no 
502         need anymore to support Apple.
503
504 * Tue Jun 16 1998 (2.0-0)
505         Now-less-ads-than-ever (SM)
506         compiled with gcc instead of cc
507         compiled with -O3, thus it should be a little faster
508         show-proxy-args now works
509         /etc/junkbuster.init wasn't necessary
510
511 * Tue Jun 16 1998 (1.4)
512         some more config files were put into /etc
513         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
514         displayed by Netscape instead of the blocked image.
515         Read http://www.waldherr.org/junkbuster/ for
516         further info.
517
518 * Tue Jun 16 1998 (1.3)
519         The program has been moved to /usr/sbin (from /usr/local/bin)
520         Init- and stopscripts (/etc/rc.d/rc*) have been added so
521         that the junkbuster starts automatically during bootup.
522         The /etc/blocklist file is much more sophisticated. Theoretically
523         one should e.g. browse all major US and German newspapers without
524         seeing one annoying ad.
525         junkbuster.init was modified. It now starts junkbuster with an
526         additional "-r @" flag.
527
528 # $Log: privoxy-rh.spec,v $
529 # Revision 1.8  2002/03/24 21:13:01  morcego
530 # Tis broken.
531 #
532 # Revision 1.7  2002/03/24 21:07:18  hal9
533 # Add autoheader, etc.
534 #
535 # Revision 1.6  2002/03/24 19:56:40  hal9
536 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
537 #
538 # Revision 1.4  2002/03/24 13:32:42  swa
539 # name change related issues
540 #
541 # Revision 1.3  2002/03/24 12:56:21  swa
542 # name change related issues.
543 #
544 # Revision 1.2  2002/03/24 11:40:14  swa
545 # name change
546 #
547 # Revision 1.1  2002/03/24 11:23:44  swa
548 # name change
549 #
550 # Revision 1.1  2002/03/22 20:53:03  morcego
551 # - Ongoing process to change name to JunkbusterNG
552 # - configure/configure.in: no change needed
553 # - GNUmakefile.in:
554 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
555 #         - PROGRAM    = jbng@EXEEXT@
556 #         - rh-spec now references as junkbusterng-rh.spec
557 #         - redhat-upload: references changed to junkbusterng-* (package names)
558 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
559 #         - tarball-src: now JunkbusterNG-*
560 #         - install: initscript now junkbusterng.init and junkbusterng (when
561 #                    installed)
562 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
563 # - junkbusterng.spec:
564 #         - References to the expression ijb where changed where possible
565 #         - New package name: junkbusterng (all in lower case, acording to
566 #           the LSB recomendation)
567 #         - Version changed to: 2.9.13
568 #         - Release: 1
569 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
570 #           right. If it obsoletes, why conflict ? Have to check it later)
571 #         - Summary changed: Stefan, please check and aprove it
572 #         - Changes description to use the new name
573 #         - Sed string was NOT changed. Have to wait to the manpage to
574 #           change first
575 #         - Keeping the user junkbuster for now. It will require some aditional
576 #           changes on the script (scheduled for the next specfile release)
577 #         - Added post entry to move the old logfile to the new log directory
578 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
579 #           added to the startup list).
580 #         - Added preun section to stop the service with the old name, as well
581 #           as remove it from the startup list
582 #         - Removed the chkconfig --del entry from the conditional block on
583 #           the preun scriptlet (now handled on the %files section)
584 # - junkbuster.init: renamed to junkbusterng.init
585 # - junkbusterng.init:
586 #         - Changed JB_BIN to jbng
587 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
588 #           be used where necessary (config dir)
589 #
590 # Aditional notes:
591 # - The config directory is /etc/junkbuster yet. Have to change it on the
592 # specfile, after it is changes on the code
593 # - The only files that got renamed on the cvs tree were the rh specfile and
594 # the init file. Some file references got changes on the makefile and on the
595 # rh-spec (as listed above)
596 #
597 # Revision 1.43  2002/03/21 16:04:10  hal9
598 # added ijb_docs.css to %doc
599 #
600 # Revision 1.42  2002/03/12 13:41:18  sarantis
601 # remove hard-coded "ijbswa" string in build phase
602 #
603 # Revision 1.41  2002/03/11 22:58:32  hal9
604 # Remove --enable-no-gifs
605 #
606 # Revision 1.39  2002/03/08 18:57:29  swa
607 # remove user junkbuster after de-installation.
608 #
609 # Revision 1.38  2002/03/08 13:45:27  morcego
610 # Adding libtool to Buildrequires
611 #
612 # Revision 1.37  2002/03/07 19:23:49  swa
613 # i hate to scroll. suse: wrong configdir.
614 #
615 # Revision 1.36  2002/03/07 05:06:54  morcego
616 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
617 #
618 # Revision 1.34  2002/03/07 00:11:57  morcego
619 # Few changes on the %pre and %post sections of the rh specfile to handle
620 # usernames more cleanly
621 #
622 # Revision 1.33  2002/03/05 13:13:57  morcego
623 # - Added "make redhat-dok" to the build phase
624 # - Added docbook-utils to BuildRequires
625 #
626 # Revision 1.32  2002/03/05 12:34:24  morcego
627 # - Changing section internaly on the manpage from 1 to 8
628 # - We now require packages, not files, to avoid issues with apt
629 #
630 # Revision 1.31  2002/03/04 18:06:09  morcego
631 # SPECFILE: fixing permissing of the init script (broken by the last change)
632 #
633 # Revision 1.30  2002/03/04 16:18:03  morcego
634 # General cleanup of the rh specfile.
635 #
636 # %changelog
637 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
638 # + junkbuster-2.9.11-2
639 # - General specfile fixup, using the best recomended practices, including:
640 #         - Adding -q to %%setup
641 #         - Using macros whereever possible
642 #         - Not using wildchars on %%files section
643 #         - Doubling the percentage char on changelog and comments, to
644 #           avoid rpm expanding them
645 #
646 # Revision 1.29  2002/03/03 19:21:22  hal9
647 # Init script fails if shell is /bin/false.
648 #
649 # Revision 1.28  2002/01/09 18:34:03  hal9
650 # nit.
651 #
652 # Revision 1.27  2002/01/09 18:32:02  hal9
653 # Removed RPM_OPT_FLAGS kludge.
654 #
655 # Revision 1.26  2002/01/09 18:21:10  hal9
656 # A few minor updates.
657 #
658 # Revision 1.25  2001/12/28 01:45:36  steudten
659 # Add paranoia check and BuildReq: gzip
660 #
661 # Revision 1.24  2001/12/01 21:43:14  hal9
662 # Allowed for new ijb.action file.
663 #
664 # Revision 1.23  2001/11/06 12:09:03  steudten
665 # Compress doc files. Install README and AUTHORS at last as document.
666 #
667 # Revision 1.22  2001/11/05 21:37:34  steudten
668 # Fix to include the actual version for name.
669 # Let the 'real' packager be included - sorry stefan.
670 #
671 # Revision 1.21  2001/10/31 19:27:27  swa
672 # consistent description. new name for suse since
673 # we had troubles with rpms of identical names
674 # on the webserver.
675 #
676 # Revision 1.20  2001/10/24 15:45:49  hal9
677 # To keep Thomas happy (aka correcting my  mistakes)
678 #
679 # Revision 1.19  2001/10/15 03:23:59  hal9
680 # Nits.
681 #
682 # Revision 1.17  2001/10/10 18:59:28  hal9
683 # Minor change for init script.
684 #
685 # Revision 1.16  2001/09/24 20:56:23  hal9
686 # Minor changes.
687 #
688 # Revision 1.13  2001/09/10 17:44:43  swa
689 # integrate three pieces of documentation. needs work.
690 # will not build cleanly under redhat.
691 #
692 # Revision 1.12  2001/09/10 16:25:04  swa
693 # copy all templates. version updated.
694 #
695 # Revision 1.11  2001/07/03 11:00:25  sarantis
696 # replaced permissionsfile with actionsfile
697 #
698 # Revision 1.10  2001/07/03 09:34:44  sarantis
699 # bumped up version number.
700 #
701 # Revision 1.9  2001/06/12 18:15:29  swa
702 # the %% in front of configure (see tag below) confused
703 # the rpm build process on 7.1.
704 #
705 # Revision 1.8  2001/06/12 17:15:56  swa
706 # fixes, because a clean build on rh6.1 was impossible.
707 # GZIP confuses make, %% configure confuses rpm, etc.
708 #
709 # Revision 1.7  2001/06/11 12:17:26  sarantis
710 # fix typo in %%post
711 #
712 # Revision 1.6  2001/06/11 11:28:25  sarantis
713 # Further optimizations and adaptations in the spec file.
714 #
715 # Revision 1.5  2001/06/09 09:14:11  swa
716 # shamelessly adapted RPM stuff from the newest rpm that
717 # RedHat provided for the JB.
718 #
719 # Revision 1.4  2001/06/08 20:54:18  swa
720 # type with status file. remove forward et. al from file list.
721 #
722 # Revision 1.3  2001/06/07 17:28:10  swa
723 # cosmetics
724 #
725 # Revision 1.2  2001/06/04 18:31:58  swa
726 # files are now prefixed with either `confdir' or `logdir'.
727 # `make redhat-dist' replaces both entries confdir and logdir
728 # with redhat values
729 #
730 # Revision 1.1  2001/06/04 10:44:57  swa
731 # `make redhatr-dist' now works. Except for the paths
732 # in the config file.
733 #
734 #
735 #