Remove 'make dok'.
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.21 2002/04/09 02:52:26 hal9 Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33
34 Name: privoxy
35 # ATTENTION
36 # Version and release should be updated acordingly on configure.in and
37 # configure. Otherwise, the package can be build with the wrong value
38 Version: 2.9.13
39 Release: 4
40 Summary: Privoxy - privacy enhancing proxy
41 License: GPL
42 Vendor: http://www.privoxy.org
43 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
44 BuildRoot: %{_tmppath}/%{name}-%{version}-root
45 Group: Networking/Utilities
46 URL: http://www.privoxy.org/
47 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
48 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
49 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
50 BuildRequires: perl gzip sed libtool autoconf 
51 Conflicts: junkbuster-raw junkbuster-blank junkbuster
52
53 %description 
54 Privoxy is a web proxy with advanced filtering capabilities for
55 protecting privacy, filtering web page content, managing cookies,
56 controlling access, and removing ads, banners, pop-ups and other
57 obnoxious Internet junk. Privoxy has a very flexible configuration and
58 can be customized to suit individual needs and tastes. Privoxy has application
59 for both stand-alone systems and multi-user networks.
60
61 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
62 was originally written by Junkbusters Corporation, and was released as
63 free open-source software under the GNU GPL. Stefan Waldherr made many
64 improvements, and started the SourceForge project to continue
65 development. Several other developers are now contributing.
66
67 %prep
68 %setup -q -c
69
70 %build
71 autoheader
72 autoconf
73 %configure
74 make 
75 # Docs are in CVS and tarball now.
76 #%%make dok
77
78 ## Explicitily stripping is not recomended.
79 ## This is handled altomaticaly by RPM, and can couse troubles if
80 ## anyone wants to build an unstriped version - morcego
81 #strip %{name}
82
83 %install
84 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
85 mkdir -p %{buildroot}%{_sbindir} \
86          %{buildroot}%{_mandir}/man1 \
87          %{buildroot}%{_localstatedir}/log/%{name} \
88          %{buildroot}%{privoxyconf}/templates \
89          %{buildroot}%{_sysconfdir}/logrotate.d \
90          %{buildroot}%{_sysconfdir}/rc.d/init.d 
91
92 ## Manual gziping of manpages should not be done, once it can
93 ## break the building on some distributions. Anyway, rpm does it
94 ## automagicaly these days
95 ## Gziping the documentation files is not recomended - morcego
96 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
97
98 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
99
100 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
101 cp -f *.action %{buildroot}%{privoxyconf}/
102 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
103 cp -f trust %{buildroot}%{privoxyconf}/trust
104 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
105 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
106 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
107 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
108
109 # verify all file locations, etc. in the config file
110 # don't start with ^ or commented lines are not replaced
111 ## Changing the sed paramter delimiter to @, so we don't have to
112 ## escape the slashes
113 cat config | \
114     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
115 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
116 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
117 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
118 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
119 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
120 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
121     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
122     %{buildroot}%{privoxyconf}/config
123 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
124     %{buildroot}%{privoxyconf}/default.action
125
126
127 # Creating ghost init files
128 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
129 for i in 0 1 4 6
130 do
131 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
132 done
133 for i in 2 3 5
134 do
135 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
136 done
137
138 ## Macros are expanded even on commentaries. So, we have to use %%
139 ## -- morcego
140 #%%makeinstall
141
142 %pre
143 # This is where we handle old usernames (junkbust and junkbuster)
144 # I'm not sure we should do that, but this is the way we have been
145 # doing it for some time now -- morcego
146 # We should do it for the group as well -- morcego
147 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
148
149 # Change the group name. Remove anything left behind.
150 groupmod -n %{name} %{oldname} > /dev/null 2>&1 ||:
151 groupmod -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
152 groupdel %{oldname} > /dev/null 2>&1 ||:
153 groupdel %{veryoldname} > /dev/null 2>&1 ||:
154
155 # Same for username
156 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
157 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
158 userdel %{oldname} > /dev/null 2>&1 ||:
159 userdel %{veryoldname} > /dev/null 2>&1 ||:
160
161 # Check to see if everything is okey. Create user if it still does not
162 # exist
163 id %{name} > /dev/null 2>&1
164 if [ $? -eq 1 ]; then
165         /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
166 fi
167
168 %post
169 # for upgrade from 2.0.x
170 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
171  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
172 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
173  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
174 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
175 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
176 if [ "$1" = "1" ]; then
177         /sbin/service %{name} condrestart > /dev/null 2>&1
178 fi
179
180 %preun
181 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
182 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
183
184 if [ "$1" = "0" ]; then
185         /sbin/service %{name} stop > /dev/null 2>&1 ||:
186         # No need to use chkconfig. The %%ghost files will handle it
187 fi
188
189 %postun
190 #if [ "$1" -ge "1" ]; then
191 #       /sbin/service %{name} condrestart > /dev/null 2>&1
192 #fi
193 # We only remove it we this is not an upgrade
194 if [ "$1" = "0" ]; then
195         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
196 fi
197
198 %clean
199 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
200
201 %files
202 %defattr(0644,root,root,0755)
203 %doc README AUTHORS ChangeLog LICENSE 
204 %doc doc/text/developer-manual.txt doc/text/user-manual.txt doc/text/faq.txt
205 %doc doc/webserver/developer-manual
206 %doc doc/webserver/user-manual
207 %doc doc/webserver/faq
208 %doc doc/webserver/p_doc.css doc/webserver/p_web.css doc/webserver/index.html
209
210 %dir %{privoxyconf}
211 %dir %{privoxyconf}/templates
212 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
213
214 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
215
216 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
217 # We should not use wildchars here. This could mask missing files problems
218 # -- morcego
219 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
220 %config %{privoxyconf}/config
221 %config %{privoxyconf}/advanced.action
222 %config %{privoxyconf}/basic.action
223 %config %{privoxyconf}/intermediate.action
224 %config %{privoxyconf}/default.action
225 %config %{privoxyconf}/default.filter
226 %config %{privoxyconf}/trust
227
228 %config %{privoxyconf}/templates/blocked
229 %config %{privoxyconf}/templates/cgi-error-404
230 %config %{privoxyconf}/templates/cgi-error-bad-param
231 %config %{privoxyconf}/templates/cgi-error-disabled
232 %config %{privoxyconf}/templates/cgi-error-file
233 %config %{privoxyconf}/templates/cgi-error-modified
234 %config %{privoxyconf}/templates/cgi-error-parse
235 %config %{privoxyconf}/templates/cgi-style.css
236 %config %{privoxyconf}/templates/connect-failed
237 %config %{privoxyconf}/templates/default
238 %config %{privoxyconf}/templates/edit-actions-add-url-form
239 %config %{privoxyconf}/templates/edit-actions-for-url
240 %config %{privoxyconf}/templates/edit-actions-for-url-filter
241 %config %{privoxyconf}/templates/edit-actions-list
242 %config %{privoxyconf}/templates/edit-actions-list-section
243 %config %{privoxyconf}/templates/edit-actions-list-url
244 %config %{privoxyconf}/templates/edit-actions-remove-url-form
245 %config %{privoxyconf}/templates/edit-actions-url-form
246 %config %{privoxyconf}/templates/no-such-domain
247 %config %{privoxyconf}/templates/show-request
248 %config %{privoxyconf}/templates/show-status
249 %config %{privoxyconf}/templates/show-status-file
250 %config %{privoxyconf}/templates/show-url-info
251 %config %{privoxyconf}/templates/show-version
252 %config %{privoxyconf}/templates/toggle
253 %config %{privoxyconf}/templates/toggle-mini
254 %config %{privoxyconf}/templates/untrusted
255 %config %{_sysconfdir}/logrotate.d/%{name}
256 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
257 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
258 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
259 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
260 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
261 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
262 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
263 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
264
265 %{_mandir}/man1/%{name}.*
266
267 %changelog
268 * Tue Apr 09 2002 Hal Burgiss <hal@foobox.net>
269 + privoxy-2.9.13-4
270 - Removed 'make dok'. Docs are all maintained in CVS (and tarball) now.
271
272 * Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
273 + privoxy-2.9.13-4
274 - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
275 - Remove templates/blocked-compact.
276 - Add more docbook stuff to Builderquires.
277
278 * Thu Mar 28 2002 Sarantis Paskalis <sarantis@cnl.di.uoa.gr>
279 + privoxy-2.9.13-3
280 - Include correct documentation file.
281
282 * Tue Mar 26 2002 Hal Burgiss <hal@foobox.net>
283 + privoxy-2.9.13-3
284 - Fix typo in Description.
285
286 * Tue Mar 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
287 + privoxy-2.9.13-3
288 - Added commentary asking to update the release value on the configure
289   script
290
291 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
292 + privoxy-2.9.13-3
293 - Added the missing edit-actions-for-url-filter to templates.
294
295 * Mon Mar 25 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
296 + privoxy-2.9.13-2
297 - Fixing Release number
298
299 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
300 + privoxy-2.9.13-2
301 - Added faq to docs.
302
303 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
304 + privoxy-2.9.13-2
305 - Fixed the init files entries. Now we use %%ghost
306 - improved username (and groupname) handling on the %%pre section. By improved
307   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
308   got it right. No more Mr. Nice Guy.
309 - Removed the userdel call on %%post. No need, once it's complety handled on
310   the %%pre section
311
312 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
313 + junkbusterng-2.9.13-1
314   Added autoheader. Added autoconf to buildrequires.
315
316 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
317 + junkbusterng-2.9.13-1
318 - Fixed build problems re: name conflicts with man page and logrotate.
319 - Commented out rc?d/* configs for time being, which are causing a build 
320 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
321 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
322
323 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
324 + junkbusterng-2.9.13-1
325 - References to the expression ijb where changed where possible
326 - New package name: junkbusterng (all in lower case, acording to
327   the LSB recomendation)
328 - Version changed to: 2.9.13
329 - Release: 1
330 - Added: junkbuster to obsoletes and conflicts (Not sure this is
331   right. If it obsoletes, why conflict ? Have to check it later)
332 - Summary changed: Stefan, please check and aprove it
333 - Changes description to use the new name
334 - Sed string was NOT changed. Have to wait to the manpage to
335   change first
336 - Keeping the user junkbuster for now. It will require some aditional
337   changes on the script (scheduled for the next specfile release)
338 - Added post entry to move the old logfile to the new log directory
339 - Removing "chkconfig --add" entry (not good to have it automaticaly
340   added to the startup list).
341 - Added preun section to stop the service with the old name, as well
342   as remove it from the startup list
343 - Removed the chkconfig --del entry from the conditional block on
344   the preun scriptlet (now handled on the %files section)
345
346 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
347 - added ijb_docs.css to docs.
348
349 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
350 + junkbuster-2.9.11-8 
351 - Take out --enable-no-gifs, breaks some browsers.
352
353 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
354 + junkbuster-2.9.11-8 
355 - Add --enable-no-gifs to configure.
356
357 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
358 + junkbuster-2.9.11-7
359 - Added BuildRequires to libtool.
360
361 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
362 + junkbuster-2.9.11-6
363 - Changed the routined that handle the junkbust and junkbuster users on
364   %%pre and %%post to work in a smoother manner
365 - %%files now uses hardcoded usernames, to avoid problems with package
366   name changes in the future
367
368 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
369 + junkbuster-2.9.11-5
370 - Added "make redhat-dok" to the build process
371 - Added docbook-utils to BuildRequires
372
373 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
374 + junkbuster-2.9.11-4
375 - Changing man section in the manpage from 1 to 8
376 - We now require packages, not files, to avoid issues with apt
377
378 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
379 + junkbuster-2.9.11-3
380 - Fixing permissions of the init script
381
382 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
383 + junkbuster-2.9.11-2
384 - General specfile fixup, using the best recomended practices, including:
385         - Adding -q to %%setup
386         - Using macros whereever possible
387         - Not using wildchars on %%files section
388         - Doubling the percentage char on changelog and comments, to
389           avoid rpm expanding them
390
391 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
392 - /bin/false for shell causes init script to fail. Reverting.
393
394 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
395 - Removed UID 73. Included user-manual and developer-manual in docs.
396   Include other actions files. Default shell is now /bin/false.
397   Userdel user=junkbust. ChangeLog was not zipped. Removed 
398   RPM_OPT_FLAGS kludge.
399
400 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
401 - add paranoia check for 'rm -rf %%{buildroot}'
402 - add gzip to 'BuildRequires'
403
404 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
405 - actionsfile is now ijb.action.
406
407 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
408 - Compress manpage
409 - Add more documents for installation
410 - Add version string to name and source
411
412 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
413 - Back to user 'junkbuster' and fix configure macro.
414
415 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
416 - More changes for user 'junkbust'. Init script had 'junkbuster'.
417
418 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
419 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
420 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
421
422 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
423 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
424 - made sure no default shell exists for user junkbust.
425
426 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
427 - rework of RPM
428
429 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
430 - CLF Logging patch by davep@cyw.uklinux.net
431 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
432
433 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
434 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
435 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
436   numerous fixes and enhancements for Steve's patch.
437 - adamlock@netscape.com (Adam Lock) in the windows version:
438   - Taskbar activity spinner always spins even when logging is
439   turned off (which is the default) - people who don't
440   like the spinner can turn it off from a menu option.
441   - Taskbar popup menu has a options submenu - people can now
442   open the settings files for cookies, blockers etc.
443   without opening the JB window.
444   - Logging functionality works again
445   - Buffer overflow is fixed - new code uses a bigger buffer
446   and snprintf so it shouldn't overflow anymore.
447 - Fixed userid swa, group learning problem while installing.
448   root must build RPM.
449 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
450   core dump when there is no log file.
451 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
452 - Fixed man page to include imagefile and popupfile.
453 - Sanity check for the statistics function added.
454 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
455  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
456  With IIS/5, it appears to omit the trailing \r\n from http header
457  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
458  responds with a HTTP 302 redirect header.  However, this header
459  message is missing the trailing \r\n.  IIS/5 then closes the
460  connection.  Junkbuster, unfortunately, discards the header becomes
461  it thinks it is incomplete - and it is.  MS have transmitted an
462  incomplete header!
463 - Added bug reports and patch submission forms in the docs.
464
465 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
466        Andrew <anw@tirana.freewire.co.uk> extended the JB:
467        Display of statistics of the total number of requests and the number
468        of requests filtered by junkbuster, also the percentage of requests
469        filtered. Suppression of the listing of files on the proxy-args page.
470        All stuff optional and configurable.
471
472 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
473        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
474        code which prevented the JB from handling URLs of the form
475        user:password@www.foo.com. Fixed.
476
477 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
478         Blank images are no longer cached, thanks to a hint from Markus 
479         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
480         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
481         on the correct browser version nowadays. Incorporated many 
482         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
483         spec file. Fixed logging problem and since runlevel 2 does not 
484         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
485         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
486         <walker@netgate.net>. You should now be able to build this RPM as 
487         a non-root user (mathias@weidner.sem.lipsia.de).
488
489 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
490         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
491         to allow more sophisticated matching of blocked images. Logrotate
492         logfile. Added files for auto-updating the blocklist et al.
493
494 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
495         Configure blank version via config file. No separate blank
496         version anymore. Added Roland's <roland@spinnaker.rhein.de>
497         patch to show a logo instead of a blank area. Added a suggestion
498         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
499         More regexps in the blocklist. Prepared the forwardfile for
500         squid. Extended image regexp with help from gabriel 
501         <somlo@CS.ColoState.EDU>.
502
503 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
504         All RPMs now identify themselves in the show-proxy-args page.
505         Released Windoze version. Run junkbuster as nobody instead of
506         root. 
507
508 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
509         Newest version. First release (hence the little version number
510         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
511         security over 2.0.1; some multi-user sites will need to change 
512         the listen-address in the configuration file. The blank version of
513         the Internet Junkbuster has a more sophisticated way of replacing
514         images. All RPMs identify themselves in the show-proxy-args page.
515
516 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
517         Modified the blocking feature, so that only GIFs and JPEGs are
518         blocked and replaced but not HTML pages. Thanks to 
519         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
520         idea. Added numerous stuff to the blocklist. Keep patches in
521         seperate files and no longer in diffs (easier to maintain).
522
523 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
524         Moved config files to /etc/junkbuster directory, moved man page,
525         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
526         Made new version junkbuster-raw (which is only a stripped version of 
527         the junkuster rpm, i.e. without my blocklist, etc.)
528
529 * Tue Jun 16 1998 (2.0-1)
530         Uhm, not that much. Just a new junkbuster version that
531         fixes a couple of bugs ... and of course a bigger 
532         blocklist with the unique Now-less-ads-than-ever(SM)
533         feature.
534         Oh, one thing: I changed the default user agent to Linux -- no 
535         need anymore to support Apple.
536
537 * Tue Jun 16 1998 (2.0-0)
538         Now-less-ads-than-ever (SM)
539         compiled with gcc instead of cc
540         compiled with -O3, thus it should be a little faster
541         show-proxy-args now works
542         /etc/junkbuster.init wasn't necessary
543
544 * Tue Jun 16 1998 (1.4)
545         some more config files were put into /etc
546         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
547         displayed by Netscape instead of the blocked image.
548         Read http://www.waldherr.org/junkbuster/ for
549         further info.
550
551 * Tue Jun 16 1998 (1.3)
552         The program has been moved to /usr/sbin (from /usr/local/bin)
553         Init- and stopscripts (/etc/rc.d/rc*) have been added so
554         that the junkbuster starts automatically during bootup.
555         The /etc/blocklist file is much more sophisticated. Theoretically
556         one should e.g. browse all major US and German newspapers without
557         seeing one annoying ad.
558         junkbuster.init was modified. It now starts junkbuster with an
559         additional "-r @" flag.
560
561 # $Log: privoxy-rh.spec,v $
562 # Revision 1.21  2002/04/09 02:52:26  hal9
563 # - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
564 # - Remove templates/blocked-compact.
565 # - Add more docbook stuff to Buildrequires.
566 #
567 # Revision 1.20  2002/04/08 20:27:45  swa
568 # fixed JB spelling
569 #
570 # Revision 1.19  2002/03/27 22:44:59  sarantis
571 # Include correct documentation file.
572 #
573 # Revision 1.18  2002/03/27 22:10:14  sarantis
574 # bumped Hal's last commit 1 day to the future to make rpm build again.
575 #
576 # Revision 1.17  2002/03/27 00:48:23  hal9
577 # Fix up descrition.
578 #
579 # Revision 1.16  2002/03/26 22:29:55  swa
580 # we have a new homepage!
581 #
582 # Revision 1.15  2002/03/26 17:39:54  morcego
583 # Adding comment on the specfile to remember the packager to update
584 # the release number on the configure script
585 #
586 # Revision 1.14  2002/03/26 14:25:15  hal9
587 # Added edit-actions-for-url-filter to templates in %%config
588 #
589 # Revision 1.13  2002/03/25 13:31:04  morcego
590 # Bumping Release tag.
591 #
592 # Revision 1.12  2002/03/25 03:11:40  hal9
593 # Do it right way this time :/
594 #
595 # Revision 1.11  2002/03/25 03:09:51  hal9
596 # Added faq to docs.
597 #
598 # Revision 1.10  2002/03/24 22:16:14  morcego
599 # Just removing some old commentaries.
600 #
601 # Revision 1.9  2002/03/24 22:03:22  morcego
602 # Should be working now. See %changelog for details
603 #
604 # Revision 1.8  2002/03/24 21:13:01  morcego
605 # Tis broken.
606 #
607 # Revision 1.7  2002/03/24 21:07:18  hal9
608 # Add autoheader, etc.
609 #
610 # Revision 1.6  2002/03/24 19:56:40  hal9
611 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
612 #
613 # Revision 1.4  2002/03/24 13:32:42  swa
614 # name change related issues
615 #
616 # Revision 1.3  2002/03/24 12:56:21  swa
617 # name change related issues.
618 #
619 # Revision 1.2  2002/03/24 11:40:14  swa
620 # name change
621 #
622 # Revision 1.1  2002/03/24 11:23:44  swa
623 # name change
624 #
625 # Revision 1.1  2002/03/22 20:53:03  morcego
626 # - Ongoing process to change name to JunkbusterNG
627 # - configure/configure.in: no change needed
628 # - GNUmakefile.in:
629 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
630 #         - PROGRAM    = jbng@EXEEXT@
631 #         - rh-spec now references as junkbusterng-rh.spec
632 #         - redhat-upload: references changed to junkbusterng-* (package names)
633 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
634 #         - tarball-src: now JunkbusterNG-*
635 #         - install: initscript now junkbusterng.init and junkbusterng (when
636 #                    installed)
637 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
638 # - junkbusterng.spec:
639 #         - References to the expression ijb where changed where possible
640 #         - New package name: junkbusterng (all in lower case, acording to
641 #           the LSB recomendation)
642 #         - Version changed to: 2.9.13
643 #         - Release: 1
644 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
645 #           right. If it obsoletes, why conflict ? Have to check it later)
646 #         - Summary changed: Stefan, please check and aprove it
647 #         - Changes description to use the new name
648 #         - Sed string was NOT changed. Have to wait to the manpage to
649 #           change first
650 #         - Keeping the user junkbuster for now. It will require some aditional
651 #           changes on the script (scheduled for the next specfile release)
652 #         - Added post entry to move the old logfile to the new log directory
653 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
654 #           added to the startup list).
655 #         - Added preun section to stop the service with the old name, as well
656 #           as remove it from the startup list
657 #         - Removed the chkconfig --del entry from the conditional block on
658 #           the preun scriptlet (now handled on the %files section)
659 # - junkbuster.init: renamed to junkbusterng.init
660 # - junkbusterng.init:
661 #         - Changed JB_BIN to jbng
662 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
663 #           be used where necessary (config dir)
664 #
665 # Aditional notes:
666 # - The config directory is /etc/junkbuster yet. Have to change it on the
667 # specfile, after it is changes on the code
668 # - The only files that got renamed on the cvs tree were the rh specfile and
669 # the init file. Some file references got changes on the makefile and on the
670 # rh-spec (as listed above)
671 #
672 # Revision 1.43  2002/03/21 16:04:10  hal9
673 # added ijb_docs.css to %doc
674 #
675 # Revision 1.42  2002/03/12 13:41:18  sarantis
676 # remove hard-coded "ijbswa" string in build phase
677 #
678 # Revision 1.41  2002/03/11 22:58:32  hal9
679 # Remove --enable-no-gifs
680 #
681 # Revision 1.39  2002/03/08 18:57:29  swa
682 # remove user junkbuster after de-installation.
683 #
684 # Revision 1.38  2002/03/08 13:45:27  morcego
685 # Adding libtool to Buildrequires
686 #
687 # Revision 1.37  2002/03/07 19:23:49  swa
688 # i hate to scroll. suse: wrong configdir.
689 #
690 # Revision 1.36  2002/03/07 05:06:54  morcego
691 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
692 #
693 # Revision 1.34  2002/03/07 00:11:57  morcego
694 # Few changes on the %pre and %post sections of the rh specfile to handle
695 # usernames more cleanly
696 #
697 # Revision 1.33  2002/03/05 13:13:57  morcego
698 # - Added "make redhat-dok" to the build phase
699 # - Added docbook-utils to BuildRequires
700 #
701 # Revision 1.32  2002/03/05 12:34:24  morcego
702 # - Changing section internaly on the manpage from 1 to 8
703 # - We now require packages, not files, to avoid issues with apt
704 #
705 # Revision 1.31  2002/03/04 18:06:09  morcego
706 # SPECFILE: fixing permissing of the init script (broken by the last change)
707 #
708 # Revision 1.30  2002/03/04 16:18:03  morcego
709 # General cleanup of the rh specfile.
710 #
711 # %changelog
712 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
713 # + junkbuster-2.9.11-2
714 # - General specfile fixup, using the best recomended practices, including:
715 #         - Adding -q to %%setup
716 #         - Using macros whereever possible
717 #         - Not using wildchars on %%files section
718 #         - Doubling the percentage char on changelog and comments, to
719 #           avoid rpm expanding them
720 #
721 # Revision 1.29  2002/03/03 19:21:22  hal9
722 # Init script fails if shell is /bin/false.
723 #
724 # Revision 1.28  2002/01/09 18:34:03  hal9
725 # nit.
726 #
727 # Revision 1.27  2002/01/09 18:32:02  hal9
728 # Removed RPM_OPT_FLAGS kludge.
729 #
730 # Revision 1.26  2002/01/09 18:21:10  hal9
731 # A few minor updates.
732 #
733 # Revision 1.25  2001/12/28 01:45:36  steudten
734 # Add paranoia check and BuildReq: gzip
735 #
736 # Revision 1.24  2001/12/01 21:43:14  hal9
737 # Allowed for new ijb.action file.
738 #
739 # Revision 1.23  2001/11/06 12:09:03  steudten
740 # Compress doc files. Install README and AUTHORS at last as document.
741 #
742 # Revision 1.22  2001/11/05 21:37:34  steudten
743 # Fix to include the actual version for name.
744 # Let the 'real' packager be included - sorry stefan.
745 #
746 # Revision 1.21  2001/10/31 19:27:27  swa
747 # consistent description. new name for suse since
748 # we had troubles with rpms of identical names
749 # on the webserver.
750 #
751 # Revision 1.20  2001/10/24 15:45:49  hal9
752 # To keep Thomas happy (aka correcting my  mistakes)
753 #
754 # Revision 1.19  2001/10/15 03:23:59  hal9
755 # Nits.
756 #
757 # Revision 1.17  2001/10/10 18:59:28  hal9
758 # Minor change for init script.
759 #
760 # Revision 1.16  2001/09/24 20:56:23  hal9
761 # Minor changes.
762 #
763 # Revision 1.13  2001/09/10 17:44:43  swa
764 # integrate three pieces of documentation. needs work.
765 # will not build cleanly under redhat.
766 #
767 # Revision 1.12  2001/09/10 16:25:04  swa
768 # copy all templates. version updated.
769 #
770 # Revision 1.11  2001/07/03 11:00:25  sarantis
771 # replaced permissionsfile with actionsfile
772 #
773 # Revision 1.10  2001/07/03 09:34:44  sarantis
774 # bumped up version number.
775 #
776 # Revision 1.9  2001/06/12 18:15:29  swa
777 # the %% in front of configure (see tag below) confused
778 # the rpm build process on 7.1.
779 #
780 # Revision 1.8  2001/06/12 17:15:56  swa
781 # fixes, because a clean build on rh6.1 was impossible.
782 # GZIP confuses make, %% configure confuses rpm, etc.
783 #
784 # Revision 1.7  2001/06/11 12:17:26  sarantis
785 # fix typo in %%post
786 #
787 # Revision 1.6  2001/06/11 11:28:25  sarantis
788 # Further optimizations and adaptations in the spec file.
789 #
790 # Revision 1.5  2001/06/09 09:14:11  swa
791 # shamelessly adapted RPM stuff from the newest rpm that
792 # RedHat provided for the JB.
793 #
794 # Revision 1.4  2001/06/08 20:54:18  swa
795 # type with status file. remove forward et. al from file list.
796 #
797 # Revision 1.3  2001/06/07 17:28:10  swa
798 # cosmetics
799 #
800 # Revision 1.2  2001/06/04 18:31:58  swa
801 # files are now prefixed with either `confdir' or `logdir'.
802 # `make redhat-dist' replaces both entries confdir and logdir
803 # with redhat values
804 #
805 # Revision 1.1  2001/06/04 10:44:57  swa
806 # `make redhatr-dist' now works. Except for the paths
807 # in the config file.
808 #
809 #
810 #