Bumping Release tag.
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.12 2002/03/25 03:11:40 hal9 Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # PRIVOXY team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33
34 Name: privoxy
35 Version: 2.9.13
36 Release: 2
37 Summary: Privoxy - privacy enhancing proxy
38 License: GPL
39 Vendor: http://ijbswa.sourceforge.net
40 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
41 BuildRoot: %{_tmppath}/%{name}-%{version}-root
42 Group: Networking/Utilities
43 URL: http://ijbswa.sourceforge.net/
44 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
45 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
46 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
47 BuildRequires: perl gzip sed docbook-utils libtool autoconf
48 Conflicts: junkbuster-raw junkbuster-blank junkbuster
49
50 %description 
51 Privoxy is a web proxy with advanced filtering capabilities for
52 protecting privacy, filtering web page content, managing cookies,
53 controlling access, and removing ads, banners, pop-ups and other
54 obnoxious Internet junk. Privoxy has a very flexible configuration and
55 can be customized to suit individual needs and tastes. Internet
56 Privoxy has application for both stand-alone systems and multi-user
57 networks.
58
59 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
60 was originally written by JunkBusters Corporation, and was released as
61 free open-source software under the GNU GPL. Stefan Waldherr made many
62 improvements, and started the SourceForge project to continue
63 development. Several other developers are now contributing.
64
65 %prep
66 %setup -q -c
67
68 %build
69 autoheader
70 autoconf
71 %configure
72 make 
73 make redhat-dok
74
75 ## Explicitily stripping is not recomended.
76 ## This is handled altomaticaly by RPM, and can couse troubles if
77 ## anyone wants to build an unstriped version - morcego
78 #strip %{name}
79
80 %install
81 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
82 mkdir -p %{buildroot}%{_sbindir} \
83          %{buildroot}%{_mandir}/man1 \
84          %{buildroot}%{_localstatedir}/log/%{name} \
85          %{buildroot}%{privoxyconf}/templates \
86          %{buildroot}%{_sysconfdir}/logrotate.d \
87          %{buildroot}%{_sysconfdir}/rc.d/init.d 
88
89 ## Manual gziping of manpages should not be done, once it can
90 ## break the building on some distributions. Anyway, rpm does it
91 ## automagicaly these days
92 ## Gziping the documentation files is not recomended - morcego
93 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
94
95 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
96
97 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
98 cp -f *.action %{buildroot}%{privoxyconf}/
99 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
100 cp -f trust %{buildroot}%{privoxyconf}/trust
101 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
102 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
103 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
104 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
105
106 # verify all file locations, etc. in the config file
107 # don't start with ^ or commented lines are not replaced
108 ## Changing the sed paramter delimiter to @, so we don't have to
109 ## escape the slashes
110 cat config | \
111     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
112 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
113 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
114 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
115 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
116 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
117 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
118     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
119     %{buildroot}%{privoxyconf}/config
120 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
121     %{buildroot}%{privoxyconf}/default.action
122
123
124 # Creating ghost init files
125 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
126 for i in 0 1 4 6
127 do
128 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
129 done
130 for i in 2 3 5
131 do
132 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
133 done
134
135 ## Macros are expanded even on commentaries. So, we have to use %%
136 ## -- morcego
137 #%%makeinstall
138
139 %pre
140 # This is where we handle old usernames (junkbust and junkbuster)
141 # I'm not sure we should do that, but this is the way we have been
142 # doing it for some time now -- morcego
143 # We should do it for the group as well -- morcego
144 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
145
146 # Change the group name. Remove anything left behind.
147 groupmod -n %{name} %{oldname} > /dev/null 2>&1 ||:
148 groupmod -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
149 groupdel %{oldname} > /dev/null 2>&1 ||:
150 groupdel %{veryoldname} > /dev/null 2>&1 ||:
151
152 # Same for username
153 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
154 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
155 userdel %{oldname} > /dev/null 2>&1 ||:
156 userdel %{veryoldname} > /dev/null 2>&1 ||:
157
158 # Check to see if everything is okey. Create user if it still does not
159 # exist
160 id %{name} > /dev/null 2>&1
161 if [ $? -eq 1 ]; then
162         /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
163 fi
164
165 %post
166 # for upgrade from 2.0.x
167 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
168  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
169 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
170  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
171 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
172 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
173 if [ "$1" = "1" ]; then
174         /sbin/service %{name} condrestart > /dev/null 2>&1
175 fi
176
177 %preun
178 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
179 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
180
181 if [ "$1" = "0" ]; then
182         /sbin/service %{name} stop > /dev/null 2>&1 ||:
183         # No need to use chkconfig. The %%ghost files will handle it
184 fi
185
186 %postun
187 #if [ "$1" -ge "1" ]; then
188 #       /sbin/service %{name} condrestart > /dev/null 2>&1
189 #fi
190 # We only remove it we this is not an upgrade
191 if [ "$1" = "0" ]; then
192         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
193 fi
194
195 %clean
196 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
197
198 %files
199 %defattr(0644,root,root,0755)
200 %doc README AUTHORS ChangeLog
201 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
202 %doc doc/webserver/developer-manual
203 %doc doc/webserver/user-manual
204 %doc doc/webserver/faq
205 %doc doc/webserver/ijb_docs.css
206
207 %dir %{privoxyconf}
208 %dir %{privoxyconf}/templates
209 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
210
211 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
212
213 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
214 # We should not use wildchars here. This could mask missing files problems
215 # -- morcego
216 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
217 %config %{privoxyconf}/config
218 %config %{privoxyconf}/advanced.action
219 %config %{privoxyconf}/basic.action
220 %config %{privoxyconf}/intermediate.action
221 %config %{privoxyconf}/default.action
222 %config %{privoxyconf}/default.filter
223 %config %{privoxyconf}/trust
224
225 %config %{privoxyconf}/templates/blocked
226 %config %{privoxyconf}/templates/blocked-compact
227 %config %{privoxyconf}/templates/cgi-error-404
228 %config %{privoxyconf}/templates/cgi-error-bad-param
229 %config %{privoxyconf}/templates/cgi-error-disabled
230 %config %{privoxyconf}/templates/cgi-error-file
231 %config %{privoxyconf}/templates/cgi-error-modified
232 %config %{privoxyconf}/templates/cgi-error-parse
233 %config %{privoxyconf}/templates/connect-failed
234 %config %{privoxyconf}/templates/default
235 %config %{privoxyconf}/templates/edit-actions-add-url-form
236 %config %{privoxyconf}/templates/edit-actions-for-url
237 %config %{privoxyconf}/templates/edit-actions-list
238 %config %{privoxyconf}/templates/edit-actions-list-section
239 %config %{privoxyconf}/templates/edit-actions-list-url
240 %config %{privoxyconf}/templates/edit-actions-remove-url-form
241 %config %{privoxyconf}/templates/edit-actions-url-form
242 %config %{privoxyconf}/templates/no-such-domain
243 %config %{privoxyconf}/templates/show-request
244 %config %{privoxyconf}/templates/show-status
245 %config %{privoxyconf}/templates/show-status-file
246 %config %{privoxyconf}/templates/show-url-info
247 %config %{privoxyconf}/templates/show-version
248 %config %{privoxyconf}/templates/toggle
249 %config %{privoxyconf}/templates/toggle-mini
250 %config %{privoxyconf}/templates/untrusted
251
252 %config %{_sysconfdir}/logrotate.d/%{name}
253 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
254 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
255 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
256 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
257 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
258 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
259 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
260 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
261
262 %{_mandir}/man1/%{name}.*
263
264 %changelog
265 * Mon Mar 25 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
266 + privoxy-2.9.13-2
267 - Fixing Release number
268
269 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
270 + privoxy-2.9.13-2
271 - Added faq to docs.
272
273 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
274 + privoxy-2.9.13-2
275 - Fixed the init files entries. Now we use %%ghost
276 - improved username (and groupname) handling on the %%pre section. By improved
277   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
278   got it right. No more Mr. Nice Guy.
279 - Removed the userdel call on %%post. No need, once it's complety handled on
280   the %%pre section
281
282 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
283 + junkbusterng-2.9.13-1
284   Added autoheader. Added autoconf to buildrequires.
285
286 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
287 + junkbusterng-2.9.13-1
288 - Fixed build problems re: name conflicts with man page and logrotate.
289 - Commented out rc?d/* configs for time being, which are causing a build 
290 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
291 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
292
293 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
294 + junkbusterng-2.9.13-1
295 - References to the expression ijb where changed where possible
296 - New package name: junkbusterng (all in lower case, acording to
297   the LSB recomendation)
298 - Version changed to: 2.9.13
299 - Release: 1
300 - Added: junkbuster to obsoletes and conflicts (Not sure this is
301   right. If it obsoletes, why conflict ? Have to check it later)
302 - Summary changed: Stefan, please check and aprove it
303 - Changes description to use the new name
304 - Sed string was NOT changed. Have to wait to the manpage to
305   change first
306 - Keeping the user junkbuster for now. It will require some aditional
307   changes on the script (scheduled for the next specfile release)
308 - Added post entry to move the old logfile to the new log directory
309 - Removing "chkconfig --add" entry (not good to have it automaticaly
310   added to the startup list).
311 - Added preun section to stop the service with the old name, as well
312   as remove it from the startup list
313 - Removed the chkconfig --del entry from the conditional block on
314   the preun scriptlet (now handled on the %files section)
315
316 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
317 - added ijb_docs.css to docs.
318
319 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
320 + junkbuster-2.9.11-8 
321 - Take out --enable-no-gifs, breaks some browsers.
322
323 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
324 + junkbuster-2.9.11-8 
325 - Add --enable-no-gifs to configure.
326
327 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
328 + junkbuster-2.9.11-7
329 - Added BuildRequires to libtool.
330
331 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
332 + junkbuster-2.9.11-6
333 - Changed the routined that handle the junkbust and junkbuster users on
334   %%pre and %%post to work in a smoother manner
335 - %%files now uses hardcoded usernames, to avoid problems with package
336   name changes in the future
337
338 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
339 + junkbuster-2.9.11-5
340 - Added "make redhat-dok" to the build process
341 - Added docbook-utils to BuildRequires
342
343 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
344 + junkbuster-2.9.11-4
345 - Changing man section in the manpage from 1 to 8
346 - We now require packages, not files, to avoid issues with apt
347
348 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
349 + junkbuster-2.9.11-3
350 - Fixing permissions of the init script
351
352 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
353 + junkbuster-2.9.11-2
354 - General specfile fixup, using the best recomended practices, including:
355         - Adding -q to %%setup
356         - Using macros whereever possible
357         - Not using wildchars on %%files section
358         - Doubling the percentage char on changelog and comments, to
359           avoid rpm expanding them
360
361 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
362 - /bin/false for shell causes init script to fail. Reverting.
363
364 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
365 - Removed UID 73. Included user-manual and developer-manual in docs.
366   Include other actions files. Default shell is now /bin/false.
367   Userdel user=junkbust. ChangeLog was not zipped. Removed 
368   RPM_OPT_FLAGS kludge.
369
370 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
371 - add paranoia check for 'rm -rf %%{buildroot}'
372 - add gzip to 'BuildRequires'
373
374 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
375 - actionsfile is now ijb.action.
376
377 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
378 - Compress manpage
379 - Add more documents for installation
380 - Add version string to name and source
381
382 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
383 - Back to user 'junkbuster' and fix configure macro.
384
385 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
386 - More changes for user 'junkbust'. Init script had 'junkbuster'.
387
388 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
389 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
390 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
391
392 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
393 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
394 - made sure no default shell exists for user junkbust.
395
396 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
397 - rework of RPM
398
399 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
400 - CLF Logging patch by davep@cyw.uklinux.net
401 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
402
403 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
404 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
405 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
406   numerous fixes and enhancements for Steve's patch.
407 - adamlock@netscape.com (Adam Lock) in the windows version:
408   - Taskbar activity spinner always spins even when logging is
409   turned off (which is the default) - people who don't
410   like the spinner can turn it off from a menu option.
411   - Taskbar popup menu has a options submenu - people can now
412   open the settings files for cookies, blockers etc.
413   without opening the JB window.
414   - Logging functionality works again
415   - Buffer overflow is fixed - new code uses a bigger buffer
416   and snprintf so it shouldn't overflow anymore.
417 - Fixed userid swa, group learning problem while installing.
418   root must build RPM.
419 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
420   core dump when there is no log file.
421 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
422 - Fixed man page to include imagefile and popupfile.
423 - Sanity check for the statistics function added.
424 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
425  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
426  With IIS/5, it appears to omit the trailing \r\n from http header
427  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
428  responds with a HTTP 302 redirect header.  However, this header
429  message is missing the trailing \r\n.  IIS/5 then closes the
430  connection.  Junkbuster, unfortunately, discards the header becomes
431  it thinks it is incomplete - and it is.  MS have transmitted an
432  incomplete header!
433 - Added bug reports and patch submission forms in the docs.
434
435 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
436        Andrew <anw@tirana.freewire.co.uk> extended the JB:
437        Display of statistics of the total number of requests and the number
438        of requests filtered by junkbuster, also the percentage of requests
439        filtered. Suppression of the listing of files on the proxy-args page.
440        All stuff optional and configurable.
441
442 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
443        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
444        code which prevented the JB from handling URLs of the form
445        user:password@www.foo.com. Fixed.
446
447 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
448         Blank images are no longer cached, thanks to a hint from Markus 
449         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
450         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
451         on the correct browser version nowadays. Incorporated many 
452         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
453         spec file. Fixed logging problem and since runlevel 2 does not 
454         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
455         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
456         <walker@netgate.net>. You should now be able to build this RPM as 
457         a non-root user (mathias@weidner.sem.lipsia.de).
458
459 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
460         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
461         to allow more sophisticated matching of blocked images. Logrotate
462         logfile. Added files for auto-updating the blocklist et al.
463
464 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
465         Configure blank version via config file. No separate blank
466         version anymore. Added Roland's <roland@spinnaker.rhein.de>
467         patch to show a logo instead of a blank area. Added a suggestion
468         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
469         More regexps in the blocklist. Prepared the forwardfile for
470         squid. Extended image regexp with help from gabriel 
471         <somlo@CS.ColoState.EDU>.
472
473 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
474         All RPMs now identify themselves in the show-proxy-args page.
475         Released Windoze version. Run junkbuster as nobody instead of
476         root. 
477
478 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
479         Newest version. First release (hence the little version number
480         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
481         security over 2.0.1; some multi-user sites will need to change 
482         the listen-address in the configuration file. The blank version of
483         the Internet Junkbuster has a more sophisticated way of replacing
484         images. All RPMs identify themselves in the show-proxy-args page.
485
486 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
487         Modified the blocking feature, so that only GIFs and JPEGs are
488         blocked and replaced but not HTML pages. Thanks to 
489         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
490         idea. Added numerous stuff to the blocklist. Keep patches in
491         seperate files and no longer in diffs (easier to maintain).
492
493 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
494         Moved config files to /etc/junkbuster directory, moved man page,
495         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
496         Made new version junkbuster-raw (which is only a stripped version of 
497         the junkuster rpm, i.e. without my blocklist, etc.)
498
499 * Tue Jun 16 1998 (2.0-1)
500         Uhm, not that much. Just a new junkbuster version that
501         fixes a couple of bugs ... and of course a bigger 
502         blocklist with the unique Now-less-ads-than-ever(SM)
503         feature.
504         Oh, one thing: I changed the default user agent to Linux -- no 
505         need anymore to support Apple.
506
507 * Tue Jun 16 1998 (2.0-0)
508         Now-less-ads-than-ever (SM)
509         compiled with gcc instead of cc
510         compiled with -O3, thus it should be a little faster
511         show-proxy-args now works
512         /etc/junkbuster.init wasn't necessary
513
514 * Tue Jun 16 1998 (1.4)
515         some more config files were put into /etc
516         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
517         displayed by Netscape instead of the blocked image.
518         Read http://www.waldherr.org/junkbuster/ for
519         further info.
520
521 * Tue Jun 16 1998 (1.3)
522         The program has been moved to /usr/sbin (from /usr/local/bin)
523         Init- and stopscripts (/etc/rc.d/rc*) have been added so
524         that the junkbuster starts automatically during bootup.
525         The /etc/blocklist file is much more sophisticated. Theoretically
526         one should e.g. browse all major US and German newspapers without
527         seeing one annoying ad.
528         junkbuster.init was modified. It now starts junkbuster with an
529         additional "-r @" flag.
530
531 # $Log: privoxy-rh.spec,v $
532 # Revision 1.12  2002/03/25 03:11:40  hal9
533 # Do it right way this time :/
534 #
535 # Revision 1.11  2002/03/25 03:09:51  hal9
536 # Added faq to docs.
537 #
538 # Revision 1.10  2002/03/24 22:16:14  morcego
539 # Just removing some old commentaries.
540 #
541 # Revision 1.9  2002/03/24 22:03:22  morcego
542 # Should be working now. See %changelog for details
543 #
544 # Revision 1.8  2002/03/24 21:13:01  morcego
545 # Tis broken.
546 #
547 # Revision 1.7  2002/03/24 21:07:18  hal9
548 # Add autoheader, etc.
549 #
550 # Revision 1.6  2002/03/24 19:56:40  hal9
551 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
552 #
553 # Revision 1.4  2002/03/24 13:32:42  swa
554 # name change related issues
555 #
556 # Revision 1.3  2002/03/24 12:56:21  swa
557 # name change related issues.
558 #
559 # Revision 1.2  2002/03/24 11:40:14  swa
560 # name change
561 #
562 # Revision 1.1  2002/03/24 11:23:44  swa
563 # name change
564 #
565 # Revision 1.1  2002/03/22 20:53:03  morcego
566 # - Ongoing process to change name to JunkbusterNG
567 # - configure/configure.in: no change needed
568 # - GNUmakefile.in:
569 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
570 #         - PROGRAM    = jbng@EXEEXT@
571 #         - rh-spec now references as junkbusterng-rh.spec
572 #         - redhat-upload: references changed to junkbusterng-* (package names)
573 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
574 #         - tarball-src: now JunkbusterNG-*
575 #         - install: initscript now junkbusterng.init and junkbusterng (when
576 #                    installed)
577 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
578 # - junkbusterng.spec:
579 #         - References to the expression ijb where changed where possible
580 #         - New package name: junkbusterng (all in lower case, acording to
581 #           the LSB recomendation)
582 #         - Version changed to: 2.9.13
583 #         - Release: 1
584 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
585 #           right. If it obsoletes, why conflict ? Have to check it later)
586 #         - Summary changed: Stefan, please check and aprove it
587 #         - Changes description to use the new name
588 #         - Sed string was NOT changed. Have to wait to the manpage to
589 #           change first
590 #         - Keeping the user junkbuster for now. It will require some aditional
591 #           changes on the script (scheduled for the next specfile release)
592 #         - Added post entry to move the old logfile to the new log directory
593 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
594 #           added to the startup list).
595 #         - Added preun section to stop the service with the old name, as well
596 #           as remove it from the startup list
597 #         - Removed the chkconfig --del entry from the conditional block on
598 #           the preun scriptlet (now handled on the %files section)
599 # - junkbuster.init: renamed to junkbusterng.init
600 # - junkbusterng.init:
601 #         - Changed JB_BIN to jbng
602 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
603 #           be used where necessary (config dir)
604 #
605 # Aditional notes:
606 # - The config directory is /etc/junkbuster yet. Have to change it on the
607 # specfile, after it is changes on the code
608 # - The only files that got renamed on the cvs tree were the rh specfile and
609 # the init file. Some file references got changes on the makefile and on the
610 # rh-spec (as listed above)
611 #
612 # Revision 1.43  2002/03/21 16:04:10  hal9
613 # added ijb_docs.css to %doc
614 #
615 # Revision 1.42  2002/03/12 13:41:18  sarantis
616 # remove hard-coded "ijbswa" string in build phase
617 #
618 # Revision 1.41  2002/03/11 22:58:32  hal9
619 # Remove --enable-no-gifs
620 #
621 # Revision 1.39  2002/03/08 18:57:29  swa
622 # remove user junkbuster after de-installation.
623 #
624 # Revision 1.38  2002/03/08 13:45:27  morcego
625 # Adding libtool to Buildrequires
626 #
627 # Revision 1.37  2002/03/07 19:23:49  swa
628 # i hate to scroll. suse: wrong configdir.
629 #
630 # Revision 1.36  2002/03/07 05:06:54  morcego
631 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
632 #
633 # Revision 1.34  2002/03/07 00:11:57  morcego
634 # Few changes on the %pre and %post sections of the rh specfile to handle
635 # usernames more cleanly
636 #
637 # Revision 1.33  2002/03/05 13:13:57  morcego
638 # - Added "make redhat-dok" to the build phase
639 # - Added docbook-utils to BuildRequires
640 #
641 # Revision 1.32  2002/03/05 12:34:24  morcego
642 # - Changing section internaly on the manpage from 1 to 8
643 # - We now require packages, not files, to avoid issues with apt
644 #
645 # Revision 1.31  2002/03/04 18:06:09  morcego
646 # SPECFILE: fixing permissing of the init script (broken by the last change)
647 #
648 # Revision 1.30  2002/03/04 16:18:03  morcego
649 # General cleanup of the rh specfile.
650 #
651 # %changelog
652 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
653 # + junkbuster-2.9.11-2
654 # - General specfile fixup, using the best recomended practices, including:
655 #         - Adding -q to %%setup
656 #         - Using macros whereever possible
657 #         - Not using wildchars on %%files section
658 #         - Doubling the percentage char on changelog and comments, to
659 #           avoid rpm expanding them
660 #
661 # Revision 1.29  2002/03/03 19:21:22  hal9
662 # Init script fails if shell is /bin/false.
663 #
664 # Revision 1.28  2002/01/09 18:34:03  hal9
665 # nit.
666 #
667 # Revision 1.27  2002/01/09 18:32:02  hal9
668 # Removed RPM_OPT_FLAGS kludge.
669 #
670 # Revision 1.26  2002/01/09 18:21:10  hal9
671 # A few minor updates.
672 #
673 # Revision 1.25  2001/12/28 01:45:36  steudten
674 # Add paranoia check and BuildReq: gzip
675 #
676 # Revision 1.24  2001/12/01 21:43:14  hal9
677 # Allowed for new ijb.action file.
678 #
679 # Revision 1.23  2001/11/06 12:09:03  steudten
680 # Compress doc files. Install README and AUTHORS at last as document.
681 #
682 # Revision 1.22  2001/11/05 21:37:34  steudten
683 # Fix to include the actual version for name.
684 # Let the 'real' packager be included - sorry stefan.
685 #
686 # Revision 1.21  2001/10/31 19:27:27  swa
687 # consistent description. new name for suse since
688 # we had troubles with rpms of identical names
689 # on the webserver.
690 #
691 # Revision 1.20  2001/10/24 15:45:49  hal9
692 # To keep Thomas happy (aka correcting my  mistakes)
693 #
694 # Revision 1.19  2001/10/15 03:23:59  hal9
695 # Nits.
696 #
697 # Revision 1.17  2001/10/10 18:59:28  hal9
698 # Minor change for init script.
699 #
700 # Revision 1.16  2001/09/24 20:56:23  hal9
701 # Minor changes.
702 #
703 # Revision 1.13  2001/09/10 17:44:43  swa
704 # integrate three pieces of documentation. needs work.
705 # will not build cleanly under redhat.
706 #
707 # Revision 1.12  2001/09/10 16:25:04  swa
708 # copy all templates. version updated.
709 #
710 # Revision 1.11  2001/07/03 11:00:25  sarantis
711 # replaced permissionsfile with actionsfile
712 #
713 # Revision 1.10  2001/07/03 09:34:44  sarantis
714 # bumped up version number.
715 #
716 # Revision 1.9  2001/06/12 18:15:29  swa
717 # the %% in front of configure (see tag below) confused
718 # the rpm build process on 7.1.
719 #
720 # Revision 1.8  2001/06/12 17:15:56  swa
721 # fixes, because a clean build on rh6.1 was impossible.
722 # GZIP confuses make, %% configure confuses rpm, etc.
723 #
724 # Revision 1.7  2001/06/11 12:17:26  sarantis
725 # fix typo in %%post
726 #
727 # Revision 1.6  2001/06/11 11:28:25  sarantis
728 # Further optimizations and adaptations in the spec file.
729 #
730 # Revision 1.5  2001/06/09 09:14:11  swa
731 # shamelessly adapted RPM stuff from the newest rpm that
732 # RedHat provided for the JB.
733 #
734 # Revision 1.4  2001/06/08 20:54:18  swa
735 # type with status file. remove forward et. al from file list.
736 #
737 # Revision 1.3  2001/06/07 17:28:10  swa
738 # cosmetics
739 #
740 # Revision 1.2  2001/06/04 18:31:58  swa
741 # files are now prefixed with either `confdir' or `logdir'.
742 # `make redhat-dist' replaces both entries confdir and logdir
743 # with redhat values
744 #
745 # Revision 1.1  2001/06/04 10:44:57  swa
746 # `make redhatr-dist' now works. Except for the paths
747 # in the config file.
748 #
749 #
750 #