/etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.4 2002/03/24 13:32:42 swa Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # PRIVOXY team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define oldname junkbuster
31 %define privoxyconf %{_sysconfdir}/%{name}
32
33 Summary: Privoxy - privacy enhancing proxy
34 Vendor: http://ijbswa.sourceforge.net
35 Name: privoxy
36 Version: 2.9.13
37 Release: 1
38 Source0: http://www.waldherr.org/%{name}/privoxy-%{version}.tar.gz
39 License: GPL
40 BuildRoot: %{_tmppath}/%{name}-%{version}-root
41 Group: Networking/Utilities
42 URL: http://ijbswa.sourceforge.net/
43 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
44 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
45 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
46 BuildRequires: perl gzip sed docbook-utils libtool
47 Conflicts: junkbuster-raw junkbuster-blank junkbuster
48
49 %description 
50 Privoxy is a web proxy with advanced filtering capabilities for
51 protecting privacy, filtering web page content, managing cookies,
52 controlling access, and removing ads, banners, pop-ups and other
53 obnoxious Internet junk. Privoxy has a very flexible configuration and
54 can be customized to suit individual needs and tastes. Internet
55 Privoxy has application for both stand-alone systems and multi-user
56 networks.
57
58 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
59 was originally written by JunkBusters Corporation, and was released as
60 free open-source software under the GNU GPL. Stefan Waldherr made many
61 improvements, and started the SourceForge project to continue
62 development. Several other developers are now contributing.
63
64 %prep
65 %setup -q -c
66
67 %build
68 autoconf
69 %configure
70 make 
71 make redhat-dok
72
73 ## Explicitily stripping is not recomended.
74 ## This is handled altomaticaly by RPM, and can couse troubles if
75 ## anyone wants to build an unstriped version - morcego
76 #strip %{name}
77
78 %install
79 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
80 mkdir -p %{buildroot}%{_sbindir} \
81          %{buildroot}%{_mandir}/man1 \
82          %{buildroot}%{_localstatedir}/log/%{name} \
83          %{buildroot}%{privoxyconf}/templates \
84          %{buildroot}%{_sysconfdir}/logrotate.d \
85          %{buildroot}%{_sysconfdir}/rc.d/init.d 
86
87 ## Manual gziping of manpages should not be done, once it can
88 ## break the building on some distributions. Anyway, rpm does it
89 ## automagicaly these days
90 ## Gziping the documentation files is not recomended - morcego
91 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
92
93 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
94
95 ## We need to change the man section internaly on the manpage
96 ## -- morcego (sugestion by Hal Burgiss)
97 #cp -f %{name}.1 %{buildroot}%{_mandir}/man8/%{name}.8
98
99 # do we need this???
100 #sed -e 's@^.TH JUNKBUSTER 1@.TH JUNKBUSTER 8@g' %{oldname}.1 > %{buildroot}%{_mandir}/man8/%{oldname}.8
101 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
102 cp -f *.action %{buildroot}%{privoxyconf}/
103 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
104 cp -f trust %{buildroot}%{privoxyconf}/trust
105 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
106 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
107 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
108 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
109
110 # verify all file locations, etc. in the config file
111 # don't start with ^ or commented lines are not replaced
112 ## Changing the sed paramter delimiter to @, so we don't have to
113 ## escape the slashes
114 cat config | \
115     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
116 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
117 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
118 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
119 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
120 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
121 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
122     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
123     %{buildroot}%{privoxyconf}/config
124 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
125     %{buildroot}%{privoxyconf}/default.action
126
127 ## Macros are expanded even on commentaries. So, we have to use %%
128 ## -- morcego
129 #%%makeinstall
130
131 %pre
132 # We check to see if the user privoxy exists.
133 # If it does, we do nothing
134 # If we don't, we check to see if the user junkbust exist and, in case it
135 # does, we change it do junkbuster. If it also does not exist, we create the
136 # privoxy user -- morcego
137 id privoxy > /dev/null 2>&1 
138 if [ $? -eq 1 ]; then
139         id privoxy > /dev/null 2>&1 
140         if [ $? -eq 0 ]; then
141                 /usr/sbin/usermod -l privoxy -d %{_sysconfdir}/%{name} -s "" privoxy  > /dev/null 2>&1
142         else
143                 /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" privoxy > /dev/null 2>&1 
144         fi
145 fi
146
147 %post
148 # for upgrade from 2.0.x
149 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
150  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
151 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
152  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
153 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
154 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
155 if [ "$1" = "1" ]; then
156 #     /sbin/chkconfig --add %{name}
157         /sbin/service %{name} condrestart > /dev/null 2>&1
158 fi
159 # 01/09/02 HB, getting rid of any user=junkbust
160 # Changed by morcego to use the id command.
161 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
162
163 %preun
164 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
165 /sbin/chkconfig --del %{oldname} ||:
166
167 if [ "$1" = "0" ]; then
168         /sbin/service %{name} stop > /dev/null 2>&1 ||:
169 fi
170
171 %postun
172 #if [ "$1" -ge "1" ]; then
173 #       /sbin/service %{name} condrestart > /dev/null 2>&1
174 #fi
175 # dont forget to remove user and group privoxy
176 id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
177
178 %clean
179 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
180
181 %files
182 %defattr(0644,root,root,0755)
183 %doc README AUTHORS ChangeLog
184 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
185 %doc doc/webserver/developer-manual
186 %doc doc/webserver/user-manual
187 %doc doc/webserver/ijb_docs.css
188 #%doc %{name}.weekly %{name}.monthly AUTHORS
189
190 %dir %{privoxyconf}
191 %dir %{privoxyconf}/templates
192 %attr(0744,privoxy,privoxy) %dir %{_localstatedir}/log/%{name}
193
194 %attr(0744,privoxy,privoxy)%{_sbindir}/%{name}
195
196 # We should not use wildchars here. This could mask missing files problems
197 # -- morcego
198 %config %{privoxyconf}/config
199 %config %{privoxyconf}/advanced.action
200 %config %{privoxyconf}/basic.action
201 %config %{privoxyconf}/intermediate.action
202 %config %{privoxyconf}/default.action
203 %config %{privoxyconf}/default.filter
204 %config %{privoxyconf}/trust
205
206 %config %{privoxyconf}/templates/blocked
207 %config %{privoxyconf}/templates/blocked-compact
208 %config %{privoxyconf}/templates/cgi-error-404
209 %config %{privoxyconf}/templates/cgi-error-bad-param
210 %config %{privoxyconf}/templates/cgi-error-disabled
211 %config %{privoxyconf}/templates/cgi-error-file
212 %config %{privoxyconf}/templates/cgi-error-modified
213 %config %{privoxyconf}/templates/cgi-error-parse
214 %config %{privoxyconf}/templates/connect-failed
215 %config %{privoxyconf}/templates/default
216 %config %{privoxyconf}/templates/edit-actions-add-url-form
217 %config %{privoxyconf}/templates/edit-actions-for-url
218 %config %{privoxyconf}/templates/edit-actions-list
219 %config %{privoxyconf}/templates/edit-actions-list-section
220 %config %{privoxyconf}/templates/edit-actions-list-url
221 %config %{privoxyconf}/templates/edit-actions-remove-url-form
222 %config %{privoxyconf}/templates/edit-actions-url-form
223 %config %{privoxyconf}/templates/no-such-domain
224 %config %{privoxyconf}/templates/show-request
225 %config %{privoxyconf}/templates/show-status
226 %config %{privoxyconf}/templates/show-status-file
227 %config %{privoxyconf}/templates/show-url-info
228 %config %{privoxyconf}/templates/show-version
229 %config %{privoxyconf}/templates/toggle
230 %config %{privoxyconf}/templates/toggle-mini
231 %config %{privoxyconf}/templates/untrusted
232
233 %config %{_sysconfdir}/logrotate.d/%{name}
234 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
235 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
236 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
237 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
238 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
239 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/S84%{name}
240 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
241 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/S84%{name}
242
243 %{_mandir}/man1/%{name}.*
244
245 %changelog
246 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
247 + junkbusterng-2.9.13-1
248 - Fixed build problems re: name conflicts with man page and logrotate.
249 - Commented out rc?d/* configs for time being, which are causing a build 
250 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
251 - changes. Fixed typo ';' should be ':'.
252
253 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
254 + junkbusterng-2.9.13-1
255 - References to the expression ijb where changed where possible
256 - New package name: junkbusterng (all in lower case, acording to
257   the LSB recomendation)
258 - Version changed to: 2.9.13
259 - Release: 1
260 - Added: junkbuster to obsoletes and conflicts (Not sure this is
261   right. If it obsoletes, why conflict ? Have to check it later)
262 - Summary changed: Stefan, please check and aprove it
263 - Changes description to use the new name
264 - Sed string was NOT changed. Have to wait to the manpage to
265   change first
266 - Keeping the user junkbuster for now. It will require some aditional
267   changes on the script (scheduled for the next specfile release)
268 - Added post entry to move the old logfile to the new log directory
269 - Removing "chkconfig --add" entry (not good to have it automaticaly
270   added to the startup list).
271 - Added preun section to stop the service with the old name, as well
272   as remove it from the startup list
273 - Removed the chkconfig --del entry from the conditional block on
274   the preun scriptlet (now handled on the %files section)
275
276 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
277 - added ijb_docs.css to docs.
278
279 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
280 + junkbuster-2.9.11-8 
281 - Take out --enable-no-gifs, breaks some browsers.
282
283 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
284 + junkbuster-2.9.11-8 
285 - Add --enable-no-gifs to configure.
286
287 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
288 + junkbuster-2.9.11-7
289 - Added BuildRequires to libtool.
290
291 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
292 + junkbuster-2.9.11-6
293 - Changed the routined that handle the junkbust and junkbuster users on
294   %%pre and %%post to work in a smoother manner
295 - %%files now uses hardcoded usernames, to avoid problems with package
296   name changes in the future
297
298 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
299 + junkbuster-2.9.11-5
300 - Added "make redhat-dok" to the build process
301 - Added docbook-utils to BuildRequires
302
303 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
304 + junkbuster-2.9.11-4
305 - Changing man section in the manpage from 1 to 8
306 - We now require packages, not files, to avoid issues with apt
307
308 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
309 + junkbuster-2.9.11-3
310 - Fixing permissions of the init script
311
312 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
313 + junkbuster-2.9.11-2
314 - General specfile fixup, using the best recomended practices, including:
315         - Adding -q to %%setup
316         - Using macros whereever possible
317         - Not using wildchars on %%files section
318         - Doubling the percentage char on changelog and comments, to
319           avoid rpm expanding them
320
321 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
322 - /bin/false for shell causes init script to fail. Reverting.
323
324 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
325 - Removed UID 73. Included user-manual and developer-manual in docs.
326   Include other actions files. Default shell is now /bin/false.
327   Userdel user=junkbust. ChangeLog was not zipped. Removed 
328   RPM_OPT_FLAGS kludge.
329
330 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
331 - add paranoia check for 'rm -rf %%{buildroot}'
332 - add gzip to 'BuildRequires'
333
334 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
335 - actionsfile is now ijb.action.
336
337 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
338 - Compress manpage
339 - Add more documents for installation
340 - Add version string to name and source
341
342 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
343 - Back to user 'junkbuster' and fix configure macro.
344
345 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
346 - More changes for user 'junkbust'. Init script had 'junkbuster'.
347
348 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
349 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
350 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
351
352 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
353 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
354 - made sure no default shell exists for user junkbust.
355
356 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
357 - rework of RPM
358
359 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
360 - CLF Logging patch by davep@cyw.uklinux.net
361 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
362
363 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
364 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
365 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
366   numerous fixes and enhancements for Steve's patch.
367 - adamlock@netscape.com (Adam Lock) in the windows version:
368   - Taskbar activity spinner always spins even when logging is
369   turned off (which is the default) - people who don't
370   like the spinner can turn it off from a menu option.
371   - Taskbar popup menu has a options submenu - people can now
372   open the settings files for cookies, blockers etc.
373   without opening the JB window.
374   - Logging functionality works again
375   - Buffer overflow is fixed - new code uses a bigger buffer
376   and snprintf so it shouldn't overflow anymore.
377 - Fixed userid swa, group learning problem while installing.
378   root must build RPM.
379 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
380   core dump when there is no log file.
381 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
382 - Fixed man page to include imagefile and popupfile.
383 - Sanity check for the statistics function added.
384 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
385  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
386  With IIS/5, it appears to omit the trailing \r\n from http header
387  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
388  responds with a HTTP 302 redirect header.  However, this header
389  message is missing the trailing \r\n.  IIS/5 then closes the
390  connection.  Junkbuster, unfortunately, discards the header becomes
391  it thinks it is incomplete - and it is.  MS have transmitted an
392  incomplete header!
393 - Added bug reports and patch submission forms in the docs.
394
395 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
396        Andrew <anw@tirana.freewire.co.uk> extended the JB:
397        Display of statistics of the total number of requests and the number
398        of requests filtered by junkbuster, also the percentage of requests
399        filtered. Suppression of the listing of files on the proxy-args page.
400        All stuff optional and configurable.
401
402 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
403        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
404        code which prevented the JB from handling URLs of the form
405        user:password@www.foo.com. Fixed.
406
407 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
408         Blank images are no longer cached, thanks to a hint from Markus 
409         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
410         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
411         on the correct browser version nowadays. Incorporated many 
412         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
413         spec file. Fixed logging problem and since runlevel 2 does not 
414         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
415         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
416         <walker@netgate.net>. You should now be able to build this RPM as 
417         a non-root user (mathias@weidner.sem.lipsia.de).
418
419 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
420         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
421         to allow more sophisticated matching of blocked images. Logrotate
422         logfile. Added files for auto-updating the blocklist et al.
423
424 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
425         Configure blank version via config file. No separate blank
426         version anymore. Added Roland's <roland@spinnaker.rhein.de>
427         patch to show a logo instead of a blank area. Added a suggestion
428         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
429         More regexps in the blocklist. Prepared the forwardfile for
430         squid. Extended image regexp with help from gabriel 
431         <somlo@CS.ColoState.EDU>.
432
433 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
434         All RPMs now identify themselves in the show-proxy-args page.
435         Released Windoze version. Run junkbuster as nobody instead of
436         root. 
437
438 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
439         Newest version. First release (hence the little version number
440         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
441         security over 2.0.1; some multi-user sites will need to change 
442         the listen-address in the configuration file. The blank version of
443         the Internet Junkbuster has a more sophisticated way of replacing
444         images. All RPMs identify themselves in the show-proxy-args page.
445
446 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
447         Modified the blocking feature, so that only GIFs and JPEGs are
448         blocked and replaced but not HTML pages. Thanks to 
449         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
450         idea. Added numerous stuff to the blocklist. Keep patches in
451         seperate files and no longer in diffs (easier to maintain).
452
453 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
454         Moved config files to /etc/junkbuster directory, moved man page,
455         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
456         Made new version junkbuster-raw (which is only a stripped version of 
457         the junkuster rpm, i.e. without my blocklist, etc.)
458
459 * Tue Jun 16 1998 (2.0-1)
460         Uhm, not that much. Just a new junkbuster version that
461         fixes a couple of bugs ... and of course a bigger 
462         blocklist with the unique Now-less-ads-than-ever(SM)
463         feature.
464         Oh, one thing: I changed the default user agent to Linux -- no 
465         need anymore to support Apple.
466
467 * Tue Jun 16 1998 (2.0-0)
468         Now-less-ads-than-ever (SM)
469         compiled with gcc instead of cc
470         compiled with -O3, thus it should be a little faster
471         show-proxy-args now works
472         /etc/junkbuster.init wasn't necessary
473
474 * Tue Jun 16 1998 (1.4)
475         some more config files were put into /etc
476         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
477         displayed by Netscape instead of the blocked image.
478         Read http://www.waldherr.org/junkbuster/ for
479         further info.
480
481 * Tue Jun 16 1998 (1.3)
482         The program has been moved to /usr/sbin (from /usr/local/bin)
483         Init- and stopscripts (/etc/rc.d/rc*) have been added so
484         that the junkbuster starts automatically during bootup.
485         The /etc/blocklist file is much more sophisticated. Theoretically
486         one should e.g. browse all major US and German newspapers without
487         seeing one annoying ad.
488         junkbuster.init was modified. It now starts junkbuster with an
489         additional "-r @" flag.
490
491 # $Log: privoxy-rh.spec,v $
492 # Revision 1.4  2002/03/24 13:32:42  swa
493 # name change related issues
494 #
495 # Revision 1.3  2002/03/24 12:56:21  swa
496 # name change related issues.
497 #
498 # Revision 1.2  2002/03/24 11:40:14  swa
499 # name change
500 #
501 # Revision 1.1  2002/03/24 11:23:44  swa
502 # name change
503 #
504 # Revision 1.1  2002/03/22 20:53:03  morcego
505 # - Ongoing process to change name to JunkbusterNG
506 # - configure/configure.in: no change needed
507 # - GNUmakefile.in:
508 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
509 #         - PROGRAM    = jbng@EXEEXT@
510 #         - rh-spec now references as junkbusterng-rh.spec
511 #         - redhat-upload: references changed to junkbusterng-* (package names)
512 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
513 #         - tarball-src: now JunkbusterNG-*
514 #         - install: initscript now junkbusterng.init and junkbusterng (when
515 #                    installed)
516 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
517 # - junkbusterng.spec:
518 #         - References to the expression ijb where changed where possible
519 #         - New package name: junkbusterng (all in lower case, acording to
520 #           the LSB recomendation)
521 #         - Version changed to: 2.9.13
522 #         - Release: 1
523 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
524 #           right. If it obsoletes, why conflict ? Have to check it later)
525 #         - Summary changed: Stefan, please check and aprove it
526 #         - Changes description to use the new name
527 #         - Sed string was NOT changed. Have to wait to the manpage to
528 #           change first
529 #         - Keeping the user junkbuster for now. It will require some aditional
530 #           changes on the script (scheduled for the next specfile release)
531 #         - Added post entry to move the old logfile to the new log directory
532 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
533 #           added to the startup list).
534 #         - Added preun section to stop the service with the old name, as well
535 #           as remove it from the startup list
536 #         - Removed the chkconfig --del entry from the conditional block on
537 #           the preun scriptlet (now handled on the %files section)
538 # - junkbuster.init: renamed to junkbusterng.init
539 # - junkbusterng.init:
540 #         - Changed JB_BIN to jbng
541 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
542 #           be used where necessary (config dir)
543 #
544 # Aditional notes:
545 # - The config directory is /etc/junkbuster yet. Have to change it on the
546 # specfile, after it is changes on the code
547 # - The only files that got renamed on the cvs tree were the rh specfile and
548 # the init file. Some file references got changes on the makefile and on the
549 # rh-spec (as listed above)
550 #
551 # Revision 1.43  2002/03/21 16:04:10  hal9
552 # added ijb_docs.css to %doc
553 #
554 # Revision 1.42  2002/03/12 13:41:18  sarantis
555 # remove hard-coded "ijbswa" string in build phase
556 #
557 # Revision 1.41  2002/03/11 22:58:32  hal9
558 # Remove --enable-no-gifs
559 #
560 # Revision 1.39  2002/03/08 18:57:29  swa
561 # remove user junkbuster after de-installation.
562 #
563 # Revision 1.38  2002/03/08 13:45:27  morcego
564 # Adding libtool to Buildrequires
565 #
566 # Revision 1.37  2002/03/07 19:23:49  swa
567 # i hate to scroll. suse: wrong configdir.
568 #
569 # Revision 1.36  2002/03/07 05:06:54  morcego
570 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
571 #
572 # Revision 1.34  2002/03/07 00:11:57  morcego
573 # Few changes on the %pre and %post sections of the rh specfile to handle
574 # usernames more cleanly
575 #
576 # Revision 1.33  2002/03/05 13:13:57  morcego
577 # - Added "make redhat-dok" to the build phase
578 # - Added docbook-utils to BuildRequires
579 #
580 # Revision 1.32  2002/03/05 12:34:24  morcego
581 # - Changing section internaly on the manpage from 1 to 8
582 # - We now require packages, not files, to avoid issues with apt
583 #
584 # Revision 1.31  2002/03/04 18:06:09  morcego
585 # SPECFILE: fixing permissing of the init script (broken by the last change)
586 #
587 # Revision 1.30  2002/03/04 16:18:03  morcego
588 # General cleanup of the rh specfile.
589 #
590 # %changelog
591 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
592 # + junkbuster-2.9.11-2
593 # - General specfile fixup, using the best recomended practices, including:
594 #         - Adding -q to %%setup
595 #         - Using macros whereever possible
596 #         - Not using wildchars on %%files section
597 #         - Doubling the percentage char on changelog and comments, to
598 #           avoid rpm expanding them
599 #
600 # Revision 1.29  2002/03/03 19:21:22  hal9
601 # Init script fails if shell is /bin/false.
602 #
603 # Revision 1.28  2002/01/09 18:34:03  hal9
604 # nit.
605 #
606 # Revision 1.27  2002/01/09 18:32:02  hal9
607 # Removed RPM_OPT_FLAGS kludge.
608 #
609 # Revision 1.26  2002/01/09 18:21:10  hal9
610 # A few minor updates.
611 #
612 # Revision 1.25  2001/12/28 01:45:36  steudten
613 # Add paranoia check and BuildReq: gzip
614 #
615 # Revision 1.24  2001/12/01 21:43:14  hal9
616 # Allowed for new ijb.action file.
617 #
618 # Revision 1.23  2001/11/06 12:09:03  steudten
619 # Compress doc files. Install README and AUTHORS at last as document.
620 #
621 # Revision 1.22  2001/11/05 21:37:34  steudten
622 # Fix to include the actual version for name.
623 # Let the 'real' packager be included - sorry stefan.
624 #
625 # Revision 1.21  2001/10/31 19:27:27  swa
626 # consistent description. new name for suse since
627 # we had troubles with rpms of identical names
628 # on the webserver.
629 #
630 # Revision 1.20  2001/10/24 15:45:49  hal9
631 # To keep Thomas happy (aka correcting my  mistakes)
632 #
633 # Revision 1.19  2001/10/15 03:23:59  hal9
634 # Nits.
635 #
636 # Revision 1.17  2001/10/10 18:59:28  hal9
637 # Minor change for init script.
638 #
639 # Revision 1.16  2001/09/24 20:56:23  hal9
640 # Minor changes.
641 #
642 # Revision 1.13  2001/09/10 17:44:43  swa
643 # integrate three pieces of documentation. needs work.
644 # will not build cleanly under redhat.
645 #
646 # Revision 1.12  2001/09/10 16:25:04  swa
647 # copy all templates. version updated.
648 #
649 # Revision 1.11  2001/07/03 11:00:25  sarantis
650 # replaced permissionsfile with actionsfile
651 #
652 # Revision 1.10  2001/07/03 09:34:44  sarantis
653 # bumped up version number.
654 #
655 # Revision 1.9  2001/06/12 18:15:29  swa
656 # the %% in front of configure (see tag below) confused
657 # the rpm build process on 7.1.
658 #
659 # Revision 1.8  2001/06/12 17:15:56  swa
660 # fixes, because a clean build on rh6.1 was impossible.
661 # GZIP confuses make, %% configure confuses rpm, etc.
662 #
663 # Revision 1.7  2001/06/11 12:17:26  sarantis
664 # fix typo in %%post
665 #
666 # Revision 1.6  2001/06/11 11:28:25  sarantis
667 # Further optimizations and adaptations in the spec file.
668 #
669 # Revision 1.5  2001/06/09 09:14:11  swa
670 # shamelessly adapted RPM stuff from the newest rpm that
671 # RedHat provided for the JB.
672 #
673 # Revision 1.4  2001/06/08 20:54:18  swa
674 # type with status file. remove forward et. al from file list.
675 #
676 # Revision 1.3  2001/06/07 17:28:10  swa
677 # cosmetics
678 #
679 # Revision 1.2  2001/06/04 18:31:58  swa
680 # files are now prefixed with either `confdir' or `logdir'.
681 # `make redhat-dist' replaces both entries confdir and logdir
682 # with redhat values
683 #
684 # Revision 1.1  2001/06/04 10:44:57  swa
685 # `make redhatr-dist' now works. Except for the paths
686 # in the config file.
687 #
688 #
689 #