Just removing some old commentaries.
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.9 2002/03/24 22:03:22 morcego Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # PRIVOXY team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33
34 Name: privoxy
35 Version: 2.9.13
36 Release: 2
37 Summary: Privoxy - privacy enhancing proxy
38 License: GPL
39 Vendor: http://ijbswa.sourceforge.net
40 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
41 BuildRoot: %{_tmppath}/%{name}-%{version}-root
42 Group: Networking/Utilities
43 URL: http://ijbswa.sourceforge.net/
44 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
45 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
46 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
47 BuildRequires: perl gzip sed docbook-utils libtool autoconf
48 Conflicts: junkbuster-raw junkbuster-blank junkbuster
49
50 %description 
51 Privoxy is a web proxy with advanced filtering capabilities for
52 protecting privacy, filtering web page content, managing cookies,
53 controlling access, and removing ads, banners, pop-ups and other
54 obnoxious Internet junk. Privoxy has a very flexible configuration and
55 can be customized to suit individual needs and tastes. Internet
56 Privoxy has application for both stand-alone systems and multi-user
57 networks.
58
59 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
60 was originally written by JunkBusters Corporation, and was released as
61 free open-source software under the GNU GPL. Stefan Waldherr made many
62 improvements, and started the SourceForge project to continue
63 development. Several other developers are now contributing.
64
65 %prep
66 %setup -q -c
67
68 %build
69 autoheader
70 autoconf
71 %configure
72 make 
73 make redhat-dok
74
75 ## Explicitily stripping is not recomended.
76 ## This is handled altomaticaly by RPM, and can couse troubles if
77 ## anyone wants to build an unstriped version - morcego
78 #strip %{name}
79
80 %install
81 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
82 mkdir -p %{buildroot}%{_sbindir} \
83          %{buildroot}%{_mandir}/man1 \
84          %{buildroot}%{_localstatedir}/log/%{name} \
85          %{buildroot}%{privoxyconf}/templates \
86          %{buildroot}%{_sysconfdir}/logrotate.d \
87          %{buildroot}%{_sysconfdir}/rc.d/init.d 
88
89 ## Manual gziping of manpages should not be done, once it can
90 ## break the building on some distributions. Anyway, rpm does it
91 ## automagicaly these days
92 ## Gziping the documentation files is not recomended - morcego
93 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
94
95 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
96
97 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
98 cp -f *.action %{buildroot}%{privoxyconf}/
99 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
100 cp -f trust %{buildroot}%{privoxyconf}/trust
101 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
102 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
103 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
104 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
105
106 # verify all file locations, etc. in the config file
107 # don't start with ^ or commented lines are not replaced
108 ## Changing the sed paramter delimiter to @, so we don't have to
109 ## escape the slashes
110 cat config | \
111     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
112 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
113 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
114 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
115 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
116 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
117 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
118     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
119     %{buildroot}%{privoxyconf}/config
120 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
121     %{buildroot}%{privoxyconf}/default.action
122
123
124 # Creating ghost init files
125 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
126 for i in 0 1 4 6
127 do
128 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
129 done
130 for i in 2 3 5
131 do
132 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
133 done
134
135 ## Macros are expanded even on commentaries. So, we have to use %%
136 ## -- morcego
137 #%%makeinstall
138
139 %pre
140 # This is where we handle old usernames (junkbust and junkbuster)
141 # I'm not sure we should do that, but this is the way we have been
142 # doing it for some time now -- morcego
143 # We should do it for the group as well -- morcego
144 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
145
146 # Change the group name. Remove anything left behind.
147 groupmod -n %{name} %{oldname} > /dev/null 2>&1 ||:
148 groupmod -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
149 groupdel %{oldname} > /dev/null 2>&1 ||:
150 groupdel %{veryoldname} > /dev/null 2>&1 ||:
151
152 # Same for username
153 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
154 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
155 userdel %{oldname} > /dev/null 2>&1 ||:
156 userdel %{veryoldname} > /dev/null 2>&1 ||:
157
158 # Check to see if everything is okey. Create user if it still does not
159 # exist
160 id %{name} > /dev/null 2>&1
161 if [ $? -eq 1 ]; then
162         /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
163 fi
164
165 %post
166 # for upgrade from 2.0.x
167 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
168  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
169 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
170  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
171 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
172 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
173 if [ "$1" = "1" ]; then
174         /sbin/service %{name} condrestart > /dev/null 2>&1
175 fi
176
177 %preun
178 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
179 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
180
181 if [ "$1" = "0" ]; then
182         /sbin/service %{name} stop > /dev/null 2>&1 ||:
183         # No need to use chkconfig. The %%ghost files will handle it
184 fi
185
186 %postun
187 #if [ "$1" -ge "1" ]; then
188 #       /sbin/service %{name} condrestart > /dev/null 2>&1
189 #fi
190 # We only remove it we this is not an upgrade
191 if [ "$1" = "0" ]; then
192         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
193 fi
194
195 %clean
196 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
197
198 %files
199 %defattr(0644,root,root,0755)
200 %doc README AUTHORS ChangeLog
201 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
202 %doc doc/webserver/developer-manual
203 %doc doc/webserver/user-manual
204 %doc doc/webserver/ijb_docs.css
205
206 %dir %{privoxyconf}
207 %dir %{privoxyconf}/templates
208 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
209
210 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
211
212 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
213 # We should not use wildchars here. This could mask missing files problems
214 # -- morcego
215 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
216 %config %{privoxyconf}/config
217 %config %{privoxyconf}/advanced.action
218 %config %{privoxyconf}/basic.action
219 %config %{privoxyconf}/intermediate.action
220 %config %{privoxyconf}/default.action
221 %config %{privoxyconf}/default.filter
222 %config %{privoxyconf}/trust
223
224 %config %{privoxyconf}/templates/blocked
225 %config %{privoxyconf}/templates/blocked-compact
226 %config %{privoxyconf}/templates/cgi-error-404
227 %config %{privoxyconf}/templates/cgi-error-bad-param
228 %config %{privoxyconf}/templates/cgi-error-disabled
229 %config %{privoxyconf}/templates/cgi-error-file
230 %config %{privoxyconf}/templates/cgi-error-modified
231 %config %{privoxyconf}/templates/cgi-error-parse
232 %config %{privoxyconf}/templates/connect-failed
233 %config %{privoxyconf}/templates/default
234 %config %{privoxyconf}/templates/edit-actions-add-url-form
235 %config %{privoxyconf}/templates/edit-actions-for-url
236 %config %{privoxyconf}/templates/edit-actions-list
237 %config %{privoxyconf}/templates/edit-actions-list-section
238 %config %{privoxyconf}/templates/edit-actions-list-url
239 %config %{privoxyconf}/templates/edit-actions-remove-url-form
240 %config %{privoxyconf}/templates/edit-actions-url-form
241 %config %{privoxyconf}/templates/no-such-domain
242 %config %{privoxyconf}/templates/show-request
243 %config %{privoxyconf}/templates/show-status
244 %config %{privoxyconf}/templates/show-status-file
245 %config %{privoxyconf}/templates/show-url-info
246 %config %{privoxyconf}/templates/show-version
247 %config %{privoxyconf}/templates/toggle
248 %config %{privoxyconf}/templates/toggle-mini
249 %config %{privoxyconf}/templates/untrusted
250
251 %config %{_sysconfdir}/logrotate.d/%{name}
252 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
253 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
254 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
255 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
256 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
257 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
258 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
259 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
260
261 %{_mandir}/man1/%{name}.*
262
263 %changelog
264 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
265 + privoxy-2.9.13-2
266 - Fixed the init files entries. Now we use %%ghost
267 - improved username (and groupname) handling on the %%pre section. By improved
268   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
269   got it right. No more Mr. Nice Guy.
270 - Removed the userdel call on %%post. No need, once it's complety handled on
271   the %%pre section
272
273 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
274 + junkbusterng-2.9.13-1
275   Added autoheader. Added autoconf to buildrequires.
276
277 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
278 + junkbusterng-2.9.13-1
279 - Fixed build problems re: name conflicts with man page and logrotate.
280 - Commented out rc?d/* configs for time being, which are causing a build 
281 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
282 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
283
284 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
285 + junkbusterng-2.9.13-1
286 - References to the expression ijb where changed where possible
287 - New package name: junkbusterng (all in lower case, acording to
288   the LSB recomendation)
289 - Version changed to: 2.9.13
290 - Release: 1
291 - Added: junkbuster to obsoletes and conflicts (Not sure this is
292   right. If it obsoletes, why conflict ? Have to check it later)
293 - Summary changed: Stefan, please check and aprove it
294 - Changes description to use the new name
295 - Sed string was NOT changed. Have to wait to the manpage to
296   change first
297 - Keeping the user junkbuster for now. It will require some aditional
298   changes on the script (scheduled for the next specfile release)
299 - Added post entry to move the old logfile to the new log directory
300 - Removing "chkconfig --add" entry (not good to have it automaticaly
301   added to the startup list).
302 - Added preun section to stop the service with the old name, as well
303   as remove it from the startup list
304 - Removed the chkconfig --del entry from the conditional block on
305   the preun scriptlet (now handled on the %files section)
306
307 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
308 - added ijb_docs.css to docs.
309
310 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
311 + junkbuster-2.9.11-8 
312 - Take out --enable-no-gifs, breaks some browsers.
313
314 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
315 + junkbuster-2.9.11-8 
316 - Add --enable-no-gifs to configure.
317
318 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
319 + junkbuster-2.9.11-7
320 - Added BuildRequires to libtool.
321
322 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
323 + junkbuster-2.9.11-6
324 - Changed the routined that handle the junkbust and junkbuster users on
325   %%pre and %%post to work in a smoother manner
326 - %%files now uses hardcoded usernames, to avoid problems with package
327   name changes in the future
328
329 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
330 + junkbuster-2.9.11-5
331 - Added "make redhat-dok" to the build process
332 - Added docbook-utils to BuildRequires
333
334 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
335 + junkbuster-2.9.11-4
336 - Changing man section in the manpage from 1 to 8
337 - We now require packages, not files, to avoid issues with apt
338
339 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
340 + junkbuster-2.9.11-3
341 - Fixing permissions of the init script
342
343 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
344 + junkbuster-2.9.11-2
345 - General specfile fixup, using the best recomended practices, including:
346         - Adding -q to %%setup
347         - Using macros whereever possible
348         - Not using wildchars on %%files section
349         - Doubling the percentage char on changelog and comments, to
350           avoid rpm expanding them
351
352 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
353 - /bin/false for shell causes init script to fail. Reverting.
354
355 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
356 - Removed UID 73. Included user-manual and developer-manual in docs.
357   Include other actions files. Default shell is now /bin/false.
358   Userdel user=junkbust. ChangeLog was not zipped. Removed 
359   RPM_OPT_FLAGS kludge.
360
361 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
362 - add paranoia check for 'rm -rf %%{buildroot}'
363 - add gzip to 'BuildRequires'
364
365 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
366 - actionsfile is now ijb.action.
367
368 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
369 - Compress manpage
370 - Add more documents for installation
371 - Add version string to name and source
372
373 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
374 - Back to user 'junkbuster' and fix configure macro.
375
376 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
377 - More changes for user 'junkbust'. Init script had 'junkbuster'.
378
379 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
380 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
381 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
382
383 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
384 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
385 - made sure no default shell exists for user junkbust.
386
387 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
388 - rework of RPM
389
390 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
391 - CLF Logging patch by davep@cyw.uklinux.net
392 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
393
394 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
395 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
396 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
397   numerous fixes and enhancements for Steve's patch.
398 - adamlock@netscape.com (Adam Lock) in the windows version:
399   - Taskbar activity spinner always spins even when logging is
400   turned off (which is the default) - people who don't
401   like the spinner can turn it off from a menu option.
402   - Taskbar popup menu has a options submenu - people can now
403   open the settings files for cookies, blockers etc.
404   without opening the JB window.
405   - Logging functionality works again
406   - Buffer overflow is fixed - new code uses a bigger buffer
407   and snprintf so it shouldn't overflow anymore.
408 - Fixed userid swa, group learning problem while installing.
409   root must build RPM.
410 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
411   core dump when there is no log file.
412 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
413 - Fixed man page to include imagefile and popupfile.
414 - Sanity check for the statistics function added.
415 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
416  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
417  With IIS/5, it appears to omit the trailing \r\n from http header
418  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
419  responds with a HTTP 302 redirect header.  However, this header
420  message is missing the trailing \r\n.  IIS/5 then closes the
421  connection.  Junkbuster, unfortunately, discards the header becomes
422  it thinks it is incomplete - and it is.  MS have transmitted an
423  incomplete header!
424 - Added bug reports and patch submission forms in the docs.
425
426 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
427        Andrew <anw@tirana.freewire.co.uk> extended the JB:
428        Display of statistics of the total number of requests and the number
429        of requests filtered by junkbuster, also the percentage of requests
430        filtered. Suppression of the listing of files on the proxy-args page.
431        All stuff optional and configurable.
432
433 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
434        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
435        code which prevented the JB from handling URLs of the form
436        user:password@www.foo.com. Fixed.
437
438 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
439         Blank images are no longer cached, thanks to a hint from Markus 
440         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
441         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
442         on the correct browser version nowadays. Incorporated many 
443         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
444         spec file. Fixed logging problem and since runlevel 2 does not 
445         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
446         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
447         <walker@netgate.net>. You should now be able to build this RPM as 
448         a non-root user (mathias@weidner.sem.lipsia.de).
449
450 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
451         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
452         to allow more sophisticated matching of blocked images. Logrotate
453         logfile. Added files for auto-updating the blocklist et al.
454
455 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
456         Configure blank version via config file. No separate blank
457         version anymore. Added Roland's <roland@spinnaker.rhein.de>
458         patch to show a logo instead of a blank area. Added a suggestion
459         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
460         More regexps in the blocklist. Prepared the forwardfile for
461         squid. Extended image regexp with help from gabriel 
462         <somlo@CS.ColoState.EDU>.
463
464 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
465         All RPMs now identify themselves in the show-proxy-args page.
466         Released Windoze version. Run junkbuster as nobody instead of
467         root. 
468
469 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
470         Newest version. First release (hence the little version number
471         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
472         security over 2.0.1; some multi-user sites will need to change 
473         the listen-address in the configuration file. The blank version of
474         the Internet Junkbuster has a more sophisticated way of replacing
475         images. All RPMs identify themselves in the show-proxy-args page.
476
477 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
478         Modified the blocking feature, so that only GIFs and JPEGs are
479         blocked and replaced but not HTML pages. Thanks to 
480         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
481         idea. Added numerous stuff to the blocklist. Keep patches in
482         seperate files and no longer in diffs (easier to maintain).
483
484 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
485         Moved config files to /etc/junkbuster directory, moved man page,
486         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
487         Made new version junkbuster-raw (which is only a stripped version of 
488         the junkuster rpm, i.e. without my blocklist, etc.)
489
490 * Tue Jun 16 1998 (2.0-1)
491         Uhm, not that much. Just a new junkbuster version that
492         fixes a couple of bugs ... and of course a bigger 
493         blocklist with the unique Now-less-ads-than-ever(SM)
494         feature.
495         Oh, one thing: I changed the default user agent to Linux -- no 
496         need anymore to support Apple.
497
498 * Tue Jun 16 1998 (2.0-0)
499         Now-less-ads-than-ever (SM)
500         compiled with gcc instead of cc
501         compiled with -O3, thus it should be a little faster
502         show-proxy-args now works
503         /etc/junkbuster.init wasn't necessary
504
505 * Tue Jun 16 1998 (1.4)
506         some more config files were put into /etc
507         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
508         displayed by Netscape instead of the blocked image.
509         Read http://www.waldherr.org/junkbuster/ for
510         further info.
511
512 * Tue Jun 16 1998 (1.3)
513         The program has been moved to /usr/sbin (from /usr/local/bin)
514         Init- and stopscripts (/etc/rc.d/rc*) have been added so
515         that the junkbuster starts automatically during bootup.
516         The /etc/blocklist file is much more sophisticated. Theoretically
517         one should e.g. browse all major US and German newspapers without
518         seeing one annoying ad.
519         junkbuster.init was modified. It now starts junkbuster with an
520         additional "-r @" flag.
521
522 # $Log: privoxy-rh.spec,v $
523 # Revision 1.9  2002/03/24 22:03:22  morcego
524 # Should be working now. See %changelog for details
525 #
526 # Revision 1.8  2002/03/24 21:13:01  morcego
527 # Tis broken.
528 #
529 # Revision 1.7  2002/03/24 21:07:18  hal9
530 # Add autoheader, etc.
531 #
532 # Revision 1.6  2002/03/24 19:56:40  hal9
533 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
534 #
535 # Revision 1.4  2002/03/24 13:32:42  swa
536 # name change related issues
537 #
538 # Revision 1.3  2002/03/24 12:56:21  swa
539 # name change related issues.
540 #
541 # Revision 1.2  2002/03/24 11:40:14  swa
542 # name change
543 #
544 # Revision 1.1  2002/03/24 11:23:44  swa
545 # name change
546 #
547 # Revision 1.1  2002/03/22 20:53:03  morcego
548 # - Ongoing process to change name to JunkbusterNG
549 # - configure/configure.in: no change needed
550 # - GNUmakefile.in:
551 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
552 #         - PROGRAM    = jbng@EXEEXT@
553 #         - rh-spec now references as junkbusterng-rh.spec
554 #         - redhat-upload: references changed to junkbusterng-* (package names)
555 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
556 #         - tarball-src: now JunkbusterNG-*
557 #         - install: initscript now junkbusterng.init and junkbusterng (when
558 #                    installed)
559 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
560 # - junkbusterng.spec:
561 #         - References to the expression ijb where changed where possible
562 #         - New package name: junkbusterng (all in lower case, acording to
563 #           the LSB recomendation)
564 #         - Version changed to: 2.9.13
565 #         - Release: 1
566 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
567 #           right. If it obsoletes, why conflict ? Have to check it later)
568 #         - Summary changed: Stefan, please check and aprove it
569 #         - Changes description to use the new name
570 #         - Sed string was NOT changed. Have to wait to the manpage to
571 #           change first
572 #         - Keeping the user junkbuster for now. It will require some aditional
573 #           changes on the script (scheduled for the next specfile release)
574 #         - Added post entry to move the old logfile to the new log directory
575 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
576 #           added to the startup list).
577 #         - Added preun section to stop the service with the old name, as well
578 #           as remove it from the startup list
579 #         - Removed the chkconfig --del entry from the conditional block on
580 #           the preun scriptlet (now handled on the %files section)
581 # - junkbuster.init: renamed to junkbusterng.init
582 # - junkbusterng.init:
583 #         - Changed JB_BIN to jbng
584 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
585 #           be used where necessary (config dir)
586 #
587 # Aditional notes:
588 # - The config directory is /etc/junkbuster yet. Have to change it on the
589 # specfile, after it is changes on the code
590 # - The only files that got renamed on the cvs tree were the rh specfile and
591 # the init file. Some file references got changes on the makefile and on the
592 # rh-spec (as listed above)
593 #
594 # Revision 1.43  2002/03/21 16:04:10  hal9
595 # added ijb_docs.css to %doc
596 #
597 # Revision 1.42  2002/03/12 13:41:18  sarantis
598 # remove hard-coded "ijbswa" string in build phase
599 #
600 # Revision 1.41  2002/03/11 22:58:32  hal9
601 # Remove --enable-no-gifs
602 #
603 # Revision 1.39  2002/03/08 18:57:29  swa
604 # remove user junkbuster after de-installation.
605 #
606 # Revision 1.38  2002/03/08 13:45:27  morcego
607 # Adding libtool to Buildrequires
608 #
609 # Revision 1.37  2002/03/07 19:23:49  swa
610 # i hate to scroll. suse: wrong configdir.
611 #
612 # Revision 1.36  2002/03/07 05:06:54  morcego
613 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
614 #
615 # Revision 1.34  2002/03/07 00:11:57  morcego
616 # Few changes on the %pre and %post sections of the rh specfile to handle
617 # usernames more cleanly
618 #
619 # Revision 1.33  2002/03/05 13:13:57  morcego
620 # - Added "make redhat-dok" to the build phase
621 # - Added docbook-utils to BuildRequires
622 #
623 # Revision 1.32  2002/03/05 12:34:24  morcego
624 # - Changing section internaly on the manpage from 1 to 8
625 # - We now require packages, not files, to avoid issues with apt
626 #
627 # Revision 1.31  2002/03/04 18:06:09  morcego
628 # SPECFILE: fixing permissing of the init script (broken by the last change)
629 #
630 # Revision 1.30  2002/03/04 16:18:03  morcego
631 # General cleanup of the rh specfile.
632 #
633 # %changelog
634 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
635 # + junkbuster-2.9.11-2
636 # - General specfile fixup, using the best recomended practices, including:
637 #         - Adding -q to %%setup
638 #         - Using macros whereever possible
639 #         - Not using wildchars on %%files section
640 #         - Doubling the percentage char on changelog and comments, to
641 #           avoid rpm expanding them
642 #
643 # Revision 1.29  2002/03/03 19:21:22  hal9
644 # Init script fails if shell is /bin/false.
645 #
646 # Revision 1.28  2002/01/09 18:34:03  hal9
647 # nit.
648 #
649 # Revision 1.27  2002/01/09 18:32:02  hal9
650 # Removed RPM_OPT_FLAGS kludge.
651 #
652 # Revision 1.26  2002/01/09 18:21:10  hal9
653 # A few minor updates.
654 #
655 # Revision 1.25  2001/12/28 01:45:36  steudten
656 # Add paranoia check and BuildReq: gzip
657 #
658 # Revision 1.24  2001/12/01 21:43:14  hal9
659 # Allowed for new ijb.action file.
660 #
661 # Revision 1.23  2001/11/06 12:09:03  steudten
662 # Compress doc files. Install README and AUTHORS at last as document.
663 #
664 # Revision 1.22  2001/11/05 21:37:34  steudten
665 # Fix to include the actual version for name.
666 # Let the 'real' packager be included - sorry stefan.
667 #
668 # Revision 1.21  2001/10/31 19:27:27  swa
669 # consistent description. new name for suse since
670 # we had troubles with rpms of identical names
671 # on the webserver.
672 #
673 # Revision 1.20  2001/10/24 15:45:49  hal9
674 # To keep Thomas happy (aka correcting my  mistakes)
675 #
676 # Revision 1.19  2001/10/15 03:23:59  hal9
677 # Nits.
678 #
679 # Revision 1.17  2001/10/10 18:59:28  hal9
680 # Minor change for init script.
681 #
682 # Revision 1.16  2001/09/24 20:56:23  hal9
683 # Minor changes.
684 #
685 # Revision 1.13  2001/09/10 17:44:43  swa
686 # integrate three pieces of documentation. needs work.
687 # will not build cleanly under redhat.
688 #
689 # Revision 1.12  2001/09/10 16:25:04  swa
690 # copy all templates. version updated.
691 #
692 # Revision 1.11  2001/07/03 11:00:25  sarantis
693 # replaced permissionsfile with actionsfile
694 #
695 # Revision 1.10  2001/07/03 09:34:44  sarantis
696 # bumped up version number.
697 #
698 # Revision 1.9  2001/06/12 18:15:29  swa
699 # the %% in front of configure (see tag below) confused
700 # the rpm build process on 7.1.
701 #
702 # Revision 1.8  2001/06/12 17:15:56  swa
703 # fixes, because a clean build on rh6.1 was impossible.
704 # GZIP confuses make, %% configure confuses rpm, etc.
705 #
706 # Revision 1.7  2001/06/11 12:17:26  sarantis
707 # fix typo in %%post
708 #
709 # Revision 1.6  2001/06/11 11:28:25  sarantis
710 # Further optimizations and adaptations in the spec file.
711 #
712 # Revision 1.5  2001/06/09 09:14:11  swa
713 # shamelessly adapted RPM stuff from the newest rpm that
714 # RedHat provided for the JB.
715 #
716 # Revision 1.4  2001/06/08 20:54:18  swa
717 # type with status file. remove forward et. al from file list.
718 #
719 # Revision 1.3  2001/06/07 17:28:10  swa
720 # cosmetics
721 #
722 # Revision 1.2  2001/06/04 18:31:58  swa
723 # files are now prefixed with either `confdir' or `logdir'.
724 # `make redhat-dist' replaces both entries confdir and logdir
725 # with redhat values
726 #
727 # Revision 1.1  2001/06/04 10:44:57  swa
728 # `make redhatr-dist' now works. Except for the paths
729 # in the config file.
730 #
731 #
732 #