Added faq to docs.
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.10 2002/03/24 22:16:14 morcego Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # PRIVOXY team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33
34 Name: privoxy
35 Version: 2.9.13
36 Release: 1
37 Summary: Privoxy - privacy enhancing proxy
38 License: GPL
39 Vendor: http://ijbswa.sourceforge.net
40 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
41 BuildRoot: %{_tmppath}/%{name}-%{version}-root
42 Group: Networking/Utilities
43 URL: http://ijbswa.sourceforge.net/
44 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
45 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
46 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
47 BuildRequires: perl gzip sed docbook-utils libtool autoconf
48 Conflicts: junkbuster-raw junkbuster-blank junkbuster
49
50 %description 
51 Privoxy is a web proxy with advanced filtering capabilities for
52 protecting privacy, filtering web page content, managing cookies,
53 controlling access, and removing ads, banners, pop-ups and other
54 obnoxious Internet junk. Privoxy has a very flexible configuration and
55 can be customized to suit individual needs and tastes. Internet
56 Privoxy has application for both stand-alone systems and multi-user
57 networks.
58
59 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
60 was originally written by JunkBusters Corporation, and was released as
61 free open-source software under the GNU GPL. Stefan Waldherr made many
62 improvements, and started the SourceForge project to continue
63 development. Several other developers are now contributing.
64
65 %prep
66 %setup -q -c
67
68 %build
69 autoheader
70 autoconf
71 %configure
72 make 
73 make redhat-dok
74
75 ## Explicitily stripping is not recomended.
76 ## This is handled altomaticaly by RPM, and can couse troubles if
77 ## anyone wants to build an unstriped version - morcego
78 #strip %{name}
79
80 %install
81 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
82 mkdir -p %{buildroot}%{_sbindir} \
83          %{buildroot}%{_mandir}/man1 \
84          %{buildroot}%{_localstatedir}/log/%{name} \
85          %{buildroot}%{privoxyconf}/templates \
86          %{buildroot}%{_sysconfdir}/logrotate.d \
87          %{buildroot}%{_sysconfdir}/rc.d/init.d 
88
89 ## Manual gziping of manpages should not be done, once it can
90 ## break the building on some distributions. Anyway, rpm does it
91 ## automagicaly these days
92 ## Gziping the documentation files is not recomended - morcego
93 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
94
95 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
96
97 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
98 cp -f *.action %{buildroot}%{privoxyconf}/
99 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
100 cp -f trust %{buildroot}%{privoxyconf}/trust
101 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
102 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
103 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
104 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
105
106 # verify all file locations, etc. in the config file
107 # don't start with ^ or commented lines are not replaced
108 ## Changing the sed paramter delimiter to @, so we don't have to
109 ## escape the slashes
110 cat config | \
111     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
112 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
113 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
114 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
115 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
116 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
117 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
118     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
119     %{buildroot}%{privoxyconf}/config
120 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
121     %{buildroot}%{privoxyconf}/default.action
122
123
124 # Creating ghost init files
125 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
126 for i in 0 1 4 6
127 do
128 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
129 done
130 for i in 2 3 5
131 do
132 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
133 done
134
135 ## Macros are expanded even on commentaries. So, we have to use %%
136 ## -- morcego
137 #%%makeinstall
138
139 %pre
140 # This is where we handle old usernames (junkbust and junkbuster)
141 # I'm not sure we should do that, but this is the way we have been
142 # doing it for some time now -- morcego
143 # We should do it for the group as well -- morcego
144 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
145
146 # Change the group name. Remove anything left behind.
147 groupmod -n %{name} %{oldname} > /dev/null 2>&1 ||:
148 groupmod -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
149 groupdel %{oldname} > /dev/null 2>&1 ||:
150 groupdel %{veryoldname} > /dev/null 2>&1 ||:
151
152 # Same for username
153 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
154 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
155 userdel %{oldname} > /dev/null 2>&1 ||:
156 userdel %{veryoldname} > /dev/null 2>&1 ||:
157
158 # Check to see if everything is okey. Create user if it still does not
159 # exist
160 id %{name} > /dev/null 2>&1
161 if [ $? -eq 1 ]; then
162         /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
163 fi
164
165 %post
166 # for upgrade from 2.0.x
167 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
168  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
169 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
170  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
171 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
172 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
173 if [ "$1" = "1" ]; then
174         /sbin/service %{name} condrestart > /dev/null 2>&1
175 fi
176
177 %preun
178 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
179 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
180
181 if [ "$1" = "0" ]; then
182         /sbin/service %{name} stop > /dev/null 2>&1 ||:
183         # No need to use chkconfig. The %%ghost files will handle it
184 fi
185
186 %postun
187 #if [ "$1" -ge "1" ]; then
188 #       /sbin/service %{name} condrestart > /dev/null 2>&1
189 #fi
190 # We only remove it we this is not an upgrade
191 if [ "$1" = "0" ]; then
192         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
193 fi
194
195 %clean
196 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
197
198 %files
199 %defattr(0644,root,root,0755)
200 %doc README AUTHORS ChangeLog
201 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
202 %doc doc/webserver/developer-manual
203 %doc doc/webserver/user-manual
204 %doc doc/webserver/faq
205 %doc doc/webserver/ijb_docs.css
206
207 %dir %{privoxyconf}
208 %dir %{privoxyconf}/templates
209 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
210
211 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
212
213 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
214 # We should not use wildchars here. This could mask missing files problems
215 # -- morcego
216 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
217 %config %{privoxyconf}/config
218 %config %{privoxyconf}/advanced.action
219 %config %{privoxyconf}/basic.action
220 %config %{privoxyconf}/intermediate.action
221 %config %{privoxyconf}/default.action
222 %config %{privoxyconf}/default.filter
223 %config %{privoxyconf}/trust
224
225 %config %{privoxyconf}/templates/blocked
226 %config %{privoxyconf}/templates/blocked-compact
227 %config %{privoxyconf}/templates/cgi-error-404
228 %config %{privoxyconf}/templates/cgi-error-bad-param
229 %config %{privoxyconf}/templates/cgi-error-disabled
230 %config %{privoxyconf}/templates/cgi-error-file
231 %config %{privoxyconf}/templates/cgi-error-modified
232 %config %{privoxyconf}/templates/cgi-error-parse
233 %config %{privoxyconf}/templates/connect-failed
234 %config %{privoxyconf}/templates/default
235 %config %{privoxyconf}/templates/edit-actions-add-url-form
236 %config %{privoxyconf}/templates/edit-actions-for-url
237 %config %{privoxyconf}/templates/edit-actions-list
238 %config %{privoxyconf}/templates/edit-actions-list-section
239 %config %{privoxyconf}/templates/edit-actions-list-url
240 %config %{privoxyconf}/templates/edit-actions-remove-url-form
241 %config %{privoxyconf}/templates/edit-actions-url-form
242 %config %{privoxyconf}/templates/no-such-domain
243 %config %{privoxyconf}/templates/show-request
244 %config %{privoxyconf}/templates/show-status
245 %config %{privoxyconf}/templates/show-status-file
246 %config %{privoxyconf}/templates/show-url-info
247 %config %{privoxyconf}/templates/show-version
248 %config %{privoxyconf}/templates/toggle
249 %config %{privoxyconf}/templates/toggle-mini
250 %config %{privoxyconf}/templates/untrusted
251
252 %config %{_sysconfdir}/logrotate.d/%{name}
253 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
254 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
255 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
256 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
257 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
258 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
259 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
260 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
261
262 %{_mandir}/man1/%{name}.*
263
264 %changelog
265 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
266 + privoxy-2.9.13-2
267 - Fixed the init files entries. Now we use %%ghost
268 - improved username (and groupname) handling on the %%pre section. By improved
269   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
270   got it right. No more Mr. Nice Guy.
271 - Removed the userdel call on %%post. No need, once it's complety handled on
272   the %%pre section
273
274 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
275 + junkbusterng-2.9.13-1
276   Added autoheader. Added autoconf to buildrequires.
277
278 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
279 + junkbusterng-2.9.13-1
280 - Fixed build problems re: name conflicts with man page and logrotate.
281 - Commented out rc?d/* configs for time being, which are causing a build 
282 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
283 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
284
285 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
286 + junkbusterng-2.9.13-1
287 - References to the expression ijb where changed where possible
288 - New package name: junkbusterng (all in lower case, acording to
289   the LSB recomendation)
290 - Version changed to: 2.9.13
291 - Release: 1
292 - Added: junkbuster to obsoletes and conflicts (Not sure this is
293   right. If it obsoletes, why conflict ? Have to check it later)
294 - Summary changed: Stefan, please check and aprove it
295 - Changes description to use the new name
296 - Sed string was NOT changed. Have to wait to the manpage to
297   change first
298 - Keeping the user junkbuster for now. It will require some aditional
299   changes on the script (scheduled for the next specfile release)
300 - Added post entry to move the old logfile to the new log directory
301 - Removing "chkconfig --add" entry (not good to have it automaticaly
302   added to the startup list).
303 - Added preun section to stop the service with the old name, as well
304   as remove it from the startup list
305 - Removed the chkconfig --del entry from the conditional block on
306   the preun scriptlet (now handled on the %files section)
307
308 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
309 - added ijb_docs.css to docs.
310
311 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
312 + junkbuster-2.9.11-8 
313 - Take out --enable-no-gifs, breaks some browsers.
314
315 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
316 + junkbuster-2.9.11-8 
317 - Add --enable-no-gifs to configure.
318
319 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
320 + junkbuster-2.9.11-7
321 - Added BuildRequires to libtool.
322
323 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
324 + junkbuster-2.9.11-6
325 - Changed the routined that handle the junkbust and junkbuster users on
326   %%pre and %%post to work in a smoother manner
327 - %%files now uses hardcoded usernames, to avoid problems with package
328   name changes in the future
329
330 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
331 + junkbuster-2.9.11-5
332 - Added "make redhat-dok" to the build process
333 - Added docbook-utils to BuildRequires
334
335 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
336 + junkbuster-2.9.11-4
337 - Changing man section in the manpage from 1 to 8
338 - We now require packages, not files, to avoid issues with apt
339
340 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
341 + junkbuster-2.9.11-3
342 - Fixing permissions of the init script
343
344 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
345 + junkbuster-2.9.11-2
346 - General specfile fixup, using the best recomended practices, including:
347         - Adding -q to %%setup
348         - Using macros whereever possible
349         - Not using wildchars on %%files section
350         - Doubling the percentage char on changelog and comments, to
351           avoid rpm expanding them
352
353 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
354 - /bin/false for shell causes init script to fail. Reverting.
355
356 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
357 - Removed UID 73. Included user-manual and developer-manual in docs.
358   Include other actions files. Default shell is now /bin/false.
359   Userdel user=junkbust. ChangeLog was not zipped. Removed 
360   RPM_OPT_FLAGS kludge.
361
362 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
363 - add paranoia check for 'rm -rf %%{buildroot}'
364 - add gzip to 'BuildRequires'
365
366 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
367 - actionsfile is now ijb.action.
368
369 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
370 - Compress manpage
371 - Add more documents for installation
372 - Add version string to name and source
373
374 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
375 - Back to user 'junkbuster' and fix configure macro.
376
377 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
378 - More changes for user 'junkbust'. Init script had 'junkbuster'.
379
380 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
381 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
382 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
383
384 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
385 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
386 - made sure no default shell exists for user junkbust.
387
388 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
389 - rework of RPM
390
391 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
392 - CLF Logging patch by davep@cyw.uklinux.net
393 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
394
395 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
396 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
397 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
398   numerous fixes and enhancements for Steve's patch.
399 - adamlock@netscape.com (Adam Lock) in the windows version:
400   - Taskbar activity spinner always spins even when logging is
401   turned off (which is the default) - people who don't
402   like the spinner can turn it off from a menu option.
403   - Taskbar popup menu has a options submenu - people can now
404   open the settings files for cookies, blockers etc.
405   without opening the JB window.
406   - Logging functionality works again
407   - Buffer overflow is fixed - new code uses a bigger buffer
408   and snprintf so it shouldn't overflow anymore.
409 - Fixed userid swa, group learning problem while installing.
410   root must build RPM.
411 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
412   core dump when there is no log file.
413 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
414 - Fixed man page to include imagefile and popupfile.
415 - Sanity check for the statistics function added.
416 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
417  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
418  With IIS/5, it appears to omit the trailing \r\n from http header
419  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
420  responds with a HTTP 302 redirect header.  However, this header
421  message is missing the trailing \r\n.  IIS/5 then closes the
422  connection.  Junkbuster, unfortunately, discards the header becomes
423  it thinks it is incomplete - and it is.  MS have transmitted an
424  incomplete header!
425 - Added bug reports and patch submission forms in the docs.
426
427 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
428        Andrew <anw@tirana.freewire.co.uk> extended the JB:
429        Display of statistics of the total number of requests and the number
430        of requests filtered by junkbuster, also the percentage of requests
431        filtered. Suppression of the listing of files on the proxy-args page.
432        All stuff optional and configurable.
433
434 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
435        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
436        code which prevented the JB from handling URLs of the form
437        user:password@www.foo.com. Fixed.
438
439 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
440         Blank images are no longer cached, thanks to a hint from Markus 
441         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
442         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
443         on the correct browser version nowadays. Incorporated many 
444         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
445         spec file. Fixed logging problem and since runlevel 2 does not 
446         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
447         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
448         <walker@netgate.net>. You should now be able to build this RPM as 
449         a non-root user (mathias@weidner.sem.lipsia.de).
450
451 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
452         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
453         to allow more sophisticated matching of blocked images. Logrotate
454         logfile. Added files for auto-updating the blocklist et al.
455
456 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
457         Configure blank version via config file. No separate blank
458         version anymore. Added Roland's <roland@spinnaker.rhein.de>
459         patch to show a logo instead of a blank area. Added a suggestion
460         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
461         More regexps in the blocklist. Prepared the forwardfile for
462         squid. Extended image regexp with help from gabriel 
463         <somlo@CS.ColoState.EDU>.
464
465 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
466         All RPMs now identify themselves in the show-proxy-args page.
467         Released Windoze version. Run junkbuster as nobody instead of
468         root. 
469
470 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
471         Newest version. First release (hence the little version number
472         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
473         security over 2.0.1; some multi-user sites will need to change 
474         the listen-address in the configuration file. The blank version of
475         the Internet Junkbuster has a more sophisticated way of replacing
476         images. All RPMs identify themselves in the show-proxy-args page.
477
478 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
479         Modified the blocking feature, so that only GIFs and JPEGs are
480         blocked and replaced but not HTML pages. Thanks to 
481         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
482         idea. Added numerous stuff to the blocklist. Keep patches in
483         seperate files and no longer in diffs (easier to maintain).
484
485 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
486         Moved config files to /etc/junkbuster directory, moved man page,
487         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
488         Made new version junkbuster-raw (which is only a stripped version of 
489         the junkuster rpm, i.e. without my blocklist, etc.)
490
491 * Tue Jun 16 1998 (2.0-1)
492         Uhm, not that much. Just a new junkbuster version that
493         fixes a couple of bugs ... and of course a bigger 
494         blocklist with the unique Now-less-ads-than-ever(SM)
495         feature.
496         Oh, one thing: I changed the default user agent to Linux -- no 
497         need anymore to support Apple.
498
499 * Tue Jun 16 1998 (2.0-0)
500         Now-less-ads-than-ever (SM)
501         compiled with gcc instead of cc
502         compiled with -O3, thus it should be a little faster
503         show-proxy-args now works
504         /etc/junkbuster.init wasn't necessary
505
506 * Tue Jun 16 1998 (1.4)
507         some more config files were put into /etc
508         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
509         displayed by Netscape instead of the blocked image.
510         Read http://www.waldherr.org/junkbuster/ for
511         further info.
512
513 * Tue Jun 16 1998 (1.3)
514         The program has been moved to /usr/sbin (from /usr/local/bin)
515         Init- and stopscripts (/etc/rc.d/rc*) have been added so
516         that the junkbuster starts automatically during bootup.
517         The /etc/blocklist file is much more sophisticated. Theoretically
518         one should e.g. browse all major US and German newspapers without
519         seeing one annoying ad.
520         junkbuster.init was modified. It now starts junkbuster with an
521         additional "-r @" flag.
522
523 # $Log: privoxy-rh.spec,v $
524 # Revision 1.10  2002/03/24 22:16:14  morcego
525 # Just removing some old commentaries.
526 #
527 # Revision 1.9  2002/03/24 22:03:22  morcego
528 # Should be working now. See %changelog for details
529 #
530 # Revision 1.8  2002/03/24 21:13:01  morcego
531 # Tis broken.
532 #
533 # Revision 1.7  2002/03/24 21:07:18  hal9
534 # Add autoheader, etc.
535 #
536 # Revision 1.6  2002/03/24 19:56:40  hal9
537 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
538 #
539 # Revision 1.4  2002/03/24 13:32:42  swa
540 # name change related issues
541 #
542 # Revision 1.3  2002/03/24 12:56:21  swa
543 # name change related issues.
544 #
545 # Revision 1.2  2002/03/24 11:40:14  swa
546 # name change
547 #
548 # Revision 1.1  2002/03/24 11:23:44  swa
549 # name change
550 #
551 # Revision 1.1  2002/03/22 20:53:03  morcego
552 # - Ongoing process to change name to JunkbusterNG
553 # - configure/configure.in: no change needed
554 # - GNUmakefile.in:
555 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
556 #         - PROGRAM    = jbng@EXEEXT@
557 #         - rh-spec now references as junkbusterng-rh.spec
558 #         - redhat-upload: references changed to junkbusterng-* (package names)
559 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
560 #         - tarball-src: now JunkbusterNG-*
561 #         - install: initscript now junkbusterng.init and junkbusterng (when
562 #                    installed)
563 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
564 # - junkbusterng.spec:
565 #         - References to the expression ijb where changed where possible
566 #         - New package name: junkbusterng (all in lower case, acording to
567 #           the LSB recomendation)
568 #         - Version changed to: 2.9.13
569 #         - Release: 1
570 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
571 #           right. If it obsoletes, why conflict ? Have to check it later)
572 #         - Summary changed: Stefan, please check and aprove it
573 #         - Changes description to use the new name
574 #         - Sed string was NOT changed. Have to wait to the manpage to
575 #           change first
576 #         - Keeping the user junkbuster for now. It will require some aditional
577 #           changes on the script (scheduled for the next specfile release)
578 #         - Added post entry to move the old logfile to the new log directory
579 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
580 #           added to the startup list).
581 #         - Added preun section to stop the service with the old name, as well
582 #           as remove it from the startup list
583 #         - Removed the chkconfig --del entry from the conditional block on
584 #           the preun scriptlet (now handled on the %files section)
585 # - junkbuster.init: renamed to junkbusterng.init
586 # - junkbusterng.init:
587 #         - Changed JB_BIN to jbng
588 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
589 #           be used where necessary (config dir)
590 #
591 # Aditional notes:
592 # - The config directory is /etc/junkbuster yet. Have to change it on the
593 # specfile, after it is changes on the code
594 # - The only files that got renamed on the cvs tree were the rh specfile and
595 # the init file. Some file references got changes on the makefile and on the
596 # rh-spec (as listed above)
597 #
598 # Revision 1.43  2002/03/21 16:04:10  hal9
599 # added ijb_docs.css to %doc
600 #
601 # Revision 1.42  2002/03/12 13:41:18  sarantis
602 # remove hard-coded "ijbswa" string in build phase
603 #
604 # Revision 1.41  2002/03/11 22:58:32  hal9
605 # Remove --enable-no-gifs
606 #
607 # Revision 1.39  2002/03/08 18:57:29  swa
608 # remove user junkbuster after de-installation.
609 #
610 # Revision 1.38  2002/03/08 13:45:27  morcego
611 # Adding libtool to Buildrequires
612 #
613 # Revision 1.37  2002/03/07 19:23:49  swa
614 # i hate to scroll. suse: wrong configdir.
615 #
616 # Revision 1.36  2002/03/07 05:06:54  morcego
617 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
618 #
619 # Revision 1.34  2002/03/07 00:11:57  morcego
620 # Few changes on the %pre and %post sections of the rh specfile to handle
621 # usernames more cleanly
622 #
623 # Revision 1.33  2002/03/05 13:13:57  morcego
624 # - Added "make redhat-dok" to the build phase
625 # - Added docbook-utils to BuildRequires
626 #
627 # Revision 1.32  2002/03/05 12:34:24  morcego
628 # - Changing section internaly on the manpage from 1 to 8
629 # - We now require packages, not files, to avoid issues with apt
630 #
631 # Revision 1.31  2002/03/04 18:06:09  morcego
632 # SPECFILE: fixing permissing of the init script (broken by the last change)
633 #
634 # Revision 1.30  2002/03/04 16:18:03  morcego
635 # General cleanup of the rh specfile.
636 #
637 # %changelog
638 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
639 # + junkbuster-2.9.11-2
640 # - General specfile fixup, using the best recomended practices, including:
641 #         - Adding -q to %%setup
642 #         - Using macros whereever possible
643 #         - Not using wildchars on %%files section
644 #         - Doubling the percentage char on changelog and comments, to
645 #           avoid rpm expanding them
646 #
647 # Revision 1.29  2002/03/03 19:21:22  hal9
648 # Init script fails if shell is /bin/false.
649 #
650 # Revision 1.28  2002/01/09 18:34:03  hal9
651 # nit.
652 #
653 # Revision 1.27  2002/01/09 18:32:02  hal9
654 # Removed RPM_OPT_FLAGS kludge.
655 #
656 # Revision 1.26  2002/01/09 18:21:10  hal9
657 # A few minor updates.
658 #
659 # Revision 1.25  2001/12/28 01:45:36  steudten
660 # Add paranoia check and BuildReq: gzip
661 #
662 # Revision 1.24  2001/12/01 21:43:14  hal9
663 # Allowed for new ijb.action file.
664 #
665 # Revision 1.23  2001/11/06 12:09:03  steudten
666 # Compress doc files. Install README and AUTHORS at last as document.
667 #
668 # Revision 1.22  2001/11/05 21:37:34  steudten
669 # Fix to include the actual version for name.
670 # Let the 'real' packager be included - sorry stefan.
671 #
672 # Revision 1.21  2001/10/31 19:27:27  swa
673 # consistent description. new name for suse since
674 # we had troubles with rpms of identical names
675 # on the webserver.
676 #
677 # Revision 1.20  2001/10/24 15:45:49  hal9
678 # To keep Thomas happy (aka correcting my  mistakes)
679 #
680 # Revision 1.19  2001/10/15 03:23:59  hal9
681 # Nits.
682 #
683 # Revision 1.17  2001/10/10 18:59:28  hal9
684 # Minor change for init script.
685 #
686 # Revision 1.16  2001/09/24 20:56:23  hal9
687 # Minor changes.
688 #
689 # Revision 1.13  2001/09/10 17:44:43  swa
690 # integrate three pieces of documentation. needs work.
691 # will not build cleanly under redhat.
692 #
693 # Revision 1.12  2001/09/10 16:25:04  swa
694 # copy all templates. version updated.
695 #
696 # Revision 1.11  2001/07/03 11:00:25  sarantis
697 # replaced permissionsfile with actionsfile
698 #
699 # Revision 1.10  2001/07/03 09:34:44  sarantis
700 # bumped up version number.
701 #
702 # Revision 1.9  2001/06/12 18:15:29  swa
703 # the %% in front of configure (see tag below) confused
704 # the rpm build process on 7.1.
705 #
706 # Revision 1.8  2001/06/12 17:15:56  swa
707 # fixes, because a clean build on rh6.1 was impossible.
708 # GZIP confuses make, %% configure confuses rpm, etc.
709 #
710 # Revision 1.7  2001/06/11 12:17:26  sarantis
711 # fix typo in %%post
712 #
713 # Revision 1.6  2001/06/11 11:28:25  sarantis
714 # Further optimizations and adaptations in the spec file.
715 #
716 # Revision 1.5  2001/06/09 09:14:11  swa
717 # shamelessly adapted RPM stuff from the newest rpm that
718 # RedHat provided for the JB.
719 #
720 # Revision 1.4  2001/06/08 20:54:18  swa
721 # type with status file. remove forward et. al from file list.
722 #
723 # Revision 1.3  2001/06/07 17:28:10  swa
724 # cosmetics
725 #
726 # Revision 1.2  2001/06/04 18:31:58  swa
727 # files are now prefixed with either `confdir' or `logdir'.
728 # `make redhat-dist' replaces both entries confdir and logdir
729 # with redhat values
730 #
731 # Revision 1.1  2001/06/04 10:44:57  swa
732 # `make redhatr-dist' now works. Except for the paths
733 # in the config file.
734 #
735 #
736 #