eb5ae307addfb6706c4ec291f724974e663a6f2b
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.20 2002/04/08 20:27:45 swa Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33
34 Name: privoxy
35 # ATTENTION
36 # Version and release should be updated acordingly on configure.in and
37 # configure. Otherwise, the package can be build with the wrong value
38 Version: 2.9.14
39 Release: 4
40 Summary: Privoxy - privacy enhancing proxy
41 License: GPL
42 Vendor: http://www.privoxy.org
43 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
44 BuildRoot: %{_tmppath}/%{name}-%{version}-root
45 Group: Networking/Utilities
46 URL: http://www.privoxy.org/
47 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
48 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
49 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
50 BuildRequires: perl gzip sed docbook-utils libtool autoconf docbook-style-dsssl docbook-dtd31-sgml
51 Conflicts: junkbuster-raw junkbuster-blank junkbuster
52
53 %description 
54 Privoxy is a web proxy with advanced filtering capabilities for
55 protecting privacy, filtering web page content, managing cookies,
56 controlling access, and removing ads, banners, pop-ups and other
57 obnoxious Internet junk. Privoxy has a very flexible configuration and
58 can be customized to suit individual needs and tastes. Privoxy has application
59 for both stand-alone systems and multi-user networks.
60
61 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
62 was originally written by Junkbusters Corporation, and was released as
63 free open-source software under the GNU GPL. Stefan Waldherr made many
64 improvements, and started the SourceForge project to continue
65 development. Several other developers are now contributing.
66
67 %prep
68 %setup -q -c
69
70 %build
71 autoheader
72 autoconf
73 %configure
74 make 
75 make dok
76
77 ## Explicitily stripping is not recomended.
78 ## This is handled altomaticaly by RPM, and can couse troubles if
79 ## anyone wants to build an unstriped version - morcego
80 #strip %{name}
81
82 %install
83 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
84 mkdir -p %{buildroot}%{_sbindir} \
85          %{buildroot}%{_mandir}/man1 \
86          %{buildroot}%{_localstatedir}/log/%{name} \
87          %{buildroot}%{privoxyconf}/templates \
88          %{buildroot}%{_sysconfdir}/logrotate.d \
89          %{buildroot}%{_sysconfdir}/rc.d/init.d 
90
91 ## Manual gziping of manpages should not be done, once it can
92 ## break the building on some distributions. Anyway, rpm does it
93 ## automagicaly these days
94 ## Gziping the documentation files is not recomended - morcego
95 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
96
97 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
98
99 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
100 cp -f *.action %{buildroot}%{privoxyconf}/
101 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
102 cp -f trust %{buildroot}%{privoxyconf}/trust
103 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
104 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
105 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
106 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
107
108 # verify all file locations, etc. in the config file
109 # don't start with ^ or commented lines are not replaced
110 ## Changing the sed paramter delimiter to @, so we don't have to
111 ## escape the slashes
112 cat config | \
113     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
114 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
115 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
116 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
117 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
118 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
119 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
120     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
121     %{buildroot}%{privoxyconf}/config
122 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
123     %{buildroot}%{privoxyconf}/default.action
124
125
126 # Creating ghost init files
127 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
128 for i in 0 1 4 6
129 do
130 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
131 done
132 for i in 2 3 5
133 do
134 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
135 done
136
137 ## Macros are expanded even on commentaries. So, we have to use %%
138 ## -- morcego
139 #%%makeinstall
140
141 %pre
142 # This is where we handle old usernames (junkbust and junkbuster)
143 # I'm not sure we should do that, but this is the way we have been
144 # doing it for some time now -- morcego
145 # We should do it for the group as well -- morcego
146 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
147
148 # Change the group name. Remove anything left behind.
149 groupmod -n %{name} %{oldname} > /dev/null 2>&1 ||:
150 groupmod -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
151 groupdel %{oldname} > /dev/null 2>&1 ||:
152 groupdel %{veryoldname} > /dev/null 2>&1 ||:
153
154 # Same for username
155 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
156 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
157 userdel %{oldname} > /dev/null 2>&1 ||:
158 userdel %{veryoldname} > /dev/null 2>&1 ||:
159
160 # Check to see if everything is okey. Create user if it still does not
161 # exist
162 id %{name} > /dev/null 2>&1
163 if [ $? -eq 1 ]; then
164         /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
165 fi
166
167 %post
168 # for upgrade from 2.0.x
169 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
170  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
171 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
172  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
173 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
174 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
175 if [ "$1" = "1" ]; then
176         /sbin/service %{name} condrestart > /dev/null 2>&1
177 fi
178
179 %preun
180 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
181 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
182
183 if [ "$1" = "0" ]; then
184         /sbin/service %{name} stop > /dev/null 2>&1 ||:
185         # No need to use chkconfig. The %%ghost files will handle it
186 fi
187
188 %postun
189 #if [ "$1" -ge "1" ]; then
190 #       /sbin/service %{name} condrestart > /dev/null 2>&1
191 #fi
192 # We only remove it we this is not an upgrade
193 if [ "$1" = "0" ]; then
194         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
195 fi
196
197 %clean
198 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
199
200 %files
201 %defattr(0644,root,root,0755)
202 %doc README AUTHORS ChangeLog LICENSE 
203 %doc doc/text/developer-manual.txt doc/text/user-manual.txt doc/text/faq.txt
204 %doc doc/webserver/developer-manual
205 %doc doc/webserver/user-manual
206 %doc doc/webserver/faq
207 %doc doc/webserver/p_doc.css doc/webserver/p_web.css doc/webserver/index.html
208
209 %dir %{privoxyconf}
210 %dir %{privoxyconf}/templates
211 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
212
213 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
214
215 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
216 # We should not use wildchars here. This could mask missing files problems
217 # -- morcego
218 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
219 %config %{privoxyconf}/config
220 %config %{privoxyconf}/advanced.action
221 %config %{privoxyconf}/basic.action
222 %config %{privoxyconf}/intermediate.action
223 %config %{privoxyconf}/default.action
224 %config %{privoxyconf}/default.filter
225 %config %{privoxyconf}/trust
226
227 %config %{privoxyconf}/templates/blocked
228 %config %{privoxyconf}/templates/cgi-error-404
229 %config %{privoxyconf}/templates/cgi-error-bad-param
230 %config %{privoxyconf}/templates/cgi-error-disabled
231 %config %{privoxyconf}/templates/cgi-error-file
232 %config %{privoxyconf}/templates/cgi-error-modified
233 %config %{privoxyconf}/templates/cgi-error-parse
234 %config %{privoxyconf}/templates/cgi-style.css
235 %config %{privoxyconf}/templates/connect-failed
236 %config %{privoxyconf}/templates/default
237 %config %{privoxyconf}/templates/edit-actions-add-url-form
238 %config %{privoxyconf}/templates/edit-actions-for-url
239 %config %{privoxyconf}/templates/edit-actions-for-url-filter
240 %config %{privoxyconf}/templates/edit-actions-list
241 %config %{privoxyconf}/templates/edit-actions-list-section
242 %config %{privoxyconf}/templates/edit-actions-list-url
243 %config %{privoxyconf}/templates/edit-actions-remove-url-form
244 %config %{privoxyconf}/templates/edit-actions-url-form
245 %config %{privoxyconf}/templates/no-such-domain
246 %config %{privoxyconf}/templates/show-request
247 %config %{privoxyconf}/templates/show-status
248 %config %{privoxyconf}/templates/show-status-file
249 %config %{privoxyconf}/templates/show-url-info
250 %config %{privoxyconf}/templates/show-version
251 %config %{privoxyconf}/templates/toggle
252 %config %{privoxyconf}/templates/toggle-mini
253 %config %{privoxyconf}/templates/untrusted
254 %config %{_sysconfdir}/logrotate.d/%{name}
255 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
256 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
257 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
258 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
259 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
260 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
261 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
262 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
263
264 %{_mandir}/man1/%{name}.*
265
266 %changelog
267 * Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
268 + privoxy-2.9.13-4
269 - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
270 - Remove templates/blocked-compact.
271 - Add more docbook stuff to Builderquires.
272
273 * Thu Mar 28 2002 Sarantis Paskalis <sarantis@cnl.di.uoa.gr>
274 + privoxy-2.9.13-3
275 - Include correct documentation file.
276
277 * Tue Mar 26 2002 Hal Burgiss <hal@foobox.net>
278 + privoxy-2.9.13-3
279 - Fix typo in Description.
280
281 * Tue Mar 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
282 + privoxy-2.9.13-3
283 - Added commentary asking to update the release value on the configure
284   script
285
286 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
287 + privoxy-2.9.13-3
288 - Added the missing edit-actions-for-url-filter to templates.
289
290 * Mon Mar 25 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
291 + privoxy-2.9.13-2
292 - Fixing Release number
293
294 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
295 + privoxy-2.9.13-2
296 - Added faq to docs.
297
298 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
299 + privoxy-2.9.13-2
300 - Fixed the init files entries. Now we use %%ghost
301 - improved username (and groupname) handling on the %%pre section. By improved
302   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
303   got it right. No more Mr. Nice Guy.
304 - Removed the userdel call on %%post. No need, once it's complety handled on
305   the %%pre section
306
307 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
308 + junkbusterng-2.9.13-1
309   Added autoheader. Added autoconf to buildrequires.
310
311 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
312 + junkbusterng-2.9.13-1
313 - Fixed build problems re: name conflicts with man page and logrotate.
314 - Commented out rc?d/* configs for time being, which are causing a build 
315 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
316 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
317
318 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
319 + junkbusterng-2.9.13-1
320 - References to the expression ijb where changed where possible
321 - New package name: junkbusterng (all in lower case, acording to
322   the LSB recomendation)
323 - Version changed to: 2.9.13
324 - Release: 1
325 - Added: junkbuster to obsoletes and conflicts (Not sure this is
326   right. If it obsoletes, why conflict ? Have to check it later)
327 - Summary changed: Stefan, please check and aprove it
328 - Changes description to use the new name
329 - Sed string was NOT changed. Have to wait to the manpage to
330   change first
331 - Keeping the user junkbuster for now. It will require some aditional
332   changes on the script (scheduled for the next specfile release)
333 - Added post entry to move the old logfile to the new log directory
334 - Removing "chkconfig --add" entry (not good to have it automaticaly
335   added to the startup list).
336 - Added preun section to stop the service with the old name, as well
337   as remove it from the startup list
338 - Removed the chkconfig --del entry from the conditional block on
339   the preun scriptlet (now handled on the %files section)
340
341 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
342 - added ijb_docs.css to docs.
343
344 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
345 + junkbuster-2.9.11-8 
346 - Take out --enable-no-gifs, breaks some browsers.
347
348 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
349 + junkbuster-2.9.11-8 
350 - Add --enable-no-gifs to configure.
351
352 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
353 + junkbuster-2.9.11-7
354 - Added BuildRequires to libtool.
355
356 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
357 + junkbuster-2.9.11-6
358 - Changed the routined that handle the junkbust and junkbuster users on
359   %%pre and %%post to work in a smoother manner
360 - %%files now uses hardcoded usernames, to avoid problems with package
361   name changes in the future
362
363 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
364 + junkbuster-2.9.11-5
365 - Added "make redhat-dok" to the build process
366 - Added docbook-utils to BuildRequires
367
368 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
369 + junkbuster-2.9.11-4
370 - Changing man section in the manpage from 1 to 8
371 - We now require packages, not files, to avoid issues with apt
372
373 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
374 + junkbuster-2.9.11-3
375 - Fixing permissions of the init script
376
377 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
378 + junkbuster-2.9.11-2
379 - General specfile fixup, using the best recomended practices, including:
380         - Adding -q to %%setup
381         - Using macros whereever possible
382         - Not using wildchars on %%files section
383         - Doubling the percentage char on changelog and comments, to
384           avoid rpm expanding them
385
386 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
387 - /bin/false for shell causes init script to fail. Reverting.
388
389 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
390 - Removed UID 73. Included user-manual and developer-manual in docs.
391   Include other actions files. Default shell is now /bin/false.
392   Userdel user=junkbust. ChangeLog was not zipped. Removed 
393   RPM_OPT_FLAGS kludge.
394
395 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
396 - add paranoia check for 'rm -rf %%{buildroot}'
397 - add gzip to 'BuildRequires'
398
399 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
400 - actionsfile is now ijb.action.
401
402 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
403 - Compress manpage
404 - Add more documents for installation
405 - Add version string to name and source
406
407 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
408 - Back to user 'junkbuster' and fix configure macro.
409
410 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
411 - More changes for user 'junkbust'. Init script had 'junkbuster'.
412
413 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
414 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
415 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
416
417 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
418 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
419 - made sure no default shell exists for user junkbust.
420
421 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
422 - rework of RPM
423
424 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
425 - CLF Logging patch by davep@cyw.uklinux.net
426 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
427
428 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
429 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
430 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
431   numerous fixes and enhancements for Steve's patch.
432 - adamlock@netscape.com (Adam Lock) in the windows version:
433   - Taskbar activity spinner always spins even when logging is
434   turned off (which is the default) - people who don't
435   like the spinner can turn it off from a menu option.
436   - Taskbar popup menu has a options submenu - people can now
437   open the settings files for cookies, blockers etc.
438   without opening the JB window.
439   - Logging functionality works again
440   - Buffer overflow is fixed - new code uses a bigger buffer
441   and snprintf so it shouldn't overflow anymore.
442 - Fixed userid swa, group learning problem while installing.
443   root must build RPM.
444 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
445   core dump when there is no log file.
446 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
447 - Fixed man page to include imagefile and popupfile.
448 - Sanity check for the statistics function added.
449 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
450  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
451  With IIS/5, it appears to omit the trailing \r\n from http header
452  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
453  responds with a HTTP 302 redirect header.  However, this header
454  message is missing the trailing \r\n.  IIS/5 then closes the
455  connection.  Junkbuster, unfortunately, discards the header becomes
456  it thinks it is incomplete - and it is.  MS have transmitted an
457  incomplete header!
458 - Added bug reports and patch submission forms in the docs.
459
460 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
461        Andrew <anw@tirana.freewire.co.uk> extended the JB:
462        Display of statistics of the total number of requests and the number
463        of requests filtered by junkbuster, also the percentage of requests
464        filtered. Suppression of the listing of files on the proxy-args page.
465        All stuff optional and configurable.
466
467 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
468        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
469        code which prevented the JB from handling URLs of the form
470        user:password@www.foo.com. Fixed.
471
472 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
473         Blank images are no longer cached, thanks to a hint from Markus 
474         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
475         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
476         on the correct browser version nowadays. Incorporated many 
477         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
478         spec file. Fixed logging problem and since runlevel 2 does not 
479         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
480         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
481         <walker@netgate.net>. You should now be able to build this RPM as 
482         a non-root user (mathias@weidner.sem.lipsia.de).
483
484 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
485         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
486         to allow more sophisticated matching of blocked images. Logrotate
487         logfile. Added files for auto-updating the blocklist et al.
488
489 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
490         Configure blank version via config file. No separate blank
491         version anymore. Added Roland's <roland@spinnaker.rhein.de>
492         patch to show a logo instead of a blank area. Added a suggestion
493         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
494         More regexps in the blocklist. Prepared the forwardfile for
495         squid. Extended image regexp with help from gabriel 
496         <somlo@CS.ColoState.EDU>.
497
498 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
499         All RPMs now identify themselves in the show-proxy-args page.
500         Released Windoze version. Run junkbuster as nobody instead of
501         root. 
502
503 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
504         Newest version. First release (hence the little version number
505         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
506         security over 2.0.1; some multi-user sites will need to change 
507         the listen-address in the configuration file. The blank version of
508         the Internet Junkbuster has a more sophisticated way of replacing
509         images. All RPMs identify themselves in the show-proxy-args page.
510
511 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
512         Modified the blocking feature, so that only GIFs and JPEGs are
513         blocked and replaced but not HTML pages. Thanks to 
514         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
515         idea. Added numerous stuff to the blocklist. Keep patches in
516         seperate files and no longer in diffs (easier to maintain).
517
518 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
519         Moved config files to /etc/junkbuster directory, moved man page,
520         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
521         Made new version junkbuster-raw (which is only a stripped version of 
522         the junkuster rpm, i.e. without my blocklist, etc.)
523
524 * Tue Jun 16 1998 (2.0-1)
525         Uhm, not that much. Just a new junkbuster version that
526         fixes a couple of bugs ... and of course a bigger 
527         blocklist with the unique Now-less-ads-than-ever(SM)
528         feature.
529         Oh, one thing: I changed the default user agent to Linux -- no 
530         need anymore to support Apple.
531
532 * Tue Jun 16 1998 (2.0-0)
533         Now-less-ads-than-ever (SM)
534         compiled with gcc instead of cc
535         compiled with -O3, thus it should be a little faster
536         show-proxy-args now works
537         /etc/junkbuster.init wasn't necessary
538
539 * Tue Jun 16 1998 (1.4)
540         some more config files were put into /etc
541         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
542         displayed by Netscape instead of the blocked image.
543         Read http://www.waldherr.org/junkbuster/ for
544         further info.
545
546 * Tue Jun 16 1998 (1.3)
547         The program has been moved to /usr/sbin (from /usr/local/bin)
548         Init- and stopscripts (/etc/rc.d/rc*) have been added so
549         that the junkbuster starts automatically during bootup.
550         The /etc/blocklist file is much more sophisticated. Theoretically
551         one should e.g. browse all major US and German newspapers without
552         seeing one annoying ad.
553         junkbuster.init was modified. It now starts junkbuster with an
554         additional "-r @" flag.
555
556 # $Log: privoxy-rh.spec,v $
557 # Revision 1.20  2002/04/08 20:27:45  swa
558 # fixed JB spelling
559 #
560 # Revision 1.19  2002/03/27 22:44:59  sarantis
561 # Include correct documentation file.
562 #
563 # Revision 1.18  2002/03/27 22:10:14  sarantis
564 # bumped Hal's last commit 1 day to the future to make rpm build again.
565 #
566 # Revision 1.17  2002/03/27 00:48:23  hal9
567 # Fix up descrition.
568 #
569 # Revision 1.16  2002/03/26 22:29:55  swa
570 # we have a new homepage!
571 #
572 # Revision 1.15  2002/03/26 17:39:54  morcego
573 # Adding comment on the specfile to remember the packager to update
574 # the release number on the configure script
575 #
576 # Revision 1.14  2002/03/26 14:25:15  hal9
577 # Added edit-actions-for-url-filter to templates in %%config
578 #
579 # Revision 1.13  2002/03/25 13:31:04  morcego
580 # Bumping Release tag.
581 #
582 # Revision 1.12  2002/03/25 03:11:40  hal9
583 # Do it right way this time :/
584 #
585 # Revision 1.11  2002/03/25 03:09:51  hal9
586 # Added faq to docs.
587 #
588 # Revision 1.10  2002/03/24 22:16:14  morcego
589 # Just removing some old commentaries.
590 #
591 # Revision 1.9  2002/03/24 22:03:22  morcego
592 # Should be working now. See %changelog for details
593 #
594 # Revision 1.8  2002/03/24 21:13:01  morcego
595 # Tis broken.
596 #
597 # Revision 1.7  2002/03/24 21:07:18  hal9
598 # Add autoheader, etc.
599 #
600 # Revision 1.6  2002/03/24 19:56:40  hal9
601 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
602 #
603 # Revision 1.4  2002/03/24 13:32:42  swa
604 # name change related issues
605 #
606 # Revision 1.3  2002/03/24 12:56:21  swa
607 # name change related issues.
608 #
609 # Revision 1.2  2002/03/24 11:40:14  swa
610 # name change
611 #
612 # Revision 1.1  2002/03/24 11:23:44  swa
613 # name change
614 #
615 # Revision 1.1  2002/03/22 20:53:03  morcego
616 # - Ongoing process to change name to JunkbusterNG
617 # - configure/configure.in: no change needed
618 # - GNUmakefile.in:
619 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
620 #         - PROGRAM    = jbng@EXEEXT@
621 #         - rh-spec now references as junkbusterng-rh.spec
622 #         - redhat-upload: references changed to junkbusterng-* (package names)
623 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
624 #         - tarball-src: now JunkbusterNG-*
625 #         - install: initscript now junkbusterng.init and junkbusterng (when
626 #                    installed)
627 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
628 # - junkbusterng.spec:
629 #         - References to the expression ijb where changed where possible
630 #         - New package name: junkbusterng (all in lower case, acording to
631 #           the LSB recomendation)
632 #         - Version changed to: 2.9.13
633 #         - Release: 1
634 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
635 #           right. If it obsoletes, why conflict ? Have to check it later)
636 #         - Summary changed: Stefan, please check and aprove it
637 #         - Changes description to use the new name
638 #         - Sed string was NOT changed. Have to wait to the manpage to
639 #           change first
640 #         - Keeping the user junkbuster for now. It will require some aditional
641 #           changes on the script (scheduled for the next specfile release)
642 #         - Added post entry to move the old logfile to the new log directory
643 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
644 #           added to the startup list).
645 #         - Added preun section to stop the service with the old name, as well
646 #           as remove it from the startup list
647 #         - Removed the chkconfig --del entry from the conditional block on
648 #           the preun scriptlet (now handled on the %files section)
649 # - junkbuster.init: renamed to junkbusterng.init
650 # - junkbusterng.init:
651 #         - Changed JB_BIN to jbng
652 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
653 #           be used where necessary (config dir)
654 #
655 # Aditional notes:
656 # - The config directory is /etc/junkbuster yet. Have to change it on the
657 # specfile, after it is changes on the code
658 # - The only files that got renamed on the cvs tree were the rh specfile and
659 # the init file. Some file references got changes on the makefile and on the
660 # rh-spec (as listed above)
661 #
662 # Revision 1.43  2002/03/21 16:04:10  hal9
663 # added ijb_docs.css to %doc
664 #
665 # Revision 1.42  2002/03/12 13:41:18  sarantis
666 # remove hard-coded "ijbswa" string in build phase
667 #
668 # Revision 1.41  2002/03/11 22:58:32  hal9
669 # Remove --enable-no-gifs
670 #
671 # Revision 1.39  2002/03/08 18:57:29  swa
672 # remove user junkbuster after de-installation.
673 #
674 # Revision 1.38  2002/03/08 13:45:27  morcego
675 # Adding libtool to Buildrequires
676 #
677 # Revision 1.37  2002/03/07 19:23:49  swa
678 # i hate to scroll. suse: wrong configdir.
679 #
680 # Revision 1.36  2002/03/07 05:06:54  morcego
681 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
682 #
683 # Revision 1.34  2002/03/07 00:11:57  morcego
684 # Few changes on the %pre and %post sections of the rh specfile to handle
685 # usernames more cleanly
686 #
687 # Revision 1.33  2002/03/05 13:13:57  morcego
688 # - Added "make redhat-dok" to the build phase
689 # - Added docbook-utils to BuildRequires
690 #
691 # Revision 1.32  2002/03/05 12:34:24  morcego
692 # - Changing section internaly on the manpage from 1 to 8
693 # - We now require packages, not files, to avoid issues with apt
694 #
695 # Revision 1.31  2002/03/04 18:06:09  morcego
696 # SPECFILE: fixing permissing of the init script (broken by the last change)
697 #
698 # Revision 1.30  2002/03/04 16:18:03  morcego
699 # General cleanup of the rh specfile.
700 #
701 # %changelog
702 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
703 # + junkbuster-2.9.11-2
704 # - General specfile fixup, using the best recomended practices, including:
705 #         - Adding -q to %%setup
706 #         - Using macros whereever possible
707 #         - Not using wildchars on %%files section
708 #         - Doubling the percentage char on changelog and comments, to
709 #           avoid rpm expanding them
710 #
711 # Revision 1.29  2002/03/03 19:21:22  hal9
712 # Init script fails if shell is /bin/false.
713 #
714 # Revision 1.28  2002/01/09 18:34:03  hal9
715 # nit.
716 #
717 # Revision 1.27  2002/01/09 18:32:02  hal9
718 # Removed RPM_OPT_FLAGS kludge.
719 #
720 # Revision 1.26  2002/01/09 18:21:10  hal9
721 # A few minor updates.
722 #
723 # Revision 1.25  2001/12/28 01:45:36  steudten
724 # Add paranoia check and BuildReq: gzip
725 #
726 # Revision 1.24  2001/12/01 21:43:14  hal9
727 # Allowed for new ijb.action file.
728 #
729 # Revision 1.23  2001/11/06 12:09:03  steudten
730 # Compress doc files. Install README and AUTHORS at last as document.
731 #
732 # Revision 1.22  2001/11/05 21:37:34  steudten
733 # Fix to include the actual version for name.
734 # Let the 'real' packager be included - sorry stefan.
735 #
736 # Revision 1.21  2001/10/31 19:27:27  swa
737 # consistent description. new name for suse since
738 # we had troubles with rpms of identical names
739 # on the webserver.
740 #
741 # Revision 1.20  2001/10/24 15:45:49  hal9
742 # To keep Thomas happy (aka correcting my  mistakes)
743 #
744 # Revision 1.19  2001/10/15 03:23:59  hal9
745 # Nits.
746 #
747 # Revision 1.17  2001/10/10 18:59:28  hal9
748 # Minor change for init script.
749 #
750 # Revision 1.16  2001/09/24 20:56:23  hal9
751 # Minor changes.
752 #
753 # Revision 1.13  2001/09/10 17:44:43  swa
754 # integrate three pieces of documentation. needs work.
755 # will not build cleanly under redhat.
756 #
757 # Revision 1.12  2001/09/10 16:25:04  swa
758 # copy all templates. version updated.
759 #
760 # Revision 1.11  2001/07/03 11:00:25  sarantis
761 # replaced permissionsfile with actionsfile
762 #
763 # Revision 1.10  2001/07/03 09:34:44  sarantis
764 # bumped up version number.
765 #
766 # Revision 1.9  2001/06/12 18:15:29  swa
767 # the %% in front of configure (see tag below) confused
768 # the rpm build process on 7.1.
769 #
770 # Revision 1.8  2001/06/12 17:15:56  swa
771 # fixes, because a clean build on rh6.1 was impossible.
772 # GZIP confuses make, %% configure confuses rpm, etc.
773 #
774 # Revision 1.7  2001/06/11 12:17:26  sarantis
775 # fix typo in %%post
776 #
777 # Revision 1.6  2001/06/11 11:28:25  sarantis
778 # Further optimizations and adaptations in the spec file.
779 #
780 # Revision 1.5  2001/06/09 09:14:11  swa
781 # shamelessly adapted RPM stuff from the newest rpm that
782 # RedHat provided for the JB.
783 #
784 # Revision 1.4  2001/06/08 20:54:18  swa
785 # type with status file. remove forward et. al from file list.
786 #
787 # Revision 1.3  2001/06/07 17:28:10  swa
788 # cosmetics
789 #
790 # Revision 1.2  2001/06/04 18:31:58  swa
791 # files are now prefixed with either `confdir' or `logdir'.
792 # `make redhat-dist' replaces both entries confdir and logdir
793 # with redhat values
794 #
795 # Revision 1.1  2001/06/04 10:44:57  swa
796 # `make redhatr-dist' now works. Except for the paths
797 # in the config file.
798 #
799 #
800 #