Create HTML and ASCII versions of the documentation using docbook now.
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.18 2002/03/27 22:10:14 sarantis Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33
34 Name: privoxy
35 # ATTENTION
36 # Version and release should be updated acordingly on configure.in and
37 # configure. Otherwise, the package can be build with the wrong value
38 Version: 2.9.13
39 Release: 3
40 Summary: Privoxy - privacy enhancing proxy
41 License: GPL
42 Vendor: http://www.privoxy.org
43 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
44 BuildRoot: %{_tmppath}/%{name}-%{version}-root
45 Group: Networking/Utilities
46 URL: http://www.privoxy.org/
47 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
48 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
49 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
50 BuildRequires: perl gzip sed docbook-utils libtool autoconf
51 Conflicts: junkbuster-raw junkbuster-blank junkbuster
52
53 %description 
54 Privoxy is a web proxy with advanced filtering capabilities for
55 protecting privacy, filtering web page content, managing cookies,
56 controlling access, and removing ads, banners, pop-ups and other
57 obnoxious Internet junk. Privoxy has a very flexible configuration and
58 can be customized to suit individual needs and tastes. Privoxy has application
59 for both stand-alone systems and multi-user networks.
60
61 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
62 was originally written by JunkBusters Corporation, and was released as
63 free open-source software under the GNU GPL. Stefan Waldherr made many
64 improvements, and started the SourceForge project to continue
65 development. Several other developers are now contributing.
66
67 %prep
68 %setup -q -c
69
70 %build
71 autoheader
72 autoconf
73 %configure
74 make 
75 make redhat-dok
76
77 ## Explicitily stripping is not recomended.
78 ## This is handled altomaticaly by RPM, and can couse troubles if
79 ## anyone wants to build an unstriped version - morcego
80 #strip %{name}
81
82 %install
83 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
84 mkdir -p %{buildroot}%{_sbindir} \
85          %{buildroot}%{_mandir}/man1 \
86          %{buildroot}%{_localstatedir}/log/%{name} \
87          %{buildroot}%{privoxyconf}/templates \
88          %{buildroot}%{_sysconfdir}/logrotate.d \
89          %{buildroot}%{_sysconfdir}/rc.d/init.d 
90
91 ## Manual gziping of manpages should not be done, once it can
92 ## break the building on some distributions. Anyway, rpm does it
93 ## automagicaly these days
94 ## Gziping the documentation files is not recomended - morcego
95 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
96
97 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
98
99 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
100 cp -f *.action %{buildroot}%{privoxyconf}/
101 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
102 cp -f trust %{buildroot}%{privoxyconf}/trust
103 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
104 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
105 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
106 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
107
108 # verify all file locations, etc. in the config file
109 # don't start with ^ or commented lines are not replaced
110 ## Changing the sed paramter delimiter to @, so we don't have to
111 ## escape the slashes
112 cat config | \
113     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
114 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
115 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
116 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
117 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
118 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
119 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
120     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
121     %{buildroot}%{privoxyconf}/config
122 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
123     %{buildroot}%{privoxyconf}/default.action
124
125
126 # Creating ghost init files
127 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
128 for i in 0 1 4 6
129 do
130 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
131 done
132 for i in 2 3 5
133 do
134 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
135 done
136
137 ## Macros are expanded even on commentaries. So, we have to use %%
138 ## -- morcego
139 #%%makeinstall
140
141 %pre
142 # This is where we handle old usernames (junkbust and junkbuster)
143 # I'm not sure we should do that, but this is the way we have been
144 # doing it for some time now -- morcego
145 # We should do it for the group as well -- morcego
146 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
147
148 # Change the group name. Remove anything left behind.
149 groupmod -n %{name} %{oldname} > /dev/null 2>&1 ||:
150 groupmod -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
151 groupdel %{oldname} > /dev/null 2>&1 ||:
152 groupdel %{veryoldname} > /dev/null 2>&1 ||:
153
154 # Same for username
155 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
156 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
157 userdel %{oldname} > /dev/null 2>&1 ||:
158 userdel %{veryoldname} > /dev/null 2>&1 ||:
159
160 # Check to see if everything is okey. Create user if it still does not
161 # exist
162 id %{name} > /dev/null 2>&1
163 if [ $? -eq 1 ]; then
164         /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
165 fi
166
167 %post
168 # for upgrade from 2.0.x
169 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
170  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
171 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
172  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
173 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
174 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
175 if [ "$1" = "1" ]; then
176         /sbin/service %{name} condrestart > /dev/null 2>&1
177 fi
178
179 %preun
180 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
181 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
182
183 if [ "$1" = "0" ]; then
184         /sbin/service %{name} stop > /dev/null 2>&1 ||:
185         # No need to use chkconfig. The %%ghost files will handle it
186 fi
187
188 %postun
189 #if [ "$1" -ge "1" ]; then
190 #       /sbin/service %{name} condrestart > /dev/null 2>&1
191 #fi
192 # We only remove it we this is not an upgrade
193 if [ "$1" = "0" ]; then
194         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
195 fi
196
197 %clean
198 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
199
200 %files
201 %defattr(0644,root,root,0755)
202 %doc README AUTHORS ChangeLog
203 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
204 %doc doc/webserver/developer-manual
205 %doc doc/webserver/user-manual
206 %doc doc/webserver/faq
207 %doc doc/webserver/p_doc.css
208
209 %dir %{privoxyconf}
210 %dir %{privoxyconf}/templates
211 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
212
213 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
214
215 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
216 # We should not use wildchars here. This could mask missing files problems
217 # -- morcego
218 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
219 %config %{privoxyconf}/config
220 %config %{privoxyconf}/advanced.action
221 %config %{privoxyconf}/basic.action
222 %config %{privoxyconf}/intermediate.action
223 %config %{privoxyconf}/default.action
224 %config %{privoxyconf}/default.filter
225 %config %{privoxyconf}/trust
226
227 %config %{privoxyconf}/templates/blocked
228 %config %{privoxyconf}/templates/blocked-compact
229 %config %{privoxyconf}/templates/cgi-error-404
230 %config %{privoxyconf}/templates/cgi-error-bad-param
231 %config %{privoxyconf}/templates/cgi-error-disabled
232 %config %{privoxyconf}/templates/cgi-error-file
233 %config %{privoxyconf}/templates/cgi-error-modified
234 %config %{privoxyconf}/templates/cgi-error-parse
235 %config %{privoxyconf}/templates/connect-failed
236 %config %{privoxyconf}/templates/default
237 %config %{privoxyconf}/templates/edit-actions-add-url-form
238 %config %{privoxyconf}/templates/edit-actions-for-url
239 %config %{privoxyconf}/templates/edit-actions-list
240 %config %{privoxyconf}/templates/edit-actions-list-section
241 %config %{privoxyconf}/templates/edit-actions-list-url
242 %config %{privoxyconf}/templates/edit-actions-remove-url-form
243 %config %{privoxyconf}/templates/edit-actions-url-form
244 %config %{privoxyconf}/templates/no-such-domain
245 %config %{privoxyconf}/templates/show-request
246 %config %{privoxyconf}/templates/show-status
247 %config %{privoxyconf}/templates/show-status-file
248 %config %{privoxyconf}/templates/show-url-info
249 %config %{privoxyconf}/templates/show-version
250 %config %{privoxyconf}/templates/toggle
251 %config %{privoxyconf}/templates/toggle-mini
252 %config %{privoxyconf}/templates/untrusted
253 %config %{privoxyconf}/templates/edit-actions-for-url-filter
254 %config %{_sysconfdir}/logrotate.d/%{name}
255 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
256 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
257 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
258 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
259 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
260 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
261 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
262 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
263
264 %{_mandir}/man1/%{name}.*
265
266 %changelog
267 * Thu Mar 28 2002 Sarantis Paskalis <sarantis@cnl.di.uoa.gr>
268 + privoxy-2.9.13-3
269 - Include correct documentation file.
270
271 * Tue Mar 26 2002 Hal Burgiss <hal@foobox.net>
272 + privoxy-2.9.13-3
273 - Fix typo in Description.
274
275 * Tue Mar 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
276 + privoxy-2.9.13-3
277 - Added commentary asking to update the release value on the configure
278   script
279
280 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
281 + privoxy-2.9.13-3
282 - Added the missing edit-actions-for-url-filter to templates.
283
284 * Mon Mar 25 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
285 + privoxy-2.9.13-2
286 - Fixing Release number
287
288 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
289 + privoxy-2.9.13-2
290 - Added faq to docs.
291
292 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
293 + privoxy-2.9.13-2
294 - Fixed the init files entries. Now we use %%ghost
295 - improved username (and groupname) handling on the %%pre section. By improved
296   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
297   got it right. No more Mr. Nice Guy.
298 - Removed the userdel call on %%post. No need, once it's complety handled on
299   the %%pre section
300
301 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
302 + junkbusterng-2.9.13-1
303   Added autoheader. Added autoconf to buildrequires.
304
305 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
306 + junkbusterng-2.9.13-1
307 - Fixed build problems re: name conflicts with man page and logrotate.
308 - Commented out rc?d/* configs for time being, which are causing a build 
309 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
310 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
311
312 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
313 + junkbusterng-2.9.13-1
314 - References to the expression ijb where changed where possible
315 - New package name: junkbusterng (all in lower case, acording to
316   the LSB recomendation)
317 - Version changed to: 2.9.13
318 - Release: 1
319 - Added: junkbuster to obsoletes and conflicts (Not sure this is
320   right. If it obsoletes, why conflict ? Have to check it later)
321 - Summary changed: Stefan, please check and aprove it
322 - Changes description to use the new name
323 - Sed string was NOT changed. Have to wait to the manpage to
324   change first
325 - Keeping the user junkbuster for now. It will require some aditional
326   changes on the script (scheduled for the next specfile release)
327 - Added post entry to move the old logfile to the new log directory
328 - Removing "chkconfig --add" entry (not good to have it automaticaly
329   added to the startup list).
330 - Added preun section to stop the service with the old name, as well
331   as remove it from the startup list
332 - Removed the chkconfig --del entry from the conditional block on
333   the preun scriptlet (now handled on the %files section)
334
335 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
336 - added ijb_docs.css to docs.
337
338 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
339 + junkbuster-2.9.11-8 
340 - Take out --enable-no-gifs, breaks some browsers.
341
342 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
343 + junkbuster-2.9.11-8 
344 - Add --enable-no-gifs to configure.
345
346 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
347 + junkbuster-2.9.11-7
348 - Added BuildRequires to libtool.
349
350 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
351 + junkbuster-2.9.11-6
352 - Changed the routined that handle the junkbust and junkbuster users on
353   %%pre and %%post to work in a smoother manner
354 - %%files now uses hardcoded usernames, to avoid problems with package
355   name changes in the future
356
357 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
358 + junkbuster-2.9.11-5
359 - Added "make redhat-dok" to the build process
360 - Added docbook-utils to BuildRequires
361
362 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
363 + junkbuster-2.9.11-4
364 - Changing man section in the manpage from 1 to 8
365 - We now require packages, not files, to avoid issues with apt
366
367 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
368 + junkbuster-2.9.11-3
369 - Fixing permissions of the init script
370
371 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
372 + junkbuster-2.9.11-2
373 - General specfile fixup, using the best recomended practices, including:
374         - Adding -q to %%setup
375         - Using macros whereever possible
376         - Not using wildchars on %%files section
377         - Doubling the percentage char on changelog and comments, to
378           avoid rpm expanding them
379
380 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
381 - /bin/false for shell causes init script to fail. Reverting.
382
383 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
384 - Removed UID 73. Included user-manual and developer-manual in docs.
385   Include other actions files. Default shell is now /bin/false.
386   Userdel user=junkbust. ChangeLog was not zipped. Removed 
387   RPM_OPT_FLAGS kludge.
388
389 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
390 - add paranoia check for 'rm -rf %%{buildroot}'
391 - add gzip to 'BuildRequires'
392
393 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
394 - actionsfile is now ijb.action.
395
396 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
397 - Compress manpage
398 - Add more documents for installation
399 - Add version string to name and source
400
401 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
402 - Back to user 'junkbuster' and fix configure macro.
403
404 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
405 - More changes for user 'junkbust'. Init script had 'junkbuster'.
406
407 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
408 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
409 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
410
411 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
412 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
413 - made sure no default shell exists for user junkbust.
414
415 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
416 - rework of RPM
417
418 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
419 - CLF Logging patch by davep@cyw.uklinux.net
420 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
421
422 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
423 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
424 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
425   numerous fixes and enhancements for Steve's patch.
426 - adamlock@netscape.com (Adam Lock) in the windows version:
427   - Taskbar activity spinner always spins even when logging is
428   turned off (which is the default) - people who don't
429   like the spinner can turn it off from a menu option.
430   - Taskbar popup menu has a options submenu - people can now
431   open the settings files for cookies, blockers etc.
432   without opening the JB window.
433   - Logging functionality works again
434   - Buffer overflow is fixed - new code uses a bigger buffer
435   and snprintf so it shouldn't overflow anymore.
436 - Fixed userid swa, group learning problem while installing.
437   root must build RPM.
438 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
439   core dump when there is no log file.
440 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
441 - Fixed man page to include imagefile and popupfile.
442 - Sanity check for the statistics function added.
443 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
444  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
445  With IIS/5, it appears to omit the trailing \r\n from http header
446  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
447  responds with a HTTP 302 redirect header.  However, this header
448  message is missing the trailing \r\n.  IIS/5 then closes the
449  connection.  Junkbuster, unfortunately, discards the header becomes
450  it thinks it is incomplete - and it is.  MS have transmitted an
451  incomplete header!
452 - Added bug reports and patch submission forms in the docs.
453
454 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
455        Andrew <anw@tirana.freewire.co.uk> extended the JB:
456        Display of statistics of the total number of requests and the number
457        of requests filtered by junkbuster, also the percentage of requests
458        filtered. Suppression of the listing of files on the proxy-args page.
459        All stuff optional and configurable.
460
461 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
462        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
463        code which prevented the JB from handling URLs of the form
464        user:password@www.foo.com. Fixed.
465
466 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
467         Blank images are no longer cached, thanks to a hint from Markus 
468         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
469         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
470         on the correct browser version nowadays. Incorporated many 
471         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
472         spec file. Fixed logging problem and since runlevel 2 does not 
473         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
474         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
475         <walker@netgate.net>. You should now be able to build this RPM as 
476         a non-root user (mathias@weidner.sem.lipsia.de).
477
478 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
479         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
480         to allow more sophisticated matching of blocked images. Logrotate
481         logfile. Added files for auto-updating the blocklist et al.
482
483 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
484         Configure blank version via config file. No separate blank
485         version anymore. Added Roland's <roland@spinnaker.rhein.de>
486         patch to show a logo instead of a blank area. Added a suggestion
487         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
488         More regexps in the blocklist. Prepared the forwardfile for
489         squid. Extended image regexp with help from gabriel 
490         <somlo@CS.ColoState.EDU>.
491
492 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
493         All RPMs now identify themselves in the show-proxy-args page.
494         Released Windoze version. Run junkbuster as nobody instead of
495         root. 
496
497 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
498         Newest version. First release (hence the little version number
499         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
500         security over 2.0.1; some multi-user sites will need to change 
501         the listen-address in the configuration file. The blank version of
502         the Internet Junkbuster has a more sophisticated way of replacing
503         images. All RPMs identify themselves in the show-proxy-args page.
504
505 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
506         Modified the blocking feature, so that only GIFs and JPEGs are
507         blocked and replaced but not HTML pages. Thanks to 
508         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
509         idea. Added numerous stuff to the blocklist. Keep patches in
510         seperate files and no longer in diffs (easier to maintain).
511
512 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
513         Moved config files to /etc/junkbuster directory, moved man page,
514         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
515         Made new version junkbuster-raw (which is only a stripped version of 
516         the junkuster rpm, i.e. without my blocklist, etc.)
517
518 * Tue Jun 16 1998 (2.0-1)
519         Uhm, not that much. Just a new junkbuster version that
520         fixes a couple of bugs ... and of course a bigger 
521         blocklist with the unique Now-less-ads-than-ever(SM)
522         feature.
523         Oh, one thing: I changed the default user agent to Linux -- no 
524         need anymore to support Apple.
525
526 * Tue Jun 16 1998 (2.0-0)
527         Now-less-ads-than-ever (SM)
528         compiled with gcc instead of cc
529         compiled with -O3, thus it should be a little faster
530         show-proxy-args now works
531         /etc/junkbuster.init wasn't necessary
532
533 * Tue Jun 16 1998 (1.4)
534         some more config files were put into /etc
535         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
536         displayed by Netscape instead of the blocked image.
537         Read http://www.waldherr.org/junkbuster/ for
538         further info.
539
540 * Tue Jun 16 1998 (1.3)
541         The program has been moved to /usr/sbin (from /usr/local/bin)
542         Init- and stopscripts (/etc/rc.d/rc*) have been added so
543         that the junkbuster starts automatically during bootup.
544         The /etc/blocklist file is much more sophisticated. Theoretically
545         one should e.g. browse all major US and German newspapers without
546         seeing one annoying ad.
547         junkbuster.init was modified. It now starts junkbuster with an
548         additional "-r @" flag.
549
550 # $Log: privoxy-rh.spec,v $
551 # Revision 1.18  2002/03/27 22:10:14  sarantis
552 # bumped Hal's last commit 1 day to the future to make rpm build again.
553 #
554 # Revision 1.17  2002/03/27 00:48:23  hal9
555 # Fix up descrition.
556 #
557 # Revision 1.16  2002/03/26 22:29:55  swa
558 # we have a new homepage!
559 #
560 # Revision 1.15  2002/03/26 17:39:54  morcego
561 # Adding comment on the specfile to remember the packager to update
562 # the release number on the configure script
563 #
564 # Revision 1.14  2002/03/26 14:25:15  hal9
565 # Added edit-actions-for-url-filter to templates in %%config
566 #
567 # Revision 1.13  2002/03/25 13:31:04  morcego
568 # Bumping Release tag.
569 #
570 # Revision 1.12  2002/03/25 03:11:40  hal9
571 # Do it right way this time :/
572 #
573 # Revision 1.11  2002/03/25 03:09:51  hal9
574 # Added faq to docs.
575 #
576 # Revision 1.10  2002/03/24 22:16:14  morcego
577 # Just removing some old commentaries.
578 #
579 # Revision 1.9  2002/03/24 22:03:22  morcego
580 # Should be working now. See %changelog for details
581 #
582 # Revision 1.8  2002/03/24 21:13:01  morcego
583 # Tis broken.
584 #
585 # Revision 1.7  2002/03/24 21:07:18  hal9
586 # Add autoheader, etc.
587 #
588 # Revision 1.6  2002/03/24 19:56:40  hal9
589 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
590 #
591 # Revision 1.4  2002/03/24 13:32:42  swa
592 # name change related issues
593 #
594 # Revision 1.3  2002/03/24 12:56:21  swa
595 # name change related issues.
596 #
597 # Revision 1.2  2002/03/24 11:40:14  swa
598 # name change
599 #
600 # Revision 1.1  2002/03/24 11:23:44  swa
601 # name change
602 #
603 # Revision 1.1  2002/03/22 20:53:03  morcego
604 # - Ongoing process to change name to JunkbusterNG
605 # - configure/configure.in: no change needed
606 # - GNUmakefile.in:
607 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
608 #         - PROGRAM    = jbng@EXEEXT@
609 #         - rh-spec now references as junkbusterng-rh.spec
610 #         - redhat-upload: references changed to junkbusterng-* (package names)
611 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
612 #         - tarball-src: now JunkbusterNG-*
613 #         - install: initscript now junkbusterng.init and junkbusterng (when
614 #                    installed)
615 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
616 # - junkbusterng.spec:
617 #         - References to the expression ijb where changed where possible
618 #         - New package name: junkbusterng (all in lower case, acording to
619 #           the LSB recomendation)
620 #         - Version changed to: 2.9.13
621 #         - Release: 1
622 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
623 #           right. If it obsoletes, why conflict ? Have to check it later)
624 #         - Summary changed: Stefan, please check and aprove it
625 #         - Changes description to use the new name
626 #         - Sed string was NOT changed. Have to wait to the manpage to
627 #           change first
628 #         - Keeping the user junkbuster for now. It will require some aditional
629 #           changes on the script (scheduled for the next specfile release)
630 #         - Added post entry to move the old logfile to the new log directory
631 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
632 #           added to the startup list).
633 #         - Added preun section to stop the service with the old name, as well
634 #           as remove it from the startup list
635 #         - Removed the chkconfig --del entry from the conditional block on
636 #           the preun scriptlet (now handled on the %files section)
637 # - junkbuster.init: renamed to junkbusterng.init
638 # - junkbusterng.init:
639 #         - Changed JB_BIN to jbng
640 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
641 #           be used where necessary (config dir)
642 #
643 # Aditional notes:
644 # - The config directory is /etc/junkbuster yet. Have to change it on the
645 # specfile, after it is changes on the code
646 # - The only files that got renamed on the cvs tree were the rh specfile and
647 # the init file. Some file references got changes on the makefile and on the
648 # rh-spec (as listed above)
649 #
650 # Revision 1.43  2002/03/21 16:04:10  hal9
651 # added ijb_docs.css to %doc
652 #
653 # Revision 1.42  2002/03/12 13:41:18  sarantis
654 # remove hard-coded "ijbswa" string in build phase
655 #
656 # Revision 1.41  2002/03/11 22:58:32  hal9
657 # Remove --enable-no-gifs
658 #
659 # Revision 1.39  2002/03/08 18:57:29  swa
660 # remove user junkbuster after de-installation.
661 #
662 # Revision 1.38  2002/03/08 13:45:27  morcego
663 # Adding libtool to Buildrequires
664 #
665 # Revision 1.37  2002/03/07 19:23:49  swa
666 # i hate to scroll. suse: wrong configdir.
667 #
668 # Revision 1.36  2002/03/07 05:06:54  morcego
669 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
670 #
671 # Revision 1.34  2002/03/07 00:11:57  morcego
672 # Few changes on the %pre and %post sections of the rh specfile to handle
673 # usernames more cleanly
674 #
675 # Revision 1.33  2002/03/05 13:13:57  morcego
676 # - Added "make redhat-dok" to the build phase
677 # - Added docbook-utils to BuildRequires
678 #
679 # Revision 1.32  2002/03/05 12:34:24  morcego
680 # - Changing section internaly on the manpage from 1 to 8
681 # - We now require packages, not files, to avoid issues with apt
682 #
683 # Revision 1.31  2002/03/04 18:06:09  morcego
684 # SPECFILE: fixing permissing of the init script (broken by the last change)
685 #
686 # Revision 1.30  2002/03/04 16:18:03  morcego
687 # General cleanup of the rh specfile.
688 #
689 # %changelog
690 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
691 # + junkbuster-2.9.11-2
692 # - General specfile fixup, using the best recomended practices, including:
693 #         - Adding -q to %%setup
694 #         - Using macros whereever possible
695 #         - Not using wildchars on %%files section
696 #         - Doubling the percentage char on changelog and comments, to
697 #           avoid rpm expanding them
698 #
699 # Revision 1.29  2002/03/03 19:21:22  hal9
700 # Init script fails if shell is /bin/false.
701 #
702 # Revision 1.28  2002/01/09 18:34:03  hal9
703 # nit.
704 #
705 # Revision 1.27  2002/01/09 18:32:02  hal9
706 # Removed RPM_OPT_FLAGS kludge.
707 #
708 # Revision 1.26  2002/01/09 18:21:10  hal9
709 # A few minor updates.
710 #
711 # Revision 1.25  2001/12/28 01:45:36  steudten
712 # Add paranoia check and BuildReq: gzip
713 #
714 # Revision 1.24  2001/12/01 21:43:14  hal9
715 # Allowed for new ijb.action file.
716 #
717 # Revision 1.23  2001/11/06 12:09:03  steudten
718 # Compress doc files. Install README and AUTHORS at last as document.
719 #
720 # Revision 1.22  2001/11/05 21:37:34  steudten
721 # Fix to include the actual version for name.
722 # Let the 'real' packager be included - sorry stefan.
723 #
724 # Revision 1.21  2001/10/31 19:27:27  swa
725 # consistent description. new name for suse since
726 # we had troubles with rpms of identical names
727 # on the webserver.
728 #
729 # Revision 1.20  2001/10/24 15:45:49  hal9
730 # To keep Thomas happy (aka correcting my  mistakes)
731 #
732 # Revision 1.19  2001/10/15 03:23:59  hal9
733 # Nits.
734 #
735 # Revision 1.17  2001/10/10 18:59:28  hal9
736 # Minor change for init script.
737 #
738 # Revision 1.16  2001/09/24 20:56:23  hal9
739 # Minor changes.
740 #
741 # Revision 1.13  2001/09/10 17:44:43  swa
742 # integrate three pieces of documentation. needs work.
743 # will not build cleanly under redhat.
744 #
745 # Revision 1.12  2001/09/10 16:25:04  swa
746 # copy all templates. version updated.
747 #
748 # Revision 1.11  2001/07/03 11:00:25  sarantis
749 # replaced permissionsfile with actionsfile
750 #
751 # Revision 1.10  2001/07/03 09:34:44  sarantis
752 # bumped up version number.
753 #
754 # Revision 1.9  2001/06/12 18:15:29  swa
755 # the %% in front of configure (see tag below) confused
756 # the rpm build process on 7.1.
757 #
758 # Revision 1.8  2001/06/12 17:15:56  swa
759 # fixes, because a clean build on rh6.1 was impossible.
760 # GZIP confuses make, %% configure confuses rpm, etc.
761 #
762 # Revision 1.7  2001/06/11 12:17:26  sarantis
763 # fix typo in %%post
764 #
765 # Revision 1.6  2001/06/11 11:28:25  sarantis
766 # Further optimizations and adaptations in the spec file.
767 #
768 # Revision 1.5  2001/06/09 09:14:11  swa
769 # shamelessly adapted RPM stuff from the newest rpm that
770 # RedHat provided for the JB.
771 #
772 # Revision 1.4  2001/06/08 20:54:18  swa
773 # type with status file. remove forward et. al from file list.
774 #
775 # Revision 1.3  2001/06/07 17:28:10  swa
776 # cosmetics
777 #
778 # Revision 1.2  2001/06/04 18:31:58  swa
779 # files are now prefixed with either `confdir' or `logdir'.
780 # `make redhat-dist' replaces both entries confdir and logdir
781 # with redhat values
782 #
783 # Revision 1.1  2001/06/04 10:44:57  swa
784 # `make redhatr-dist' now works. Except for the paths
785 # in the config file.
786 #
787 #
788 #