bb404dad5a9e0a37fd8b3d052ca56446df68685e
[privoxy.git] / privoxy-rh.spec
1 # $Id: junkbusterng-rh.spec,v 1.1 2002/03/22 20:53:03 morcego Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define oldname junkbuster
31 %define jbngconf %{_sysconfdir}/%{oldname}
32
33 Summary: JunkbusterNG (The Internet Junkbuster NextGeneration)
34 Vendor: http://ijbswa.sourceforge.net
35 Name: junkbusterng
36 Version: 2.9.13
37 Release: 1
38 Source0: http://www.waldherr.org/%{name}/ijbswa-%{version}.tar.gz
39 License: GPL
40 BuildRoot: %{_tmppath}/%{name}-%{version}-root
41 Group: Networking/Utilities
42 URL: http://ijbswa.sourceforge.net/
43 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
44 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
45 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
46 BuildRequires: perl gzip sed docbook-utils libtool
47 Conflicts: junkbuster-raw junkbuster-blank junkbuster
48
49 %description
50 JunkbusterNG is a web proxy with advanced filtering
51 capabilities for protecting privacy, filtering web page content,
52 managing cookies, controlling access, and removing ads, banners,
53 pop-ups and other obnoxious Internet Junk. JunkbusterNG has a very
54 flexible configuration and can be customized to suit individual needs
55 and tastes. JunkbusterNG has application for both stand-alone
56 systems and multi-user networks.
57
58 %prep
59 %setup -q -c
60
61 %build
62 %configure
63 make 
64 make redhat-dok
65
66 ## Explicitily stripping is not recomended.
67 ## This is handled altomaticaly by RPM, and can couse troubles if
68 ## anyone wants to build an unstriped version - morcego
69 #strip %{name}
70
71 %install
72 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
73 mkdir -p %{buildroot}%{_sbindir} \
74          %{buildroot}%{_mandir}/man8 \
75          %{buildroot}%{_localstatedir}/log/%{name} \
76          %{buildroot}%{jbngconf}/templates \
77          %{buildroot}%{_sysconfdir}/logrotate.d \
78          %{buildroot}%{_sysconfdir}/rc.d/init.d 
79
80 ## Manual gziping of manpages should not be done, once it can
81 ## break the building on some distributions. Anyway, rpm does it
82 ## automagicaly these days
83 ## Gziping the documentation files is not recomended - morcego
84 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
85
86 install -s -m 744 jbng %{buildroot}%{_sbindir}/jbng
87
88 ## We need to change the man section internaly on the manpage
89 ## -- morcego (sugestion by Hal Burgiss)
90 #cp -f %{name}.1 %{buildroot}%{_mandir}/man8/%{name}.8
91 sed -e 's@^.TH JUNKBUSTER 1@.TH JUNKBUSTER 8@g' %{oldname}.1 > %{buildroot}%{_mandir}/man8/%{oldname}.8
92 cp -f *.action %{buildroot}%{jbngconf}/
93 cp -f re_filterfile %{buildroot}%{jbngconf}/re_filterfile
94 cp -f trust %{buildroot}%{jbngconf}/trust
95 cp -f templates/*  %{buildroot}%{jbngconf}/templates/
96 cp -f %{oldname}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{oldname}
97 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
98 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
99
100 # verify all file locations, etc. in the config file
101 # don't start with ^ or commented lines are not replaced
102 ## Changing the sed paramter delimiter to @, so we don't have to
103 ## escape the slashes
104 cat config | \
105     sed 's@^confdir.*@confdir %{jbngconf}@g' | \
106 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
107 #    sed 's/^re_filterfile.*/re_filterfile \/etc\/%{name}\/re_filterfile/g' | \
108 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
109 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
110 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
111 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
112     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
113     %{buildroot}%{jbngconf}/config
114 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' ijb.action >\
115     %{buildroot}%{jbngconf}/ijb.action
116
117 ## Macros are expanded even on commentaries. So, we have to use %%
118 ## -- morcego
119 #%%makeinstall
120
121 %pre
122 # We check to see if the user junkbuster exists.
123 # If it does, we do nothing
124 # If we don't, we check to see if the user junkbust exist and, in case it
125 # does, we change it do junkbuster. If it also does not exist, we create the
126 # junkbuster user -- morcego
127 id junkbuster > /dev/null 2>&1 
128 if [ $? -eq 1 ]; then
129         id junkbust > /dev/null 2>&1 
130         if [ $? -eq 0 ]; then
131                 /usr/sbin/usermod -l junkbuster -d %{_sysconfdir}/%{name} -s "" junkbust  > /dev/null 2>&1
132         else
133                 /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" junkbuster > /dev/null 2>&1 
134         fi
135 fi
136
137 %post
138 # for upgrade from 2.0.x
139 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
140  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
141 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
142  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
143 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
144 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
145 if [ "$1" = "1" ]; then
146 #     /sbin/chkconfig --add %{name}
147         /sbin/service %{name} condrestart > /dev/null 2>&1
148 fi
149 # 01/09/02 HB, getting rid of any user=junkbust
150 # Changed by morcego to use the id command.
151 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
152
153 %preun
154 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
155 /sbin/chkconfig --del %{oldname}
156
157 if [ "$1" = "0" ]; then
158         /sbin/service %{name} stop > /dev/null 2>&1 ||:
159 fi
160
161 %postun
162 #if [ "$1" -ge "1" ]; then
163 #       /sbin/service %{name} condrestart > /dev/null 2>&1
164 #fi
165 # dont forget to remove user and group junkbuster
166 id junkbuster > /dev/null 2>&1 && /usr/sbin/userdel junkbuster || /bin/true
167
168 %clean
169 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
170
171 %files
172 %defattr(0644,root,root,0755)
173 %doc README AUTHORS ChangeLog
174 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
175 %doc doc/webserver/developer-manual
176 %doc doc/webserver/user-manual
177 %doc doc/webserver/ijb_docs.css
178 #%doc %{name}.weekly %{name}.monthly AUTHORS
179
180 %dir %{jbngconf}
181 %dir %{jbngconf}/templates
182 %attr(0744,junkbuster,junkbuster) %dir %{_localstatedir}/log/%{name}
183
184 %attr(0744,junkbuster,junkbuster)%{_sbindir}/jbng
185
186 # We should not use wildchars here. This could mask missing files problems
187 # -- morcego
188 %config %{jbngconf}/config
189 %config %{jbngconf}/ijb-advanced.action
190 %config %{jbngconf}/ijb-basic.action
191 %config %{jbngconf}/ijb-intermediate.action
192 %config %{jbngconf}/ijb.action
193 %config %{jbngconf}/re_filterfile
194 %config %{jbngconf}/trust
195
196 %config %{jbngconf}/templates/blocked
197 %config %{jbngconf}/templates/blocked-compact
198 %config %{jbngconf}/templates/cgi-error-404
199 %config %{jbngconf}/templates/cgi-error-bad-param
200 %config %{jbngconf}/templates/cgi-error-disabled
201 %config %{jbngconf}/templates/cgi-error-file
202 %config %{jbngconf}/templates/cgi-error-modified
203 %config %{jbngconf}/templates/cgi-error-parse
204 %config %{jbngconf}/templates/connect-failed
205 %config %{jbngconf}/templates/default
206 %config %{jbngconf}/templates/edit-actions-add-url-form
207 %config %{jbngconf}/templates/edit-actions-for-url
208 %config %{jbngconf}/templates/edit-actions-list
209 %config %{jbngconf}/templates/edit-actions-list-section
210 %config %{jbngconf}/templates/edit-actions-list-url
211 %config %{jbngconf}/templates/edit-actions-remove-url-form
212 %config %{jbngconf}/templates/edit-actions-url-form
213 %config %{jbngconf}/templates/no-such-domain
214 %config %{jbngconf}/templates/show-request
215 %config %{jbngconf}/templates/show-status
216 %config %{jbngconf}/templates/show-status-file
217 %config %{jbngconf}/templates/show-url-info
218 %config %{jbngconf}/templates/show-version
219 %config %{jbngconf}/templates/toggle
220 %config %{jbngconf}/templates/toggle-mini
221 %config %{jbngconf}/templates/untrusted
222
223 %config %{_sysconfdir}/logrotate.d/%{oldname}
224 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
225 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
226 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
227 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
228 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
229 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/S84%{name}
230 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
231 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/S84%{name}
232
233 %{_mandir}/man8/%{oldname}.8*
234
235 %changelog
236 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
237 + junkbusterng-2.9.13-1
238 - References to the expression ijb where changed where possible
239 - New package name: junkbusterng (all in lower case, acording to
240   the LSB recomendation)
241 - Version changed to: 2.9.13
242 - Release: 1
243 - Added: junkbuster to obsoletes and conflicts (Not sure this is
244   right. If it obsoletes, why conflict ? Have to check it later)
245 - Summary changed: Stefan, please check and aprove it
246 - Changes description to use the new name
247 - Sed string was NOT changed. Have to wait to the manpage to
248   change first
249 - Keeping the user junkbuster for now. It will require some aditional
250   changes on the script (scheduled for the next specfile release)
251 - Added post entry to move the old logfile to the new log directory
252 - Removing "chkconfig --add" entry (not good to have it automaticaly
253   added to the startup list).
254 - Added preun section to stop the service with the old name, as well
255   as remove it from the startup list
256 - Removed the chkconfig --del entry from the conditional block on
257   the preun scriptlet (now handled on the %files section)
258
259 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
260 - added ijb_docs.css to docs.
261
262 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
263 + junkbuster-2.9.11-8 
264 - Take out --enable-no-gifs, breaks some browsers.
265
266 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
267 + junkbuster-2.9.11-8 
268 - Add --enable-no-gifs to configure.
269
270 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
271 + junkbuster-2.9.11-7
272 - Added BuildRequires to libtool.
273
274 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
275 + junkbuster-2.9.11-6
276 - Changed the routined that handle the junkbust and junkbuster users on
277   %%pre and %%post to work in a smoother manner
278 - %%files now uses hardcoded usernames, to avoid problems with package
279   name changes in the future
280
281 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
282 + junkbuster-2.9.11-5
283 - Added "make redhat-dok" to the build process
284 - Added docbook-utils to BuildRequires
285
286 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
287 + junkbuster-2.9.11-4
288 - Changing man section in the manpage from 1 to 8
289 - We now require packages, not files, to avoid issues with apt
290
291 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
292 + junkbuster-2.9.11-3
293 - Fixing permissions of the init script
294
295 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
296 + junkbuster-2.9.11-2
297 - General specfile fixup, using the best recomended practices, including:
298         - Adding -q to %%setup
299         - Using macros whereever possible
300         - Not using wildchars on %%files section
301         - Doubling the percentage char on changelog and comments, to
302           avoid rpm expanding them
303
304 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
305 - /bin/false for shell causes init script to fail. Reverting.
306
307 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
308 - Removed UID 73. Included user-manual and developer-manual in docs.
309   Include other actions files. Default shell is now /bin/false.
310   Userdel user=junkbust. ChangeLog was not zipped. Removed 
311   RPM_OPT_FLAGS kludge.
312
313 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
314 - add paranoia check for 'rm -rf %%{buildroot}'
315 - add gzip to 'BuildRequires'
316
317 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
318 - actionsfile is now ijb.action.
319
320 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
321 - Compress manpage
322 - Add more documents for installation
323 - Add version string to name and source
324
325 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
326 - Back to user 'junkbuster' and fix configure macro.
327
328 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
329 - More changes for user 'junkbust'. Init script had 'junkbuster'.
330
331 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
332 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
333 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
334
335 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
336 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
337 - made sure no default shell exists for user junkbust.
338
339 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
340 - rework of RPM
341
342 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
343 - CLF Logging patch by davep@cyw.uklinux.net
344 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
345
346 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
347 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
348 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
349   numerous fixes and enhancements for Steve's patch.
350 - adamlock@netscape.com (Adam Lock) in the windows version:
351   - Taskbar activity spinner always spins even when logging is
352   turned off (which is the default) - people who don't
353   like the spinner can turn it off from a menu option.
354   - Taskbar popup menu has a options submenu - people can now
355   open the settings files for cookies, blockers etc.
356   without opening the JB window.
357   - Logging functionality works again
358   - Buffer overflow is fixed - new code uses a bigger buffer
359   and snprintf so it shouldn't overflow anymore.
360 - Fixed userid swa, group learning problem while installing.
361   root must build RPM.
362 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
363   core dump when there is no log file.
364 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
365 - Fixed man page to include imagefile and popupfile.
366 - Sanity check for the statistics function added.
367 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
368  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
369  With IIS/5, it appears to omit the trailing \r\n from http header
370  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
371  responds with a HTTP 302 redirect header.  However, this header
372  message is missing the trailing \r\n.  IIS/5 then closes the
373  connection.  Junkbuster, unfortunately, discards the header becomes
374  it thinks it is incomplete - and it is.  MS have transmitted an
375  incomplete header!
376 - Added bug reports and patch submission forms in the docs.
377
378 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
379        Andrew <anw@tirana.freewire.co.uk> extended the JB:
380        Display of statistics of the total number of requests and the number
381        of requests filtered by junkbuster, also the percentage of requests
382        filtered. Suppression of the listing of files on the proxy-args page.
383        All stuff optional and configurable.
384
385 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
386        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
387        code which prevented the JB from handling URLs of the form
388        user:password@www.foo.com. Fixed.
389
390 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
391         Blank images are no longer cached, thanks to a hint from Markus 
392         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
393         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
394         on the correct browser version nowadays. Incorporated many 
395         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
396         spec file. Fixed logging problem and since runlevel 2 does not 
397         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
398         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
399         <walker@netgate.net>. You should now be able to build this RPM as 
400         a non-root user (mathias@weidner.sem.lipsia.de).
401
402 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
403         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
404         to allow more sophisticated matching of blocked images. Logrotate
405         logfile. Added files for auto-updating the blocklist et al.
406
407 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
408         Configure blank version via config file. No separate blank
409         version anymore. Added Roland's <roland@spinnaker.rhein.de>
410         patch to show a logo instead of a blank area. Added a suggestion
411         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
412         More regexps in the blocklist. Prepared the forwardfile for
413         squid. Extended image regexp with help from gabriel 
414         <somlo@CS.ColoState.EDU>.
415
416 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
417         All RPMs now identify themselves in the show-proxy-args page.
418         Released Windoze version. Run junkbuster as nobody instead of
419         root. 
420
421 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
422         Newest version. First release (hence the little version number
423         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
424         security over 2.0.1; some multi-user sites will need to change 
425         the listen-address in the configuration file. The blank version of
426         the Internet Junkbuster has a more sophisticated way of replacing
427         images. All RPMs identify themselves in the show-proxy-args page.
428
429 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
430         Modified the blocking feature, so that only GIFs and JPEGs are
431         blocked and replaced but not HTML pages. Thanks to 
432         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
433         idea. Added numerous stuff to the blocklist. Keep patches in
434         seperate files and no longer in diffs (easier to maintain).
435
436 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
437         Moved config files to /etc/junkbuster directory, moved man page,
438         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
439         Made new version junkbuster-raw (which is only a stripped version of 
440         the junkuster rpm, i.e. without my blocklist, etc.)
441
442 * Tue Jun 16 1998 (2.0-1)
443         Uhm, not that much. Just a new junkbuster version that
444         fixes a couple of bugs ... and of course a bigger 
445         blocklist with the unique Now-less-ads-than-ever(SM)
446         feature.
447         Oh, one thing: I changed the default user agent to Linux -- no 
448         need anymore to support Apple.
449
450 * Tue Jun 16 1998 (2.0-0)
451         Now-less-ads-than-ever (SM)
452         compiled with gcc instead of cc
453         compiled with -O3, thus it should be a little faster
454         show-proxy-args now works
455         /etc/junkbuster.init wasn't necessary
456
457 * Tue Jun 16 1998 (1.4)
458         some more config files were put into /etc
459         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
460         displayed by Netscape instead of the blocked image.
461         Read http://www.waldherr.org/junkbuster/ for
462         further info.
463
464 * Tue Jun 16 1998 (1.3)
465         The program has been moved to /usr/sbin (from /usr/local/bin)
466         Init- and stopscripts (/etc/rc.d/rc*) have been added so
467         that the junkbuster starts automatically during bootup.
468         The /etc/blocklist file is much more sophisticated. Theoretically
469         one should e.g. browse all major US and German newspapers without
470         seeing one annoying ad.
471         junkbuster.init was modified. It now starts junkbuster with an
472         additional "-r @" flag.
473
474 # $Log: junkbusterng-rh.spec,v $
475 # Revision 1.1  2002/03/22 20:53:03  morcego
476 # - Ongoing process to change name to JunkbusterNG
477 # - configure/configure.in: no change needed
478 # - GNUmakefile.in:
479 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
480 #         - PROGRAM    = jbng@EXEEXT@
481 #         - rh-spec now references as junkbusterng-rh.spec
482 #         - redhat-upload: references changed to junkbusterng-* (package names)
483 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
484 #         - tarball-src: now JunkbusterNG-*
485 #         - install: initscript now junkbusterng.init and junkbusterng (when
486 #                    installed)
487 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
488 # - junkbusterng.spec:
489 #         - References to the expression ijb where changed where possible
490 #         - New package name: junkbusterng (all in lower case, acording to
491 #           the LSB recomendation)
492 #         - Version changed to: 2.9.13
493 #         - Release: 1
494 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
495 #           right. If it obsoletes, why conflict ? Have to check it later)
496 #         - Summary changed: Stefan, please check and aprove it
497 #         - Changes description to use the new name
498 #         - Sed string was NOT changed. Have to wait to the manpage to
499 #           change first
500 #         - Keeping the user junkbuster for now. It will require some aditional
501 #           changes on the script (scheduled for the next specfile release)
502 #         - Added post entry to move the old logfile to the new log directory
503 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
504 #           added to the startup list).
505 #         - Added preun section to stop the service with the old name, as well
506 #           as remove it from the startup list
507 #         - Removed the chkconfig --del entry from the conditional block on
508 #           the preun scriptlet (now handled on the %files section)
509 # - junkbuster.init: renamed to junkbusterng.init
510 # - junkbusterng.init:
511 #         - Changed JB_BIN to jbng
512 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
513 #           be used where necessary (config dir)
514 #
515 # Aditional notes:
516 # - The config directory is /etc/junkbuster yet. Have to change it on the
517 # specfile, after it is changes on the code
518 # - The only files that got renamed on the cvs tree were the rh specfile and
519 # the init file. Some file references got changes on the makefile and on the
520 # rh-spec (as listed above)
521 #
522 # Revision 1.43  2002/03/21 16:04:10  hal9
523 # added ijb_docs.css to %doc
524 #
525 # Revision 1.42  2002/03/12 13:41:18  sarantis
526 # remove hard-coded "ijbswa" string in build phase
527 #
528 # Revision 1.41  2002/03/11 22:58:32  hal9
529 # Remove --enable-no-gifs
530 #
531 # Revision 1.39  2002/03/08 18:57:29  swa
532 # remove user junkbuster after de-installation.
533 #
534 # Revision 1.38  2002/03/08 13:45:27  morcego
535 # Adding libtool to Buildrequires
536 #
537 # Revision 1.37  2002/03/07 19:23:49  swa
538 # i hate to scroll. suse: wrong configdir.
539 #
540 # Revision 1.36  2002/03/07 05:06:54  morcego
541 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
542 #
543 # Revision 1.34  2002/03/07 00:11:57  morcego
544 # Few changes on the %pre and %post sections of the rh specfile to handle
545 # usernames more cleanly
546 #
547 # Revision 1.33  2002/03/05 13:13:57  morcego
548 # - Added "make redhat-dok" to the build phase
549 # - Added docbook-utils to BuildRequires
550 #
551 # Revision 1.32  2002/03/05 12:34:24  morcego
552 # - Changing section internaly on the manpage from 1 to 8
553 # - We now require packages, not files, to avoid issues with apt
554 #
555 # Revision 1.31  2002/03/04 18:06:09  morcego
556 # SPECFILE: fixing permissing of the init script (broken by the last change)
557 #
558 # Revision 1.30  2002/03/04 16:18:03  morcego
559 # General cleanup of the rh specfile.
560 #
561 # %changelog
562 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
563 # + junkbuster-2.9.11-2
564 # - General specfile fixup, using the best recomended practices, including:
565 #         - Adding -q to %%setup
566 #         - Using macros whereever possible
567 #         - Not using wildchars on %%files section
568 #         - Doubling the percentage char on changelog and comments, to
569 #           avoid rpm expanding them
570 #
571 # Revision 1.29  2002/03/03 19:21:22  hal9
572 # Init script fails if shell is /bin/false.
573 #
574 # Revision 1.28  2002/01/09 18:34:03  hal9
575 # nit.
576 #
577 # Revision 1.27  2002/01/09 18:32:02  hal9
578 # Removed RPM_OPT_FLAGS kludge.
579 #
580 # Revision 1.26  2002/01/09 18:21:10  hal9
581 # A few minor updates.
582 #
583 # Revision 1.25  2001/12/28 01:45:36  steudten
584 # Add paranoia check and BuildReq: gzip
585 #
586 # Revision 1.24  2001/12/01 21:43:14  hal9
587 # Allowed for new ijb.action file.
588 #
589 # Revision 1.23  2001/11/06 12:09:03  steudten
590 # Compress doc files. Install README and AUTHORS at last as document.
591 #
592 # Revision 1.22  2001/11/05 21:37:34  steudten
593 # Fix to include the actual version for name.
594 # Let the 'real' packager be included - sorry stefan.
595 #
596 # Revision 1.21  2001/10/31 19:27:27  swa
597 # consistent description. new name for suse since
598 # we had troubles with rpms of identical names
599 # on the webserver.
600 #
601 # Revision 1.20  2001/10/24 15:45:49  hal9
602 # To keep Thomas happy (aka correcting my  mistakes)
603 #
604 # Revision 1.19  2001/10/15 03:23:59  hal9
605 # Nits.
606 #
607 # Revision 1.17  2001/10/10 18:59:28  hal9
608 # Minor change for init script.
609 #
610 # Revision 1.16  2001/09/24 20:56:23  hal9
611 # Minor changes.
612 #
613 # Revision 1.13  2001/09/10 17:44:43  swa
614 # integrate three pieces of documentation. needs work.
615 # will not build cleanly under redhat.
616 #
617 # Revision 1.12  2001/09/10 16:25:04  swa
618 # copy all templates. version updated.
619 #
620 # Revision 1.11  2001/07/03 11:00:25  sarantis
621 # replaced permissionsfile with actionsfile
622 #
623 # Revision 1.10  2001/07/03 09:34:44  sarantis
624 # bumped up version number.
625 #
626 # Revision 1.9  2001/06/12 18:15:29  swa
627 # the %% in front of configure (see tag below) confused
628 # the rpm build process on 7.1.
629 #
630 # Revision 1.8  2001/06/12 17:15:56  swa
631 # fixes, because a clean build on rh6.1 was impossible.
632 # GZIP confuses make, %% configure confuses rpm, etc.
633 #
634 # Revision 1.7  2001/06/11 12:17:26  sarantis
635 # fix typo in %%post
636 #
637 # Revision 1.6  2001/06/11 11:28:25  sarantis
638 # Further optimizations and adaptations in the spec file.
639 #
640 # Revision 1.5  2001/06/09 09:14:11  swa
641 # shamelessly adapted RPM stuff from the newest rpm that
642 # RedHat provided for the JB.
643 #
644 # Revision 1.4  2001/06/08 20:54:18  swa
645 # type with status file. remove forward et. al from file list.
646 #
647 # Revision 1.3  2001/06/07 17:28:10  swa
648 # cosmetics
649 #
650 # Revision 1.2  2001/06/04 18:31:58  swa
651 # files are now prefixed with either `confdir' or `logdir'.
652 # `make redhat-dist' replaces both entries confdir and logdir
653 # with redhat values
654 #
655 # Revision 1.1  2001/06/04 10:44:57  swa
656 # `make redhatr-dist' now works. Except for the paths
657 # in the config file.
658 #
659 #
660 #