- Show name of actions file being edited
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.27 2002/04/22 16:32:31 morcego Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33 %define privoxy_uid 73
34 %define privoxy_gid 73
35
36 Name: privoxy
37 # ATTENTION
38 # Version and release should be updated acordingly on configure.in and
39 # configure. Otherwise, the package can be build with the wrong value
40 Version: 2.9.14
41 Release: 2
42 Summary: Privoxy - privacy enhancing proxy
43 License: GPL
44 Vendor: http://www.privoxy.org
45 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
46 BuildRoot: %{_tmppath}/%{name}-%{version}-root
47 Group: Networking/Utilities
48 URL: http://www.privoxy.org/
49 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
50 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
51 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
52 BuildRequires: perl gzip sed libtool autoconf 
53 Conflicts: junkbuster-raw junkbuster-blank junkbuster
54
55 %description 
56 Privoxy is a web proxy with advanced filtering capabilities for
57 protecting privacy, filtering web page content, managing cookies,
58 controlling access, and removing ads, banners, pop-ups and other
59 obnoxious Internet junk. Privoxy has a very flexible configuration and
60 can be customized to suit individual needs and tastes. Privoxy has application
61 for both stand-alone systems and multi-user networks.
62
63 Privoxy is based on the Internet Junkbuster.
64
65 %prep
66 %setup -q -c
67
68 %build
69 autoheader
70 autoconf
71 %configure --disable-dynamic-pcre
72 make 
73 # Docs are in CVS and tarball now.
74 #%%make dok
75
76 ## Explicitily stripping is not recomended.
77 ## This is handled altomaticaly by RPM, and can couse troubles if
78 ## anyone wants to build an unstriped version - morcego
79 #strip %{name}
80
81 %install
82 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
83 mkdir -p %{buildroot}%{_sbindir} \
84          %{buildroot}%{_mandir}/man1 \
85          %{buildroot}%{_localstatedir}/log/%{name} \
86          %{buildroot}%{privoxyconf}/templates \
87          %{buildroot}%{_sysconfdir}/logrotate.d \
88          %{buildroot}%{_sysconfdir}/rc.d/init.d 
89
90 ## Manual gziping of manpages should not be done, once it can
91 ## break the building on some distributions. Anyway, rpm does it
92 ## automagicaly these days
93 ## Gziping the documentation files is not recomended - morcego
94 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
95
96 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
97
98 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
99 cp -f *.action %{buildroot}%{privoxyconf}/
100 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
101 cp -f trust %{buildroot}%{privoxyconf}/trust
102 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
103 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
104 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
105 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
106
107 # verify all file locations, etc. in the config file
108 # don't start with ^ or commented lines are not replaced
109 ## Changing the sed paramter delimiter to @, so we don't have to
110 ## escape the slashes
111 cat config | \
112     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
113 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
114 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
115 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
116 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
117 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
118 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
119     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
120     %{buildroot}%{privoxyconf}/config
121 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
122     %{buildroot}%{privoxyconf}/default.action
123
124
125 # Creating ghost init files
126 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
127 for i in 0 1 4 6
128 do
129 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
130 done
131 for i in 2 3 5
132 do
133 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
134 done
135
136 ## Macros are expanded even on commentaries. So, we have to use %%
137 ## -- morcego
138 #%%makeinstall
139
140 %pre
141 # This is where we handle old usernames (junkbust and junkbuster)
142 # I'm not sure we should do that, but this is the way we have been
143 # doing it for some time now -- morcego
144 # We should do it for the group as well -- morcego
145 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
146
147 # Change the group name. Remove anything left behind.
148 groupmod -g %{privoxy_gid} -n %{name} %{oldname} > /dev/null 2>&1 ||:
149 groupmod -g %{privoxy_gid} -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
150 groupdel %{oldname} > /dev/null 2>&1 ||:
151 groupdel %{veryoldname} > /dev/null 2>&1 ||:
152
153 # Same for username
154 usermod -u %{privoxy_uid} -g %{privoxy_gid} -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
155 usermod -u %{privoxy_uid} -g %{privoxy_gid} -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
156 userdel %{oldname} > /dev/null 2>&1 ||:
157 userdel %{veryoldname} > /dev/null 2>&1 ||:
158
159 # Doublecheck to see if the group exist, and that it has the correct gid
160 /bin/grep -E '^%{name}:' /etc/group > /dev/null 2>&1
161 if [ $? -eq 1 ]; then
162         # Looks like it does not exist. Create it
163         groupadd -g %{privoxy_gid} %{name} > /dev/null 2>&1
164 else
165         /bin/grep -E '^%{name}:[^:]*:%{privoxy_gid}:' /etc/group > /dev/null 2>&1
166         if [ $? -eq 1 ]; then
167                 # The group exists, but does not have the correct gid
168                 groupmod -g %{privoxy_gid} %{name} > /dev/null 2>&1
169         fi
170 fi
171
172 # Check to see if everything is okey. Create user if it still does not
173 # exist
174 id %{name} > /dev/null 2>&1
175 if [ $? -eq 1 ]; then
176         /usr/sbin/useradd -u %{privoxy_uid} -g %{privoxy_gid} -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
177 fi
178
179 # Double check that the group has the correct uid
180 P_UID=`id -u %{name} 2>/dev/null`
181 if [ $P_UID -ne %{privoxy_uid} ]; then
182         /usr/sbin/usermod -u %{privoxy_uid} %{name}
183 fi
184
185 # The same for the gid
186 P_GID=`id -g %{name} 2>/dev/null`
187 if [ $P_GID -ne %{privoxy_gid} ]; then
188         /usr/sbin/usermod -g %{privoxy_gid} %{name}
189 fi
190
191 %post
192 # for upgrade from 2.0.x
193 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
194  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
195 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
196  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
197 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
198 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
199 if [ "$1" = "1" ]; then
200         /sbin/service %{name} condrestart > /dev/null 2>&1
201 fi
202
203 %preun
204 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
205 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
206
207 if [ "$1" = "0" ]; then
208         /sbin/service %{name} stop > /dev/null 2>&1 ||:
209         # No need to use chkconfig. The %%ghost files will handle it
210 fi
211
212 %postun
213 #if [ "$1" -ge "1" ]; then
214 #       /sbin/service %{name} condrestart > /dev/null 2>&1
215 #fi
216 # We only remove it we this is not an upgrade
217 if [ "$1" = "0" ]; then
218         /bin/grep -E '^%{name}:' /etc/group > /dev/null && /usr/sbin/groupdel %{name} || /bin/true
219         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
220 fi
221
222 %clean
223 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
224
225 %files
226 %defattr(0644,root,root,0755)
227 %doc README AUTHORS ChangeLog LICENSE 
228 %doc doc/text/developer-manual.txt doc/text/user-manual.txt doc/text/faq.txt
229 %doc doc/webserver/developer-manual
230 %doc doc/webserver/user-manual
231 %doc doc/webserver/faq
232 %doc doc/webserver/p_doc.css doc/webserver/p_web.css doc/webserver/index.html
233
234 %dir %{privoxyconf}
235 %dir %{privoxyconf}/templates
236 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
237
238 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
239
240 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
241 # We should not use wildchars here. This could mask missing files problems
242 # -- morcego
243 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
244 %config %{privoxyconf}/config
245 %config %{privoxyconf}/advanced.action
246 %config %{privoxyconf}/basic.action
247 %config %{privoxyconf}/intermediate.action
248 %config %{privoxyconf}/default.action
249 %config %{privoxyconf}/default.filter
250 %config %{privoxyconf}/trust
251
252 %config %{privoxyconf}/templates/untrusted
253 %config %{privoxyconf}/templates/toggle-mini
254 %config %{privoxyconf}/templates/default
255 %config %{privoxyconf}/templates/connect-failed
256 %config %{privoxyconf}/templates/show-status-file
257 %config %{privoxyconf}/templates/cgi-error-bad-param
258 %config %{privoxyconf}/templates/show-version
259 %config %{privoxyconf}/templates/cgi-error-file
260 %config %{privoxyconf}/templates/cgi-error-404
261 %config %{privoxyconf}/templates/cgi-error-parse
262 %config %{privoxyconf}/templates/edit-actions-url-form
263 %config %{privoxyconf}/templates/no-such-domain
264 %config %{privoxyconf}/templates/edit-actions-add-url-form
265 %config %{privoxyconf}/templates/cgi-style.css
266 %config %{privoxyconf}/templates/edit-actions-for-url-filter
267 %config %{privoxyconf}/templates/cgi-error-disabled
268 %config %{privoxyconf}/templates/edit-actions-remove-url-form
269 %config %{privoxyconf}/templates/show-request
270 %config %{privoxyconf}/templates/cgi-error-modified
271 %config %{privoxyconf}/templates/mod-unstable-warning
272 %config %{privoxyconf}/templates/edit-actions-list
273 %config %{privoxyconf}/templates/toggle
274 %config %{privoxyconf}/templates/edit-actions-list-section
275 %config %{privoxyconf}/templates/mod-title
276 %config %{privoxyconf}/templates/edit-actions-list-url
277 %config %{privoxyconf}/templates/show-status
278 %config %{privoxyconf}/templates/blocked
279 %config %{privoxyconf}/templates/mod-support-and-service
280 %config %{privoxyconf}/templates/mod-local-help
281 %config %{privoxyconf}/templates/show-url-info
282 %config %{privoxyconf}/templates/edit-actions-for-url
283
284 %config %{_sysconfdir}/logrotate.d/%{name}
285 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
286 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
287 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
288 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
289 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
290 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
291 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
292 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
293
294 %{_mandir}/man1/%{name}.*
295
296 %changelog
297 * Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
298 + privoxy-2.9.14-2
299 - Removed the redhat hack that prevented the user and group from
300   being dealocated. That was a misundestanding of my part regarding
301   redhat policy.
302
303 * Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
304 + privoxy-2.9.14-2
305 - Using macros to define uid and gid values
306 - Bumping release
307
308 * Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
309 + privoxy-2.9.14-1
310 - Changes to fixate the uid and gid values as (both) 73. This is a 
311   value we hope to standarize for all distributions. RedHat already
312   uses it, and Conectiva should start as soon as I find where the heck
313   I left my cluebat :-)
314 - Only remove the user and group on uninstall if this is not redhat, once
315   redhat likes to have the values allocated even if the package is not 
316   installed
317
318 * Tue Apr 16 2002 Hal Burgiss <hal@foobox.net>
319 + privoxy-2.9.13-6
320 - Add --disable-dynamic-pcre to configure.
321
322 * Wed Apr 10 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
323 + privoxy-2.9.13-5
324 - Relisting template files on the %%files section
325
326 * Tue Apr 09 2002 Hal Burgiss <hal@foobox.net>
327 + privoxy-2.9.13-4
328 - Removed 'make dok'. Docs are all maintained in CVS (and tarball) now.
329
330 * Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
331 + privoxy-2.9.13-4
332 - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
333 - Remove templates/blocked-compact.
334 - Add more docbook stuff to Builderquires.
335
336 * Thu Mar 28 2002 Sarantis Paskalis <sarantis@cnl.di.uoa.gr>
337 + privoxy-2.9.13-3
338 - Include correct documentation file.
339
340 * Tue Mar 26 2002 Hal Burgiss <hal@foobox.net>
341 + privoxy-2.9.13-3
342 - Fix typo in Description.
343
344 * Tue Mar 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
345 + privoxy-2.9.13-3
346 - Added commentary asking to update the release value on the configure
347   script
348
349 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
350 + privoxy-2.9.13-3
351 - Added the missing edit-actions-for-url-filter to templates.
352
353 * Mon Mar 25 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
354 + privoxy-2.9.13-2
355 - Fixing Release number
356
357 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
358 + privoxy-2.9.13-2
359 - Added faq to docs.
360
361 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
362 + privoxy-2.9.13-2
363 - Fixed the init files entries. Now we use %%ghost
364 - improved username (and groupname) handling on the %%pre section. By improved
365   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
366   got it right. No more Mr. Nice Guy.
367 - Removed the userdel call on %%post. No need, once it's complety handled on
368   the %%pre section
369
370 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
371 + junkbusterng-2.9.13-1
372   Added autoheader. Added autoconf to buildrequires.
373
374 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
375 + junkbusterng-2.9.13-1
376 - Fixed build problems re: name conflicts with man page and logrotate.
377 - Commented out rc?d/* configs for time being, which are causing a build 
378 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
379 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
380
381 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
382 + junkbusterng-2.9.13-1
383 - References to the expression ijb where changed where possible
384 - New package name: junkbusterng (all in lower case, acording to
385   the LSB recomendation)
386 - Version changed to: 2.9.13
387 - Release: 1
388 - Added: junkbuster to obsoletes and conflicts (Not sure this is
389   right. If it obsoletes, why conflict ? Have to check it later)
390 - Summary changed: Stefan, please check and aprove it
391 - Changes description to use the new name
392 - Sed string was NOT changed. Have to wait to the manpage to
393   change first
394 - Keeping the user junkbuster for now. It will require some aditional
395   changes on the script (scheduled for the next specfile release)
396 - Added post entry to move the old logfile to the new log directory
397 - Removing "chkconfig --add" entry (not good to have it automaticaly
398   added to the startup list).
399 - Added preun section to stop the service with the old name, as well
400   as remove it from the startup list
401 - Removed the chkconfig --del entry from the conditional block on
402   the preun scriptlet (now handled on the %files section)
403
404 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
405 - added ijb_docs.css to docs.
406
407 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
408 + junkbuster-2.9.11-8 
409 - Take out --enable-no-gifs, breaks some browsers.
410
411 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
412 + junkbuster-2.9.11-8 
413 - Add --enable-no-gifs to configure.
414
415 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
416 + junkbuster-2.9.11-7
417 - Added BuildRequires to libtool.
418
419 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
420 + junkbuster-2.9.11-6
421 - Changed the routined that handle the junkbust and junkbuster users on
422   %%pre and %%post to work in a smoother manner
423 - %%files now uses hardcoded usernames, to avoid problems with package
424   name changes in the future
425
426 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
427 + junkbuster-2.9.11-5
428 - Added "make redhat-dok" to the build process
429 - Added docbook-utils to BuildRequires
430
431 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
432 + junkbuster-2.9.11-4
433 - Changing man section in the manpage from 1 to 8
434 - We now require packages, not files, to avoid issues with apt
435
436 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
437 + junkbuster-2.9.11-3
438 - Fixing permissions of the init script
439
440 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
441 + junkbuster-2.9.11-2
442 - General specfile fixup, using the best recomended practices, including:
443         - Adding -q to %%setup
444         - Using macros whereever possible
445         - Not using wildchars on %%files section
446         - Doubling the percentage char on changelog and comments, to
447           avoid rpm expanding them
448
449 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
450 - /bin/false for shell causes init script to fail. Reverting.
451
452 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
453 - Removed UID 73. Included user-manual and developer-manual in docs.
454   Include other actions files. Default shell is now /bin/false.
455   Userdel user=junkbust. ChangeLog was not zipped. Removed 
456   RPM_OPT_FLAGS kludge.
457
458 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
459 - add paranoia check for 'rm -rf %%{buildroot}'
460 - add gzip to 'BuildRequires'
461
462 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
463 - actionsfile is now ijb.action.
464
465 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
466 - Compress manpage
467 - Add more documents for installation
468 - Add version string to name and source
469
470 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
471 - Back to user 'junkbuster' and fix configure macro.
472
473 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
474 - More changes for user 'junkbust'. Init script had 'junkbuster'.
475
476 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
477 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
478 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
479
480 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
481 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
482 - made sure no default shell exists for user junkbust.
483
484 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
485 - rework of RPM
486
487 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
488 - CLF Logging patch by davep@cyw.uklinux.net
489 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
490
491 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
492 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
493 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
494   numerous fixes and enhancements for Steve's patch.
495 - adamlock@netscape.com (Adam Lock) in the windows version:
496   - Taskbar activity spinner always spins even when logging is
497   turned off (which is the default) - people who don't
498   like the spinner can turn it off from a menu option.
499   - Taskbar popup menu has a options submenu - people can now
500   open the settings files for cookies, blockers etc.
501   without opening the JB window.
502   - Logging functionality works again
503   - Buffer overflow is fixed - new code uses a bigger buffer
504   and snprintf so it shouldn't overflow anymore.
505 - Fixed userid swa, group learning problem while installing.
506   root must build RPM.
507 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
508   core dump when there is no log file.
509 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
510 - Fixed man page to include imagefile and popupfile.
511 - Sanity check for the statistics function added.
512 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
513  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
514  With IIS/5, it appears to omit the trailing \r\n from http header
515  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
516  responds with a HTTP 302 redirect header.  However, this header
517  message is missing the trailing \r\n.  IIS/5 then closes the
518  connection.  Junkbuster, unfortunately, discards the header becomes
519  it thinks it is incomplete - and it is.  MS have transmitted an
520  incomplete header!
521 - Added bug reports and patch submission forms in the docs.
522
523 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
524        Andrew <anw@tirana.freewire.co.uk> extended the JB:
525        Display of statistics of the total number of requests and the number
526        of requests filtered by junkbuster, also the percentage of requests
527        filtered. Suppression of the listing of files on the proxy-args page.
528        All stuff optional and configurable.
529
530 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
531        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
532        code which prevented the JB from handling URLs of the form
533        user:password@www.foo.com. Fixed.
534
535 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
536         Blank images are no longer cached, thanks to a hint from Markus 
537         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
538         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
539         on the correct browser version nowadays. Incorporated many 
540         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
541         spec file. Fixed logging problem and since runlevel 2 does not 
542         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
543         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
544         <walker@netgate.net>. You should now be able to build this RPM as 
545         a non-root user (mathias@weidner.sem.lipsia.de).
546
547 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
548         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
549         to allow more sophisticated matching of blocked images. Logrotate
550         logfile. Added files for auto-updating the blocklist et al.
551
552 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
553         Configure blank version via config file. No separate blank
554         version anymore. Added Roland's <roland@spinnaker.rhein.de>
555         patch to show a logo instead of a blank area. Added a suggestion
556         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
557         More regexps in the blocklist. Prepared the forwardfile for
558         squid. Extended image regexp with help from gabriel 
559         <somlo@CS.ColoState.EDU>.
560
561 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
562         All RPMs now identify themselves in the show-proxy-args page.
563         Released Windoze version. Run junkbuster as nobody instead of
564         root. 
565
566 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
567         Newest version. First release (hence the little version number
568         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
569         security over 2.0.1; some multi-user sites will need to change 
570         the listen-address in the configuration file. The blank version of
571         the Internet Junkbuster has a more sophisticated way of replacing
572         images. All RPMs identify themselves in the show-proxy-args page.
573
574 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
575         Modified the blocking feature, so that only GIFs and JPEGs are
576         blocked and replaced but not HTML pages. Thanks to 
577         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
578         idea. Added numerous stuff to the blocklist. Keep patches in
579         seperate files and no longer in diffs (easier to maintain).
580
581 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
582         Moved config files to /etc/junkbuster directory, moved man page,
583         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
584         Made new version junkbuster-raw (which is only a stripped version of 
585         the junkuster rpm, i.e. without my blocklist, etc.)
586
587 * Tue Jun 16 1998 (2.0-1)
588         Uhm, not that much. Just a new junkbuster version that
589         fixes a couple of bugs ... and of course a bigger 
590         blocklist with the unique Now-less-ads-than-ever(SM)
591         feature.
592         Oh, one thing: I changed the default user agent to Linux -- no 
593         need anymore to support Apple.
594
595 * Tue Jun 16 1998 (2.0-0)
596         Now-less-ads-than-ever (SM)
597         compiled with gcc instead of cc
598         compiled with -O3, thus it should be a little faster
599         show-proxy-args now works
600         /etc/junkbuster.init wasn't necessary
601
602 * Tue Jun 16 1998 (1.4)
603         some more config files were put into /etc
604         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
605         displayed by Netscape instead of the blocked image.
606         Read http://www.waldherr.org/junkbuster/ for
607         further info.
608
609 * Tue Jun 16 1998 (1.3)
610         The program has been moved to /usr/sbin (from /usr/local/bin)
611         Init- and stopscripts (/etc/rc.d/rc*) have been added so
612         that the junkbuster starts automatically during bootup.
613         The /etc/blocklist file is much more sophisticated. Theoretically
614         one should e.g. browse all major US and German newspapers without
615         seeing one annoying ad.
616         junkbuster.init was modified. It now starts junkbuster with an
617         additional "-r @" flag.
618
619 # $Log: privoxy-rh.spec,v $
620 # Revision 1.27  2002/04/22 16:32:31  morcego
621 # configure.in, *.spec: Bumping release to 2 (2.9.14-2)
622 # -rh.spec: uid and gid are now macros
623 # -suse.spec: Changing the header Copyright to License (Copyright is
624 #             deprecable)
625 #
626 # Revision 1.26  2002/04/22 16:24:36  morcego
627 # - Changes to fixate the uid and gid values as (both) 73. This is a
628 #   value we hope to standarize for all distributions. RedHat already
629 #   uses it, and Conectiva should start as soon as I find where the heck
630 #   I left my cluebat :-)
631 # - Only remove the user and group on uninstall if this is not redhat, once
632 #   redhat likes to have the values allocated even if the package is not
633 #   installed
634 #
635 # Revision 1.25  2002/04/17 01:59:12  hal9
636 # Add --disable-dynamic-pcre.
637 #
638 # Revision 1.24  2002/04/11 10:09:20  oes
639 # Version 2.9.14
640 #
641 # Revision 1.23  2002/04/10 18:14:45  morcego
642 # - (privoxy-rh.spec only) Relisting template files on the %%files section
643 # - (configure.in, privoxy-rh.spec) Bumped package release to 5
644 #
645 # Revision 1.22  2002/04/09 22:06:12  hal9
646 # Remove 'make dok'.
647 #
648 # Revision 1.21  2002/04/09 02:52:26  hal9
649 # - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
650 # - Remove templates/blocked-compact.
651 # - Add more docbook stuff to Buildrequires.
652 #
653 # Revision 1.20  2002/04/08 20:27:45  swa
654 # fixed JB spelling
655 #
656 # Revision 1.19  2002/03/27 22:44:59  sarantis
657 # Include correct documentation file.
658 #
659 # Revision 1.18  2002/03/27 22:10:14  sarantis
660 # bumped Hal's last commit 1 day to the future to make rpm build again.
661 #
662 # Revision 1.17  2002/03/27 00:48:23  hal9
663 # Fix up descrition.
664 #
665 # Revision 1.16  2002/03/26 22:29:55  swa
666 # we have a new homepage!
667 #
668 # Revision 1.15  2002/03/26 17:39:54  morcego
669 # Adding comment on the specfile to remember the packager to update
670 # the release number on the configure script
671 #
672 # Revision 1.14  2002/03/26 14:25:15  hal9
673 # Added edit-actions-for-url-filter to templates in %%config
674 #
675 # Revision 1.13  2002/03/25 13:31:04  morcego
676 # Bumping Release tag.
677 #
678 # Revision 1.12  2002/03/25 03:11:40  hal9
679 # Do it right way this time :/
680 #
681 # Revision 1.11  2002/03/25 03:09:51  hal9
682 # Added faq to docs.
683 #
684 # Revision 1.10  2002/03/24 22:16:14  morcego
685 # Just removing some old commentaries.
686 #
687 # Revision 1.9  2002/03/24 22:03:22  morcego
688 # Should be working now. See %changelog for details
689 #
690 # Revision 1.8  2002/03/24 21:13:01  morcego
691 # Tis broken.
692 #
693 # Revision 1.7  2002/03/24 21:07:18  hal9
694 # Add autoheader, etc.
695 #
696 # Revision 1.6  2002/03/24 19:56:40  hal9
697 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
698 #
699 # Revision 1.4  2002/03/24 13:32:42  swa
700 # name change related issues
701 #
702 # Revision 1.3  2002/03/24 12:56:21  swa
703 # name change related issues.
704 #
705 # Revision 1.2  2002/03/24 11:40:14  swa
706 # name change
707 #
708 # Revision 1.1  2002/03/24 11:23:44  swa
709 # name change
710 #
711 # Revision 1.1  2002/03/22 20:53:03  morcego
712 # - Ongoing process to change name to JunkbusterNG
713 # - configure/configure.in: no change needed
714 # - GNUmakefile.in:
715 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
716 #         - PROGRAM    = jbng@EXEEXT@
717 #         - rh-spec now references as junkbusterng-rh.spec
718 #         - redhat-upload: references changed to junkbusterng-* (package names)
719 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
720 #         - tarball-src: now JunkbusterNG-*
721 #         - install: initscript now junkbusterng.init and junkbusterng (when
722 #                    installed)
723 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
724 # - junkbusterng.spec:
725 #         - References to the expression ijb where changed where possible
726 #         - New package name: junkbusterng (all in lower case, acording to
727 #           the LSB recomendation)
728 #         - Version changed to: 2.9.13
729 #         - Release: 1
730 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
731 #           right. If it obsoletes, why conflict ? Have to check it later)
732 #         - Summary changed: Stefan, please check and aprove it
733 #         - Changes description to use the new name
734 #         - Sed string was NOT changed. Have to wait to the manpage to
735 #           change first
736 #         - Keeping the user junkbuster for now. It will require some aditional
737 #           changes on the script (scheduled for the next specfile release)
738 #         - Added post entry to move the old logfile to the new log directory
739 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
740 #           added to the startup list).
741 #         - Added preun section to stop the service with the old name, as well
742 #           as remove it from the startup list
743 #         - Removed the chkconfig --del entry from the conditional block on
744 #           the preun scriptlet (now handled on the %files section)
745 # - junkbuster.init: renamed to junkbusterng.init
746 # - junkbusterng.init:
747 #         - Changed JB_BIN to jbng
748 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
749 #           be used where necessary (config dir)
750 #
751 # Aditional notes:
752 # - The config directory is /etc/junkbuster yet. Have to change it on the
753 # specfile, after it is changes on the code
754 # - The only files that got renamed on the cvs tree were the rh specfile and
755 # the init file. Some file references got changes on the makefile and on the
756 # rh-spec (as listed above)
757 #
758 # Revision 1.43  2002/03/21 16:04:10  hal9
759 # added ijb_docs.css to %doc
760 #
761 # Revision 1.42  2002/03/12 13:41:18  sarantis
762 # remove hard-coded "ijbswa" string in build phase
763 #
764 # Revision 1.41  2002/03/11 22:58:32  hal9
765 # Remove --enable-no-gifs
766 #
767 # Revision 1.39  2002/03/08 18:57:29  swa
768 # remove user junkbuster after de-installation.
769 #
770 # Revision 1.38  2002/03/08 13:45:27  morcego
771 # Adding libtool to Buildrequires
772 #
773 # Revision 1.37  2002/03/07 19:23:49  swa
774 # i hate to scroll. suse: wrong configdir.
775 #
776 # Revision 1.36  2002/03/07 05:06:54  morcego
777 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
778 #
779 # Revision 1.34  2002/03/07 00:11:57  morcego
780 # Few changes on the %pre and %post sections of the rh specfile to handle
781 # usernames more cleanly
782 #
783 # Revision 1.33  2002/03/05 13:13:57  morcego
784 # - Added "make redhat-dok" to the build phase
785 # - Added docbook-utils to BuildRequires
786 #
787 # Revision 1.32  2002/03/05 12:34:24  morcego
788 # - Changing section internaly on the manpage from 1 to 8
789 # - We now require packages, not files, to avoid issues with apt
790 #
791 # Revision 1.31  2002/03/04 18:06:09  morcego
792 # SPECFILE: fixing permissing of the init script (broken by the last change)
793 #
794 # Revision 1.30  2002/03/04 16:18:03  morcego
795 # General cleanup of the rh specfile.
796 #
797 # %changelog
798 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
799 # + junkbuster-2.9.11-2
800 # - General specfile fixup, using the best recomended practices, including:
801 #         - Adding -q to %%setup
802 #         - Using macros whereever possible
803 #         - Not using wildchars on %%files section
804 #         - Doubling the percentage char on changelog and comments, to
805 #           avoid rpm expanding them
806 #
807 # Revision 1.29  2002/03/03 19:21:22  hal9
808 # Init script fails if shell is /bin/false.
809 #
810 # Revision 1.28  2002/01/09 18:34:03  hal9
811 # nit.
812 #
813 # Revision 1.27  2002/01/09 18:32:02  hal9
814 # Removed RPM_OPT_FLAGS kludge.
815 #
816 # Revision 1.26  2002/01/09 18:21:10  hal9
817 # A few minor updates.
818 #
819 # Revision 1.25  2001/12/28 01:45:36  steudten
820 # Add paranoia check and BuildReq: gzip
821 #
822 # Revision 1.24  2001/12/01 21:43:14  hal9
823 # Allowed for new ijb.action file.
824 #
825 # Revision 1.23  2001/11/06 12:09:03  steudten
826 # Compress doc files. Install README and AUTHORS at last as document.
827 #
828 # Revision 1.22  2001/11/05 21:37:34  steudten
829 # Fix to include the actual version for name.
830 # Let the 'real' packager be included - sorry stefan.
831 #
832 # Revision 1.21  2001/10/31 19:27:27  swa
833 # consistent description. new name for suse since
834 # we had troubles with rpms of identical names
835 # on the webserver.
836 #
837 # Revision 1.20  2001/10/24 15:45:49  hal9
838 # To keep Thomas happy (aka correcting my  mistakes)
839 #
840 # Revision 1.19  2001/10/15 03:23:59  hal9
841 # Nits.
842 #
843 # Revision 1.17  2001/10/10 18:59:28  hal9
844 # Minor change for init script.
845 #
846 # Revision 1.16  2001/09/24 20:56:23  hal9
847 # Minor changes.
848 #
849 # Revision 1.13  2001/09/10 17:44:43  swa
850 # integrate three pieces of documentation. needs work.
851 # will not build cleanly under redhat.
852 #
853 # Revision 1.12  2001/09/10 16:25:04  swa
854 # copy all templates. version updated.
855 #
856 # Revision 1.11  2001/07/03 11:00:25  sarantis
857 # replaced permissionsfile with actionsfile
858 #
859 # Revision 1.10  2001/07/03 09:34:44  sarantis
860 # bumped up version number.
861 #
862 # Revision 1.9  2001/06/12 18:15:29  swa
863 # the %% in front of configure (see tag below) confused
864 # the rpm build process on 7.1.
865 #
866 # Revision 1.8  2001/06/12 17:15:56  swa
867 # fixes, because a clean build on rh6.1 was impossible.
868 # GZIP confuses make, %% configure confuses rpm, etc.
869 #
870 # Revision 1.7  2001/06/11 12:17:26  sarantis
871 # fix typo in %%post
872 #
873 # Revision 1.6  2001/06/11 11:28:25  sarantis
874 # Further optimizations and adaptations in the spec file.
875 #
876 # Revision 1.5  2001/06/09 09:14:11  swa
877 # shamelessly adapted RPM stuff from the newest rpm that
878 # RedHat provided for the JB.
879 #
880 # Revision 1.4  2001/06/08 20:54:18  swa
881 # type with status file. remove forward et. al from file list.
882 #
883 # Revision 1.3  2001/06/07 17:28:10  swa
884 # cosmetics
885 #
886 # Revision 1.2  2001/06/04 18:31:58  swa
887 # files are now prefixed with either `confdir' or `logdir'.
888 # `make redhat-dist' replaces both entries confdir and logdir
889 # with redhat values
890 #
891 # Revision 1.1  2001/06/04 10:44:57  swa
892 # `make redhatr-dist' now works. Except for the paths
893 # in the config file.
894 #
895 #
896 #