More Mac OSX support:
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.16 2002/03/26 22:29:55 swa Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33
34 Name: privoxy
35 # ATTENTION
36 # Version and release should be updated acordingly on configure.in and
37 # configure. Otherwise, the package can be build with the wrong value
38 Version: 2.9.13
39 Release: 3
40 Summary: Privoxy - privacy enhancing proxy
41 License: GPL
42 Vendor: http://www.privoxy.org
43 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
44 BuildRoot: %{_tmppath}/%{name}-%{version}-root
45 Group: Networking/Utilities
46 URL: http://www.privoxy.org/
47 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
48 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
49 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
50 BuildRequires: perl gzip sed docbook-utils libtool autoconf
51 Conflicts: junkbuster-raw junkbuster-blank junkbuster
52
53 %description 
54 Privoxy is a web proxy with advanced filtering capabilities for
55 protecting privacy, filtering web page content, managing cookies,
56 controlling access, and removing ads, banners, pop-ups and other
57 obnoxious Internet junk. Privoxy has a very flexible configuration and
58 can be customized to suit individual needs and tastes. Privoxy has application
59 for both stand-alone systems and multi-user networks.
60
61 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
62 was originally written by JunkBusters Corporation, and was released as
63 free open-source software under the GNU GPL. Stefan Waldherr made many
64 improvements, and started the SourceForge project to continue
65 development. Several other developers are now contributing.
66
67 %prep
68 %setup -q -c
69
70 %build
71 autoheader
72 autoconf
73 %configure
74 make 
75 make redhat-dok
76
77 ## Explicitily stripping is not recomended.
78 ## This is handled altomaticaly by RPM, and can couse troubles if
79 ## anyone wants to build an unstriped version - morcego
80 #strip %{name}
81
82 %install
83 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
84 mkdir -p %{buildroot}%{_sbindir} \
85          %{buildroot}%{_mandir}/man1 \
86          %{buildroot}%{_localstatedir}/log/%{name} \
87          %{buildroot}%{privoxyconf}/templates \
88          %{buildroot}%{_sysconfdir}/logrotate.d \
89          %{buildroot}%{_sysconfdir}/rc.d/init.d 
90
91 ## Manual gziping of manpages should not be done, once it can
92 ## break the building on some distributions. Anyway, rpm does it
93 ## automagicaly these days
94 ## Gziping the documentation files is not recomended - morcego
95 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
96
97 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
98
99 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
100 cp -f *.action %{buildroot}%{privoxyconf}/
101 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
102 cp -f trust %{buildroot}%{privoxyconf}/trust
103 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
104 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
105 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
106 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
107
108 # verify all file locations, etc. in the config file
109 # don't start with ^ or commented lines are not replaced
110 ## Changing the sed paramter delimiter to @, so we don't have to
111 ## escape the slashes
112 cat config | \
113     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
114 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
115 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
116 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
117 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
118 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
119 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
120     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
121     %{buildroot}%{privoxyconf}/config
122 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
123     %{buildroot}%{privoxyconf}/default.action
124
125
126 # Creating ghost init files
127 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
128 for i in 0 1 4 6
129 do
130 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
131 done
132 for i in 2 3 5
133 do
134 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
135 done
136
137 ## Macros are expanded even on commentaries. So, we have to use %%
138 ## -- morcego
139 #%%makeinstall
140
141 %pre
142 # This is where we handle old usernames (junkbust and junkbuster)
143 # I'm not sure we should do that, but this is the way we have been
144 # doing it for some time now -- morcego
145 # We should do it for the group as well -- morcego
146 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
147
148 # Change the group name. Remove anything left behind.
149 groupmod -n %{name} %{oldname} > /dev/null 2>&1 ||:
150 groupmod -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
151 groupdel %{oldname} > /dev/null 2>&1 ||:
152 groupdel %{veryoldname} > /dev/null 2>&1 ||:
153
154 # Same for username
155 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
156 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
157 userdel %{oldname} > /dev/null 2>&1 ||:
158 userdel %{veryoldname} > /dev/null 2>&1 ||:
159
160 # Check to see if everything is okey. Create user if it still does not
161 # exist
162 id %{name} > /dev/null 2>&1
163 if [ $? -eq 1 ]; then
164         /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
165 fi
166
167 %post
168 # for upgrade from 2.0.x
169 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
170  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
171 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
172  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
173 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
174 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
175 if [ "$1" = "1" ]; then
176         /sbin/service %{name} condrestart > /dev/null 2>&1
177 fi
178
179 %preun
180 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
181 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
182
183 if [ "$1" = "0" ]; then
184         /sbin/service %{name} stop > /dev/null 2>&1 ||:
185         # No need to use chkconfig. The %%ghost files will handle it
186 fi
187
188 %postun
189 #if [ "$1" -ge "1" ]; then
190 #       /sbin/service %{name} condrestart > /dev/null 2>&1
191 #fi
192 # We only remove it we this is not an upgrade
193 if [ "$1" = "0" ]; then
194         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
195 fi
196
197 %clean
198 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
199
200 %files
201 %defattr(0644,root,root,0755)
202 %doc README AUTHORS ChangeLog
203 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
204 %doc doc/webserver/developer-manual
205 %doc doc/webserver/user-manual
206 %doc doc/webserver/faq
207 %doc doc/webserver/ijb_docs.css
208
209 %dir %{privoxyconf}
210 %dir %{privoxyconf}/templates
211 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
212
213 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
214
215 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
216 # We should not use wildchars here. This could mask missing files problems
217 # -- morcego
218 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
219 %config %{privoxyconf}/config
220 %config %{privoxyconf}/advanced.action
221 %config %{privoxyconf}/basic.action
222 %config %{privoxyconf}/intermediate.action
223 %config %{privoxyconf}/default.action
224 %config %{privoxyconf}/default.filter
225 %config %{privoxyconf}/trust
226
227 %config %{privoxyconf}/templates/blocked
228 %config %{privoxyconf}/templates/blocked-compact
229 %config %{privoxyconf}/templates/cgi-error-404
230 %config %{privoxyconf}/templates/cgi-error-bad-param
231 %config %{privoxyconf}/templates/cgi-error-disabled
232 %config %{privoxyconf}/templates/cgi-error-file
233 %config %{privoxyconf}/templates/cgi-error-modified
234 %config %{privoxyconf}/templates/cgi-error-parse
235 %config %{privoxyconf}/templates/connect-failed
236 %config %{privoxyconf}/templates/default
237 %config %{privoxyconf}/templates/edit-actions-add-url-form
238 %config %{privoxyconf}/templates/edit-actions-for-url
239 %config %{privoxyconf}/templates/edit-actions-list
240 %config %{privoxyconf}/templates/edit-actions-list-section
241 %config %{privoxyconf}/templates/edit-actions-list-url
242 %config %{privoxyconf}/templates/edit-actions-remove-url-form
243 %config %{privoxyconf}/templates/edit-actions-url-form
244 %config %{privoxyconf}/templates/no-such-domain
245 %config %{privoxyconf}/templates/show-request
246 %config %{privoxyconf}/templates/show-status
247 %config %{privoxyconf}/templates/show-status-file
248 %config %{privoxyconf}/templates/show-url-info
249 %config %{privoxyconf}/templates/show-version
250 %config %{privoxyconf}/templates/toggle
251 %config %{privoxyconf}/templates/toggle-mini
252 %config %{privoxyconf}/templates/untrusted
253 %config %{privoxyconf}/templates/edit-actions-for-url-filter
254 %config %{_sysconfdir}/logrotate.d/%{name}
255 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
256 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
257 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
258 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
259 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
260 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
261 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
262 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
263
264 %{_mandir}/man1/%{name}.*
265
266 %changelog
267 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
268 + privoxy-2.9.13-3
269 - Fix typo in Description.
270
271 * Tue Mar 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
272 + privoxy-2.9.13-3
273 - Added commentary asking to update the release value on the configure
274   script
275
276 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
277 + privoxy-2.9.13-3
278 - Added the missing edit-actions-for-url-filter to templates.
279
280 * Mon Mar 25 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
281 + privoxy-2.9.13-2
282 - Fixing Release number
283
284 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
285 + privoxy-2.9.13-2
286 - Added faq to docs.
287
288 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
289 + privoxy-2.9.13-2
290 - Fixed the init files entries. Now we use %%ghost
291 - improved username (and groupname) handling on the %%pre section. By improved
292   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
293   got it right. No more Mr. Nice Guy.
294 - Removed the userdel call on %%post. No need, once it's complety handled on
295   the %%pre section
296
297 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
298 + junkbusterng-2.9.13-1
299   Added autoheader. Added autoconf to buildrequires.
300
301 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
302 + junkbusterng-2.9.13-1
303 - Fixed build problems re: name conflicts with man page and logrotate.
304 - Commented out rc?d/* configs for time being, which are causing a build 
305 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
306 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
307
308 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
309 + junkbusterng-2.9.13-1
310 - References to the expression ijb where changed where possible
311 - New package name: junkbusterng (all in lower case, acording to
312   the LSB recomendation)
313 - Version changed to: 2.9.13
314 - Release: 1
315 - Added: junkbuster to obsoletes and conflicts (Not sure this is
316   right. If it obsoletes, why conflict ? Have to check it later)
317 - Summary changed: Stefan, please check and aprove it
318 - Changes description to use the new name
319 - Sed string was NOT changed. Have to wait to the manpage to
320   change first
321 - Keeping the user junkbuster for now. It will require some aditional
322   changes on the script (scheduled for the next specfile release)
323 - Added post entry to move the old logfile to the new log directory
324 - Removing "chkconfig --add" entry (not good to have it automaticaly
325   added to the startup list).
326 - Added preun section to stop the service with the old name, as well
327   as remove it from the startup list
328 - Removed the chkconfig --del entry from the conditional block on
329   the preun scriptlet (now handled on the %files section)
330
331 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
332 - added ijb_docs.css to docs.
333
334 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
335 + junkbuster-2.9.11-8 
336 - Take out --enable-no-gifs, breaks some browsers.
337
338 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
339 + junkbuster-2.9.11-8 
340 - Add --enable-no-gifs to configure.
341
342 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
343 + junkbuster-2.9.11-7
344 - Added BuildRequires to libtool.
345
346 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
347 + junkbuster-2.9.11-6
348 - Changed the routined that handle the junkbust and junkbuster users on
349   %%pre and %%post to work in a smoother manner
350 - %%files now uses hardcoded usernames, to avoid problems with package
351   name changes in the future
352
353 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
354 + junkbuster-2.9.11-5
355 - Added "make redhat-dok" to the build process
356 - Added docbook-utils to BuildRequires
357
358 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
359 + junkbuster-2.9.11-4
360 - Changing man section in the manpage from 1 to 8
361 - We now require packages, not files, to avoid issues with apt
362
363 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
364 + junkbuster-2.9.11-3
365 - Fixing permissions of the init script
366
367 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
368 + junkbuster-2.9.11-2
369 - General specfile fixup, using the best recomended practices, including:
370         - Adding -q to %%setup
371         - Using macros whereever possible
372         - Not using wildchars on %%files section
373         - Doubling the percentage char on changelog and comments, to
374           avoid rpm expanding them
375
376 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
377 - /bin/false for shell causes init script to fail. Reverting.
378
379 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
380 - Removed UID 73. Included user-manual and developer-manual in docs.
381   Include other actions files. Default shell is now /bin/false.
382   Userdel user=junkbust. ChangeLog was not zipped. Removed 
383   RPM_OPT_FLAGS kludge.
384
385 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
386 - add paranoia check for 'rm -rf %%{buildroot}'
387 - add gzip to 'BuildRequires'
388
389 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
390 - actionsfile is now ijb.action.
391
392 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
393 - Compress manpage
394 - Add more documents for installation
395 - Add version string to name and source
396
397 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
398 - Back to user 'junkbuster' and fix configure macro.
399
400 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
401 - More changes for user 'junkbust'. Init script had 'junkbuster'.
402
403 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
404 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
405 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
406
407 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
408 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
409 - made sure no default shell exists for user junkbust.
410
411 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
412 - rework of RPM
413
414 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
415 - CLF Logging patch by davep@cyw.uklinux.net
416 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
417
418 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
419 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
420 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
421   numerous fixes and enhancements for Steve's patch.
422 - adamlock@netscape.com (Adam Lock) in the windows version:
423   - Taskbar activity spinner always spins even when logging is
424   turned off (which is the default) - people who don't
425   like the spinner can turn it off from a menu option.
426   - Taskbar popup menu has a options submenu - people can now
427   open the settings files for cookies, blockers etc.
428   without opening the JB window.
429   - Logging functionality works again
430   - Buffer overflow is fixed - new code uses a bigger buffer
431   and snprintf so it shouldn't overflow anymore.
432 - Fixed userid swa, group learning problem while installing.
433   root must build RPM.
434 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
435   core dump when there is no log file.
436 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
437 - Fixed man page to include imagefile and popupfile.
438 - Sanity check for the statistics function added.
439 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
440  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
441  With IIS/5, it appears to omit the trailing \r\n from http header
442  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
443  responds with a HTTP 302 redirect header.  However, this header
444  message is missing the trailing \r\n.  IIS/5 then closes the
445  connection.  Junkbuster, unfortunately, discards the header becomes
446  it thinks it is incomplete - and it is.  MS have transmitted an
447  incomplete header!
448 - Added bug reports and patch submission forms in the docs.
449
450 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
451        Andrew <anw@tirana.freewire.co.uk> extended the JB:
452        Display of statistics of the total number of requests and the number
453        of requests filtered by junkbuster, also the percentage of requests
454        filtered. Suppression of the listing of files on the proxy-args page.
455        All stuff optional and configurable.
456
457 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
458        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
459        code which prevented the JB from handling URLs of the form
460        user:password@www.foo.com. Fixed.
461
462 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
463         Blank images are no longer cached, thanks to a hint from Markus 
464         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
465         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
466         on the correct browser version nowadays. Incorporated many 
467         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
468         spec file. Fixed logging problem and since runlevel 2 does not 
469         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
470         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
471         <walker@netgate.net>. You should now be able to build this RPM as 
472         a non-root user (mathias@weidner.sem.lipsia.de).
473
474 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
475         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
476         to allow more sophisticated matching of blocked images. Logrotate
477         logfile. Added files for auto-updating the blocklist et al.
478
479 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
480         Configure blank version via config file. No separate blank
481         version anymore. Added Roland's <roland@spinnaker.rhein.de>
482         patch to show a logo instead of a blank area. Added a suggestion
483         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
484         More regexps in the blocklist. Prepared the forwardfile for
485         squid. Extended image regexp with help from gabriel 
486         <somlo@CS.ColoState.EDU>.
487
488 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
489         All RPMs now identify themselves in the show-proxy-args page.
490         Released Windoze version. Run junkbuster as nobody instead of
491         root. 
492
493 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
494         Newest version. First release (hence the little version number
495         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
496         security over 2.0.1; some multi-user sites will need to change 
497         the listen-address in the configuration file. The blank version of
498         the Internet Junkbuster has a more sophisticated way of replacing
499         images. All RPMs identify themselves in the show-proxy-args page.
500
501 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
502         Modified the blocking feature, so that only GIFs and JPEGs are
503         blocked and replaced but not HTML pages. Thanks to 
504         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
505         idea. Added numerous stuff to the blocklist. Keep patches in
506         seperate files and no longer in diffs (easier to maintain).
507
508 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
509         Moved config files to /etc/junkbuster directory, moved man page,
510         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
511         Made new version junkbuster-raw (which is only a stripped version of 
512         the junkuster rpm, i.e. without my blocklist, etc.)
513
514 * Tue Jun 16 1998 (2.0-1)
515         Uhm, not that much. Just a new junkbuster version that
516         fixes a couple of bugs ... and of course a bigger 
517         blocklist with the unique Now-less-ads-than-ever(SM)
518         feature.
519         Oh, one thing: I changed the default user agent to Linux -- no 
520         need anymore to support Apple.
521
522 * Tue Jun 16 1998 (2.0-0)
523         Now-less-ads-than-ever (SM)
524         compiled with gcc instead of cc
525         compiled with -O3, thus it should be a little faster
526         show-proxy-args now works
527         /etc/junkbuster.init wasn't necessary
528
529 * Tue Jun 16 1998 (1.4)
530         some more config files were put into /etc
531         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
532         displayed by Netscape instead of the blocked image.
533         Read http://www.waldherr.org/junkbuster/ for
534         further info.
535
536 * Tue Jun 16 1998 (1.3)
537         The program has been moved to /usr/sbin (from /usr/local/bin)
538         Init- and stopscripts (/etc/rc.d/rc*) have been added so
539         that the junkbuster starts automatically during bootup.
540         The /etc/blocklist file is much more sophisticated. Theoretically
541         one should e.g. browse all major US and German newspapers without
542         seeing one annoying ad.
543         junkbuster.init was modified. It now starts junkbuster with an
544         additional "-r @" flag.
545
546 # $Log: privoxy-rh.spec,v $
547 # Revision 1.16  2002/03/26 22:29:55  swa
548 # we have a new homepage!
549 #
550 # Revision 1.15  2002/03/26 17:39:54  morcego
551 # Adding comment on the specfile to remember the packager to update
552 # the release number on the configure script
553 #
554 # Revision 1.14  2002/03/26 14:25:15  hal9
555 # Added edit-actions-for-url-filter to templates in %%config
556 #
557 # Revision 1.13  2002/03/25 13:31:04  morcego
558 # Bumping Release tag.
559 #
560 # Revision 1.12  2002/03/25 03:11:40  hal9
561 # Do it right way this time :/
562 #
563 # Revision 1.11  2002/03/25 03:09:51  hal9
564 # Added faq to docs.
565 #
566 # Revision 1.10  2002/03/24 22:16:14  morcego
567 # Just removing some old commentaries.
568 #
569 # Revision 1.9  2002/03/24 22:03:22  morcego
570 # Should be working now. See %changelog for details
571 #
572 # Revision 1.8  2002/03/24 21:13:01  morcego
573 # Tis broken.
574 #
575 # Revision 1.7  2002/03/24 21:07:18  hal9
576 # Add autoheader, etc.
577 #
578 # Revision 1.6  2002/03/24 19:56:40  hal9
579 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
580 #
581 # Revision 1.4  2002/03/24 13:32:42  swa
582 # name change related issues
583 #
584 # Revision 1.3  2002/03/24 12:56:21  swa
585 # name change related issues.
586 #
587 # Revision 1.2  2002/03/24 11:40:14  swa
588 # name change
589 #
590 # Revision 1.1  2002/03/24 11:23:44  swa
591 # name change
592 #
593 # Revision 1.1  2002/03/22 20:53:03  morcego
594 # - Ongoing process to change name to JunkbusterNG
595 # - configure/configure.in: no change needed
596 # - GNUmakefile.in:
597 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
598 #         - PROGRAM    = jbng@EXEEXT@
599 #         - rh-spec now references as junkbusterng-rh.spec
600 #         - redhat-upload: references changed to junkbusterng-* (package names)
601 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
602 #         - tarball-src: now JunkbusterNG-*
603 #         - install: initscript now junkbusterng.init and junkbusterng (when
604 #                    installed)
605 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
606 # - junkbusterng.spec:
607 #         - References to the expression ijb where changed where possible
608 #         - New package name: junkbusterng (all in lower case, acording to
609 #           the LSB recomendation)
610 #         - Version changed to: 2.9.13
611 #         - Release: 1
612 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
613 #           right. If it obsoletes, why conflict ? Have to check it later)
614 #         - Summary changed: Stefan, please check and aprove it
615 #         - Changes description to use the new name
616 #         - Sed string was NOT changed. Have to wait to the manpage to
617 #           change first
618 #         - Keeping the user junkbuster for now. It will require some aditional
619 #           changes on the script (scheduled for the next specfile release)
620 #         - Added post entry to move the old logfile to the new log directory
621 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
622 #           added to the startup list).
623 #         - Added preun section to stop the service with the old name, as well
624 #           as remove it from the startup list
625 #         - Removed the chkconfig --del entry from the conditional block on
626 #           the preun scriptlet (now handled on the %files section)
627 # - junkbuster.init: renamed to junkbusterng.init
628 # - junkbusterng.init:
629 #         - Changed JB_BIN to jbng
630 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
631 #           be used where necessary (config dir)
632 #
633 # Aditional notes:
634 # - The config directory is /etc/junkbuster yet. Have to change it on the
635 # specfile, after it is changes on the code
636 # - The only files that got renamed on the cvs tree were the rh specfile and
637 # the init file. Some file references got changes on the makefile and on the
638 # rh-spec (as listed above)
639 #
640 # Revision 1.43  2002/03/21 16:04:10  hal9
641 # added ijb_docs.css to %doc
642 #
643 # Revision 1.42  2002/03/12 13:41:18  sarantis
644 # remove hard-coded "ijbswa" string in build phase
645 #
646 # Revision 1.41  2002/03/11 22:58:32  hal9
647 # Remove --enable-no-gifs
648 #
649 # Revision 1.39  2002/03/08 18:57:29  swa
650 # remove user junkbuster after de-installation.
651 #
652 # Revision 1.38  2002/03/08 13:45:27  morcego
653 # Adding libtool to Buildrequires
654 #
655 # Revision 1.37  2002/03/07 19:23:49  swa
656 # i hate to scroll. suse: wrong configdir.
657 #
658 # Revision 1.36  2002/03/07 05:06:54  morcego
659 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
660 #
661 # Revision 1.34  2002/03/07 00:11:57  morcego
662 # Few changes on the %pre and %post sections of the rh specfile to handle
663 # usernames more cleanly
664 #
665 # Revision 1.33  2002/03/05 13:13:57  morcego
666 # - Added "make redhat-dok" to the build phase
667 # - Added docbook-utils to BuildRequires
668 #
669 # Revision 1.32  2002/03/05 12:34:24  morcego
670 # - Changing section internaly on the manpage from 1 to 8
671 # - We now require packages, not files, to avoid issues with apt
672 #
673 # Revision 1.31  2002/03/04 18:06:09  morcego
674 # SPECFILE: fixing permissing of the init script (broken by the last change)
675 #
676 # Revision 1.30  2002/03/04 16:18:03  morcego
677 # General cleanup of the rh specfile.
678 #
679 # %changelog
680 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
681 # + junkbuster-2.9.11-2
682 # - General specfile fixup, using the best recomended practices, including:
683 #         - Adding -q to %%setup
684 #         - Using macros whereever possible
685 #         - Not using wildchars on %%files section
686 #         - Doubling the percentage char on changelog and comments, to
687 #           avoid rpm expanding them
688 #
689 # Revision 1.29  2002/03/03 19:21:22  hal9
690 # Init script fails if shell is /bin/false.
691 #
692 # Revision 1.28  2002/01/09 18:34:03  hal9
693 # nit.
694 #
695 # Revision 1.27  2002/01/09 18:32:02  hal9
696 # Removed RPM_OPT_FLAGS kludge.
697 #
698 # Revision 1.26  2002/01/09 18:21:10  hal9
699 # A few minor updates.
700 #
701 # Revision 1.25  2001/12/28 01:45:36  steudten
702 # Add paranoia check and BuildReq: gzip
703 #
704 # Revision 1.24  2001/12/01 21:43:14  hal9
705 # Allowed for new ijb.action file.
706 #
707 # Revision 1.23  2001/11/06 12:09:03  steudten
708 # Compress doc files. Install README and AUTHORS at last as document.
709 #
710 # Revision 1.22  2001/11/05 21:37:34  steudten
711 # Fix to include the actual version for name.
712 # Let the 'real' packager be included - sorry stefan.
713 #
714 # Revision 1.21  2001/10/31 19:27:27  swa
715 # consistent description. new name for suse since
716 # we had troubles with rpms of identical names
717 # on the webserver.
718 #
719 # Revision 1.20  2001/10/24 15:45:49  hal9
720 # To keep Thomas happy (aka correcting my  mistakes)
721 #
722 # Revision 1.19  2001/10/15 03:23:59  hal9
723 # Nits.
724 #
725 # Revision 1.17  2001/10/10 18:59:28  hal9
726 # Minor change for init script.
727 #
728 # Revision 1.16  2001/09/24 20:56:23  hal9
729 # Minor changes.
730 #
731 # Revision 1.13  2001/09/10 17:44:43  swa
732 # integrate three pieces of documentation. needs work.
733 # will not build cleanly under redhat.
734 #
735 # Revision 1.12  2001/09/10 16:25:04  swa
736 # copy all templates. version updated.
737 #
738 # Revision 1.11  2001/07/03 11:00:25  sarantis
739 # replaced permissionsfile with actionsfile
740 #
741 # Revision 1.10  2001/07/03 09:34:44  sarantis
742 # bumped up version number.
743 #
744 # Revision 1.9  2001/06/12 18:15:29  swa
745 # the %% in front of configure (see tag below) confused
746 # the rpm build process on 7.1.
747 #
748 # Revision 1.8  2001/06/12 17:15:56  swa
749 # fixes, because a clean build on rh6.1 was impossible.
750 # GZIP confuses make, %% configure confuses rpm, etc.
751 #
752 # Revision 1.7  2001/06/11 12:17:26  sarantis
753 # fix typo in %%post
754 #
755 # Revision 1.6  2001/06/11 11:28:25  sarantis
756 # Further optimizations and adaptations in the spec file.
757 #
758 # Revision 1.5  2001/06/09 09:14:11  swa
759 # shamelessly adapted RPM stuff from the newest rpm that
760 # RedHat provided for the JB.
761 #
762 # Revision 1.4  2001/06/08 20:54:18  swa
763 # type with status file. remove forward et. al from file list.
764 #
765 # Revision 1.3  2001/06/07 17:28:10  swa
766 # cosmetics
767 #
768 # Revision 1.2  2001/06/04 18:31:58  swa
769 # files are now prefixed with either `confdir' or `logdir'.
770 # `make redhat-dist' replaces both entries confdir and logdir
771 # with redhat values
772 #
773 # Revision 1.1  2001/06/04 10:44:57  swa
774 # `make redhatr-dist' now works. Except for the paths
775 # in the config file.
776 #
777 #
778 #