name change related issue.
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.3 2002/03/24 12:56:21 swa Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # PRIVOXY team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define oldname junkbuster
31 %define privoxyconf %{_sysconfdir}/%{oldname}
32
33 Summary: Privoxy - privacy enhancing proxy
34 Vendor: http://ijbswa.sourceforge.net
35 Name: privoxy
36 Version: 2.9.13
37 Release: 1
38 Source0: http://www.waldherr.org/%{name}/privoxy-%{version}.tar.gz
39 License: GPL
40 BuildRoot: %{_tmppath}/%{name}-%{version}-root
41 Group: Networking/Utilities
42 URL: http://ijbswa.sourceforge.net/
43 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
44 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
45 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
46 BuildRequires: perl gzip sed docbook-utils libtool
47 Conflicts: junkbuster-raw junkbuster-blank junkbuster
48
49 %description 
50 Privoxy is a web proxy with advanced filtering capabilities for
51 protecting privacy, filtering web page content, managing cookies,
52 controlling access, and removing ads, banners, pop-ups and other
53 obnoxious Internet junk. Privoxy has a very flexible configuration and
54 can be customized to suit individual needs and tastes. Internet
55 Privoxy has application for both stand-alone systems and multi-user
56 networks.
57
58 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
59 was originally written by JunkBusters Corporation, and was released as
60 free open-source software under the GNU GPL. Stefan Waldherr made many
61 improvements, and started the SourceForge project to continue
62 development. Several other developers are now contributing.
63
64 %prep
65 %setup -q -c
66
67 %build
68 %configure
69 make 
70 make redhat-dok
71
72 ## Explicitily stripping is not recomended.
73 ## This is handled altomaticaly by RPM, and can couse troubles if
74 ## anyone wants to build an unstriped version - morcego
75 #strip %{name}
76
77 %install
78 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
79 mkdir -p %{buildroot}%{_sbindir} \
80          %{buildroot}%{_mandir}/man8 \
81          %{buildroot}%{_localstatedir}/log/%{name} \
82          %{buildroot}%{privoxyconf}/templates \
83          %{buildroot}%{_sysconfdir}/logrotate.d \
84          %{buildroot}%{_sysconfdir}/rc.d/init.d 
85
86 ## Manual gziping of manpages should not be done, once it can
87 ## break the building on some distributions. Anyway, rpm does it
88 ## automagicaly these days
89 ## Gziping the documentation files is not recomended - morcego
90 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
91
92 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
93
94 ## We need to change the man section internaly on the manpage
95 ## -- morcego (sugestion by Hal Burgiss)
96 #cp -f %{name}.1 %{buildroot}%{_mandir}/man8/%{name}.8
97
98 # do we need this???
99 #sed -e 's@^.TH JUNKBUSTER 1@.TH JUNKBUSTER 8@g' %{oldname}.1 > %{buildroot}%{_mandir}/man8/%{oldname}.8
100 cp -f *.action %{buildroot}%{privoxyconf}/
101 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
102 cp -f trust %{buildroot}%{privoxyconf}/trust
103 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
104 cp -f %{oldname}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{oldname}
105 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
106 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
107
108 # verify all file locations, etc. in the config file
109 # don't start with ^ or commented lines are not replaced
110 ## Changing the sed paramter delimiter to @, so we don't have to
111 ## escape the slashes
112 cat config | \
113     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
114 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
115 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
116 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
117 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
118 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
119 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
120     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
121     %{buildroot}%{privoxyconf}/config
122 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
123     %{buildroot}%{privoxyconf}/default.action
124
125 ## Macros are expanded even on commentaries. So, we have to use %%
126 ## -- morcego
127 #%%makeinstall
128
129 %pre
130 # We check to see if the user privoxy exists.
131 # If it does, we do nothing
132 # If we don't, we check to see if the user junkbust exist and, in case it
133 # does, we change it do junkbuster. If it also does not exist, we create the
134 # privoxy user -- morcego
135 id privoxy > /dev/null 2>&1 
136 if [ $? -eq 1 ]; then
137         id privoxy > /dev/null 2>&1 
138         if [ $? -eq 0 ]; then
139                 /usr/sbin/usermod -l privoxy -d %{_sysconfdir}/%{name} -s "" privoxy  > /dev/null 2>&1
140         else
141                 /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" privoxy > /dev/null 2>&1 
142         fi
143 fi
144
145 %post
146 # for upgrade from 2.0.x
147 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
148  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
149 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
150  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
151 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
152 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
153 if [ "$1" = "1" ]; then
154 #     /sbin/chkconfig --add %{name}
155         /sbin/service %{name} condrestart > /dev/null 2>&1
156 fi
157 # 01/09/02 HB, getting rid of any user=junkbust
158 # Changed by morcego to use the id command.
159 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
160
161 %preun
162 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
163 /sbin/chkconfig --del %{oldname}
164
165 if [ "$1" = "0" ]; then
166         /sbin/service %{name} stop > /dev/null 2>&1 ||:
167 fi
168
169 %postun
170 #if [ "$1" -ge "1" ]; then
171 #       /sbin/service %{name} condrestart > /dev/null 2>&1
172 #fi
173 # dont forget to remove user and group privoxy
174 id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
175
176 %clean
177 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
178
179 %files
180 %defattr(0644,root,root,0755)
181 %doc README AUTHORS ChangeLog
182 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
183 %doc doc/webserver/developer-manual
184 %doc doc/webserver/user-manual
185 %doc doc/webserver/ijb_docs.css
186 #%doc %{name}.weekly %{name}.monthly AUTHORS
187
188 %dir %{privoxyconf}
189 %dir %{privoxyconf}/templates
190 %attr(0744,privoxy,privoxy) %dir %{_localstatedir}/log/%{name}
191
192 %attr(0744,privoxy,privoxy)%{_sbindir}/%{name}
193
194 # We should not use wildchars here. This could mask missing files problems
195 # -- morcego
196 %config %{privoxyconf}/config
197 %config %{privoxyconf}/advanced.action
198 %config %{privoxyconf}/basic.action
199 %config %{privoxyconf}/intermediate.action
200 %config %{privoxyconf}/default.action
201 %config %{privoxyconf}/default.filter
202 %config %{privoxyconf}/trust
203
204 %config %{privoxyconf}/templates/blocked
205 %config %{privoxyconf}/templates/blocked-compact
206 %config %{privoxyconf}/templates/cgi-error-404
207 %config %{privoxyconf}/templates/cgi-error-bad-param
208 %config %{privoxyconf}/templates/cgi-error-disabled
209 %config %{privoxyconf}/templates/cgi-error-file
210 %config %{privoxyconf}/templates/cgi-error-modified
211 %config %{privoxyconf}/templates/cgi-error-parse
212 %config %{privoxyconf}/templates/connect-failed
213 %config %{privoxyconf}/templates/default
214 %config %{privoxyconf}/templates/edit-actions-add-url-form
215 %config %{privoxyconf}/templates/edit-actions-for-url
216 %config %{privoxyconf}/templates/edit-actions-list
217 %config %{privoxyconf}/templates/edit-actions-list-section
218 %config %{privoxyconf}/templates/edit-actions-list-url
219 %config %{privoxyconf}/templates/edit-actions-remove-url-form
220 %config %{privoxyconf}/templates/edit-actions-url-form
221 %config %{privoxyconf}/templates/no-such-domain
222 %config %{privoxyconf}/templates/show-request
223 %config %{privoxyconf}/templates/show-status
224 %config %{privoxyconf}/templates/show-status-file
225 %config %{privoxyconf}/templates/show-url-info
226 %config %{privoxyconf}/templates/show-version
227 %config %{privoxyconf}/templates/toggle
228 %config %{privoxyconf}/templates/toggle-mini
229 %config %{privoxyconf}/templates/untrusted
230
231 %config %{_sysconfdir}/logrotate.d/%{oldname}
232 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
233 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
234 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
235 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
236 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
237 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/S84%{name}
238 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
239 %config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/S84%{name}
240
241 %{_mandir}/man8/%{oldname}.8*
242
243 %changelog
244 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
245 + junkbusterng-2.9.13-1
246 - References to the expression ijb where changed where possible
247 - New package name: junkbusterng (all in lower case, acording to
248   the LSB recomendation)
249 - Version changed to: 2.9.13
250 - Release: 1
251 - Added: junkbuster to obsoletes and conflicts (Not sure this is
252   right. If it obsoletes, why conflict ? Have to check it later)
253 - Summary changed: Stefan, please check and aprove it
254 - Changes description to use the new name
255 - Sed string was NOT changed. Have to wait to the manpage to
256   change first
257 - Keeping the user junkbuster for now. It will require some aditional
258   changes on the script (scheduled for the next specfile release)
259 - Added post entry to move the old logfile to the new log directory
260 - Removing "chkconfig --add" entry (not good to have it automaticaly
261   added to the startup list).
262 - Added preun section to stop the service with the old name, as well
263   as remove it from the startup list
264 - Removed the chkconfig --del entry from the conditional block on
265   the preun scriptlet (now handled on the %files section)
266
267 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
268 - added ijb_docs.css to docs.
269
270 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
271 + junkbuster-2.9.11-8 
272 - Take out --enable-no-gifs, breaks some browsers.
273
274 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
275 + junkbuster-2.9.11-8 
276 - Add --enable-no-gifs to configure.
277
278 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
279 + junkbuster-2.9.11-7
280 - Added BuildRequires to libtool.
281
282 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
283 + junkbuster-2.9.11-6
284 - Changed the routined that handle the junkbust and junkbuster users on
285   %%pre and %%post to work in a smoother manner
286 - %%files now uses hardcoded usernames, to avoid problems with package
287   name changes in the future
288
289 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
290 + junkbuster-2.9.11-5
291 - Added "make redhat-dok" to the build process
292 - Added docbook-utils to BuildRequires
293
294 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
295 + junkbuster-2.9.11-4
296 - Changing man section in the manpage from 1 to 8
297 - We now require packages, not files, to avoid issues with apt
298
299 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
300 + junkbuster-2.9.11-3
301 - Fixing permissions of the init script
302
303 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
304 + junkbuster-2.9.11-2
305 - General specfile fixup, using the best recomended practices, including:
306         - Adding -q to %%setup
307         - Using macros whereever possible
308         - Not using wildchars on %%files section
309         - Doubling the percentage char on changelog and comments, to
310           avoid rpm expanding them
311
312 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
313 - /bin/false for shell causes init script to fail. Reverting.
314
315 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
316 - Removed UID 73. Included user-manual and developer-manual in docs.
317   Include other actions files. Default shell is now /bin/false.
318   Userdel user=junkbust. ChangeLog was not zipped. Removed 
319   RPM_OPT_FLAGS kludge.
320
321 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
322 - add paranoia check for 'rm -rf %%{buildroot}'
323 - add gzip to 'BuildRequires'
324
325 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
326 - actionsfile is now ijb.action.
327
328 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
329 - Compress manpage
330 - Add more documents for installation
331 - Add version string to name and source
332
333 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
334 - Back to user 'junkbuster' and fix configure macro.
335
336 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
337 - More changes for user 'junkbust'. Init script had 'junkbuster'.
338
339 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
340 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
341 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
342
343 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
344 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
345 - made sure no default shell exists for user junkbust.
346
347 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
348 - rework of RPM
349
350 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
351 - CLF Logging patch by davep@cyw.uklinux.net
352 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
353
354 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
355 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
356 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
357   numerous fixes and enhancements for Steve's patch.
358 - adamlock@netscape.com (Adam Lock) in the windows version:
359   - Taskbar activity spinner always spins even when logging is
360   turned off (which is the default) - people who don't
361   like the spinner can turn it off from a menu option.
362   - Taskbar popup menu has a options submenu - people can now
363   open the settings files for cookies, blockers etc.
364   without opening the JB window.
365   - Logging functionality works again
366   - Buffer overflow is fixed - new code uses a bigger buffer
367   and snprintf so it shouldn't overflow anymore.
368 - Fixed userid swa, group learning problem while installing.
369   root must build RPM.
370 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
371   core dump when there is no log file.
372 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
373 - Fixed man page to include imagefile and popupfile.
374 - Sanity check for the statistics function added.
375 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
376  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
377  With IIS/5, it appears to omit the trailing \r\n from http header
378  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
379  responds with a HTTP 302 redirect header.  However, this header
380  message is missing the trailing \r\n.  IIS/5 then closes the
381  connection.  Junkbuster, unfortunately, discards the header becomes
382  it thinks it is incomplete - and it is.  MS have transmitted an
383  incomplete header!
384 - Added bug reports and patch submission forms in the docs.
385
386 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
387        Andrew <anw@tirana.freewire.co.uk> extended the JB:
388        Display of statistics of the total number of requests and the number
389        of requests filtered by junkbuster, also the percentage of requests
390        filtered. Suppression of the listing of files on the proxy-args page.
391        All stuff optional and configurable.
392
393 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
394        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
395        code which prevented the JB from handling URLs of the form
396        user:password@www.foo.com. Fixed.
397
398 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
399         Blank images are no longer cached, thanks to a hint from Markus 
400         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
401         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
402         on the correct browser version nowadays. Incorporated many 
403         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
404         spec file. Fixed logging problem and since runlevel 2 does not 
405         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
406         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
407         <walker@netgate.net>. You should now be able to build this RPM as 
408         a non-root user (mathias@weidner.sem.lipsia.de).
409
410 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
411         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
412         to allow more sophisticated matching of blocked images. Logrotate
413         logfile. Added files for auto-updating the blocklist et al.
414
415 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
416         Configure blank version via config file. No separate blank
417         version anymore. Added Roland's <roland@spinnaker.rhein.de>
418         patch to show a logo instead of a blank area. Added a suggestion
419         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
420         More regexps in the blocklist. Prepared the forwardfile for
421         squid. Extended image regexp with help from gabriel 
422         <somlo@CS.ColoState.EDU>.
423
424 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
425         All RPMs now identify themselves in the show-proxy-args page.
426         Released Windoze version. Run junkbuster as nobody instead of
427         root. 
428
429 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
430         Newest version. First release (hence the little version number
431         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
432         security over 2.0.1; some multi-user sites will need to change 
433         the listen-address in the configuration file. The blank version of
434         the Internet Junkbuster has a more sophisticated way of replacing
435         images. All RPMs identify themselves in the show-proxy-args page.
436
437 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
438         Modified the blocking feature, so that only GIFs and JPEGs are
439         blocked and replaced but not HTML pages. Thanks to 
440         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
441         idea. Added numerous stuff to the blocklist. Keep patches in
442         seperate files and no longer in diffs (easier to maintain).
443
444 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
445         Moved config files to /etc/junkbuster directory, moved man page,
446         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
447         Made new version junkbuster-raw (which is only a stripped version of 
448         the junkuster rpm, i.e. without my blocklist, etc.)
449
450 * Tue Jun 16 1998 (2.0-1)
451         Uhm, not that much. Just a new junkbuster version that
452         fixes a couple of bugs ... and of course a bigger 
453         blocklist with the unique Now-less-ads-than-ever(SM)
454         feature.
455         Oh, one thing: I changed the default user agent to Linux -- no 
456         need anymore to support Apple.
457
458 * Tue Jun 16 1998 (2.0-0)
459         Now-less-ads-than-ever (SM)
460         compiled with gcc instead of cc
461         compiled with -O3, thus it should be a little faster
462         show-proxy-args now works
463         /etc/junkbuster.init wasn't necessary
464
465 * Tue Jun 16 1998 (1.4)
466         some more config files were put into /etc
467         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
468         displayed by Netscape instead of the blocked image.
469         Read http://www.waldherr.org/junkbuster/ for
470         further info.
471
472 * Tue Jun 16 1998 (1.3)
473         The program has been moved to /usr/sbin (from /usr/local/bin)
474         Init- and stopscripts (/etc/rc.d/rc*) have been added so
475         that the junkbuster starts automatically during bootup.
476         The /etc/blocklist file is much more sophisticated. Theoretically
477         one should e.g. browse all major US and German newspapers without
478         seeing one annoying ad.
479         junkbuster.init was modified. It now starts junkbuster with an
480         additional "-r @" flag.
481
482 # $Log: privoxy-rh.spec,v $
483 # Revision 1.3  2002/03/24 12:56:21  swa
484 # name change related issues.
485 #
486 # Revision 1.2  2002/03/24 11:40:14  swa
487 # name change
488 #
489 # Revision 1.1  2002/03/24 11:23:44  swa
490 # name change
491 #
492 # Revision 1.1  2002/03/22 20:53:03  morcego
493 # - Ongoing process to change name to JunkbusterNG
494 # - configure/configure.in: no change needed
495 # - GNUmakefile.in:
496 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
497 #         - PROGRAM    = jbng@EXEEXT@
498 #         - rh-spec now references as junkbusterng-rh.spec
499 #         - redhat-upload: references changed to junkbusterng-* (package names)
500 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
501 #         - tarball-src: now JunkbusterNG-*
502 #         - install: initscript now junkbusterng.init and junkbusterng (when
503 #                    installed)
504 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
505 # - junkbusterng.spec:
506 #         - References to the expression ijb where changed where possible
507 #         - New package name: junkbusterng (all in lower case, acording to
508 #           the LSB recomendation)
509 #         - Version changed to: 2.9.13
510 #         - Release: 1
511 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
512 #           right. If it obsoletes, why conflict ? Have to check it later)
513 #         - Summary changed: Stefan, please check and aprove it
514 #         - Changes description to use the new name
515 #         - Sed string was NOT changed. Have to wait to the manpage to
516 #           change first
517 #         - Keeping the user junkbuster for now. It will require some aditional
518 #           changes on the script (scheduled for the next specfile release)
519 #         - Added post entry to move the old logfile to the new log directory
520 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
521 #           added to the startup list).
522 #         - Added preun section to stop the service with the old name, as well
523 #           as remove it from the startup list
524 #         - Removed the chkconfig --del entry from the conditional block on
525 #           the preun scriptlet (now handled on the %files section)
526 # - junkbuster.init: renamed to junkbusterng.init
527 # - junkbusterng.init:
528 #         - Changed JB_BIN to jbng
529 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
530 #           be used where necessary (config dir)
531 #
532 # Aditional notes:
533 # - The config directory is /etc/junkbuster yet. Have to change it on the
534 # specfile, after it is changes on the code
535 # - The only files that got renamed on the cvs tree were the rh specfile and
536 # the init file. Some file references got changes on the makefile and on the
537 # rh-spec (as listed above)
538 #
539 # Revision 1.43  2002/03/21 16:04:10  hal9
540 # added ijb_docs.css to %doc
541 #
542 # Revision 1.42  2002/03/12 13:41:18  sarantis
543 # remove hard-coded "ijbswa" string in build phase
544 #
545 # Revision 1.41  2002/03/11 22:58:32  hal9
546 # Remove --enable-no-gifs
547 #
548 # Revision 1.39  2002/03/08 18:57:29  swa
549 # remove user junkbuster after de-installation.
550 #
551 # Revision 1.38  2002/03/08 13:45:27  morcego
552 # Adding libtool to Buildrequires
553 #
554 # Revision 1.37  2002/03/07 19:23:49  swa
555 # i hate to scroll. suse: wrong configdir.
556 #
557 # Revision 1.36  2002/03/07 05:06:54  morcego
558 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
559 #
560 # Revision 1.34  2002/03/07 00:11:57  morcego
561 # Few changes on the %pre and %post sections of the rh specfile to handle
562 # usernames more cleanly
563 #
564 # Revision 1.33  2002/03/05 13:13:57  morcego
565 # - Added "make redhat-dok" to the build phase
566 # - Added docbook-utils to BuildRequires
567 #
568 # Revision 1.32  2002/03/05 12:34:24  morcego
569 # - Changing section internaly on the manpage from 1 to 8
570 # - We now require packages, not files, to avoid issues with apt
571 #
572 # Revision 1.31  2002/03/04 18:06:09  morcego
573 # SPECFILE: fixing permissing of the init script (broken by the last change)
574 #
575 # Revision 1.30  2002/03/04 16:18:03  morcego
576 # General cleanup of the rh specfile.
577 #
578 # %changelog
579 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
580 # + junkbuster-2.9.11-2
581 # - General specfile fixup, using the best recomended practices, including:
582 #         - Adding -q to %%setup
583 #         - Using macros whereever possible
584 #         - Not using wildchars on %%files section
585 #         - Doubling the percentage char on changelog and comments, to
586 #           avoid rpm expanding them
587 #
588 # Revision 1.29  2002/03/03 19:21:22  hal9
589 # Init script fails if shell is /bin/false.
590 #
591 # Revision 1.28  2002/01/09 18:34:03  hal9
592 # nit.
593 #
594 # Revision 1.27  2002/01/09 18:32:02  hal9
595 # Removed RPM_OPT_FLAGS kludge.
596 #
597 # Revision 1.26  2002/01/09 18:21:10  hal9
598 # A few minor updates.
599 #
600 # Revision 1.25  2001/12/28 01:45:36  steudten
601 # Add paranoia check and BuildReq: gzip
602 #
603 # Revision 1.24  2001/12/01 21:43:14  hal9
604 # Allowed for new ijb.action file.
605 #
606 # Revision 1.23  2001/11/06 12:09:03  steudten
607 # Compress doc files. Install README and AUTHORS at last as document.
608 #
609 # Revision 1.22  2001/11/05 21:37:34  steudten
610 # Fix to include the actual version for name.
611 # Let the 'real' packager be included - sorry stefan.
612 #
613 # Revision 1.21  2001/10/31 19:27:27  swa
614 # consistent description. new name for suse since
615 # we had troubles with rpms of identical names
616 # on the webserver.
617 #
618 # Revision 1.20  2001/10/24 15:45:49  hal9
619 # To keep Thomas happy (aka correcting my  mistakes)
620 #
621 # Revision 1.19  2001/10/15 03:23:59  hal9
622 # Nits.
623 #
624 # Revision 1.17  2001/10/10 18:59:28  hal9
625 # Minor change for init script.
626 #
627 # Revision 1.16  2001/09/24 20:56:23  hal9
628 # Minor changes.
629 #
630 # Revision 1.13  2001/09/10 17:44:43  swa
631 # integrate three pieces of documentation. needs work.
632 # will not build cleanly under redhat.
633 #
634 # Revision 1.12  2001/09/10 16:25:04  swa
635 # copy all templates. version updated.
636 #
637 # Revision 1.11  2001/07/03 11:00:25  sarantis
638 # replaced permissionsfile with actionsfile
639 #
640 # Revision 1.10  2001/07/03 09:34:44  sarantis
641 # bumped up version number.
642 #
643 # Revision 1.9  2001/06/12 18:15:29  swa
644 # the %% in front of configure (see tag below) confused
645 # the rpm build process on 7.1.
646 #
647 # Revision 1.8  2001/06/12 17:15:56  swa
648 # fixes, because a clean build on rh6.1 was impossible.
649 # GZIP confuses make, %% configure confuses rpm, etc.
650 #
651 # Revision 1.7  2001/06/11 12:17:26  sarantis
652 # fix typo in %%post
653 #
654 # Revision 1.6  2001/06/11 11:28:25  sarantis
655 # Further optimizations and adaptations in the spec file.
656 #
657 # Revision 1.5  2001/06/09 09:14:11  swa
658 # shamelessly adapted RPM stuff from the newest rpm that
659 # RedHat provided for the JB.
660 #
661 # Revision 1.4  2001/06/08 20:54:18  swa
662 # type with status file. remove forward et. al from file list.
663 #
664 # Revision 1.3  2001/06/07 17:28:10  swa
665 # cosmetics
666 #
667 # Revision 1.2  2001/06/04 18:31:58  swa
668 # files are now prefixed with either `confdir' or `logdir'.
669 # `make redhat-dist' replaces both entries confdir and logdir
670 # with redhat values
671 #
672 # Revision 1.1  2001/06/04 10:44:57  swa
673 # `make redhatr-dist' now works. Except for the paths
674 # in the config file.
675 #
676 #
677 #