oes for Hal: Replace comments with explanations from user manual
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.24 2002/04/11 10:09:20 oes Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define veryoldname junkbust
31 %define oldname junkbuster
32 %define privoxyconf %{_sysconfdir}/%{name}
33
34 Name: privoxy
35 # ATTENTION
36 # Version and release should be updated acordingly on configure.in and
37 # configure. Otherwise, the package can be build with the wrong value
38 Version: 2.9.14
39 Release: 1
40 Summary: Privoxy - privacy enhancing proxy
41 License: GPL
42 Vendor: http://www.privoxy.org
43 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
44 BuildRoot: %{_tmppath}/%{name}-%{version}-root
45 Group: Networking/Utilities
46 URL: http://www.privoxy.org/
47 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
48 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
49 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
50 BuildRequires: perl gzip sed libtool autoconf 
51 Conflicts: junkbuster-raw junkbuster-blank junkbuster
52
53 %description 
54 Privoxy is a web proxy with advanced filtering capabilities for
55 protecting privacy, filtering web page content, managing cookies,
56 controlling access, and removing ads, banners, pop-ups and other
57 obnoxious Internet junk. Privoxy has a very flexible configuration and
58 can be customized to suit individual needs and tastes. Privoxy has application
59 for both stand-alone systems and multi-user networks.
60
61 Privoxy is based on the Internet Junkbuster.
62
63 %prep
64 %setup -q -c
65
66 %build
67 autoheader
68 autoconf
69 %configure --disable-dynamic-pcre
70 make 
71 # Docs are in CVS and tarball now.
72 #%%make dok
73
74 ## Explicitily stripping is not recomended.
75 ## This is handled altomaticaly by RPM, and can couse troubles if
76 ## anyone wants to build an unstriped version - morcego
77 #strip %{name}
78
79 %install
80 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
81 mkdir -p %{buildroot}%{_sbindir} \
82          %{buildroot}%{_mandir}/man1 \
83          %{buildroot}%{_localstatedir}/log/%{name} \
84          %{buildroot}%{privoxyconf}/templates \
85          %{buildroot}%{_sysconfdir}/logrotate.d \
86          %{buildroot}%{_sysconfdir}/rc.d/init.d 
87
88 ## Manual gziping of manpages should not be done, once it can
89 ## break the building on some distributions. Anyway, rpm does it
90 ## automagicaly these days
91 ## Gziping the documentation files is not recomended - morcego
92 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
93
94 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
95
96 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
97 cp -f *.action %{buildroot}%{privoxyconf}/
98 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
99 cp -f trust %{buildroot}%{privoxyconf}/trust
100 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
101 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
102 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
103 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
104
105 # verify all file locations, etc. in the config file
106 # don't start with ^ or commented lines are not replaced
107 ## Changing the sed paramter delimiter to @, so we don't have to
108 ## escape the slashes
109 cat config | \
110     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
111 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
112 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
113 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
114 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
115 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
116 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
117     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
118     %{buildroot}%{privoxyconf}/config
119 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
120     %{buildroot}%{privoxyconf}/default.action
121
122
123 # Creating ghost init files
124 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc{0,1,2,3,4,5,6}.d
125 for i in 0 1 4 6
126 do
127 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/K09%{name}
128 done
129 for i in 2 3 5
130 do
131 ln -sf ../init.d/%{name} %{buildroot}/%{_sysconfdir}/rc.d/rc${i}.d/S84%{name}
132 done
133
134 ## Macros are expanded even on commentaries. So, we have to use %%
135 ## -- morcego
136 #%%makeinstall
137
138 %pre
139 # This is where we handle old usernames (junkbust and junkbuster)
140 # I'm not sure we should do that, but this is the way we have been
141 # doing it for some time now -- morcego
142 # We should do it for the group as well -- morcego
143 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
144
145 # Change the group name. Remove anything left behind.
146 groupmod -n %{name} %{oldname} > /dev/null 2>&1 ||:
147 groupmod -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
148 groupdel %{oldname} > /dev/null 2>&1 ||:
149 groupdel %{veryoldname} > /dev/null 2>&1 ||:
150
151 # Same for username
152 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
153 usermod -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
154 userdel %{oldname} > /dev/null 2>&1 ||:
155 userdel %{veryoldname} > /dev/null 2>&1 ||:
156
157 # Check to see if everything is okey. Create user if it still does not
158 # exist
159 id %{name} > /dev/null 2>&1
160 if [ $? -eq 1 ]; then
161         /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1 
162 fi
163
164 %post
165 # for upgrade from 2.0.x
166 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
167  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
168 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
169  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
170 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
171 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
172 if [ "$1" = "1" ]; then
173         /sbin/service %{name} condrestart > /dev/null 2>&1
174 fi
175
176 %preun
177 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
178 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
179
180 if [ "$1" = "0" ]; then
181         /sbin/service %{name} stop > /dev/null 2>&1 ||:
182         # No need to use chkconfig. The %%ghost files will handle it
183 fi
184
185 %postun
186 #if [ "$1" -ge "1" ]; then
187 #       /sbin/service %{name} condrestart > /dev/null 2>&1
188 #fi
189 # We only remove it we this is not an upgrade
190 if [ "$1" = "0" ]; then
191         id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
192 fi
193
194 %clean
195 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
196
197 %files
198 %defattr(0644,root,root,0755)
199 %doc README AUTHORS ChangeLog LICENSE 
200 %doc doc/text/developer-manual.txt doc/text/user-manual.txt doc/text/faq.txt
201 %doc doc/webserver/developer-manual
202 %doc doc/webserver/user-manual
203 %doc doc/webserver/faq
204 %doc doc/webserver/p_doc.css doc/webserver/p_web.css doc/webserver/index.html
205
206 %dir %{privoxyconf}
207 %dir %{privoxyconf}/templates
208 %attr(0744,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
209
210 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
211
212 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
213 # We should not use wildchars here. This could mask missing files problems
214 # -- morcego
215 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
216 %config %{privoxyconf}/config
217 %config %{privoxyconf}/advanced.action
218 %config %{privoxyconf}/basic.action
219 %config %{privoxyconf}/intermediate.action
220 %config %{privoxyconf}/default.action
221 %config %{privoxyconf}/default.filter
222 %config %{privoxyconf}/trust
223
224 %config %{privoxyconf}/templates/untrusted
225 %config %{privoxyconf}/templates/toggle-mini
226 %config %{privoxyconf}/templates/default
227 %config %{privoxyconf}/templates/connect-failed
228 %config %{privoxyconf}/templates/show-status-file
229 %config %{privoxyconf}/templates/cgi-error-bad-param
230 %config %{privoxyconf}/templates/show-version
231 %config %{privoxyconf}/templates/cgi-error-file
232 %config %{privoxyconf}/templates/cgi-error-404
233 %config %{privoxyconf}/templates/cgi-error-parse
234 %config %{privoxyconf}/templates/edit-actions-url-form
235 %config %{privoxyconf}/templates/no-such-domain
236 %config %{privoxyconf}/templates/edit-actions-add-url-form
237 %config %{privoxyconf}/templates/cgi-style.css
238 %config %{privoxyconf}/templates/edit-actions-for-url-filter
239 %config %{privoxyconf}/templates/cgi-error-disabled
240 %config %{privoxyconf}/templates/edit-actions-remove-url-form
241 %config %{privoxyconf}/templates/show-request
242 %config %{privoxyconf}/templates/cgi-error-modified
243 %config %{privoxyconf}/templates/mod-unstable-warning
244 %config %{privoxyconf}/templates/edit-actions-list
245 %config %{privoxyconf}/templates/toggle
246 %config %{privoxyconf}/templates/edit-actions-list-section
247 %config %{privoxyconf}/templates/mod-title
248 %config %{privoxyconf}/templates/edit-actions-list-url
249 %config %{privoxyconf}/templates/show-status
250 %config %{privoxyconf}/templates/blocked
251 %config %{privoxyconf}/templates/mod-support-and-service
252 %config %{privoxyconf}/templates/mod-local-help
253 %config %{privoxyconf}/templates/show-url-info
254 %config %{privoxyconf}/templates/edit-actions-for-url
255
256 %config %{_sysconfdir}/logrotate.d/%{name}
257 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
258 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
259 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
260 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
261 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
262 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/K09%{name}
263 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
264 %ghost %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/K09%{name}
265
266 %{_mandir}/man1/%{name}.*
267
268 %changelog
269 * Tue Apr 16 2002 Hal Burgiss <hal@foobox.net>
270 + privoxy-2.9.13-6
271 - Add --disable-dynamic-pcre to configure.
272
273 * Wed Apr 10 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
274 + privoxy-2.9.13-5
275 - Relisting template files on the %%files section
276
277 * Tue Apr 09 2002 Hal Burgiss <hal@foobox.net>
278 + privoxy-2.9.13-4
279 - Removed 'make dok'. Docs are all maintained in CVS (and tarball) now.
280
281 * Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
282 + privoxy-2.9.13-4
283 - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
284 - Remove templates/blocked-compact.
285 - Add more docbook stuff to Builderquires.
286
287 * Thu Mar 28 2002 Sarantis Paskalis <sarantis@cnl.di.uoa.gr>
288 + privoxy-2.9.13-3
289 - Include correct documentation file.
290
291 * Tue Mar 26 2002 Hal Burgiss <hal@foobox.net>
292 + privoxy-2.9.13-3
293 - Fix typo in Description.
294
295 * Tue Mar 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
296 + privoxy-2.9.13-3
297 - Added commentary asking to update the release value on the configure
298   script
299
300 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
301 + privoxy-2.9.13-3
302 - Added the missing edit-actions-for-url-filter to templates.
303
304 * Mon Mar 25 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
305 + privoxy-2.9.13-2
306 - Fixing Release number
307
308 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
309 + privoxy-2.9.13-2
310 - Added faq to docs.
311
312 * Sun Mar 24 2002 Rodrigo Barbosa <rodrigob@suespammers.org>
313 + privoxy-2.9.13-2
314 - Fixed the init files entries. Now we use %%ghost
315 - improved username (and groupname) handling on the %%pre section. By improved
316   I mean: we do it by brute force now. Much easier to maintain. Yeah, you
317   got it right. No more Mr. Nice Guy.
318 - Removed the userdel call on %%post. No need, once it's complety handled on
319   the %%pre section
320
321 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
322 + junkbusterng-2.9.13-1
323   Added autoheader. Added autoconf to buildrequires.
324
325 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
326 + junkbusterng-2.9.13-1
327 - Fixed build problems re: name conflicts with man page and logrotate.
328 - Commented out rc?d/* configs for time being, which are causing a build 
329 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
330 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
331
332 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
333 + junkbusterng-2.9.13-1
334 - References to the expression ijb where changed where possible
335 - New package name: junkbusterng (all in lower case, acording to
336   the LSB recomendation)
337 - Version changed to: 2.9.13
338 - Release: 1
339 - Added: junkbuster to obsoletes and conflicts (Not sure this is
340   right. If it obsoletes, why conflict ? Have to check it later)
341 - Summary changed: Stefan, please check and aprove it
342 - Changes description to use the new name
343 - Sed string was NOT changed. Have to wait to the manpage to
344   change first
345 - Keeping the user junkbuster for now. It will require some aditional
346   changes on the script (scheduled for the next specfile release)
347 - Added post entry to move the old logfile to the new log directory
348 - Removing "chkconfig --add" entry (not good to have it automaticaly
349   added to the startup list).
350 - Added preun section to stop the service with the old name, as well
351   as remove it from the startup list
352 - Removed the chkconfig --del entry from the conditional block on
353   the preun scriptlet (now handled on the %files section)
354
355 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
356 - added ijb_docs.css to docs.
357
358 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
359 + junkbuster-2.9.11-8 
360 - Take out --enable-no-gifs, breaks some browsers.
361
362 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
363 + junkbuster-2.9.11-8 
364 - Add --enable-no-gifs to configure.
365
366 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
367 + junkbuster-2.9.11-7
368 - Added BuildRequires to libtool.
369
370 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
371 + junkbuster-2.9.11-6
372 - Changed the routined that handle the junkbust and junkbuster users on
373   %%pre and %%post to work in a smoother manner
374 - %%files now uses hardcoded usernames, to avoid problems with package
375   name changes in the future
376
377 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
378 + junkbuster-2.9.11-5
379 - Added "make redhat-dok" to the build process
380 - Added docbook-utils to BuildRequires
381
382 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
383 + junkbuster-2.9.11-4
384 - Changing man section in the manpage from 1 to 8
385 - We now require packages, not files, to avoid issues with apt
386
387 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
388 + junkbuster-2.9.11-3
389 - Fixing permissions of the init script
390
391 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
392 + junkbuster-2.9.11-2
393 - General specfile fixup, using the best recomended practices, including:
394         - Adding -q to %%setup
395         - Using macros whereever possible
396         - Not using wildchars on %%files section
397         - Doubling the percentage char on changelog and comments, to
398           avoid rpm expanding them
399
400 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
401 - /bin/false for shell causes init script to fail. Reverting.
402
403 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
404 - Removed UID 73. Included user-manual and developer-manual in docs.
405   Include other actions files. Default shell is now /bin/false.
406   Userdel user=junkbust. ChangeLog was not zipped. Removed 
407   RPM_OPT_FLAGS kludge.
408
409 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
410 - add paranoia check for 'rm -rf %%{buildroot}'
411 - add gzip to 'BuildRequires'
412
413 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
414 - actionsfile is now ijb.action.
415
416 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
417 - Compress manpage
418 - Add more documents for installation
419 - Add version string to name and source
420
421 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
422 - Back to user 'junkbuster' and fix configure macro.
423
424 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
425 - More changes for user 'junkbust'. Init script had 'junkbuster'.
426
427 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
428 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
429 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
430
431 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
432 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
433 - made sure no default shell exists for user junkbust.
434
435 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
436 - rework of RPM
437
438 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
439 - CLF Logging patch by davep@cyw.uklinux.net
440 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
441
442 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
443 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
444 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
445   numerous fixes and enhancements for Steve's patch.
446 - adamlock@netscape.com (Adam Lock) in the windows version:
447   - Taskbar activity spinner always spins even when logging is
448   turned off (which is the default) - people who don't
449   like the spinner can turn it off from a menu option.
450   - Taskbar popup menu has a options submenu - people can now
451   open the settings files for cookies, blockers etc.
452   without opening the JB window.
453   - Logging functionality works again
454   - Buffer overflow is fixed - new code uses a bigger buffer
455   and snprintf so it shouldn't overflow anymore.
456 - Fixed userid swa, group learning problem while installing.
457   root must build RPM.
458 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
459   core dump when there is no log file.
460 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
461 - Fixed man page to include imagefile and popupfile.
462 - Sanity check for the statistics function added.
463 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
464  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
465  With IIS/5, it appears to omit the trailing \r\n from http header
466  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
467  responds with a HTTP 302 redirect header.  However, this header
468  message is missing the trailing \r\n.  IIS/5 then closes the
469  connection.  Junkbuster, unfortunately, discards the header becomes
470  it thinks it is incomplete - and it is.  MS have transmitted an
471  incomplete header!
472 - Added bug reports and patch submission forms in the docs.
473
474 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
475        Andrew <anw@tirana.freewire.co.uk> extended the JB:
476        Display of statistics of the total number of requests and the number
477        of requests filtered by junkbuster, also the percentage of requests
478        filtered. Suppression of the listing of files on the proxy-args page.
479        All stuff optional and configurable.
480
481 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
482        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
483        code which prevented the JB from handling URLs of the form
484        user:password@www.foo.com. Fixed.
485
486 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
487         Blank images are no longer cached, thanks to a hint from Markus 
488         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
489         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
490         on the correct browser version nowadays. Incorporated many 
491         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
492         spec file. Fixed logging problem and since runlevel 2 does not 
493         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
494         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
495         <walker@netgate.net>. You should now be able to build this RPM as 
496         a non-root user (mathias@weidner.sem.lipsia.de).
497
498 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
499         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
500         to allow more sophisticated matching of blocked images. Logrotate
501         logfile. Added files for auto-updating the blocklist et al.
502
503 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
504         Configure blank version via config file. No separate blank
505         version anymore. Added Roland's <roland@spinnaker.rhein.de>
506         patch to show a logo instead of a blank area. Added a suggestion
507         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
508         More regexps in the blocklist. Prepared the forwardfile for
509         squid. Extended image regexp with help from gabriel 
510         <somlo@CS.ColoState.EDU>.
511
512 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
513         All RPMs now identify themselves in the show-proxy-args page.
514         Released Windoze version. Run junkbuster as nobody instead of
515         root. 
516
517 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
518         Newest version. First release (hence the little version number
519         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
520         security over 2.0.1; some multi-user sites will need to change 
521         the listen-address in the configuration file. The blank version of
522         the Internet Junkbuster has a more sophisticated way of replacing
523         images. All RPMs identify themselves in the show-proxy-args page.
524
525 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
526         Modified the blocking feature, so that only GIFs and JPEGs are
527         blocked and replaced but not HTML pages. Thanks to 
528         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
529         idea. Added numerous stuff to the blocklist. Keep patches in
530         seperate files and no longer in diffs (easier to maintain).
531
532 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
533         Moved config files to /etc/junkbuster directory, moved man page,
534         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
535         Made new version junkbuster-raw (which is only a stripped version of 
536         the junkuster rpm, i.e. without my blocklist, etc.)
537
538 * Tue Jun 16 1998 (2.0-1)
539         Uhm, not that much. Just a new junkbuster version that
540         fixes a couple of bugs ... and of course a bigger 
541         blocklist with the unique Now-less-ads-than-ever(SM)
542         feature.
543         Oh, one thing: I changed the default user agent to Linux -- no 
544         need anymore to support Apple.
545
546 * Tue Jun 16 1998 (2.0-0)
547         Now-less-ads-than-ever (SM)
548         compiled with gcc instead of cc
549         compiled with -O3, thus it should be a little faster
550         show-proxy-args now works
551         /etc/junkbuster.init wasn't necessary
552
553 * Tue Jun 16 1998 (1.4)
554         some more config files were put into /etc
555         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
556         displayed by Netscape instead of the blocked image.
557         Read http://www.waldherr.org/junkbuster/ for
558         further info.
559
560 * Tue Jun 16 1998 (1.3)
561         The program has been moved to /usr/sbin (from /usr/local/bin)
562         Init- and stopscripts (/etc/rc.d/rc*) have been added so
563         that the junkbuster starts automatically during bootup.
564         The /etc/blocklist file is much more sophisticated. Theoretically
565         one should e.g. browse all major US and German newspapers without
566         seeing one annoying ad.
567         junkbuster.init was modified. It now starts junkbuster with an
568         additional "-r @" flag.
569
570 # $Log: privoxy-rh.spec,v $
571 # Revision 1.24  2002/04/11 10:09:20  oes
572 # Version 2.9.14
573 #
574 # Revision 1.23  2002/04/10 18:14:45  morcego
575 # - (privoxy-rh.spec only) Relisting template files on the %%files section
576 # - (configure.in, privoxy-rh.spec) Bumped package release to 5
577 #
578 # Revision 1.22  2002/04/09 22:06:12  hal9
579 # Remove 'make dok'.
580 #
581 # Revision 1.21  2002/04/09 02:52:26  hal9
582 # - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
583 # - Remove templates/blocked-compact.
584 # - Add more docbook stuff to Buildrequires.
585 #
586 # Revision 1.20  2002/04/08 20:27:45  swa
587 # fixed JB spelling
588 #
589 # Revision 1.19  2002/03/27 22:44:59  sarantis
590 # Include correct documentation file.
591 #
592 # Revision 1.18  2002/03/27 22:10:14  sarantis
593 # bumped Hal's last commit 1 day to the future to make rpm build again.
594 #
595 # Revision 1.17  2002/03/27 00:48:23  hal9
596 # Fix up descrition.
597 #
598 # Revision 1.16  2002/03/26 22:29:55  swa
599 # we have a new homepage!
600 #
601 # Revision 1.15  2002/03/26 17:39:54  morcego
602 # Adding comment on the specfile to remember the packager to update
603 # the release number on the configure script
604 #
605 # Revision 1.14  2002/03/26 14:25:15  hal9
606 # Added edit-actions-for-url-filter to templates in %%config
607 #
608 # Revision 1.13  2002/03/25 13:31:04  morcego
609 # Bumping Release tag.
610 #
611 # Revision 1.12  2002/03/25 03:11:40  hal9
612 # Do it right way this time :/
613 #
614 # Revision 1.11  2002/03/25 03:09:51  hal9
615 # Added faq to docs.
616 #
617 # Revision 1.10  2002/03/24 22:16:14  morcego
618 # Just removing some old commentaries.
619 #
620 # Revision 1.9  2002/03/24 22:03:22  morcego
621 # Should be working now. See %changelog for details
622 #
623 # Revision 1.8  2002/03/24 21:13:01  morcego
624 # Tis broken.
625 #
626 # Revision 1.7  2002/03/24 21:07:18  hal9
627 # Add autoheader, etc.
628 #
629 # Revision 1.6  2002/03/24 19:56:40  hal9
630 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
631 #
632 # Revision 1.4  2002/03/24 13:32:42  swa
633 # name change related issues
634 #
635 # Revision 1.3  2002/03/24 12:56:21  swa
636 # name change related issues.
637 #
638 # Revision 1.2  2002/03/24 11:40:14  swa
639 # name change
640 #
641 # Revision 1.1  2002/03/24 11:23:44  swa
642 # name change
643 #
644 # Revision 1.1  2002/03/22 20:53:03  morcego
645 # - Ongoing process to change name to JunkbusterNG
646 # - configure/configure.in: no change needed
647 # - GNUmakefile.in:
648 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
649 #         - PROGRAM    = jbng@EXEEXT@
650 #         - rh-spec now references as junkbusterng-rh.spec
651 #         - redhat-upload: references changed to junkbusterng-* (package names)
652 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
653 #         - tarball-src: now JunkbusterNG-*
654 #         - install: initscript now junkbusterng.init and junkbusterng (when
655 #                    installed)
656 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
657 # - junkbusterng.spec:
658 #         - References to the expression ijb where changed where possible
659 #         - New package name: junkbusterng (all in lower case, acording to
660 #           the LSB recomendation)
661 #         - Version changed to: 2.9.13
662 #         - Release: 1
663 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
664 #           right. If it obsoletes, why conflict ? Have to check it later)
665 #         - Summary changed: Stefan, please check and aprove it
666 #         - Changes description to use the new name
667 #         - Sed string was NOT changed. Have to wait to the manpage to
668 #           change first
669 #         - Keeping the user junkbuster for now. It will require some aditional
670 #           changes on the script (scheduled for the next specfile release)
671 #         - Added post entry to move the old logfile to the new log directory
672 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
673 #           added to the startup list).
674 #         - Added preun section to stop the service with the old name, as well
675 #           as remove it from the startup list
676 #         - Removed the chkconfig --del entry from the conditional block on
677 #           the preun scriptlet (now handled on the %files section)
678 # - junkbuster.init: renamed to junkbusterng.init
679 # - junkbusterng.init:
680 #         - Changed JB_BIN to jbng
681 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
682 #           be used where necessary (config dir)
683 #
684 # Aditional notes:
685 # - The config directory is /etc/junkbuster yet. Have to change it on the
686 # specfile, after it is changes on the code
687 # - The only files that got renamed on the cvs tree were the rh specfile and
688 # the init file. Some file references got changes on the makefile and on the
689 # rh-spec (as listed above)
690 #
691 # Revision 1.43  2002/03/21 16:04:10  hal9
692 # added ijb_docs.css to %doc
693 #
694 # Revision 1.42  2002/03/12 13:41:18  sarantis
695 # remove hard-coded "ijbswa" string in build phase
696 #
697 # Revision 1.41  2002/03/11 22:58:32  hal9
698 # Remove --enable-no-gifs
699 #
700 # Revision 1.39  2002/03/08 18:57:29  swa
701 # remove user junkbuster after de-installation.
702 #
703 # Revision 1.38  2002/03/08 13:45:27  morcego
704 # Adding libtool to Buildrequires
705 #
706 # Revision 1.37  2002/03/07 19:23:49  swa
707 # i hate to scroll. suse: wrong configdir.
708 #
709 # Revision 1.36  2002/03/07 05:06:54  morcego
710 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
711 #
712 # Revision 1.34  2002/03/07 00:11:57  morcego
713 # Few changes on the %pre and %post sections of the rh specfile to handle
714 # usernames more cleanly
715 #
716 # Revision 1.33  2002/03/05 13:13:57  morcego
717 # - Added "make redhat-dok" to the build phase
718 # - Added docbook-utils to BuildRequires
719 #
720 # Revision 1.32  2002/03/05 12:34:24  morcego
721 # - Changing section internaly on the manpage from 1 to 8
722 # - We now require packages, not files, to avoid issues with apt
723 #
724 # Revision 1.31  2002/03/04 18:06:09  morcego
725 # SPECFILE: fixing permissing of the init script (broken by the last change)
726 #
727 # Revision 1.30  2002/03/04 16:18:03  morcego
728 # General cleanup of the rh specfile.
729 #
730 # %changelog
731 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
732 # + junkbuster-2.9.11-2
733 # - General specfile fixup, using the best recomended practices, including:
734 #         - Adding -q to %%setup
735 #         - Using macros whereever possible
736 #         - Not using wildchars on %%files section
737 #         - Doubling the percentage char on changelog and comments, to
738 #           avoid rpm expanding them
739 #
740 # Revision 1.29  2002/03/03 19:21:22  hal9
741 # Init script fails if shell is /bin/false.
742 #
743 # Revision 1.28  2002/01/09 18:34:03  hal9
744 # nit.
745 #
746 # Revision 1.27  2002/01/09 18:32:02  hal9
747 # Removed RPM_OPT_FLAGS kludge.
748 #
749 # Revision 1.26  2002/01/09 18:21:10  hal9
750 # A few minor updates.
751 #
752 # Revision 1.25  2001/12/28 01:45:36  steudten
753 # Add paranoia check and BuildReq: gzip
754 #
755 # Revision 1.24  2001/12/01 21:43:14  hal9
756 # Allowed for new ijb.action file.
757 #
758 # Revision 1.23  2001/11/06 12:09:03  steudten
759 # Compress doc files. Install README and AUTHORS at last as document.
760 #
761 # Revision 1.22  2001/11/05 21:37:34  steudten
762 # Fix to include the actual version for name.
763 # Let the 'real' packager be included - sorry stefan.
764 #
765 # Revision 1.21  2001/10/31 19:27:27  swa
766 # consistent description. new name for suse since
767 # we had troubles with rpms of identical names
768 # on the webserver.
769 #
770 # Revision 1.20  2001/10/24 15:45:49  hal9
771 # To keep Thomas happy (aka correcting my  mistakes)
772 #
773 # Revision 1.19  2001/10/15 03:23:59  hal9
774 # Nits.
775 #
776 # Revision 1.17  2001/10/10 18:59:28  hal9
777 # Minor change for init script.
778 #
779 # Revision 1.16  2001/09/24 20:56:23  hal9
780 # Minor changes.
781 #
782 # Revision 1.13  2001/09/10 17:44:43  swa
783 # integrate three pieces of documentation. needs work.
784 # will not build cleanly under redhat.
785 #
786 # Revision 1.12  2001/09/10 16:25:04  swa
787 # copy all templates. version updated.
788 #
789 # Revision 1.11  2001/07/03 11:00:25  sarantis
790 # replaced permissionsfile with actionsfile
791 #
792 # Revision 1.10  2001/07/03 09:34:44  sarantis
793 # bumped up version number.
794 #
795 # Revision 1.9  2001/06/12 18:15:29  swa
796 # the %% in front of configure (see tag below) confused
797 # the rpm build process on 7.1.
798 #
799 # Revision 1.8  2001/06/12 17:15:56  swa
800 # fixes, because a clean build on rh6.1 was impossible.
801 # GZIP confuses make, %% configure confuses rpm, etc.
802 #
803 # Revision 1.7  2001/06/11 12:17:26  sarantis
804 # fix typo in %%post
805 #
806 # Revision 1.6  2001/06/11 11:28:25  sarantis
807 # Further optimizations and adaptations in the spec file.
808 #
809 # Revision 1.5  2001/06/09 09:14:11  swa
810 # shamelessly adapted RPM stuff from the newest rpm that
811 # RedHat provided for the JB.
812 #
813 # Revision 1.4  2001/06/08 20:54:18  swa
814 # type with status file. remove forward et. al from file list.
815 #
816 # Revision 1.3  2001/06/07 17:28:10  swa
817 # cosmetics
818 #
819 # Revision 1.2  2001/06/04 18:31:58  swa
820 # files are now prefixed with either `confdir' or `logdir'.
821 # `make redhat-dist' replaces both entries confdir and logdir
822 # with redhat values
823 #
824 # Revision 1.1  2001/06/04 10:44:57  swa
825 # `make redhatr-dist' now works. Except for the paths
826 # in the config file.
827 #
828 #
829 #