first attempt. plz verify and test.
[privoxy.git] / junkbuster-suse.spec
1 # $Id: junkbuster-suse.spec,v 1.10 2001/10/31 19:27:27 swa Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28 # $Log: junkbuster-suse.spec,v $
29 # Revision 1.10  2001/10/31 19:27:27  swa
30 # consistent description. new name for suse since
31 # we had troubles with rpms of identical names
32 # on the webserver.
33 #
34 # Revision 1.9  2001/10/26 18:17:23  swa
35 # new version string
36 #
37 # Revision 1.8  2001/09/13 16:22:42  swa
38 # man page is legacy. suse rpm now contains html
39 # documentation.
40 #
41 # Revision 1.7  2001/09/10 17:44:22  swa
42 # integrate three pieces of documentation.
43 #
44 # Revision 1.6  2001/09/10 16:29:23  swa
45 # binary contained debug info.
46 # buildroot definition fucks up the build process under suse.
47 # program needs to write in varlogjunkbuster
48 # install all templates
49 # create varlogjunkbuster
50 #
51 # Revision 1.5  2001/06/09 09:13:29  swa
52 # description shorter
53 #
54 # Revision 1.4  2001/06/08 20:53:36  swa
55 # use buildroot, export init to separate file (better manageability)
56 #
57 # Revision 1.3  2001/06/07 17:28:10  swa
58 # cosmetics
59 #
60 # Revision 1.2  2001/06/07 17:18:44  swa
61 # header fixed
62 #
63 #
64 # neededforbuild  -ijb
65 # usedforbuild    -ijb aaa_base aaa_dir autoconf automake base bash bindutil binutils bison bzip compress cpio cracklib db devs diffutils e2fsprogs file fileutils findutils flex gawk gcc gdbm gdbm-devel gettext glibc glibc-devel gpm gppshare groff gzip kbd less libtool libz lx_suse make mktemp modutils ncurses ncurses-devel net-tools netcfg nkitb pam pam-devel patch perl pgp ps rcs rpm sendmail sh-utils shadow strace syslogd sysvinit texinfo textutils timezone unzip util-linux vim xdevel xf86 xshared
66
67 Vendor:       http://ijbswa.sourceforge.net
68 Distribution: defineme
69 Name:         junkbuster-suse
70 Packager:     Stefan Waldherr <stefan@waldherr.org>
71
72 Copyright:    GPL
73 # buildroot does not work under f*cking suse :-(
74 #BuildRoot: /tmp/junkbuster-rpmbuild
75 Group:        Networking/Utilities
76 Provides:     ijb
77 Obsoletes:    ijb
78 Autoreqprov:  on
79 Version: 2.9.10
80 Release: 1
81 Summary:      The Internet Junkbuster
82 Source:  http://www.waldherr.org/junkbuster/ijbswa.tar.gz
83
84 #
85 # -----------------------------------------------------------------------------
86 #
87 %description
88 Internet Junkbuster is a web proxy with advanced filtering
89 capabilities for protecting privacy, filtering web page content,
90 managing cookies, controlling access, and removing ads, banners,
91 pop-ups and other obnoxious Internet Junk. Junkbuster has a very
92 flexible configuration and can be customized to suit individual needs
93 and tastes. Internet Junkbuster has application for both stand-alone
94 systems and multi-user networks.
95
96 Authors:
97 --------
98     http://ijbswa.sourceforge.net
99
100 SuSE series: n
101
102 #
103 # -----------------------------------------------------------------------------
104 #
105 %prep
106 %setup -c -n ijbswa
107
108 #
109 # -----------------------------------------------------------------------------
110 #
111 %build
112 autoheader
113 autoconf
114 ./configure
115 gmake
116 strip junkbuster
117
118 #
119 # -----------------------------------------------------------------------------
120 #
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 mkdir -p $RPM_BUILD_ROOT/{var/log/junkbuster,usr/{sbin,share/man/man1,share/doc/packages/junkbuster,share/doc/packages/junkbuster/user-manual,share/doc/packages/junkbuster/developer-manual,share/doc/packages/junkbuster/faq},etc/{junkbuster,junkbuster/templates,init.d}}
124
125 # make sure that we can write in the log directory
126 chown nobody.nogroup $RPM_BUILD_ROOT/var/log/junkbuster
127 install -m 755 junkbuster.init.suse $RPM_BUILD_ROOT/etc/init.d/junkbuster
128 # next line might require an additional rpm_build_root
129 ln -sf /etc/init.d/junkbuster $RPM_BUILD_ROOT/usr/sbin/rcjunkbuster
130
131 install -m 755 junkbuster $RPM_BUILD_ROOT/usr/sbin
132 install -d $RPM_BUILD_ROOT/etc/junkbuster
133 install -d $RPM_BUILD_ROOT/etc/junkbuster/templates
134 install -m 644 ijb.action $RPM_BUILD_ROOT/etc/junkbuster
135 install -m 644 re_filterfile $RPM_BUILD_ROOT/etc/junkbuster
136 # verify all file locations, etc. in the config file
137 # don't start with ^ or commented lines are not replaced
138 cat config | \
139     sed 's/^confdir.*/confdir \/etc\/junkbuster/g' | \
140     sed 's/^ijb.action.*/ijb.action \/etc\/junkbuster\/ijb.action/g' | \
141 #    sed 's/^re_filterfile.*/re_filterfile \/etc\/junkbuster\/re_filterfile/g' | \
142 #    sed 's/^logfile.*/logfile \/var\/log\/junkbuster\/logfile/g' | \
143 #    sed 's/^jarfile.*/jarfile \/var\/log\/junkbuster\/jarfile/g' | \
144 #    sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
145 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
146     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
147     config.tmp
148 cp -f config.tmp config
149 install -m 644 config $RPM_BUILD_ROOT/etc/junkbuster
150 #install -m 644 forward $RPM_BUILD_ROOT/etc/junkbuster
151 install -m 644 trust $RPM_BUILD_ROOT/etc/junkbuster
152 install -m 644 templates/* $RPM_BUILD_ROOT/etc/junkbuster/templates
153 # install -m 644 junkbuster.1 $RPM_BUILD_ROOT/usr/share/man/man1
154 cp -r doc/webserver/user-manual $RPM_BUILD_ROOT/usr/share/doc/packages/junkbuster
155 cp -r doc/webserver/developer-manual $RPM_BUILD_ROOT/usr/share/doc/packages/junkbuster
156 cp -r doc/webserver/faq $RPM_BUILD_ROOT/usr/share/doc/packages/junkbuster
157 %{?suse_check}
158
159 #
160 # -----------------------------------------------------------------------------
161 #
162 %post
163 sbin/insserv etc/init.d/junkbuster
164
165 #
166 # -----------------------------------------------------------------------------
167 #
168 %postun
169 sbin/insserv etc/init.d/
170
171 #
172 # -----------------------------------------------------------------------------
173 #
174 %files
175 %doc /usr/share/doc/packages/junkbuster/faq/
176 %doc /usr/share/doc/packages/junkbuster/user-manual/
177 %doc /usr/share/doc/packages/junkbuster/developer-manual/
178 /usr/sbin/junkbuster
179 #/usr/share/man/man1/junkbuster.1.gz
180 %config(noreplace) /etc/junkbuster
181 /etc/init.d/junkbuster
182 /usr/sbin/rcjunkbuster
183 /var/log/junkbuster
184
185 #
186 # -----------------------------------------------------------------------------
187 #
188 %changelog -n junkbuster
189 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
190 - rework of RPM
191 * Wed Feb 14 2001 - uli@suse.de
192 - fixed init script
193 * Wed Dec 06 2000 - bjacke@suse.de
194 - renamed package to junkbuster
195 - fixed copyright tag
196 * Thu Nov 30 2000 - uli@suse.de
197 - moved init script to /etc/init.d
198 * Wed Feb 16 2000 - kukuk@suse.de
199 - Move /usr/man -> /usr/share/man
200 - Mark /etc/ijb as "config(noreplace)"
201 * Mon Sep 20 1999 - uli@suse.de
202 - fixed init script
203 * Mon Sep 13 1999 - bs@suse.de
204 - ran old prepare_spec on spec file to switch to new prepare_spec.
205 * Thu Apr 01 1999 - daniel@suse.de
206 - do not start ijb as root (security)
207 * Tue Mar 30 1999 - daniel@suse.de
208 - donĀ“t use saclfile.ini
209 * Tue Mar 30 1999 - daniel@suse.de
210 - small fix to whitelist-configuration,
211   version is and was 2.0.2 WITHOUT Stefan Waldherr's patches
212   (http://www.waldherr.org/junkbuster/)
213 * Mon Mar 01 1999 - daniel@suse.de
214 - new package: version 2.0