renamed every reference to the old name with foobar.
[privoxy.git] / junkbuster-suse.spec
1 # $Id: junkbuster-suse.spec,v 1.20 2002/03/12 13:42:14 sarantis Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # do not set to %{name}
30 %define ijbconf %{_sysconfdir}/junkbuster
31
32 Summary:      The Internet Junkbuster
33 Vendor:       http://ijbswa.sourceforge.net
34 Name:         junkbuster-suse
35 Distribution: defineme
36 Version: 2.9.11
37 Release: 1
38 Source: http://www.waldherr.org/%{name}/ijbswa-%{version}.tar.gz
39 # not sure if this works
40 BuildRoot: %{_tmppath}/%{name}-%{version}-root
41 Packager:     Stefan Waldherr <stefan@waldherr.org>
42 Copyright:    GPL
43 Group:        Networking/Utilities
44 URL: http://ijbswa.sourceforge.net/
45 Provides:     ijb
46 Obsoletes:    ijb
47 Autoreqprov:  on
48 BuildRequires: perl gzip docbktls libtool
49
50 #
51 # -----------------------------------------------------------------------------
52 #
53 %description
54 Internet Junkbuster is a web proxy with advanced filtering
55 capabilities for protecting privacy, filtering web page content,
56 managing cookies, controlling access, and removing ads, banners,
57 pop-ups and other obnoxious Internet Junk. Junkbuster has a very
58 flexible configuration and can be customized to suit individual needs
59 and tastes. Internet Junkbuster has application for both stand-alone
60 systems and multi-user networks.
61
62 Authors:
63 --------
64     http://ijbswa.sourceforge.net
65
66 SuSE series: n
67
68 #
69 # -----------------------------------------------------------------------------
70 #
71 %prep
72 %setup -c
73
74 #
75 # -----------------------------------------------------------------------------
76 #
77 %build
78 autoheader
79 autoconf
80 ./configure
81 make
82 make dok
83
84 ## Explicitily stripping is not recomended.
85 ## This is handled altomaticaly by RPM, and can couse troubles if
86 ## anyone wants to build an unstriped version - morcego
87 #strip junkbuster
88
89 #
90 # -----------------------------------------------------------------------------
91 #
92 %install
93 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
94 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
95          ${RPM_BUILD_ROOT}%{_mandir}/man8 \
96          ${RPM_BUILD_ROOT}/var/log/junkbuster \
97          ${RPM_BUILD_ROOT}%{ijbconf}/templates \
98          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
99          ${RPM_BUILD_ROOT}%{_sysconfdir}/init.d
100 gzip README AUTHORS ChangeLog junkbuster.1 || /bin/true
101 install -s -m 744 junkbuster $RPM_BUILD_ROOT%{_sbindir}/junkbuster
102 cp -f junkbuster.1.gz $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8.gz
103 cp -f *.action $RPM_BUILD_ROOT%{ijbconf}/
104 cp -f re_filterfile $RPM_BUILD_ROOT%{ijbconf}/re_filterfile
105 cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
106 cp -f templates/*  $RPM_BUILD_ROOT%{ijbconf}/templates/
107 cp -f junkbuster.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/junkbuster
108 install -m 755 junkbuster.init.suse $RPM_BUILD_ROOT%{_sysconfdir}/init.d/junkbuster
109 install -m 711 -d $RPM_BUILD_ROOT/var/log/junkbuster
110 ln -sf /etc/init.d/junkbuster $RPM_BUILD_ROOT/usr/sbin/rcjunkbuster
111
112 # verify all file locations, etc. in the config file
113 # don't start with ^ or commented lines are not replaced
114 cat config | \
115     sed 's/^confdir.*/confdir \/etc\/junkbuster/g' | \
116 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/junkbuster\/permissionsfile/g' | \
117 #    sed 's/^re_filterfile.*/re_filterfile \/etc\/junkbuster\/re_filterfile/g' | \
118 #    sed 's/^logfile.*/logfile \/var\/log\/junkbuster\/logfile/g' | \
119 #    sed 's/^jarfile.*/jarfile \/var\/log\/junkbuster\/jarfile/g' | \
120 #    sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
121 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
122     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
123     $RPM_BUILD_ROOT%{ijbconf}/config
124
125 #
126 # -----------------------------------------------------------------------------
127 #
128 %pre
129 # We check to see if the user junkbuster exists.
130 # If it does, we do nothing
131 # If we don't, we check to see if the user junkbust exist and, in case it
132 # does, we change it do junkbuster. If it also does not exist, we create the
133 # junkbuster user -- morcego
134 id junkbuster > /dev/null 2>&1 
135 if [ $? -eq 1 ]; then
136         id junkbust > /dev/null 2>&1 
137         if [ $? -eq 0 ]; then
138                 /usr/sbin/usermod -l junkbuster -d %{_sysconfdir}/junkbuster -s "" junkbust  > /dev/null 2>&1
139         else
140 # -r does not work on suse.
141                 /usr/sbin/groupadd junkbuster
142                 /usr/sbin/useradd -d %{_sysconfdir}/junkbuster -g junkbuster -s "" junkbuster > /dev/null 2>&1 
143         fi
144 fi
145
146 #
147 # -----------------------------------------------------------------------------
148 #
149 %post
150 [ -f /var/log/junkbuster/junkbuster ] &&\
151  mv -f /var/log/junkbuster/junkbuster /var/log/junkbuster/logfile || /bin/true
152 chown -R junkbuster:junkbuster /var/log/junkbuster 2>/dev/null
153 chown -R junkbuster:junkbuster /etc/junkbuster 2>/dev/null
154 # not available on suse
155 #if [ "$1" = "1" ]; then
156 #     /sbin/chkconfig --add junkbuster
157 #       /sbin/service junkbuster condrestart > /dev/null 2>&1
158 #fi
159 # 01/09/02 HB, getting rid of any user=junkbust
160 # Changed by morcego to use the id command.
161 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
162 sbin/insserv etc/init.d/junkbuster
163
164 #
165 # -----------------------------------------------------------------------------
166 #
167 %preun
168 # need to stop the service on suse. swa.
169 #if [ "$1" = "0" ]; then
170 #       /sbin/service junkbuster stop > /dev/null 2>&1 ||:
171 #fi
172
173 #
174 # -----------------------------------------------------------------------------
175 #
176 %postun
177 sbin/insserv etc/init.d/
178 # dont forget to remove user and group junkbuster
179 id junkbuster > /dev/null 2>&1 && /usr/sbin/userdel junkbuster || /bin/true
180
181 #
182 # -----------------------------------------------------------------------------
183 #
184 %clean
185 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
186
187 #
188 # -----------------------------------------------------------------------------
189 #
190 %files
191 %defattr(-,root,root)
192 %doc README.gz AUTHORS.gz ChangeLog.gz
193 %doc doc/webserver/developer-manual doc/webserver/user-manual
194 %doc doc/webserver/user-manual
195 %doc doc/webserver/ijb_docs.css
196 #%doc junkbuster.weekly junkbuster.monthly AUTHORS
197 %dir %{ijbconf}
198 %config %{ijbconf}/*
199 %attr(0744,junkbuster,junkbuster) %dir /var/log/junkbuster
200 %config %{_sysconfdir}/logrotate.d/junkbuster
201 %attr(0755,root,root)/usr/sbin/junkbuster
202 %{_mandir}/man8/*
203 %config %{_sysconfdir}/init.d/junkbuster
204 /usr/sbin/rcjunkbuster
205
206 #
207 # -----------------------------------------------------------------------------
208 #
209 %changelog
210 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
211 - added ijb_docs.css to docs.
212
213 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
214 - Remove --enable-no-gifs from configure.
215
216 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
217 - /bin/false for shell causes init script to fail. Reverting.
218
219 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
220 - Removed UID 73. Included user-manual and developer-manual in docs.
221   Include other actions files. Default shell is now /bin/false.
222   Userdel user=junkbust. ChangeLog was not zipped. Removed
223   RPM_OPT_FLAGS kludge.
224
225 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
226 - add paranoia check for 'rm -rf $RPM_BUILD_ROOT'
227 - add gzip to 'BuildRequires'
228
229 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
230 - actionsfile is now ijb.action.
231
232 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
233 - Compress manpage
234 - Add more documents for installation
235 - Add version string to name and source
236
237 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
238 - Back to user 'junkbuster' and fix configure macro.
239
240 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
241 - More changes for user 'junkbust'. Init script had 'junkbuster'.
242
243 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
244 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
245 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
246
247 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
248 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and
249 - made sure no default shell exists for user junkbust.
250
251 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
252 - rework of RPM
253 * Wed Feb 14 2001 - uli@suse.de
254 - fixed init script
255 * Wed Dec 06 2000 - bjacke@suse.de
256 - renamed package to junkbuster
257 - fixed copyright tag
258 * Thu Nov 30 2000 - uli@suse.de
259 - moved init script to /etc/init.d
260 * Wed Feb 16 2000 - kukuk@suse.de
261 - Move /usr/man -> /usr/share/man
262 - Mark /etc/ijb as "config(noreplace)"
263 * Mon Sep 20 1999 - uli@suse.de
264 - fixed init script
265 * Mon Sep 13 1999 - bs@suse.de
266 - ran old prepare_spec on spec file to switch to new prepare_spec.
267 * Thu Apr 01 1999 - daniel@suse.de
268 - do not start ijb as root (security)
269 * Tue Mar 30 1999 - daniel@suse.de
270 - donĀ“t use saclfile.ini
271 * Tue Mar 30 1999 - daniel@suse.de
272 - small fix to whitelist-configuration,
273   version is and was 2.0.2 WITHOUT Stefan Waldherr's patches
274   (http://www.waldherr.org/junkbuster/)
275 * Mon Mar 01 1999 - daniel@suse.de
276 - new package: version 2.0
277
278 # $Log: junkbuster-suse.spec,v $
279 # Revision 1.20  2002/03/12 13:42:14  sarantis
280 # remove hardcoded "ijbswa" from build phase
281 #
282 # Revision 1.19  2002/03/11 22:59:05  hal9
283 # Remove --enable-no-gifs
284 #
285 # Revision 1.18  2002/03/11 12:30:31  swa
286 # be consistent with rh spec file
287 #
288 # Revision 1.17  2002/03/08 19:30:23  swa
289 # remove user junkbuster after de-installation.
290 # synced suse with rh-specfile. installation
291 # and de-installation seem to work.
292 #
293 # Revision 1.16  2002/03/08 18:40:44  swa
294 # build requires tools. useradd and del works
295 # now.
296 #
297 # Revision 1.15  2002/03/07 19:23:50  swa
298 # i hate to scroll. suse: wrong configdir.
299 #
300 # Revision 1.14  2002/03/07 19:10:21  swa
301 # builds cleanly. thanks to kukuk@suse.de
302 # not yet tested.
303 #
304 # Revision 1.13  2002/03/07 18:25:56  swa
305 # synced redhat and suse build process
306 #
307 # Revision 1.12  2002/03/02 15:50:04  swa
308 # 2.9.11 version. more input for docs.
309 #
310 # Revision 1.11  2001/12/02 10:29:26  swa
311 # New version made these changes necessary.
312 #
313 # Revision 1.10  2001/10/31 19:27:27  swa
314 # consistent description. new name for suse since
315 # we had troubles with rpms of identical names
316 # on the webserver.
317 #
318 # Revision 1.9  2001/10/26 18:17:23  swa
319 # new version string
320 #
321 # Revision 1.8  2001/09/13 16:22:42  swa
322 # man page is legacy. suse rpm now contains html
323 # documentation.
324 #
325 # Revision 1.7  2001/09/10 17:44:22  swa
326 # integrate three pieces of documentation.
327 #
328 # Revision 1.6  2001/09/10 16:29:23  swa
329 # binary contained debug info.
330 # buildroot definition fucks up the build process under suse.
331 # program needs to write in varlogjunkbuster
332 # install all templates
333 # create varlogjunkbuster
334 #
335 # Revision 1.5  2001/06/09 09:13:29  swa
336 # description shorter
337 #
338 # Revision 1.4  2001/06/08 20:53:36  swa
339 # use buildroot, export init to separate file (better manageability)
340 #
341 # Revision 1.3  2001/06/07 17:28:10  swa
342 # cosmetics
343 #
344 # Revision 1.2  2001/06/07 17:18:44  swa
345 # header fixed
346 #
347 #