Fixing detection of stylesheets on SuSe.
[privoxy.git] / junkbuster-suse.spec
1 # $Id: junkbuster-suse.spec,v 1.11 2001/12/02 10:29:26 swa Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28 # $Log: junkbuster-suse.spec,v $
29 # Revision 1.11  2001/12/02 10:29:26  swa
30 # New version made these changes necessary.
31 #
32 # Revision 1.10  2001/10/31 19:27:27  swa
33 # consistent description. new name for suse since
34 # we had troubles with rpms of identical names
35 # on the webserver.
36 #
37 # Revision 1.9  2001/10/26 18:17:23  swa
38 # new version string
39 #
40 # Revision 1.8  2001/09/13 16:22:42  swa
41 # man page is legacy. suse rpm now contains html
42 # documentation.
43 #
44 # Revision 1.7  2001/09/10 17:44:22  swa
45 # integrate three pieces of documentation.
46 #
47 # Revision 1.6  2001/09/10 16:29:23  swa
48 # binary contained debug info.
49 # buildroot definition fucks up the build process under suse.
50 # program needs to write in varlogjunkbuster
51 # install all templates
52 # create varlogjunkbuster
53 #
54 # Revision 1.5  2001/06/09 09:13:29  swa
55 # description shorter
56 #
57 # Revision 1.4  2001/06/08 20:53:36  swa
58 # use buildroot, export init to separate file (better manageability)
59 #
60 # Revision 1.3  2001/06/07 17:28:10  swa
61 # cosmetics
62 #
63 # Revision 1.2  2001/06/07 17:18:44  swa
64 # header fixed
65 #
66 #
67 # neededforbuild  -ijb
68 # usedforbuild    -ijb aaa_base aaa_dir autoconf automake base bash bindutil binutils bison bzip compress cpio cracklib db devs diffutils e2fsprogs file fileutils findutils flex gawk gcc gdbm gdbm-devel gettext glibc glibc-devel gpm gppshare groff gzip kbd less libtool libz lx_suse make mktemp modutils ncurses ncurses-devel net-tools netcfg nkitb pam pam-devel patch perl pgp ps rcs rpm sendmail sh-utils shadow strace syslogd sysvinit texinfo textutils timezone unzip util-linux vim xdevel xf86 xshared
69
70 Vendor:       http://ijbswa.sourceforge.net
71 Distribution: defineme
72 Name:         junkbuster-suse
73 Packager:     Stefan Waldherr <stefan@waldherr.org>
74
75 Copyright:    GPL
76 # buildroot does not work under f*cking suse :-(
77 #BuildRoot: /tmp/junkbuster-rpmbuild
78 Group:        Networking/Utilities
79 Provides:     ijb
80 Obsoletes:    ijb
81 Autoreqprov:  on
82 Version: 2.9.11
83 Release: 1
84 Summary:      The Internet Junkbuster
85 Source:  http://www.waldherr.org/junkbuster/ijbswa.tar.gz
86
87 #
88 # -----------------------------------------------------------------------------
89 #
90 %description
91 Internet Junkbuster is a web proxy with advanced filtering
92 capabilities for protecting privacy, filtering web page content,
93 managing cookies, controlling access, and removing ads, banners,
94 pop-ups and other obnoxious Internet Junk. Junkbuster has a very
95 flexible configuration and can be customized to suit individual needs
96 and tastes. Internet Junkbuster has application for both stand-alone
97 systems and multi-user networks.
98
99 Authors:
100 --------
101     http://ijbswa.sourceforge.net
102
103 SuSE series: n
104
105 #
106 # -----------------------------------------------------------------------------
107 #
108 %prep
109 %setup -c -n ijbswa
110
111 #
112 # -----------------------------------------------------------------------------
113 #
114 %build
115 autoheader
116 autoconf
117 ./configure
118 gmake
119 strip junkbuster
120
121 #
122 # -----------------------------------------------------------------------------
123 #
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 mkdir -p $RPM_BUILD_ROOT/{var/log/junkbuster,usr/{sbin,share/man/man1,share/doc/packages/junkbuster,share/doc/packages/junkbuster/user-manual,share/doc/packages/junkbuster/developer-manual,share/doc/packages/junkbuster/faq},etc/{junkbuster,junkbuster/templates,init.d}}
127
128 # make sure that we can write in the log directory
129 chown nobody.nogroup $RPM_BUILD_ROOT/var/log/junkbuster
130 install -m 755 junkbuster.init.suse $RPM_BUILD_ROOT/etc/init.d/junkbuster
131 # next line might require an additional rpm_build_root
132 ln -sf /etc/init.d/junkbuster $RPM_BUILD_ROOT/usr/sbin/rcjunkbuster
133
134 install -m 755 junkbuster $RPM_BUILD_ROOT/usr/sbin
135 install -d $RPM_BUILD_ROOT/etc/junkbuster
136 install -d $RPM_BUILD_ROOT/etc/junkbuster/templates
137 install -m 644 ijb.action $RPM_BUILD_ROOT/etc/junkbuster
138 install -m 644 re_filterfile $RPM_BUILD_ROOT/etc/junkbuster
139 # verify all file locations, etc. in the config file
140 # don't start with ^ or commented lines are not replaced
141 cat config | \
142     sed 's/^confdir.*/confdir \/etc\/junkbuster/g' | \
143     sed 's/^ijb.action.*/ijb.action \/etc\/junkbuster\/ijb.action/g' | \
144 #    sed 's/^re_filterfile.*/re_filterfile \/etc\/junkbuster\/re_filterfile/g' | \
145 #    sed 's/^logfile.*/logfile \/var\/log\/junkbuster\/logfile/g' | \
146 #    sed 's/^jarfile.*/jarfile \/var\/log\/junkbuster\/jarfile/g' | \
147 #    sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
148 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
149     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
150     config.tmp
151 cp -f config.tmp config
152 install -m 644 config $RPM_BUILD_ROOT/etc/junkbuster
153 #install -m 644 forward $RPM_BUILD_ROOT/etc/junkbuster
154 install -m 644 trust $RPM_BUILD_ROOT/etc/junkbuster
155 install -m 644 templates/* $RPM_BUILD_ROOT/etc/junkbuster/templates
156 # install -m 644 junkbuster.1 $RPM_BUILD_ROOT/usr/share/man/man1
157 cp -r doc/webserver/user-manual $RPM_BUILD_ROOT/usr/share/doc/packages/junkbuster
158 cp -r doc/webserver/developer-manual $RPM_BUILD_ROOT/usr/share/doc/packages/junkbuster
159 cp -r doc/webserver/faq $RPM_BUILD_ROOT/usr/share/doc/packages/junkbuster
160 %{?suse_check}
161
162 #
163 # -----------------------------------------------------------------------------
164 #
165 %post
166 sbin/insserv etc/init.d/junkbuster
167
168 #
169 # -----------------------------------------------------------------------------
170 #
171 %postun
172 sbin/insserv etc/init.d/
173
174 #
175 # -----------------------------------------------------------------------------
176 #
177 %files
178 %doc /usr/share/doc/packages/junkbuster/faq/
179 %doc /usr/share/doc/packages/junkbuster/user-manual/
180 %doc /usr/share/doc/packages/junkbuster/developer-manual/
181 /usr/sbin/junkbuster
182 #/usr/share/man/man1/junkbuster.1.gz
183 %config(noreplace) /etc/junkbuster
184 /etc/init.d/junkbuster
185 /usr/sbin/rcjunkbuster
186 /var/log/junkbuster
187
188 #
189 # -----------------------------------------------------------------------------
190 #
191 %changelog -n junkbuster
192 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
193 - rework of RPM
194 * Wed Feb 14 2001 - uli@suse.de
195 - fixed init script
196 * Wed Dec 06 2000 - bjacke@suse.de
197 - renamed package to junkbuster
198 - fixed copyright tag
199 * Thu Nov 30 2000 - uli@suse.de
200 - moved init script to /etc/init.d
201 * Wed Feb 16 2000 - kukuk@suse.de
202 - Move /usr/man -> /usr/share/man
203 - Mark /etc/ijb as "config(noreplace)"
204 * Mon Sep 20 1999 - uli@suse.de
205 - fixed init script
206 * Mon Sep 13 1999 - bs@suse.de
207 - ran old prepare_spec on spec file to switch to new prepare_spec.
208 * Thu Apr 01 1999 - daniel@suse.de
209 - do not start ijb as root (security)
210 * Tue Mar 30 1999 - daniel@suse.de
211 - donĀ“t use saclfile.ini
212 * Tue Mar 30 1999 - daniel@suse.de
213 - small fix to whitelist-configuration,
214   version is and was 2.0.2 WITHOUT Stefan Waldherr's patches
215   (http://www.waldherr.org/junkbuster/)
216 * Mon Mar 01 1999 - daniel@suse.de
217 - new package: version 2.0