Miniscule English edits on template HTML
[privoxy.git] / junkbuster-suse.spec
1 # $Id: junkbuster-suse.spec,v 1.6 2001/09/10 16:29:23 swa Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28 # $Log: junkbuster-suse.spec,v $
29 # Revision 1.6  2001/09/10 16:29:23  swa
30 # binary contained debug info.
31 # buildroot definition fucks up the build process under suse.
32 # program needs to write in varlogjunkbuster
33 # install all templates
34 # create varlogjunkbuster
35 #
36 # Revision 1.5  2001/06/09 09:13:29  swa
37 # description shorter
38 #
39 # Revision 1.4  2001/06/08 20:53:36  swa
40 # use buildroot, export init to separate file (better manageability)
41 #
42 # Revision 1.3  2001/06/07 17:28:10  swa
43 # cosmetics
44 #
45 # Revision 1.2  2001/06/07 17:18:44  swa
46 # header fixed
47 #
48 #
49 # neededforbuild  -ijb
50 # usedforbuild    -ijb aaa_base aaa_dir autoconf automake base bash bindutil binutils bison bzip compress cpio cracklib db devs diffutils e2fsprogs file fileutils findutils flex gawk gcc gdbm gdbm-devel gettext glibc glibc-devel gpm gppshare groff gzip kbd less libtool libz lx_suse make mktemp modutils ncurses ncurses-devel net-tools netcfg nkitb pam pam-devel patch perl pgp ps rcs rpm sendmail sh-utils shadow strace syslogd sysvinit texinfo textutils timezone unzip util-linux vim xdevel xf86 xshared
51
52 Vendor:       http://ijbswa.sourceforge.net
53 Distribution: defineme
54 Name:         junkbuster
55 Packager:     Stefan Waldherr <stefan@waldherr.org>
56
57 Copyright:    GPL
58 # buildroot does not work under f*cking suse :-(
59 #BuildRoot: /tmp/junkbuster-rpmbuild
60 Group:        Networking/Utilities
61 Provides:     ijb
62 Obsoletes:    ijb
63 Autoreqprov:  on
64 Version: 2.9.8
65 Release: 1
66 Summary:      The Internet Junkbuster
67 Source:  http://www.waldherr.org/junkbuster/ijbswa.tar.gz
68
69 #
70 # -----------------------------------------------------------------------------
71 #
72 %description
73 The Internet Junkbuster stops your browser from displaying the
74 advertisement images that pervade many commercial web pages.  Since
75 your browser has to download fewer images, surfing the web should be
76 faster.
77
78 Authors:
79 --------
80     http://ijbswa.sourceforge.net
81
82 SuSE series: n
83
84 #
85 # -----------------------------------------------------------------------------
86 #
87 %prep
88 %setup -c -n ijbswa
89
90 #
91 # -----------------------------------------------------------------------------
92 #
93 %build
94 ./configure
95 make
96 strip junkbuster
97
98 #
99 # -----------------------------------------------------------------------------
100 #
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 mkdir -p $RPM_BUILD_ROOT/{var/log/junkbuster,usr/{sbin,share/man/man1,share/doc/packages/junkbuster},etc/{junkbuster,junkbuster/templates,init.d}}
104
105 # make sure that we can write in the log directory
106 chown nobody.nogroup $RPM_BUILD_ROOT/var/log/junkbuster
107 install -m 755 junkbuster.init.suse $RPM_BUILD_ROOT/etc/init.d/junkbuster
108 # next line might require an additional rpm_build_root
109 ln -sf /etc/init.d/junkbuster $RPM_BUILD_ROOT/usr/sbin/rcjunkbuster
110
111 install -m 755 junkbuster $RPM_BUILD_ROOT/usr/sbin
112 install -d $RPM_BUILD_ROOT/etc/junkbuster
113 install -d $RPM_BUILD_ROOT/etc/junkbuster/templates
114 install -m 644 actionsfile $RPM_BUILD_ROOT/etc/junkbuster
115 install -m 644 re_filterfile $RPM_BUILD_ROOT/etc/junkbuster
116 # verify all file locations, etc. in the config file
117 # don't start with ^ or commented lines are not replaced
118 cat config | \
119     sed 's/^confdir.*/confdir \/etc\/junkbuster/g' | \
120     sed 's/^actionsfile.*/actionsfile \/etc\/junkbuster\/actionsfile/g' | \
121 #    sed 's/^re_filterfile.*/re_filterfile \/etc\/junkbuster\/re_filterfile/g' | \
122 #    sed 's/^logfile.*/logfile \/var\/log\/junkbuster\/logfile/g' | \
123 #    sed 's/^jarfile.*/jarfile \/var\/log\/junkbuster\/jarfile/g' | \
124 #    sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
125 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
126     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
127     config.tmp
128 cp -f config.tmp config
129 install -m 644 config $RPM_BUILD_ROOT/etc/junkbuster
130 #install -m 644 forward $RPM_BUILD_ROOT/etc/junkbuster
131 install -m 644 trust $RPM_BUILD_ROOT/etc/junkbuster
132 install -m 644 templates/* $RPM_BUILD_ROOT/etc/junkbuster/templates
133 install -m 644 junkbuster.1 $RPM_BUILD_ROOT/usr/share/man/man1
134 install -m 644 doc/webserver/user-manual.html $RPM_BUILD_ROOT/usr/share/doc/packages/junkbuster
135 install -m 644 doc/webserver/developer-manual.html $RPM_BUILD_ROOT/usr/share/doc/packages/junkbuster
136 install -m 644 doc/webserver/faq.html $RPM_BUILD_ROOT/usr/share/doc/packages/junkbuster
137 %{?suse_check}
138
139 #
140 # -----------------------------------------------------------------------------
141 #
142 %post
143 sbin/insserv etc/init.d/junkbuster
144
145 #
146 # -----------------------------------------------------------------------------
147 #
148 %postun
149 sbin/insserv etc/init.d/
150
151 #
152 # -----------------------------------------------------------------------------
153 #
154 %files
155 %doc /usr/share/doc/packages/junkbuster/faq.html
156 %doc /usr/share/doc/packages/junkbuster/user-manual.html
157 %doc /usr/share/doc/packages/junkbuster/developer-manual.html
158 /usr/sbin/junkbuster
159 /usr/share/man/man1/junkbuster.1.gz
160 %config(noreplace) /etc/junkbuster
161 /etc/init.d/junkbuster
162 /usr/sbin/rcjunkbuster
163 /var/log/junkbuster
164
165 #
166 # -----------------------------------------------------------------------------
167 #
168 %changelog -n junkbuster
169 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
170 - rework of RPM
171 * Wed Feb 14 2001 - uli@suse.de
172 - fixed init script
173 * Wed Dec 06 2000 - bjacke@suse.de
174 - renamed package to junkbuster
175 - fixed copyright tag
176 * Thu Nov 30 2000 - uli@suse.de
177 - moved init script to /etc/init.d
178 * Wed Feb 16 2000 - kukuk@suse.de
179 - Move /usr/man -> /usr/share/man
180 - Mark /etc/ijb as "config(noreplace)"
181 * Mon Sep 20 1999 - uli@suse.de
182 - fixed init script
183 * Mon Sep 13 1999 - bs@suse.de
184 - ran old prepare_spec on spec file to switch to new prepare_spec.
185 * Thu Apr 01 1999 - daniel@suse.de
186 - do not start ijb as root (security)
187 * Tue Mar 30 1999 - daniel@suse.de
188 - donĀ“t use saclfile.ini
189 * Tue Mar 30 1999 - daniel@suse.de
190 - small fix to whitelist-configuration,
191   version is and was 2.0.2 WITHOUT Stefan Waldherr's patches
192   (http://www.waldherr.org/junkbuster/)
193 * Mon Mar 01 1999 - daniel@suse.de
194 - new package: version 2.0